Upgrade to 20020328.

PR:		ports/36570
Submitted by:	Saito Tomokatsu <saito@a2z.co.jp> (maintainer)
This commit is contained in:
Jun Kuriyama 2002-04-01 08:21:20 +00:00
parent 097dc0982f
commit 7e5cf26d64
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=57118
5 changed files with 67 additions and 50 deletions

View File

@ -6,7 +6,7 @@
#
PORTNAME= asir
PORTVERSION= 20020108
PORTVERSION= 20020328
CATEGORIES= math
MASTER_SITES= ftp://ftp.asir.org/pub/asir/
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${ASIR_DOC}
@ -14,49 +14,55 @@ EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= saito@asir.org
.if defined(USE_LAPACK)
LIB_DEPENDS= lapack.3:${PORTSDIR}/math/lapack
.endif
.if defined(USE_OLDPARI)
LIB_DEPENDS+= pari.1:${PORTSDIR}/math/pari
.else
LIB_DEPENDS+= pari-2.2.0:${PORTSDIR}/math/pari-devel
.endif
.if defined(USE_LAPACK)
LAPACK= -lapack
.else
LAPACK=
.endif
.if defined(USE_OLDPARI)
PARI= -oldpari
.else
PARI= -pari
.endif
WRKSRC= ${WRKDIR}/asir2000
PREFIX?= ${LOCALBASE}
USE_IMAKE= YES
HAS_CONFIGURE= YES
CONFIGURE_ENV= OLD_PARI_VERSION=${OLD_PARI_VERSION} \
PARI_VERSION=${PARI_VERSION} \
LAPACK_VERSION=${LAPACK_VERSION}
CONFIGURE_ARGS= -oxhome ${PREFIX} -plot ${PARI} -fep -interval ${LAPACK}
ASIR_DOC= asirdoc-${PORTVERSION}.tar.gz
ASIR_DOC_VERSION= 20010313
ASIR_DOC= asirdoc-${ASIR_DOC_VERSION}.tar.gz
LIB_DATA= alpi bfct bgk const cyclic defs.h dfff dmul fctrdata fctrtest \
fff gr ifplot katsura launch mat nf num primdec \
ratint robot solve sp sturm xm
LIB_DEPENDS= # dummy
pre-everything::
@${ECHO_MSG} ""
.if !defined(USE_OLDPARI)
@${ECHO_MSG} "If you build with the older pari 2.1.1 library,"
@${ECHO_MSG} " make USE_OLDPARI=yes"
@${ECHO_MSG} "otherwise it will link the newer pari 2.2.0 library."
OLD_PARI_DIR= ${PORTSDIR}/math/pari
OLD_PARI_VERSION= `${GREP} PORTVERSION ${OLD_PARI_DIR}/Makefile | cut -f 2`
PARI_DIR= ${PORTSDIR}/math/pari-devel
PARI_VERSION= `${GREP} PORTVERSION ${PARI_DIR}/Makefile | cut -f 2`
.if defined(USE_OLDPARI)
LIB_DEPENDS+= pari.1:${OLD_PARI_DIR}
PARI= -oldpari
.else
LIB_DEPENDS+= pari-2.2.0:${PARI_DIR}
PARI= -pari
.endif
LAPACK_DIR= ${PORTSDIR}/math/lapack
LAPACK_VERSION= `${GREP} PORTVERSION ${LAPACK_DIR}/Makefile | cut -f 2`
.if defined(USE_LAPACK)
LIB_DEPENDS+= lapack.3:${LAPACK_DIR}
LAPACK= -lapack
.else
LAPACK=
.endif
pre-extract:
.if !defined(USE_OLDPARI)
@${ECHO_MSG} "If you build the pari ${OLD_PARI_VERSION} library,"
@${ECHO_MSG} " make USE_OLDPARI=yes"
@${ECHO_MSG} "otherwise link pari ${PARI_VERSION}"
.endif
@${ECHO_MSG} ""
.if !defined(USE_LAPACK)
@${ECHO_MSG} "To build with the \"LAPACK\" library,"
@${ECHO_MSG} "To build include \"LAPACK\" library,"
@${ECHO_MSG} " make USE_LAPACK=yes"
.endif
@${ECHO_MSG} ""
pre-install:
@${MKDIR} ${DATADIR}

View File

@ -1,2 +1,2 @@
MD5 (asir-20020108.tar.gz) = 4515dce7fbbb53ab117b6a153345479b
MD5 (asirdoc-20020108.tar.gz) = cec5c44e1b9ca83a34d49e10210d14cd
MD5 (asir-20020328.tar.gz) = 6b025cd79156672f64f78c1798dea09b
MD5 (asirdoc-20010313.tar.gz) = bd192a7dd920e53d927ddd4e42659942

View File

@ -1,13 +1,8 @@
--- include/version.h.orig Thu Oct 4 02:04:12 2001
+++ include/version.h Tue Oct 23 02:26:45 2001
@@ -47,5 +47,8 @@
*
* $OpenXM: OpenXM_contrib2/asir2000/include/version.h,v 1.51 2001/10/01 02:00:28 noro Exp $
--- include/version.h.orig Fri Mar 1 09:40:52 2002
+++ include/version.h Sat Mar 2 20:09:47 2002
@@ -48,4 +48,4 @@
* $OpenXM: OpenXM_contrib2/asir2000/include/version.h,v 1.61 2002/03/01 00:40:52 noro Exp $
*/
-#define ASIR_VERSION 20011001
#define ASIR_VERSION 20020301
-#define ASIR_DISTRIBUTION "Kobe"
+#define ASIR_VERSION 20011005
+#define ASIR_DISTRIBUTION "Plotting Group"
+#define PARI2_VERSION "PARI CALCULATOR Version 2.2.0 (alpha) Copyright (C) 2000 The PARI Group"
+#define PARI1_VERSION "PARI CALCULATOR Version 2.1.1 (released) Copyright (C) 2000 The PARI Group"
+#define LAPACK_VERSION "LAPACK Project Version 3.0"

View File

@ -1,5 +1,5 @@
--- configure.orig Sat Oct 6 01:24:21 2001
+++ configure Tue Oct 23 02:16:02 2001
--- configure.orig Fri Oct 5 20:01:21 2001
+++ configure Sat Mar 2 20:10:01 2002
@@ -4,6 +4,7 @@
use_plot=0
use_pari=0
@ -17,7 +17,22 @@
-fep)
use_fep=1 ;;
esac
@@ -59,6 +62,10 @@
@@ -43,12 +46,14 @@
libname=$libname"_pari"
libpari=pari
echo "#define USE_PARI" >> include/config.h
+echo "#define PARI_VERSION \"PARI CALCULATOR Version ${OLD_PARI_VERSION}, Copyright (C) 2000 The PARI Group\"" >> include/version.h
fi
if [ $use_pari = 2 ]; then
libname=$libname"_pari"
libpari=pari-2.2
echo "#define USE_PARI" >> include/config.h
+echo "#define PARI_VERSION \"PARI CALCULATOR Version ${PARI_VERSION}, Copyright (C) 2000 The PARI Group\"" >> include/version.h
fi
if [ $use_plot != 0 ]; then
@@ -59,6 +64,11 @@
if [ $use_interval != 0 ]; then
libname=$libname"_itv"
echo "#define USE_INTERVAL" >> include/config.h
@ -25,6 +40,7 @@
+
+if [ $use_lapack != 0 ]; then
+echo "#define USE_LAPACK" >> include/config.h
+echo "#define LAPACK_VERSION \"LAPACK Project Version ${LAPACK_VERSION}\"" >> include/version.h
fi
if [ $use_fep != 0 ]; then

View File

@ -1,5 +1,5 @@
--- parse/glob.c.orig Sat Nov 3 18:28:57 2001
+++ parse/glob.c Wed Nov 14 17:20:47 2001
--- parse/glob.c.orig Sat Jan 5 02:45:29 2002
+++ parse/glob.c Sat Jan 26 18:33:43 2002
@@ -51,6 +51,7 @@
#include "al.h"
#include "parse.h"
@ -14,10 +14,10 @@
printf("GC 5.3, copyright 1999, H-J. Boehm, A. J. Demers, Xerox, SGI, HP.\n");
- printf("PARI 2.2.1(alpha), copyright (C) 2000,\n");
- printf(" C. Batut, K. Belabas, D. Bernardi, H. Cohen and M. Olivier.\n");
+#if defined(PARI)
+ printf("%s.\n",PARI2_VERSION);
+#if PARI
+ printf("%s.\n",PARI_VERSION);
+#endif
+#if defined(LAPACK)
+#if LAPACK
+ printf("%s.\n",LAPACK_VERSION);
+#endif
}