Do not build the profiled library on 5-CURRENT, where g++ -pg produces

strange function calls that the assembler cannot understand.

Submitted by:	bento

http://bento.freebsd.org/errorlogs/5-latest/rudiments-0.24.log
This commit is contained in:
Akinori MUSHA 2002-12-07 10:28:15 +00:00
parent cbf1825c30
commit 7e390b4a19
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=71406
3 changed files with 37 additions and 2 deletions

View File

@ -21,9 +21,19 @@ MAKE_ARGS= VERSION="${PORTVERSION:R}"
INSTALLS_SHLIB= yes
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 500000
EXTRA_PATCHES= ${PATCHDIR}/extra-patch-*
PLIST_SUB+= PROFILE="@comment "
.else
PLIST_SUB+= PROFILE=""
.endif
post-install:
.if !defined(NOPORTDOCS)
cd ${WRKSRC} && ${MAKE} doc-install
.endif
.include <bsd.port.mk>
.include <bsd.port.post.mk>

View File

@ -0,0 +1,25 @@
--- src/Makefile.in.orig Mon Apr 15 13:21:24 2002
+++ src/Makefile.in Sat Dec 7 19:27:01 2002
@@ -17,7 +17,6 @@
all:
$(MAKE) ../lib/librudiments.a; \
- $(MAKE) ../lib/librudiments_p.a; \
if ( test ! -n "@MINGW32@" -a ! -n "@CYGWIN@" -a ! -n "@UWIN@" ); then \
$(MAKE) ../lib/librudiments.so.$(VERSION); \
else \
@@ -48,7 +47,6 @@
install:
$(top_srcdir)/mkinstalldirs $(libdir)
$(INSTALL) -m 644 ../lib/librudiments.a $(libdir); \
- $(INSTALL) -m 644 ../lib/librudiments_p.a $(libdir); \
if ( test ! -n "@MINGW32@" -a ! -n "@CYGWIN@" -a ! -n "@UWIN@" ); then \
$(RM) $(libdir)/librudiments.so*; \
$(INSTALL) ../lib/librudiments.so.$(VERSION) $(libdir); \
@@ -62,6 +60,5 @@
uninstall:
$(RM) $(libdir)/librudiments.so*
$(RM) $(libdir)/librudiments.a
- $(RM) $(libdir)/librudiments_p.a
$(RM) $(libdir)/librudiments.dll
$(RM) $(libdir)/librudiments.lib

View File

@ -30,7 +30,7 @@ include/rudiments/private/socketnode.h
lib/librudiments.a
lib/librudiments.so
lib/librudiments.so.0
lib/librudiments_p.a
%%PROFILE%%lib/librudiments_p.a
%%PORTDOCS%%share/doc/rudiments/classes/clientsocket.h.html
%%PORTDOCS%%share/doc/rudiments/classes/commandline.h.html
%%PORTDOCS%%share/doc/rudiments/classes/daemonprocess.h.html