games/powder-toy: update 95.0 → 96.2.350

- Upstream has switched to meson.
- Trim options - most defaults are good now, some other optional
  stuff (http=false, renderer) do not build.
- Wrapper script is no longer needed, the app now uses XDG dirs.
This commit is contained in:
Dmitry Marakasov 2021-07-13 17:17:26 +03:00
parent 6e7868010f
commit 7e2c5f5e88
7 changed files with 19 additions and 63 deletions

View File

@ -1,5 +1,5 @@
PORTNAME= powder-toy
PORTVERSION= 95.0
PORTVERSION= 96.2.350
DISTVERSIONPREFIX= v
CATEGORIES= games
@ -10,44 +10,31 @@ LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libfftw3f.so:math/fftw3-float \
libfftw3.so:math/fftw3
libfftw3.so:math/fftw3 \
libluajit-5.1.so:lang/luajit-openresty \
libcurl.so:ftp/curl
USE_GITHUB= yes
GH_ACCOUNT= ThePowderToy
GH_ACCOUNT= The-Powder-Toy
GH_PROJECT= The-Powder-Toy
USES= compiler:c++11-lang scons sdl localbase:ldflags lua:51 pkgconfig
USES= compiler:c++11-lang meson pkgconfig python:build sdl
USE_SDL= sdl2
MAKE_ENV= LINKFLAGS="${LINKFLAGS}"
PORTDOCS= README.md changelog.txt
SUB_FILES= ${PORTNAME}.sh
PORTDOCS= README.md TODO
OPTIONS_DEFINE= DOCS OPTIMIZED_CFLAGS SSE SSE3 OPENGL HTTP
OPTIONS_DEFAULT= OPTIMIZED_CFLAGS HTTP
OPTIONS_DEFINE= DOCS SSE
OPTIONS_DEFAULT_amd64= SSE
# upstream also uses -funsafe-loop-optimizations, but it's not supported by clang
OPTIMIZED_CFLAGS_CXXFLAGS= -O3 -ftree-vectorize -funsafe-math-optimizations -ffast-math -fomit-frame-pointer
SSE_MAKE_ARGS_OFF= --no-sse
SSE3_DESC= Enable SSE3 optimizations
SSE3_MAKE_ARGS= --sse3
SSE3_IMPLIES= SSE
OPENGL_USES= gl
OPENGL_USE= GL=gl,glu,glew
OPENGL_MAKE_ARGS= --opengl --opengl-renderer
OPENGL_BROKEN= Application dies with SIGBUS at startup
HTTP_DESC= Enable HTTP requests support
HTTP_LIB_DEPENDS= libcurl.so:ftp/curl
HTTP_MAKE_ARGS_OFF= --nohttp
SSE_DESC= Enable SSE optimizations
SSE_MESON_ON= -Dx86_sse=auto
SSE_MESON_OFF= -Dx86_sse=none
post-patch:
@${REINPLACE_CMD} -e '/#include/ s|lua5.1/|lua51/|' ${WRKSRC}/src/lua/LuaCompat.h
@${REINPLACE_CMD} -e 's|python3|${PYTHON_CMD}|' ${WRKSRC}/meson.build
do-install:
${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME}.sh ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
${INSTALL_PROGRAM} ${WRKSRC}/build/powder* ${STAGEDIR}${PREFIX}/libexec/${PORTNAME}
${INSTALL_PROGRAM} ${BUILD_WRKSRC}/powder ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
${INSTALL_DATA} ${WRKSRC}/resources/powder.desktop ${STAGEDIR}${PREFIX}/share/applications/powder-toy.desktop
@${MKDIR} ${STAGEDIR}${PREFIX}/share/appdata
${INSTALL_DATA} ${WRKSRC}/resources/powder.appdata.xml ${STAGEDIR}${PREFIX}/share/appdata/powder-toy.appdata.xml

View File

@ -1,3 +1,3 @@
TIMESTAMP = 1583263544
SHA256 (ThePowderToy-The-Powder-Toy-v95.0_GH0.tar.gz) = f60c3dc93e4ceddeda92b768e75a2d218f8df3da4a569b7d7cb57fff5515e15b
SIZE (ThePowderToy-The-Powder-Toy-v95.0_GH0.tar.gz) = 1250743
TIMESTAMP = 1646929473
SHA256 (The-Powder-Toy-The-Powder-Toy-v96.2.350_GH0.tar.gz) = d95cbadee22632687661e8fc488bd64405d81c0dca737e16420f26e93ea5bf58
SIZE (The-Powder-Toy-The-Powder-Toy-v96.2.350_GH0.tar.gz) = 1322705

View File

@ -1,15 +0,0 @@
--- SConscript.orig 2019-02-17 19:08:04 UTC
+++ SConscript
@@ -364,11 +364,7 @@ def findLibs(env, conf):
FatalError("OpenGL framework not found or not installed")
if platform == "Linux" or platform == "FreeBSD":
- if not conf.CheckLib('X11'):
- FatalError("X11 development library not found or not installed")
-
- if not conf.CheckLib('rt'):
- FatalError("librt not found or not installed")
+ pass
elif platform == "Windows":
#These need to go last
if not conf.CheckLib('gdi32') or not conf.CheckLib('winmm') or (not msvc and not conf.CheckLib('dxguid')):

View File

@ -1,11 +0,0 @@
--- src/Config.h.orig 2016-07-27 02:21:28 UTC
+++ src/Config.h
@@ -35,7 +35,7 @@
#endif
//VersionInfoEnd
-//#define IGNORE_UPDATES //uncomment this for mods, to not get any update notifications
+#define IGNORE_UPDATES //uncomment this for mods, to not get any update notifications
#if !(defined(MACOSX) && defined(DEBUG))
#define HIGH_QUALITY_RESAMPLE //High quality image resampling, slower but much higher quality than my terribad linear interpolation

View File

@ -1,5 +0,0 @@
#!/bin/sh -eu
mkdir -p $HOME/.powdertoy
cd $HOME/.powdertoy
exec %%PREFIX%%/libexec/powder-toy "$@"

View File

@ -14,4 +14,5 @@ with little stickmen or operate your machine. You can browse and
play thousands of different saves made by the community or upload
your own - we welcome your creations!
WWW: http://powdertoy.co.uk/
WWW: https://powdertoy.co.uk/
WWW: https://github.com/The-Powder-Toy/The-Powder-Toy

View File

@ -1,5 +1,4 @@
bin/powder-toy
libexec/powder-toy
share/appdata/powder-toy.appdata.xml
share/applications/powder-toy.desktop
share/icons/hicolor/128x128/apps/powder-toy.png