Fix build with clang

Submitted by:	dim
This commit is contained in:
Baptiste Daroussin 2012-05-07 20:00:39 +00:00
parent 3f5b93e83c
commit 7deec06274
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=296175
4 changed files with 67 additions and 0 deletions

View File

@ -0,0 +1,35 @@
--- configure.orig 2012-05-07 21:34:01.900594469 +0200
+++ configure 2012-05-07 21:57:05.241595943 +0200
@@ -3178,19 +3178,6 @@
fi
-if test x"$enable_werror" != "xno"; then :
-
- CFLAGS="$CFLAGS -Werror"
- CXXFLAGS="$CXXFLAGS -Werror"
-
-fi
-if test x"$GCC" = xyes; then :
-
- # Be tough with warnings and produce less careless code
- CFLAGS="$CFLAGS -Wall -pedantic"
- CXXFLAGS="$CXXFLAGS -Wall -pedantic"
-
-fi
LIBCMIS_API_VERSION=0.2
@@ -15971,6 +15958,12 @@
ac_config_files="$ac_config_files Makefile libcmis.pc src/Makefile src/libcmis/Makefile"
+if test x"$enable_werror" != "xno"; then :
+
+ CFLAGS="$CFLAGS -Werror"
+ CXXFLAGS="$CXXFLAGS -Werror"
+
+fi
cat >confcache <<\_ACEOF
# This file is a shell script that caches the results of configure
# tests run on this system so they can be shared between configure

View File

@ -0,0 +1,11 @@
--- src/libcmis/atom-document.hxx.orig 2011-10-01 14:26:15.000000000 +0200
+++ src/libcmis/atom-document.hxx 2012-05-07 20:06:51.000000000 +0200
@@ -44,7 +44,7 @@ class AtomDocument : public libcmis::Doc
public:
AtomDocument( AtomPubSession* session, std::string url );
AtomDocument( AtomPubSession* session, xmlNodePtr entryNd );
- ~AtomDocument( );
+ virtual ~AtomDocument( );
// Override content methods
virtual FILE* getContent( const char* path = NULL );

View File

@ -0,0 +1,11 @@
--- src/libcmis/atom-folder.hxx.orig 2011-09-30 20:52:01.000000000 +0200
+++ src/libcmis/atom-folder.hxx 2012-05-07 20:06:29.000000000 +0200
@@ -42,7 +42,7 @@ class AtomFolder : public libcmis::Folde
public:
AtomFolder( AtomPubSession* session, std::string url );
AtomFolder( AtomPubSession* session, xmlNodePtr entryNd );
- ~AtomFolder( );
+ virtual ~AtomFolder( );
// virtual pure methods from Folder
virtual std::vector< libcmis::CmisObjectPtr > getChildren( );

View File

@ -0,0 +1,10 @@
--- src/libcmis/session.hxx.orig 2011-09-30 20:38:39.000000000 +0200
+++ src/libcmis/session.hxx 2012-05-07 19:23:43.000000000 +0200
@@ -36,6 +36,7 @@ namespace libcmis
class Session
{
public:
+ virtual ~Session( ) { }
/** Get the Root folder of the repository
*/