Upgrade to 1.23.

Approved by:	maintainer timeout
This commit is contained in:
Dag-Erling Smørgrav 2004-02-09 21:40:47 +00:00
parent 701be0e9c4
commit 7da5c3b016
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=100524
6 changed files with 1125 additions and 1001 deletions

View File

@ -6,129 +6,34 @@
#
PORTNAME= biopython
PORTVERSION= 1.00.a4
PORTVERSION= 1.23
CATEGORIES= biology python
MASTER_SITES= http://www.biopython.org/Download/
MASTER_SITES= http://www.biopython.org/files/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
DISTNAME= ${PORTNAME}-${PORTVERSION:S/.a/a/}
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= wjv@FreeBSD.org
COMMENT= A collection of Python modules for bioinformatics
CONFLICTS= py*-martel-*
BUILD_DEPENDS= ${PYDISTUTILS}
RUN_DEPENDS= ${PYNUMERIC} \
${PYTHON_SITELIBDIR}/Martel/__init__.py:${PORTSDIR}/textproc/py-martel \
${PYTHON_SITELIBDIR}/mx/TextTools/__init__.py:${PORTSDIR}/lang/py-mx-base
USE_PERL5_BUILD=yes
USE_PYTHON= yes
USE_PYTHON= 2.0+
PYTHON_SETUP= ${SETENV} ${MAKE_ENV} ${PYTHON_CMD} setup.py
PLIST_SUB+= PLIST_CORBA=${PLIST_CORBA} PLIST_OMNIORB=${PLIST_OMNIORB} \
PLIST_FNORB=${PLIST_FNORB}
CPIO= cpio --quiet -pdum -R
EXAMPLESDIR= ${PREFIX}/share/examples/${PORTNAME}
# CORBA support (a.k.a Biopython-CORBA):
# Set WITH_CORBA to enable CORBA support for the Biopython port.
.if defined(WITH_CORBA)
# CORBA_ORB may be set from the command line to either "omniorb", "fnorb"
# or "orbit".
# - omniORB is a commercial quality, high speed ORB. The installation is
# huge and building the C++ source is a lengthy process. The omniORBpy
# Python bindings are used.
# - Fnorb is a tiny, lightweight ORB and is excellent for testing purposes.
# Its licence is non-free.
# - ORBit is a very popular and elegant ORB. The ORBit-Python bindings are
# used.
# Note: If unspecified, "orbit" is assumed as default.
CORBA_ORB?= orbit
CORBA_VERSION= 0.3.0
CORBA_DISTNAME= biopython-corba-${CORBA_VERSION}
CORBA_WRKSRC= ${WRKDIR}/${CORBA_DISTNAME}
DISTFILES+= ${CORBA_DISTNAME}${EXTRACT_SUFX}
PLIST_CORBA= ""
.if ${CORBA_ORB} == "omniorb"
RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/omniORB/__init__.py:${PORTSDIR}/devel/py-omniorb
CORBA_ORBNAME= omniORB
PLIST_OMNIORB= ""
PLIST_FNORB= "@comment "
.elif ${CORBA_ORB} == "fnorb"
BUILD_DEPENDS+= ${PYTHON_SITELIBDIR}/Fnorb/__init__.py:${PORTSDIR}/devel/fnorb
RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/Fnorb/__init__.py:${PORTSDIR}/devel/fnorb
CORBA_ORBNAME= Fnorb
PLIST_OMNIORB= "@comment "
PLIST_FNORB= ""
.elif ${CORBA_ORB} == "orbit"
RUN_DEPENDS+= ${LOCALBASE}/include/orbit-python/orbit-python.h:${PORTSDIR}/devel/py-orbit
CORBA_ORBNAME= ORBit
PLIST_OMNIORB= "@comment "
PLIST_FNORB= "@comment "
.endif
.else
PLIST_CORBA= "@comment "
PLIST_OMNIORB= "@comment "
PLIST_FNORB= "@comment "
.endif # defined(WITH_CORBA)
.if !defined(WITHOUT_REPORTLAB)
RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/reportlab/__init__.py:${PORTSDIR}/print/py-reportlab
.endif
pre-fetch:
.if !defined(BATCH) && !defined(WITH_CORBA)
@ ${CAT} ${FILESDIR}/corba.msg
.endif
post-configure:
.if defined(WITH_CORBA)
@ ${PERL} -pi.orig -e \
"/^orb_implementation/ && s/ORBit/${CORBA_ORBNAME}/" \
${CORBA_WRKSRC}/BioCorba/biocorbaconfig.py
.endif
do-build:
@ cd ${WRKSRC} && ${PYTHON_SETUP} build
.if defined(WITH_CORBA)
@ cd ${CORBA_WRKSRC} && ${PYTHON_SETUP} build
.endif
pre-install:
@ ${SH} ${PKGREQ} INSTALL
(cd ${WRKSRC} && ${PYTHON_SETUP} build)
do-install:
@ cd ${WRKSRC} && ${PYTHON_SETUP} install -c -O1 \
--prefix=${PREFIX}
.if defined(WITH_CORBA)
@ cd ${CORBA_WRKSRC} && ${PYTHON_SETUP} install -c -O1 \
--prefix=${PREFIX}
.endif
post-install:
.if !defined(NOPORTDOCS)
@ ${MKDIR} ${DOCSDIR}
.for docfiles in *.pdf *.py *.tex *.txt
@ ${INSTALL_DATA} ${WRKSRC}/Doc/${docfiles} ${DOCSDIR}
.endfor
@ ${MKDIR} ${EXAMPLESDIR}
@ ${INSTALL_DATA} ${WRKSRC}/Doc/examples/* ${EXAMPLESDIR}
@ cd ${WRKSRC}/Scripts && ${FIND} * \
| ${CPIO} ${SHAREOWN}:${SHAREGRP} ${EXAMPLESDIR}
.if defined(WITH_CORBA)
@ ${MKDIR} ${DOCSDIR}/BioCorba
.for docfiles in *.html *.pdf *.tex *.txt
@ ${INSTALL_DATA} ${CORBA_WRKSRC}/Doc/${docfiles} ${DOCSDIR}/BioCorba
.endfor
@ ${MKDIR} ${EXAMPLESDIR}/BioCorba
@ ${INSTALL_DATA} ${CORBA_WRKSRC}/Doc/examples/* \
${EXAMPLESDIR}/BioCorba
@ ${INSTALL_DATA} ${CORBA_WRKSRC}/Scripts/* \
${EXAMPLESDIR}/BioCorba
.endif # defined(WITH_CORBA)
.endif # !defined(NOPORTDOCS)
(cd ${WRKSRC} && ${PYTHON_SETUP} install -c -O1 --prefix=${PREFIX})
.include <bsd.port.mk>

View File

@ -1,2 +1 @@
MD5 (biopython-1.00a4.tar.gz) = bca77b4242c9a8495f60c7475b884c5d
MD5 (biopython-corba-0.3.0.tar.gz) = 4465f240d22b113314c70b1dc8ebc41c
MD5 (biopython-1.23.tar.gz) = 45ea628621c6b04d471f029ef5873aaf

View File

@ -1,12 +0,0 @@
---------------------------------------------------------------------------
Biopython is currently being built without CORBA support. If you wish to
enable the optional CORBA support, set the WITH_CORBA variable, e.g.:
make WITH_CORBA=yes install
If you set WITH_CORBA, you may optionally also set the CORBA_ORB variable
to "omniorb", "fnorb" or "orbit". If you do not, "omniorb" is assumed as
default.
Further details are provided in the comments in this port's Makefile.
---------------------------------------------------------------------------

View File

@ -1,11 +0,0 @@
--- setup.py.orig Fri Jul 6 01:55:51 2001
+++ setup.py Fri Jul 6 18:13:35 2001
@@ -188,7 +188,7 @@
# Martel -- for building parsers
martel_packages = ['Martel']
# a flag to determine if we should install Martel
-INSTALL_MARTEL = 1
+INSTALL_MARTEL = 0
# -- setup the packages list
all_packages = biopython_packages

File diff suppressed because it is too large Load Diff

View File

@ -1,17 +0,0 @@
#!/bin/sh
PATH=$PATH:/usr/local/bin
if [ "x$1" = "xINSTALL" -o "x$2" = "xINSTALL" ]; then
PYTHON_GT=`python -c 'import string, sys; \
print string.split(sys.version)[0] >= "2.0" and 1'`
if [ "x${PYTHON_GT}" = "x1" ]; then
exit 0
else
echo "-----------------------------------------------------------"
echo "Biopython requires Python version 2.0 or greater - "
echo " please update your Python installation before proceeding."
echo "-----------------------------------------------------------"
exit 1
fi
fi