Adding MPFI, a Multiple Precision Floating-point Interval library.

To be used by SageMath.
This commit is contained in:
Thierry Thomas 2020-04-02 16:10:45 +00:00
parent 19d02a98d9
commit 7d86d4acc3
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=530383
6 changed files with 63 additions and 0 deletions

View File

@ -399,6 +399,7 @@
SUBDIR += moo
SUBDIR += mpc
SUBDIR += mpexpr
SUBDIR += mpfi
SUBDIR += mpfr
SUBDIR += mpfrc++
SUBDIR += mpir

26
math/mpfi/Makefile Normal file
View File

@ -0,0 +1,26 @@
# Created by: thierry@pompo.net
# $FreeBSD$
PORTNAME= mpfi
PORTVERSION= 1.5.4
CATEGORIES= math
MASTER_SITES= https://gforge.inria.fr/frs/download.php/file/38111/
MAINTAINER= thierry@FreeBSD.org
COMMENT= Multiple Precision Floating-point Interval library
LICENSE= LGPL3 GPLv3
LICENSE_COMB= dual
BUILD_DEPENDS= makeinfo:print/texinfo
LIB_DEPENDS= libgmp.so:math/gmp \
libmpfr.so:math/mpfr
USES= autoreconf libtool localbase
INFO= ${PORTNAME}
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
.include <bsd.port.mk>

3
math/mpfi/distinfo Normal file
View File

@ -0,0 +1,3 @@
TIMESTAMP = 1585759151
SHA256 (mpfi-1.5.4.tar.gz) = 3b3938595d720af17973deaf727cfc0dd41c8b16c20adc103a970f4a43ae3a56
SIZE (mpfi-1.5.4.tar.gz) = 261696

View File

@ -0,0 +1,10 @@
--- tests/mpfi-tests.h.orig 2019-08-01 20:07:19 UTC
+++ tests/mpfi-tests.h
@@ -27,6 +27,7 @@ MA 02110-1301, USA. */
#ifndef __MPFI_TESTS_H__
#define __MPFI_TESTS_H__
+#include <sys/types.h>
#include <stdlib.h>
#include "mpfi_io.h"

17
math/mpfi/pkg-descr Normal file
View File

@ -0,0 +1,17 @@
MPFI is a library for interval arithmetic, which is built upon the MPFR
multiple precision floating-point arithmetic.
MPFI is intended to be a portable library written in C for arbitrary
precision interval arithmetic with intervals represented using MPFR
reliable floating-point numbers. It is based on the GNU MP library and
on the MPFR library. The purpose of an arbitrary precision interval
arithmetic is on the one hand to get "guaranteed" results, thanks to
interval computation, and on the other hand to obtain accurate results,
thanks to multiple precision arithmetic. The MPFI library is built upon
MPFR in order to benefit from the correct rounding provided, for each
operation or function, by MPFR. Further advantages of using MPFR are
its portability and compliance with the IEEE 754 standard for
floating-point arithmetic.
WWW: http://perso.ens-lyon.fr/nathalie.revol/software.html
www: http://mpfi.gforge.inria.fr/

6
math/mpfi/pkg-plist Normal file
View File

@ -0,0 +1,6 @@
include/mpfi.h
include/mpfi_io.h
lib/libmpfi.a
lib/libmpfi.so
lib/libmpfi.so.0
lib/libmpfi.so.0.0.0