- Fix a build breakage when -fno-common is specified.
- Minor style fixes.
This commit is contained in:
parent
40d782eccd
commit
7d6e9df4a5
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=545978
@ -29,11 +29,11 @@ post-extract:
|
||||
@cd ${WRKSRC} && ${MKDIR} ${PROGDIRS} ${LIBDIRS}
|
||||
|
||||
post-patch: apply-slist
|
||||
@${INSTALL_DATA} ${WRKDIR}/BSDMakefile ${WRKSRC}
|
||||
@for D in ${PROGDIRS}; do \
|
||||
${INSTALL_DATA} ${WRKDIR}/BSDMakefile ${WRKSRC}
|
||||
for D in ${PROGDIRS}; do \
|
||||
${INSTALL_DATA} ${WRKDIR}/Makefile ${WRKSRC}/$$D; \
|
||||
done
|
||||
@for D in ${LIBDIRS}; do \
|
||||
for D in ${LIBDIRS}; do \
|
||||
${INSTALL_DATA} ${WRKDIR}/Makefile.lib ${WRKSRC}/$$D/Makefile; \
|
||||
done
|
||||
|
||||
@ -41,8 +41,10 @@ post-install:
|
||||
${INSTALL_SCRIPT} ${WRKSRC}/tools/blackhole6 ${WRKSRC}/tools/script6 \
|
||||
${STAGEDIR}${PREFIX}/sbin
|
||||
|
||||
pre-install-DOCS-on:
|
||||
${MKDIR} ${STAGEDIR}${DOCSDIR}
|
||||
|
||||
post-install-DOCS-on:
|
||||
@${MKDIR} ${STAGEDIR}${DOCSDIR}
|
||||
cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
11
security/ipv6toolkit/files/patch-tools-flow6.c
Normal file
11
security/ipv6toolkit/files/patch-tools-flow6.c
Normal file
@ -0,0 +1,11 @@
|
||||
--- tools/flow6.c.orig 2015-04-05 14:00:06 UTC
|
||||
+++ tools/flow6.c
|
||||
@@ -86,7 +86,7 @@ unsigned int pktbytes;
|
||||
bpf_u_int32 my_netmask;
|
||||
bpf_u_int32 my_ip;
|
||||
struct bpf_program pcap_filter;
|
||||
-char dev[64], errbuf[PCAP_ERRBUF_SIZE];
|
||||
+char dev[64];
|
||||
unsigned char buffer[65556], buffrh[MIN_IPV6_HLEN + MIN_TCP_HLEN];
|
||||
unsigned char *v6buffer, *ptr, *startofprefixes;
|
||||
char *pref;
|
13
security/ipv6toolkit/files/patch-tools-libipv6.c
Normal file
13
security/ipv6toolkit/files/patch-tools-libipv6.c
Normal file
@ -0,0 +1,13 @@
|
||||
--- tools/libipv6.c.orig 2015-04-05 14:01:29 UTC
|
||||
+++ tools/libipv6.c
|
||||
@@ -70,8 +70,8 @@ sigjmp_buf env;
|
||||
unsigned int canjump;
|
||||
|
||||
/* pcap variables */
|
||||
-char errbuf[PCAP_ERRBUF_SIZE];
|
||||
-struct bpf_program pcap_filter;
|
||||
+static char errbuf[PCAP_ERRBUF_SIZE];
|
||||
+static struct bpf_program pcap_filter;
|
||||
|
||||
#ifdef __linux__
|
||||
/* Netlink requests */
|
@ -1,5 +1,16 @@
|
||||
--- tools/scan6.c.orig 2015-04-05 14:03:21 UTC
|
||||
+++ tools/scan6.c
|
||||
@@ -251,8 +251,8 @@ uint16_t service_ports_dec[]={21, 22, 23, 25, 49, 5
|
||||
|
||||
|
||||
/* IPv6 Address Resolution */
|
||||
-sigjmp_buf env;
|
||||
-unsigned int canjump;
|
||||
+extern sigjmp_buf env;
|
||||
+extern unsigned int canjump;
|
||||
|
||||
int main(int argc, char **argv){
|
||||
extern char *optarg;
|
||||
@@ -1504,9 +1504,11 @@ int main(int argc, char **argv){
|
||||
if(!pps_f && !bps_f)
|
||||
pktinterval= 1000;
|
||||
|
Loading…
Reference in New Issue
Block a user