math/gnuplot: 4.6.6 -> 5.0.1

- Changes:
  http://www.gnuplot.info/ReleaseNotes_5_0_1.html
- The "gnuplot mode" elisp and TeX files for use with emacs are now
  maintained as a separate project

PR:		204886
Submitted by:	pi
Approved by:	glewis (maintainer), via mail
This commit is contained in:
Kurt Jaeger 2015-12-01 20:18:31 +00:00
parent 2ed3b91c0e
commit 7d6ce6223e
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=402781
5 changed files with 45 additions and 211 deletions

View File

@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= gnuplot
PORTVERSION= 4.6.6
PORTREVISION= 2
PORTVERSION= 5.0.1
CATEGORIES= math graphics
MASTER_SITES= SF
@ -14,14 +13,14 @@ USE_TEX= kpathsea
GNU_CONFIGURE= yes
LDFLAGS+= -L${LOCALBASE}/lib ${ICONV_LIB}
CONFIGURE_ENV= LUA_VER="${LUA_VER}"
CONFIGURE_ARGS+=--with-lasergnu \
--with-readline=gnu \
CONFIGURE_ARGS+=--with-readline=gnu \
--with-kpsexpand \
--without-linux-vga \
--without-lisp-files \
--without-tutorial \
--with-bitmap-terminals \
--with-latex \
--with-qt=no \
ac_cv_prog_KPSEXPAND=${LOCALBASE}/bin/kpsexpand \
ac_cv_prog_PLAINTEX=${LOCALBASE}/bin/tex \
ac_cv_prog_LATEX=${LOCALBASE}/bin/latex \
@ -29,6 +28,8 @@ CONFIGURE_ARGS+=--with-lasergnu \
PORTDOCS= *
PORTEXAMPLES= *
# MAKE_JOBS_UNSAFE=yes
OPTIONS_DEFINE= CAIRO DOCS EXAMPLES GD GRIDBOX PDF PLOT THINSPLINES WX X11
GRIDBOX_DESC= Use the gridbox optimization for hidden3d
PLOT_DESC= Enable plot support
@ -86,7 +87,6 @@ post-build:
.endif
post-install:
${INSTALL_SCRIPT} ${WRKSRC}/src/lasergnu ${STAGEDIR}${PREFIX}/bin
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
cd ${WRKSRC}/demo && ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR}
.if ${PORT_OPTIONS:MDOCS}

View File

@ -1,2 +1,2 @@
SHA256 (gnuplot-4.6.6.tar.gz) = 1f19596fd09045f22225afbfec11fa91b9ad1d95b9f48406362f517d4f130274
SIZE (gnuplot-4.6.6.tar.gz) = 5059214
SHA256 (gnuplot-5.0.1.tar.gz) = 7cbc557e71df581ea520123fb439dea5f073adcc9010a2885dc80d4ed28b3c47
SIZE (gnuplot-5.0.1.tar.gz) = 4963747

View File

@ -1,108 +0,0 @@
--- configure.orig 2014-09-22 03:26:10.000000000 +0900
+++ configure 2014-12-06 14:27:21.000000000 +0900
@@ -5982,7 +5982,7 @@
fi
-if test "${build}" != "${host}"
+if test "$cross_compiling" != no
then
CC=${CC-${host_alias-gcc}}
CFLAGS=${CFLAGS-"-g -O2"}
@@ -10844,12 +10844,12 @@
pkg_cv_LUA_CFLAGS="$LUA_CFLAGS"
else
if test -n "$PKG_CONFIG" && \
- { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"lua5.1\""; } >&5
- ($PKG_CONFIG --exists --print-errors "lua5.1") 2>&5
+ { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"lua-${LUA_VER}\""; } >&5
+ ($PKG_CONFIG --exists --print-errors "lua-${LUA_VER}") 2>&5
ac_status=$?
$as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
test $ac_status = 0; }; then
- pkg_cv_LUA_CFLAGS=`$PKG_CONFIG --cflags "lua5.1" 2>/dev/null`
+ pkg_cv_LUA_CFLAGS=`$PKG_CONFIG --cflags "lua-${LUA_VER}" 2>/dev/null`
else
pkg_failed=yes
fi
@@ -10862,12 +10862,12 @@
pkg_cv_LUA_LIBS="$LUA_LIBS"
else
if test -n "$PKG_CONFIG" && \
- { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"lua5.1\""; } >&5
- ($PKG_CONFIG --exists --print-errors "lua5.1") 2>&5
+ { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"lua-${LUA_VER}\""; } >&5
+ ($PKG_CONFIG --exists --print-errors "lua-${LUA_VER}") 2>&5
ac_status=$?
$as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
test $ac_status = 0; }; then
- pkg_cv_LUA_LIBS=`$PKG_CONFIG --libs "lua5.1" 2>/dev/null`
+ pkg_cv_LUA_LIBS=`$PKG_CONFIG --libs "lua-${LUA_VER}" 2>/dev/null`
else
pkg_failed=yes
fi
@@ -10886,9 +10886,9 @@
_pkg_short_errors_supported=no
fi
if test $_pkg_short_errors_supported = yes; then
- LUA_PKG_ERRORS=`$PKG_CONFIG --short-errors --errors-to-stdout --print-errors "lua5.1"`
+ LUA_PKG_ERRORS=`$PKG_CONFIG --short-errors --errors-to-stdout --print-errors "lua-${LUA_VER}"`
else
- LUA_PKG_ERRORS=`$PKG_CONFIG --errors-to-stdout --print-errors "lua5.1"`
+ LUA_PKG_ERRORS=`$PKG_CONFIG --errors-to-stdout --print-errors "lua-${LUA_VER}"`
fi
# Put the nasty error message in config.log where it belongs
echo "$LUA_PKG_ERRORS" >&5
@@ -10920,12 +10920,12 @@
pkg_cv_LUA_CFLAGS="$LUA_CFLAGS"
else
if test -n "$PKG_CONFIG" && \
- { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"lua5.1\""; } >&5
- ($PKG_CONFIG --exists --print-errors "lua5.1") 2>&5
+ { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"lua-${LUA_VER}\""; } >&5
+ ($PKG_CONFIG --exists --print-errors "lua-${LUA_VER}") 2>&5
ac_status=$?
$as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
test $ac_status = 0; }; then
- pkg_cv_LUA_CFLAGS=`$PKG_CONFIG --cflags "lua5.1" 2>/dev/null`
+ pkg_cv_LUA_CFLAGS=`$PKG_CONFIG --cflags "lua-${LUA_VER}" 2>/dev/null`
else
pkg_failed=yes
fi
@@ -10938,12 +10938,12 @@
pkg_cv_LUA_LIBS="$LUA_LIBS"
else
if test -n "$PKG_CONFIG" && \
- { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"lua5.1\""; } >&5
- ($PKG_CONFIG --exists --print-errors "lua5.1") 2>&5
+ { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"lua-${LUA_VER}\""; } >&5
+ ($PKG_CONFIG --exists --print-errors "lua-${LUA_VER}") 2>&5
ac_status=$?
$as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
test $ac_status = 0; }; then
- pkg_cv_LUA_LIBS=`$PKG_CONFIG --libs "lua5.1" 2>/dev/null`
+ pkg_cv_LUA_LIBS=`$PKG_CONFIG --libs "lua-${LUA_VER}" 2>/dev/null`
else
pkg_failed=yes
fi
@@ -10962,9 +10962,9 @@
_pkg_short_errors_supported=no
fi
if test $_pkg_short_errors_supported = yes; then
- LUA_PKG_ERRORS=`$PKG_CONFIG --short-errors --errors-to-stdout --print-errors "lua5.1"`
+ LUA_PKG_ERRORS=`$PKG_CONFIG --short-errors --errors-to-stdout --print-errors "lua-${LUA_VER}"`
else
- LUA_PKG_ERRORS=`$PKG_CONFIG --errors-to-stdout --print-errors "lua5.1"`
+ LUA_PKG_ERRORS=`$PKG_CONFIG --errors-to-stdout --print-errors "lua-${LUA_VER}"`
fi
# Put the nasty error message in config.log where it belongs
echo "$LUA_PKG_ERRORS" >&5
@@ -11024,7 +11024,7 @@
return 0;
}
_ACEOF
-for ac_lib in '' lua lua5.1; do
+for ac_lib in '' lua lua-${LUA_VER}; do
if test -z "$ac_lib"; then
ac_res="none required"
else

View File

@ -1,58 +0,0 @@
--- docs/Makefile.in.orig 2013-09-23 16:16:41.000000000 -0700
+++ docs/Makefile.in 2014-04-12 20:11:45.000000000 -0700
@@ -395,15 +395,15 @@
# Thanks to Bruce Ravel for doc2texi.el!
gnuplot.texi $(srcdir)/gnuplot-eldoc.el $(srcdir)/gnuplot-eldoc.elc: $(srcdir)/doc2texi.el $(srcdir)/gnuplot.doc
@echo "Creating texinfo and eldoc strings file"
- @if test "$(EMACS)" != no; then \
- test "$(top_srcdir)" = "$(top_builddir)" || echo "COPYING GNUPLOT.DOC" ; \
- test "$(top_srcdir)" = "$(top_builddir)" || cp $(srcdir)/gnuplot.doc . ; \
- $(EMACS) -batch -q --no-site-file -l $(srcdir)/doc2texi.el -f d2t-doc-to-texi ; \
- echo "Compiling gnuplot-eldoc.el" ; \
- $(EMACS) -batch -q --no-site-file -f batch-byte-compile gnuplot-eldoc.el ; \
- else \
- echo "No emacs found - cannot create texinfo file" ; \
- fi
+# @if test "$(EMACS)" != no; then \
+# test "$(top_srcdir)" = "$(top_builddir)" || echo "COPYING GNUPLOT.DOC" ; \
+# test "$(top_srcdir)" = "$(top_builddir)" || cp $(srcdir)/gnuplot.doc . ; \
+# $(EMACS) -batch -q --no-site-file -l $(srcdir)/doc2texi.el -f d2t-doc-to-texi ; \
+# echo "Compiling gnuplot-eldoc.el" ; \
+# $(EMACS) -batch -q --no-site-file -f batch-byte-compile gnuplot-eldoc.el ; \
+# else \
+# echo "No emacs found - cannot create texinfo file" ; \
+# fi
# this is how to make OS/2 ipfc documentation
@@ -463,18 +463,18 @@
$(INSTALL_DATA) gnuplot.pdf $(DESTDIR)$(GIHDIR)/gnuplot.pdf; \
fi
-install-info: gnuplot.info gnuplot-eldoc.el gnuplot-eldoc.elc
- @if test "$(EMACS)" != no; then \
- $(top_srcdir)/mkinstalldirs $(DESTDIR)$(infodir) $(DESTDIR)$(lispdir); \
- $(INSTALL_DATA) gnuplot.info $(DESTDIR)$(infodir)/gnuplot.info; \
- $(INSTALL_DATA) gnuplot-eldoc.el $(DESTDIR)$(lispdir)/gnuplot-eldoc.el; \
- $(INSTALL_DATA) gnuplot-eldoc.elc $(DESTDIR)$(lispdir)/gnuplot-eldoc.elc; \
- else : ; fi
- @if (test "$(EMACS)" != no && install-info --version && \
- install-info --version | fgrep -i -v debian) >/dev/null 2>&1; then \
- echo "install-info --info-dir=$(DESTDIR)$(infodir) $(DESTDIR)$(infodir)/gnuplot.info";\
- install-info --info-dir=$(DESTDIR)$(infodir) $(DESTDIR)$(infodir)/gnuplot.info || :;\
- else : ; fi
+install-info:
+# @if test "$(EMACS)" != no; then \
+# $(top_srcdir)/mkinstalldirs $(DESTDIR)$(infodir) $(DESTDIR)$(lispdir); \
+# $(INSTALL_DATA) gnuplot.info $(DESTDIR)$(infodir)/gnuplot.info; \
+# $(INSTALL_DATA) gnuplot-eldoc.el $(DESTDIR)$(lispdir)/gnuplot-eldoc.el; \
+# $(INSTALL_DATA) gnuplot-eldoc.elc $(DESTDIR)$(lispdir)/gnuplot-eldoc.elc; \
+# else : ; fi
+# @if (test "$(EMACS)" != no && install-info --version && \
+# install-info --version | fgrep -i -v debian) >/dev/null 2>&1; then \
+# echo "install-info --info-dir=$(DESTDIR)$(infodir) $(DESTDIR)$(infodir)/gnuplot.info";\
+# install-info --info-dir=$(DESTDIR)$(infodir) $(DESTDIR)$(infodir)/gnuplot.info || :;\
+# else : ; fi
installcheck:

View File

@ -1,40 +1,40 @@
bin/gnuplot
bin/lasergnu
%%X11%%libexec/gnuplot/4.6/gnuplot_x11
%%X11%%libexec/gnuplot/5.0/gnuplot_x11
man/man1/gnuplot.1.gz
man/man1/lasergnu.1.gz
%%DATADIR%%/4.6/PostScript/8859-1.ps
%%DATADIR%%/4.6/PostScript/8859-15.ps
%%DATADIR%%/4.6/PostScript/8859-2.ps
%%DATADIR%%/4.6/PostScript/8859-9.ps
%%DATADIR%%/4.6/PostScript/aglfn.txt
%%DATADIR%%/4.6/PostScript/cp1250.ps
%%DATADIR%%/4.6/PostScript/cp1251.ps
%%DATADIR%%/4.6/PostScript/cp437.ps
%%DATADIR%%/4.6/PostScript/cp850.ps
%%DATADIR%%/4.6/PostScript/cp852.ps
%%DATADIR%%/4.6/PostScript/koi8r.ps
%%DATADIR%%/4.6/PostScript/koi8u.ps
%%DATADIR%%/4.6/PostScript/prologue.ps
%%DATADIR%%/4.6/PostScript/utf-8.ps
%%X11%%%%DATADIR%%/4.6/app-defaults/Gnuplot
%%DATADIR%%/4.6/colors_default.gp
%%DATADIR%%/4.6/colors_mono.gp
%%DATADIR%%/4.6/colors_podo.gp
%%DATADIR%%/4.6/gnuplot.gih
%%DATADIR%%/4.6/gnuplot.pdf
%%DATADIR%%/4.6/gnuplotrc
%%DATADIR%%/4.6/js/README
%%DATADIR%%/4.6/js/canvasmath.js
%%DATADIR%%/4.6/js/canvastext.js
%%DATADIR%%/4.6/js/gnuplot_common.js
%%DATADIR%%/4.6/js/gnuplot_dashedlines.js
%%DATADIR%%/4.6/js/gnuplot_mouse.css
%%DATADIR%%/4.6/js/gnuplot_mouse.js
%%DATADIR%%/4.6/js/gnuplot_svg.js
%%DATADIR%%/4.6/js/grid.png
%%DATADIR%%/4.6/js/help.png
%%DATADIR%%/4.6/js/nextzoom.png
%%DATADIR%%/4.6/js/previouszoom.png
%%DATADIR%%/4.6/js/textzoom.png
%%DATADIR%%/4.6/lua/gnuplot-tikz.lua
man/man1/gnuplot-ja.1.gz
%%DATADIR%%/5.0/PostScript/8859-1.ps
%%DATADIR%%/5.0/PostScript/8859-15.ps
%%DATADIR%%/5.0/PostScript/8859-2.ps
%%DATADIR%%/5.0/PostScript/8859-9.ps
%%DATADIR%%/5.0/PostScript/aglfn.txt
%%DATADIR%%/5.0/PostScript/cp1250.ps
%%DATADIR%%/5.0/PostScript/cp1251.ps
%%DATADIR%%/5.0/PostScript/cp1252.ps
%%DATADIR%%/5.0/PostScript/cp437.ps
%%DATADIR%%/5.0/PostScript/cp850.ps
%%DATADIR%%/5.0/PostScript/cp852.ps
%%DATADIR%%/5.0/PostScript/koi8r.ps
%%DATADIR%%/5.0/PostScript/koi8u.ps
%%DATADIR%%/5.0/PostScript/prologue.ps
%%DATADIR%%/5.0/PostScript/utf-8.ps
%%X11%%%%DATADIR%%/5.0/app-defaults/Gnuplot
%%DATADIR%%/5.0/colors_default.gp
%%DATADIR%%/5.0/colors_mono.gp
%%DATADIR%%/5.0/colors_podo.gp
%%DATADIR%%/5.0/gnuplot.gih
%%DATADIR%%/5.0/gnuplotrc
%%DATADIR%%/5.0/js/README
%%DATADIR%%/5.0/js/canvasmath.js
%%DATADIR%%/5.0/js/canvastext.js
%%DATADIR%%/5.0/js/gnuplot_common.js
%%DATADIR%%/5.0/js/gnuplot_dashedlines.js
%%DATADIR%%/5.0/js/gnuplot_mouse.css
%%DATADIR%%/5.0/js/gnuplot_mouse.js
%%DATADIR%%/5.0/js/gnuplot_svg.js
%%DATADIR%%/5.0/js/grid.png
%%DATADIR%%/5.0/js/help.png
%%DATADIR%%/5.0/js/nextzoom.png
%%DATADIR%%/5.0/js/previouszoom.png
%%DATADIR%%/5.0/js/return.png
%%DATADIR%%/5.0/js/textzoom.png
%%DATADIR%%/5.0/lua/gnuplot-tikz.lua