- Update to 1.4.23
PR: 136026 Submitted by: Martin Matuska <mm___FreeBSD.org>
This commit is contained in:
parent
6317da651a
commit
7d14c56f2e
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=236704
@ -6,8 +6,7 @@
|
||||
#
|
||||
|
||||
PORTNAME= lighttpd
|
||||
PORTVERSION= 1.4.22
|
||||
PORTREVISION= 2
|
||||
PORTVERSION= 1.4.23
|
||||
CATEGORIES= www
|
||||
MASTER_SITES= http://www.lighttpd.net/download/ \
|
||||
http://mirrors.cat.pdx.edu/lighttpd/
|
||||
@ -27,7 +26,7 @@ CONFIGURE_ARGS= --libdir=${PREFIX}/lib/lighttpd
|
||||
CFLAGS+= -I${LOCALBASE}/include
|
||||
LDFLAGS+= -L${LOCALBASE}/lib
|
||||
|
||||
MAN1= lighttpd.1
|
||||
MAN8= lighttpd.8
|
||||
|
||||
OPTIONS= BZIP2 "Enable Bzip2 support" off \
|
||||
CML "Enable Cache Meta Language support" off \
|
||||
@ -123,7 +122,7 @@ CONFIGURE_ARGS+= --with-webdav-props --with-webdav-locks
|
||||
SUB_LIST+= REQUIRE="${_REQUIRE}"
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|-std=gnu99||' ${WRKSRC}/configure.in
|
||||
@${REINPLACE_CMD} -e 's|-std=gnu99||' ${WRKSRC}/configure ${WRKSRC}/configure.ac
|
||||
@${REINPLACE_CMD} -E -e 's|(server.document-root.*=).*|\1 "${PREFIX}/www/data/"|' \
|
||||
-e 's|(server.errorlog.*=).*|\1 "/var/log/lighttpd.error.log"|' \
|
||||
-e 's|# server.event-handler|server.event-handler|' \
|
||||
|
@ -1,3 +1,3 @@
|
||||
MD5 (lighttpd-1.4.22.tar.bz2) = ed4ca3897eadf419c893b03fee53c982
|
||||
SHA256 (lighttpd-1.4.22.tar.bz2) = 6d217dd47fbbf431ee37aa6f12604411204be1fb37bc2a70e14d15dab507c451
|
||||
SIZE (lighttpd-1.4.22.tar.bz2) = 657939
|
||||
MD5 (lighttpd-1.4.23.tar.bz2) = 0ab6bb7b17bf0f515ce7dce68e5e215a
|
||||
SHA256 (lighttpd-1.4.23.tar.bz2) = 72896e6677b12aee2371c12e6d3f8299cfbdb2f89ad4b519a96b3ba80852a5fa
|
||||
SIZE (lighttpd-1.4.23.tar.bz2) = 641621
|
||||
|
@ -1,11 +0,0 @@
|
||||
--- doc/Makefile.in.orig 2009-04-25 00:55:41.000000000 -0300
|
||||
+++ doc/Makefile.in 2009-04-25 00:56:00.000000000 -0300
|
||||
@@ -189,7 +189,7 @@
|
||||
target_vendor = @target_vendor@
|
||||
top_builddir = @top_builddir@
|
||||
top_srcdir = @top_srcdir@
|
||||
-dist_man1_MANS = lighttpd.1 spawn-fcgi.1
|
||||
+dist_man1_MANS = lighttpd.1
|
||||
DOCS = accesslog.txt \
|
||||
authentication.txt \
|
||||
cgi.txt \
|
@ -1,66 +0,0 @@
|
||||
--- src/Makefile.in.orig 2009-04-25 00:52:47.000000000 -0300
|
||||
+++ src/Makefile.in 2009-04-25 00:54:11.000000000 -0300
|
||||
@@ -37,7 +37,6 @@
|
||||
target_triplet = @target@
|
||||
noinst_PROGRAMS = proc_open$(EXEEXT) lemon$(EXEEXT)
|
||||
sbin_PROGRAMS = lighttpd$(EXEEXT) lighttpd-angel$(EXEEXT)
|
||||
-bin_PROGRAMS = spawn-fcgi$(EXEEXT)
|
||||
|
||||
# if the linker doesn't allow referencing symbols of the binary
|
||||
# we have to put everything into a shared-lib and link it into
|
||||
@@ -380,9 +379,6 @@
|
||||
proc_open-buffer.$(OBJEXT)
|
||||
proc_open_OBJECTS = $(am_proc_open_OBJECTS)
|
||||
proc_open_LDADD = $(LDADD)
|
||||
-am_spawn_fcgi_OBJECTS = spawn-fcgi.$(OBJEXT)
|
||||
-spawn_fcgi_OBJECTS = $(am_spawn_fcgi_OBJECTS)
|
||||
-spawn_fcgi_LDADD = $(LDADD)
|
||||
DEFAULT_INCLUDES = -I.@am__isrc@ -I$(top_builddir)
|
||||
depcomp = $(SHELL) $(top_srcdir)/depcomp
|
||||
am__depfiles_maybe = depfiles
|
||||
@@ -412,8 +408,7 @@
|
||||
$(mod_status_la_SOURCES) $(mod_trigger_b4_dl_la_SOURCES) \
|
||||
$(mod_userdir_la_SOURCES) $(mod_usertrack_la_SOURCES) \
|
||||
$(mod_webdav_la_SOURCES) $(lemon_SOURCES) $(lighttpd_SOURCES) \
|
||||
- $(lighttpd_angel_SOURCES) $(proc_open_SOURCES) \
|
||||
- $(spawn_fcgi_SOURCES)
|
||||
+ $(lighttpd_angel_SOURCES) $(proc_open_SOURCES)
|
||||
DIST_SOURCES = $(am__liblightcomp_la_SOURCES_DIST) \
|
||||
$(mod_access_la_SOURCES) $(mod_accesslog_la_SOURCES) \
|
||||
$(mod_alias_la_SOURCES) $(mod_auth_la_SOURCES) \
|
||||
@@ -432,8 +427,7 @@
|
||||
$(mod_trigger_b4_dl_la_SOURCES) $(mod_userdir_la_SOURCES) \
|
||||
$(mod_usertrack_la_SOURCES) $(mod_webdav_la_SOURCES) \
|
||||
$(lemon_SOURCES) $(am__lighttpd_SOURCES_DIST) \
|
||||
- $(lighttpd_angel_SOURCES) $(proc_open_SOURCES) \
|
||||
- $(spawn_fcgi_SOURCES)
|
||||
+ $(lighttpd_angel_SOURCES) $(proc_open_SOURCES)
|
||||
HEADERS = $(noinst_HEADERS)
|
||||
ETAGS = etags
|
||||
CTAGS = ctags
|
||||
@@ -605,7 +599,6 @@
|
||||
|
||||
src = server.c response.c connections.c network.c configfile.c \
|
||||
configparser.c request.c proc_open.c $(am__append_2)
|
||||
-spawn_fcgi_SOURCES = spawn-fcgi.c
|
||||
|
||||
#lib_LTLIBRARIES += mod_httptls.la
|
||||
#mod_httptls_la_SOURCES = mod_httptls.c
|
||||
@@ -963,9 +956,6 @@
|
||||
proc_open$(EXEEXT): $(proc_open_OBJECTS) $(proc_open_DEPENDENCIES)
|
||||
@rm -f proc_open$(EXEEXT)
|
||||
$(LINK) $(proc_open_OBJECTS) $(proc_open_LDADD) $(LIBS)
|
||||
-spawn-fcgi$(EXEEXT): $(spawn_fcgi_OBJECTS) $(spawn_fcgi_DEPENDENCIES)
|
||||
- @rm -f spawn-fcgi$(EXEEXT)
|
||||
- $(LINK) $(spawn_fcgi_OBJECTS) $(spawn_fcgi_LDADD) $(LIBS)
|
||||
|
||||
mostlyclean-compile:
|
||||
-rm -f *.$(OBJEXT)
|
||||
@@ -1098,7 +1088,6 @@
|
||||
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/request.Po@am__quote@
|
||||
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/response.Po@am__quote@
|
||||
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/server.Po@am__quote@
|
||||
-@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/spawn-fcgi.Po@am__quote@
|
||||
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/splaytree.Po@am__quote@
|
||||
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/stat_cache.Po@am__quote@
|
||||
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/status_counter.Po@am__quote@
|
@ -1,21 +0,0 @@
|
||||
#
|
||||
# Do not remove until http://www.freebsd.org/cgi/query-pr.cgi?pr=kern/21768
|
||||
# is not applied and release new versions.
|
||||
#
|
||||
Index: stat_cache.c
|
||||
===================================================================
|
||||
--- src/stat_cache.c (revision 1006)
|
||||
+++ src/stat_cache.c (revision 1008)
|
||||
@@ -487,6 +487,12 @@
|
||||
|
||||
|
||||
if (S_ISREG(st.st_mode)) {
|
||||
+ /* fix broken stat/open for symlinks to reg files with appended slash on freebsd,osx */
|
||||
+ if (name->ptr[name->used-2] == '/') {
|
||||
+ errno = ENOTDIR;
|
||||
+ return HANDLER_ERROR;
|
||||
+ }
|
||||
+
|
||||
/* try to open the file to check if we can read it */
|
||||
if (-1 == (fd = open(name->ptr, O_RDONLY))) {
|
||||
return HANDLER_ERROR;
|
Loading…
Reference in New Issue
Block a user