devel/libaravis: multimedia/aravis: update to 0.8.20

ChangeLog: https://github.com/AravisProject/aravis/pull/620

PR:	261103
Reported by:	rozhuk.im@gmail.com (maintainer)
Reviewed by:	diizzy@
This commit is contained in:
Ivan Rozhuk 2022-01-14 13:45:40 +01:00 committed by Fernando Apesteguía
parent 0f4d994347
commit 7d0f2b043d
12 changed files with 267 additions and 300 deletions

View File

@ -1,49 +1,48 @@
# Created by: Rozhuk Ivan
PORTNAME= libaravis
DISTVERSIONPREFIX= ARAVIS_
DISTVERSION= 0_5_12
DISTVERSION= 0.8.20
CATEGORIES= devel
PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
PATCHFILES= cb27eb4e4c38553b6dfbbc70cc18caa51a365107.patch:-p1 # FreeBSD support
MAINTAINER= rozhuk.im@gmail.com
COMMENT= Camera control and image acquisition library
LICENSE= LGPL21+
LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= g-ir-compiler:devel/gobject-introspection
CONFLICTS_INSTALL= ${PORTNAME}*
USES= autoreconf gmake gnome libtool pkgconfig
USES= gnome libtool meson pkgconfig
USE_GITHUB= yes
GH_ACCOUNT= AravisProject
GH_PROJECT= aravis
USE_GNOME= glib20 intltool libxml2
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
INSTALL_TARGET= install-strip
CONFIGURE_ARGS= --enable-packet-socket=no --enable-viewer=no \
--enable-gst-plugin=no --enable-gst-0.10-plugin=no \
--enable-cpp-test=no --enable-zlib-pc=yes
MAKE_ARGS= pkgconfigdir="${PREFIX}/libdata/pkgconfig"
MESON_ARGS= -Dpacket-socket=disabled -Dviewer=disabled \
-Dgst-plugin=disabled -Dtests=false
DOCSDIR= ${PREFIX}/share/doc/aravis/aravis-0.6
DOCSDIR= ${PREFIX}/share/gtk-doc/html/aravis-0.8
OPTIONS_DEFINE= DOCS NLS FAST_HEARTBEAT USB
OPTIONS_DEFINE= DOCS GIR NLS FAST_HEARTBEAT USB
OPTIONS_DEFAULT= USB
OPTIONS_SUB= yes
DOCS_MESON_ENABLED= documentation
DOCS_BUILD_DEPENDS= gtkdoc-scan:textproc/gtk-doc
GIR_DESC= Build Gobject Introspection
GIR_USE= GNOME=introspection:build
GIR_MESON_ENABLED= introspection
NLS_USES= gettext
FAST_HEARTBEAT_DESC= build with extremely fast heartbeat
FAST_HEARTBEAT_CONFIGURE_ENABLE= fast-heartbeat
FAST_HEARTBEAT_MESON_TRUE= fast-heartbeat
USB_DESC= build with USB support
USB_CONFIGURE_ENABLE= usb
pre-configure:
@${ECHO_CMD} "EXTRA_DIST =" >> ${WRKSRC}/gtk-doc.make
USB_MESON_ENABLED= usb
.include <bsd.port.mk>

View File

@ -1,3 +1,5 @@
TIMESTAMP = 1526105762
SHA256 (AravisProject-aravis-ARAVIS_0_5_12_GH0.tar.gz) = 61467edecb96f7d315770f8d874860e42b2981200edb8bba879f46ec9a83e0b2
SIZE (AravisProject-aravis-ARAVIS_0_5_12_GH0.tar.gz) = 2986578
TIMESTAMP = 1642061635
SHA256 (AravisProject-aravis-0.8.20_GH0.tar.gz) = d8d15970a08538f1c61372a378750451c03856184b60dd6d8c657dca23690135
SIZE (AravisProject-aravis-0.8.20_GH0.tar.gz) = 950371
SHA256 (cb27eb4e4c38553b6dfbbc70cc18caa51a365107.patch) = dfd78636b349f6ba02fc3db9aa5bbd149e52fe4d4e54fd95126bbe5f8a470445
SIZE (cb27eb4e4c38553b6dfbbc70cc18caa51a365107.patch) = 3086

View File

@ -1,20 +0,0 @@
--- Makefile.am.orig 2018-01-29 16:03:28 UTC
+++ Makefile.am
@@ -6,7 +6,7 @@
DISTCHECK_CONFIGURE_FLAGS = --enable-introspection --enable-gtk-doc --enable-gst-plugin --enable-gst-0.10-plugin --enable-viewer --enable-cpp-test --enable-appstream-util
-SUBDIRS = src man
+SUBDIRS = src
if ARAVIS_BUILD_VIEWER
SUBDIRS += viewer
@@ -20,7 +20,7 @@ if ARAVIS_BUILD_GST_0_10_PLUGIN
SUBDIRS += gst-0.10
endif
-SUBDIRS += tests po docs
+SUBDIRS += po docs
aravisdocdir = ${docdir}/aravis-@ARAVIS_API_VERSION@
aravisdoc_DATA = \

View File

@ -1,11 +0,0 @@
--- configure.ac.orig 2018-01-29 16:03:28 UTC
+++ configure.ac
@@ -268,7 +268,7 @@ GOBJECT_INTROSPECTION_CHECK([0.10.0])
AM_CONDITIONAL([HAVE_INTROSPECTION], [false])
enable_introspection=no])
-GTK_DOC_CHECK([1.14],[--flavour no-tmpl])
+
AM_CONDITIONAL([BUILD_GTK_DOC], [test "x$enable_gtk_doc" = "xyes" || test ! -f "autogen.sh"])
APPSTREAM_XML

View File

@ -1,27 +0,0 @@
--- src/arvgvdevice.c.orig 2017-04-10 13:30:09 UTC
+++ src/arvgvdevice.c
@@ -20,6 +20,8 @@
* @short_description: GigEVision device
*/
+#include <sys/param.h>
+
#include <arvgvdeviceprivate.h>
#include <arvdeviceprivate.h>
#include <arvgc.h>
@@ -36,9 +38,14 @@
#include <arvenumtypes.h>
#include <string.h>
#include <stdlib.h>
-#ifndef __APPLE__
+#ifdef __linux__
#include <linux/ip.h>
#endif
+#ifdef BSD
+#include <netinet/in.h>
+#include <netinet/ip.h>
+#define iphdr ip
+#endif
#include <netinet/udp.h>
static GObjectClass *parent_class = NULL;

View File

@ -1,10 +0,0 @@
--- src/arvgvinterface.c.orig 2017-04-10 13:30:09 UTC
+++ src/arvgvinterface.c
@@ -38,6 +38,7 @@
#include <sys/types.h>
#include <sys/socket.h>
#include <net/if.h>
+#include <netinet/in.h>
#include <netdb.h>
#include <ifaddrs.h>
#include <stdlib.h>

View File

@ -1,24 +0,0 @@
--- src/arvrealtime.c.orig 2017-04-10 13:30:09 UTC
+++ src/arvrealtime.c
@@ -27,6 +27,8 @@
***/
+#include <sys/param.h>
+
#include <arvrealtimeprivate.h>
#include <arvdebug.h>
#include <memory.h>
@@ -219,7 +221,12 @@ arv_rtkit_make_high_priority (GDBusConne
#endif
static pid_t _gettid(void) {
+#ifdef __linux__
return (pid_t) syscall(SYS_gettid);
+#endif
+#ifdef BSD
+ return (pid_t) pthread_self();
+#endif
}
/**

View File

@ -1,110 +1,196 @@
bin/arv-fake-gv-camera-0.6
bin/arv-test-0.6
bin/arv-tool-0.6
include/aravis-0.6/arv.h
include/aravis-0.6/arvbuffer.h
include/aravis-0.6/arvcamera.h
include/aravis-0.6/arvchunkparser.h
include/aravis-0.6/arvdebug.h
include/aravis-0.6/arvdevice.h
include/aravis-0.6/arvdomcharacterdata.h
include/aravis-0.6/arvdomdocument.h
include/aravis-0.6/arvdomdocumentfragment.h
include/aravis-0.6/arvdomelement.h
include/aravis-0.6/arvdomimplementation.h
include/aravis-0.6/arvdomnamednodemap.h
include/aravis-0.6/arvdomnode.h
include/aravis-0.6/arvdomnodelist.h
include/aravis-0.6/arvdomparser.h
include/aravis-0.6/arvdomtext.h
include/aravis-0.6/arvenums.h
include/aravis-0.6/arvenumtypes.h
include/aravis-0.6/arvevaluator.h
include/aravis-0.6/arvfakecamera.h
include/aravis-0.6/arvfakedevice.h
include/aravis-0.6/arvfakeinterface.h
include/aravis-0.6/arvfakestream.h
include/aravis-0.6/arvfeatures.h
include/aravis-0.6/arvgc.h
include/aravis-0.6/arvgcboolean.h
include/aravis-0.6/arvgccategory.h
include/aravis-0.6/arvgccommand.h
include/aravis-0.6/arvgcconverter.h
include/aravis-0.6/arvgcenumentry.h
include/aravis-0.6/arvgcenumeration.h
include/aravis-0.6/arvgcfeaturenode.h
include/aravis-0.6/arvgcfloat.h
include/aravis-0.6/arvgcfloatnode.h
include/aravis-0.6/arvgcgroupnode.h
include/aravis-0.6/arvgcindexnode.h
include/aravis-0.6/arvgcinteger.h
include/aravis-0.6/arvgcintegernode.h
include/aravis-0.6/arvgcinvalidatornode.h
include/aravis-0.6/arvgcnode.h
include/aravis-0.6/arvgcport.h
include/aravis-0.6/arvgcpropertynode.h
include/aravis-0.6/arvgcregister.h
include/aravis-0.6/arvgcregisterdescriptionnode.h
include/aravis-0.6/arvgcregisternode.h
include/aravis-0.6/arvgcstring.h
include/aravis-0.6/arvgcstructentrynode.h
include/aravis-0.6/arvgcswissknife.h
include/aravis-0.6/arvgcvalueindexednode.h
include/aravis-0.6/arvgvcp.h
include/aravis-0.6/arvgvdevice.h
include/aravis-0.6/arvgvfakecamera.h
include/aravis-0.6/arvgvinterface.h
include/aravis-0.6/arvgvsp.h
include/aravis-0.6/arvgvstream.h
include/aravis-0.6/arvinterface.h
include/aravis-0.6/arvmisc.h
include/aravis-0.6/arvrealtime.h
include/aravis-0.6/arvstr.h
include/aravis-0.6/arvstream.h
include/aravis-0.6/arvsystem.h
include/aravis-0.6/arvtypes.h
include/aravis-0.6/arvuvcp.h
include/aravis-0.6/arvuvdevice.h
include/aravis-0.6/arvuvinterface.h
include/aravis-0.6/arvuvsp.h
include/aravis-0.6/arvuvstream.h
include/aravis-0.6/arvversion.h
include/aravis-0.6/arvxmlschema.h
include/aravis-0.6/arvzip.h
lib/girepository-1.0/Aravis-0.6.typelib
lib/libaravis-0.6.a
lib/libaravis-0.6.so
lib/libaravis-0.6.so.0
lib/libaravis-0.6.so.0.0.0
libdata/pkgconfig/aravis-0.6.pc
share/aravis-0.6/arv-fake-camera.xml
%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
%%PORTDOCS%%%%DOCSDIR%%/COPYING
%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
%%PORTDOCS%%%%DOCSDIR%%/NEWS
%%PORTDOCS%%%%DOCSDIR%%/README.md
share/gir-1.0/Aravis-0.6.gir
%%NLS%%share/locale/bs/LC_MESSAGES/aravis-0.6.mo
%%NLS%%share/locale/ca/LC_MESSAGES/aravis-0.6.mo
%%NLS%%share/locale/cs/LC_MESSAGES/aravis-0.6.mo
%%NLS%%share/locale/da/LC_MESSAGES/aravis-0.6.mo
%%NLS%%share/locale/de/LC_MESSAGES/aravis-0.6.mo
%%NLS%%share/locale/el/LC_MESSAGES/aravis-0.6.mo
%%NLS%%share/locale/es/LC_MESSAGES/aravis-0.6.mo
%%NLS%%share/locale/eu/LC_MESSAGES/aravis-0.6.mo
%%NLS%%share/locale/fi/LC_MESSAGES/aravis-0.6.mo
%%NLS%%share/locale/fr/LC_MESSAGES/aravis-0.6.mo
%%NLS%%share/locale/hu/LC_MESSAGES/aravis-0.6.mo
%%NLS%%share/locale/id/LC_MESSAGES/aravis-0.6.mo
%%NLS%%share/locale/lv/LC_MESSAGES/aravis-0.6.mo
%%NLS%%share/locale/oc/LC_MESSAGES/aravis-0.6.mo
%%NLS%%share/locale/pl/LC_MESSAGES/aravis-0.6.mo
%%NLS%%share/locale/pt/LC_MESSAGES/aravis-0.6.mo
%%NLS%%share/locale/pt_BR/LC_MESSAGES/aravis-0.6.mo
%%NLS%%share/locale/ru/LC_MESSAGES/aravis-0.6.mo
%%NLS%%share/locale/sl/LC_MESSAGES/aravis-0.6.mo
%%NLS%%share/locale/sr/LC_MESSAGES/aravis-0.6.mo
%%NLS%%share/locale/sr@latin/LC_MESSAGES/aravis-0.6.mo
%%NLS%%share/locale/sv/LC_MESSAGES/aravis-0.6.mo
%%NLS%%share/locale/tr/LC_MESSAGES/aravis-0.6.mo
%%NLS%%share/locale/zh_CN/LC_MESSAGES/aravis-0.6.mo
bin/arv-camera-test-0.8
bin/arv-fake-gv-camera-0.8
bin/arv-test-0.8
bin/arv-tool-0.8
include/aravis-0.8/arv.h
include/aravis-0.8/arvapi.h
include/aravis-0.8/arvbuffer.h
include/aravis-0.8/arvcamera.h
include/aravis-0.8/arvchunkparser.h
include/aravis-0.8/arvdebug.h
include/aravis-0.8/arvdevice.h
include/aravis-0.8/arvdomcharacterdata.h
include/aravis-0.8/arvdomdocument.h
include/aravis-0.8/arvdomdocumentfragment.h
include/aravis-0.8/arvdomelement.h
include/aravis-0.8/arvdomimplementation.h
include/aravis-0.8/arvdomnamednodemap.h
include/aravis-0.8/arvdomnode.h
include/aravis-0.8/arvdomnodechildlist.h
include/aravis-0.8/arvdomnodelist.h
include/aravis-0.8/arvdomparser.h
include/aravis-0.8/arvdomtext.h
include/aravis-0.8/arvenums.h
include/aravis-0.8/arvevaluator.h
include/aravis-0.8/arvfakecamera.h
include/aravis-0.8/arvfakedevice.h
include/aravis-0.8/arvfakeinterface.h
include/aravis-0.8/arvfakestream.h
include/aravis-0.8/arvfeatures.h
include/aravis-0.8/arvgc.h
include/aravis-0.8/arvgcboolean.h
include/aravis-0.8/arvgccategory.h
include/aravis-0.8/arvgccommand.h
include/aravis-0.8/arvgcconverter.h
include/aravis-0.8/arvgcconverternode.h
include/aravis-0.8/arvgcenumentry.h
include/aravis-0.8/arvgcenumeration.h
include/aravis-0.8/arvgcenums.h
include/aravis-0.8/arvgcfeaturenode.h
include/aravis-0.8/arvgcfloat.h
include/aravis-0.8/arvgcfloatnode.h
include/aravis-0.8/arvgcfloatregnode.h
include/aravis-0.8/arvgcgroupnode.h
include/aravis-0.8/arvgcindexnode.h
include/aravis-0.8/arvgcintconverternode.h
include/aravis-0.8/arvgcinteger.h
include/aravis-0.8/arvgcintegernode.h
include/aravis-0.8/arvgcintregnode.h
include/aravis-0.8/arvgcintswissknifenode.h
include/aravis-0.8/arvgcinvalidatornode.h
include/aravis-0.8/arvgcmaskedintregnode.h
include/aravis-0.8/arvgcnode.h
include/aravis-0.8/arvgcport.h
include/aravis-0.8/arvgcpropertynode.h
include/aravis-0.8/arvgcregister.h
include/aravis-0.8/arvgcregisterdescriptionnode.h
include/aravis-0.8/arvgcregisternode.h
include/aravis-0.8/arvgcselector.h
include/aravis-0.8/arvgcstring.h
include/aravis-0.8/arvgcstringnode.h
include/aravis-0.8/arvgcstringregnode.h
include/aravis-0.8/arvgcstructentrynode.h
include/aravis-0.8/arvgcstructregnode.h
include/aravis-0.8/arvgcswissknife.h
include/aravis-0.8/arvgcswissknifenode.h
include/aravis-0.8/arvgcvalueindexednode.h
include/aravis-0.8/arvgvdevice.h
include/aravis-0.8/arvgvfakecamera.h
include/aravis-0.8/arvgvinterface.h
include/aravis-0.8/arvgvstream.h
include/aravis-0.8/arvinterface.h
include/aravis-0.8/arvmisc.h
include/aravis-0.8/arvrealtime.h
include/aravis-0.8/arvstr.h
include/aravis-0.8/arvstream.h
include/aravis-0.8/arvsystem.h
include/aravis-0.8/arvtypes.h
include/aravis-0.8/arvuvdevice.h
include/aravis-0.8/arvuvinterface.h
include/aravis-0.8/arvuvstream.h
include/aravis-0.8/arvversion.h
include/aravis-0.8/arvxmlschema.h
include/aravis-0.8/arvzip.h
%%GIR%%lib/girepository-1.0/Aravis-0.8.typelib
lib/libaravis-0.8.so
lib/libaravis-0.8.so.0
lib/libaravis-0.8.so.0.8.20
libdata/pkgconfig/aravis-0.8.pc
%%PORTDOCS%%man/man1/arv-tool-0.8.1.gz
%%GIR%%share/gir-1.0/Aravis-0.8.gir
%%PORTDOCS%%%%DOCSDIR%%/ArvBuffer.html
%%PORTDOCS%%%%DOCSDIR%%/ArvCamera.html
%%PORTDOCS%%%%DOCSDIR%%/ArvChunkParser.html
%%PORTDOCS%%%%DOCSDIR%%/ArvDevice.html
%%PORTDOCS%%%%DOCSDIR%%/ArvDomCharacterData.html
%%PORTDOCS%%%%DOCSDIR%%/ArvDomDocument.html
%%PORTDOCS%%%%DOCSDIR%%/ArvDomDocumentFragment.html
%%PORTDOCS%%%%DOCSDIR%%/ArvDomElement.html
%%PORTDOCS%%%%DOCSDIR%%/ArvDomNamedNodeMap.html
%%PORTDOCS%%%%DOCSDIR%%/ArvDomNode.html
%%PORTDOCS%%%%DOCSDIR%%/ArvDomNodeChildList.html
%%PORTDOCS%%%%DOCSDIR%%/ArvDomNodeList.html
%%PORTDOCS%%%%DOCSDIR%%/ArvDomText.html
%%PORTDOCS%%%%DOCSDIR%%/ArvEvaluator.html
%%PORTDOCS%%%%DOCSDIR%%/ArvFakeCamera.html
%%PORTDOCS%%%%DOCSDIR%%/ArvFakeDevice.html
%%PORTDOCS%%%%DOCSDIR%%/ArvFakeInterface.html
%%PORTDOCS%%%%DOCSDIR%%/ArvFakeStream.html
%%PORTDOCS%%%%DOCSDIR%%/ArvGc.html
%%PORTDOCS%%%%DOCSDIR%%/ArvGcBoolean.html
%%PORTDOCS%%%%DOCSDIR%%/ArvGcCategory.html
%%PORTDOCS%%%%DOCSDIR%%/ArvGcCommand.html
%%PORTDOCS%%%%DOCSDIR%%/ArvGcConverter.html
%%PORTDOCS%%%%DOCSDIR%%/ArvGcConverterNode.html
%%PORTDOCS%%%%DOCSDIR%%/ArvGcEnumEntry.html
%%PORTDOCS%%%%DOCSDIR%%/ArvGcEnumeration.html
%%PORTDOCS%%%%DOCSDIR%%/ArvGcFeatureNode.html
%%PORTDOCS%%%%DOCSDIR%%/ArvGcFloat.html
%%PORTDOCS%%%%DOCSDIR%%/ArvGcFloatNode.html
%%PORTDOCS%%%%DOCSDIR%%/ArvGcGroupNode.html
%%PORTDOCS%%%%DOCSDIR%%/ArvGcIndexNode.html
%%PORTDOCS%%%%DOCSDIR%%/ArvGcIntConverterNode.html
%%PORTDOCS%%%%DOCSDIR%%/ArvGcInteger.html
%%PORTDOCS%%%%DOCSDIR%%/ArvGcIntegerNode.html
%%PORTDOCS%%%%DOCSDIR%%/ArvGcInvalidatorNode.html
%%PORTDOCS%%%%DOCSDIR%%/ArvGcNode.html
%%PORTDOCS%%%%DOCSDIR%%/ArvGcPort.html
%%PORTDOCS%%%%DOCSDIR%%/ArvGcPropertyNode.html
%%PORTDOCS%%%%DOCSDIR%%/ArvGcRegister.html
%%PORTDOCS%%%%DOCSDIR%%/ArvGcRegisterDescriptionNode.html
%%PORTDOCS%%%%DOCSDIR%%/ArvGcRegisterNode.html
%%PORTDOCS%%%%DOCSDIR%%/ArvGcSelector.html
%%PORTDOCS%%%%DOCSDIR%%/ArvGcString.html
%%PORTDOCS%%%%DOCSDIR%%/ArvGcStringNode.html
%%PORTDOCS%%%%DOCSDIR%%/ArvGcStructEntryNode.html
%%PORTDOCS%%%%DOCSDIR%%/ArvGcSwissKnife.html
%%PORTDOCS%%%%DOCSDIR%%/ArvGcValueIndexedNode.html
%%PORTDOCS%%%%DOCSDIR%%/ArvGvDevice.html
%%PORTDOCS%%%%DOCSDIR%%/ArvGvFakeCamera.html
%%PORTDOCS%%%%DOCSDIR%%/ArvGvInterface.html
%%PORTDOCS%%%%DOCSDIR%%/ArvGvStream.html
%%PORTDOCS%%%%DOCSDIR%%/ArvInterface.html
%%PORTDOCS%%%%DOCSDIR%%/ArvStream.html
%%PORTDOCS%%%%DOCSDIR%%/ArvUvDevice.html
%%PORTDOCS%%%%DOCSDIR%%/ArvUvInterface.html
%%PORTDOCS%%%%DOCSDIR%%/ArvUvStream.html
%%PORTDOCS%%%%DOCSDIR%%/ArvXmlSchema.html
%%PORTDOCS%%%%DOCSDIR%%/annotation-glossary.html
%%PORTDOCS%%%%DOCSDIR%%/aravis-Arv.html
%%PORTDOCS%%%%DOCSDIR%%/aravis-ArvDebug.html
%%PORTDOCS%%%%DOCSDIR%%/aravis-ArvGst.html
%%PORTDOCS%%%%DOCSDIR%%/aravis-ArvStr.html
%%PORTDOCS%%%%DOCSDIR%%/aravis-ArvZip.html
%%PORTDOCS%%%%DOCSDIR%%/aravis-building.html
%%PORTDOCS%%%%DOCSDIR%%/aravis-gv-introduction.html
%%PORTDOCS%%%%DOCSDIR%%/aravis-gv.html
%%PORTDOCS%%%%DOCSDIR%%/aravis-gvcp.html
%%PORTDOCS%%%%DOCSDIR%%/aravis-gvsp.html
%%PORTDOCS%%%%DOCSDIR%%/aravis-introduction.html
%%PORTDOCS%%%%DOCSDIR%%/aravis-overview.html
%%PORTDOCS%%%%DOCSDIR%%/aravis-reference.html
%%PORTDOCS%%%%DOCSDIR%%/aravis.devhelp2
%%PORTDOCS%%%%DOCSDIR%%/ch04.html
%%PORTDOCS%%%%DOCSDIR%%/ch05.html
%%PORTDOCS%%%%DOCSDIR%%/ch06.html
%%PORTDOCS%%%%DOCSDIR%%/ch07.html
%%PORTDOCS%%%%DOCSDIR%%/ch08.html
%%PORTDOCS%%%%DOCSDIR%%/ch09.html
%%PORTDOCS%%%%DOCSDIR%%/ch10.html
%%PORTDOCS%%%%DOCSDIR%%/ch11.html
%%PORTDOCS%%%%DOCSDIR%%/home.png
%%PORTDOCS%%%%DOCSDIR%%/index.html
%%PORTDOCS%%%%DOCSDIR%%/ix01.html
%%PORTDOCS%%%%DOCSDIR%%/ix02.html
%%PORTDOCS%%%%DOCSDIR%%/ix03.html
%%PORTDOCS%%%%DOCSDIR%%/ix04.html
%%PORTDOCS%%%%DOCSDIR%%/ix05.html
%%PORTDOCS%%%%DOCSDIR%%/ix06.html
%%PORTDOCS%%%%DOCSDIR%%/ix07.html
%%PORTDOCS%%%%DOCSDIR%%/ix08.html
%%PORTDOCS%%%%DOCSDIR%%/ix09.html
%%PORTDOCS%%%%DOCSDIR%%/ix10.html
%%PORTDOCS%%%%DOCSDIR%%/ix11.html
%%PORTDOCS%%%%DOCSDIR%%/ix12.html
%%PORTDOCS%%%%DOCSDIR%%/ix13.html
%%PORTDOCS%%%%DOCSDIR%%/ix14.html
%%PORTDOCS%%%%DOCSDIR%%/ix15.html
%%PORTDOCS%%%%DOCSDIR%%/ix16.html
%%PORTDOCS%%%%DOCSDIR%%/left-insensitive.png
%%PORTDOCS%%%%DOCSDIR%%/left.png
%%PORTDOCS%%%%DOCSDIR%%/right-insensitive.png
%%PORTDOCS%%%%DOCSDIR%%/right.png
%%PORTDOCS%%%%DOCSDIR%%/style.css
%%PORTDOCS%%%%DOCSDIR%%/thread-safety.html
%%PORTDOCS%%%%DOCSDIR%%/up-insensitive.png
%%PORTDOCS%%%%DOCSDIR%%/up.png

View File

@ -1,8 +1,7 @@
# Created by: Rozhuk Ivan rozhuk.im@gmail.com
PORTNAME= aravis
DISTVERSIONPREFIX= ARAVIS_
DISTVERSION= 0_5_12
DISTVERSION= 0.8.20
CATEGORIES= multimedia
MAINTAINER= rozhuk.im@gmail.com
@ -11,31 +10,26 @@ COMMENT= Camera control and image acquisition viewer
LICENSE= LGPL21+
LICENSE_FILE= ${WRKSRC}/COPYING
CONFLICTS_INSTALL= ${PORTNAME}*
LIB_DEPENDS+= libaravis-0.6.so:devel/libaravis \
LIB_DEPENDS= libaravis-0.8.so:devel/libaravis \
libnotify.so:devel/libnotify
USES= autoreconf gettext gmake gnome libtool pkgconfig
USES= gettext gnome meson pkgconfig
USE_GNOME= cairo glib20 intltool gtk30
USE_GSTREAMER1= yes
GNU_CONFIGURE= yes
# USE_LDCONFIG= yes
USE_GITHUB= yes
GH_ACCOUNT= AravisProject
CONFIGURE_ARGS= --enable-packet-socket=no --enable-viewer=yes \
--enable-gst-plugin=no --enable-gst-0.10-plugin=no \
--enable-gtk-doc=no --enable-cpp-test=no \
--enable-usb=no --enable-zlib-pc=yes
MAKE_ARGS= pkgconfigdir="${PREFIX}/libdata/pkgconfig"
MESON_ARGS= -Dpacket-socket=disabled -Dviewer=enabled \
-Ddocumentation=disabled -Dintrospection=disabled \
-Dgst-plugin=disabled -Dtests=false -Dusb=disabled
pre-configure:
${ECHO_CMD} "EXTRA_DIST =" >> ${WRKSRC}/gtk-doc.make
@${REINPLACE_CMD} -e 's|GTK_DOC_CHECK(\[1.14\],\[--flavour no-tmpl\])||' \
${WRKSRC}/configure.ac
@${REINPLACE_CMD} -e 's|^arv_viewer_LDADD.*=.*|arv_viewer_LDADD = $${ARAVIS_VIEWER_LIBS} -laravis-0.6|' \
${WRKSRC}/viewer/Makefile.am
post-patch:
@${REINPLACE_CMD} -e "s|subdir ('src')|aravis_dependencies += dependency ('aravis-0.8', version: '>=0.8', required: true)|g" \
-e 's|meson.override_dependency.*||g' \
${WRKSRC}/meson.build
@${REINPLACE_CMD} -e "s|.*aravis_library.*||g" \
-e "s|library_inc|include_directories('../src')|g" \
${WRKSRC}/viewer/meson.build
.include <bsd.port.mk>

View File

@ -1,3 +1,3 @@
TIMESTAMP = 1526106632
SHA256 (AravisProject-aravis-ARAVIS_0_5_12_GH0.tar.gz) = 61467edecb96f7d315770f8d874860e42b2981200edb8bba879f46ec9a83e0b2
SIZE (AravisProject-aravis-ARAVIS_0_5_12_GH0.tar.gz) = 2986578
TIMESTAMP = 1641829020
SHA256 (AravisProject-aravis-0.8.20_GH0.tar.gz) = d8d15970a08538f1c61372a378750451c03856184b60dd6d8c657dca23690135
SIZE (AravisProject-aravis-0.8.20_GH0.tar.gz) = 950371

View File

@ -1,41 +0,0 @@
--- Makefile.am.orig 2018-05-03 12:25:25 UTC
+++ Makefile.am
@@ -6,7 +6,7 @@ ACLOCAL_AMFLAGS = -I m4
DISTCHECK_CONFIGURE_FLAGS = --enable-introspection --enable-gtk-doc --enable-gst-plugin --enable-gst-0.10-plugin --enable-viewer --enable-cpp-test --enable-appstream-util
-SUBDIRS = src man
+SUBDIRS = man
if ARAVIS_BUILD_VIEWER
SUBDIRS += viewer
@@ -20,16 +20,9 @@ if ARAVIS_BUILD_GST_0_10_PLUGIN
SUBDIRS += gst-0.10
endif
-SUBDIRS += tests po docs
-aravisdocdir = ${docdir}/aravis-@ARAVIS_API_VERSION@
-aravisdoc_DATA = \
- README.md \
- COPYING \
- ChangeLog \
- AUTHORS \
- NEWS
+
EXTRA_DIST += m4/introspection.m4 README.md
# Copy all the spec files. Of cource, only one is actually used.
@@ -40,11 +33,5 @@ dist-hook:
fi \
done
-pkgconfigdir = $(libdir)/pkgconfig
-pkgconfig_DATA = aravis-@ARAVIS_API_VERSION@.pc
-CLEANFILES = $(pkgconfig_DATA)
-
-%-@ARAVIS_API_VERSION@.pc: %.pc
- cp $< $@

View File

@ -1,13 +1,32 @@
bin/arv-viewer
man/man1/arv-tool-0.6.1.gz
man/man1/arv-viewer.1.gz
share/appdata/arv-viewer.appdata.xml
share/applications/arv-viewer.desktop
%%DATADIR%%-0.6/arv-viewer.ui
share/icons/hicolor/22x22/apps/aravis.png
share/icons/hicolor/256x256/apps/aravis.png
share/icons/hicolor/32x32/apps/aravis.png
share/icons/hicolor/48x48/apps/aravis.png
share/icons/hicolor/scalable/devices/aravis-fake-symbolic.svg
share/icons/hicolor/scalable/devices/aravis-gigevision-symbolic.svg
share/icons/hicolor/scalable/devices/aravis-usb3vision-symbolic.svg
bin/arv-viewer-0.8
share/applications/arv-viewer-0.8.desktop
share/icons/hicolor/128x128/apps/aravis-0.8.png
share/icons/hicolor/22x22/apps/aravis-0.8.png
share/icons/hicolor/256x256/apps/aravis-0.8.png
share/icons/hicolor/32x32/apps/aravis-0.8.png
share/icons/hicolor/48x48/apps/aravis-0.8.png
share/locale/bs/LC_MESSAGES/aravis-0.8.mo
share/locale/ca/LC_MESSAGES/aravis-0.8.mo
share/locale/cs/LC_MESSAGES/aravis-0.8.mo
share/locale/da/LC_MESSAGES/aravis-0.8.mo
share/locale/de/LC_MESSAGES/aravis-0.8.mo
share/locale/el/LC_MESSAGES/aravis-0.8.mo
share/locale/es/LC_MESSAGES/aravis-0.8.mo
share/locale/eu/LC_MESSAGES/aravis-0.8.mo
share/locale/fi/LC_MESSAGES/aravis-0.8.mo
share/locale/fr/LC_MESSAGES/aravis-0.8.mo
share/locale/hu/LC_MESSAGES/aravis-0.8.mo
share/locale/id/LC_MESSAGES/aravis-0.8.mo
share/locale/lv/LC_MESSAGES/aravis-0.8.mo
share/locale/oc/LC_MESSAGES/aravis-0.8.mo
share/locale/pl/LC_MESSAGES/aravis-0.8.mo
share/locale/pt/LC_MESSAGES/aravis-0.8.mo
share/locale/pt_BR/LC_MESSAGES/aravis-0.8.mo
share/locale/ru/LC_MESSAGES/aravis-0.8.mo
share/locale/sl/LC_MESSAGES/aravis-0.8.mo
share/locale/sr/LC_MESSAGES/aravis-0.8.mo
share/locale/sr@latin/LC_MESSAGES/aravis-0.8.mo
share/locale/sv/LC_MESSAGES/aravis-0.8.mo
share/locale/tr/LC_MESSAGES/aravis-0.8.mo
share/locale/zh_CN/LC_MESSAGES/aravis-0.8.mo
share/metainfo/arv-viewer-0.8.appdata.xml