x11-wm/cwm: Update to 5.6-201-g5a46349
A lot of things have changed for the better since version 5.6 in cwm, but upstream has stopped tagging new releases. This updates the port to use a more recent commit to match cwm in OpenBSD more closely. This is important because configuration options have changed which makes it harder to share config files between systems. While here - Fix license which appears to not be BSD 2-clause but the ISC license - Update WWW. The old site is gone. - Remove MASTER_SITES which wasn't really used Changes: https://github.com/chneukirchen/cwm/compare/v5.6...linux PR: 222423 Approved by: braakvaak@aol.com (maintainer timeout, 2 weeks)
This commit is contained in:
parent
202acd95e4
commit
7caab4aac6
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=451080
8
UPDATING
8
UPDATING
@ -5,6 +5,14 @@ they are unavoidable.
|
||||
You should get into the habit of checking this file for changes each time
|
||||
you update your ports collection, before attempting any port upgrades.
|
||||
|
||||
20171002:
|
||||
AFFECTS: users of x11-wm/cwm
|
||||
AUTHOR: tobik@FreeBSD.org
|
||||
|
||||
Configuration options were renamed and you need to update your ~/.cwmrc
|
||||
accordingly. Make sure to check cwmrc(5) for the new option names.
|
||||
cwm-migrate-config.pl can help in migrating your ~/.cwmrc.
|
||||
|
||||
20171001:
|
||||
AFFECTS: users of mail/isync using Maildir sub-folders
|
||||
AUTHOR: ehaupt@FreeBSD.org
|
||||
|
@ -1,29 +1,44 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= cwm
|
||||
PORTVERSION= 5.6
|
||||
DISTVERSIONPREFIX= v
|
||||
DISTVERSION= 5.6-201
|
||||
DISTVERSIONSUFFIX= -g5a46349
|
||||
CATEGORIES= x11-wm
|
||||
MASTER_SITES= http://chneukirchen.org/releases/ \
|
||||
|
||||
MAINTAINER= braakvaak@aol.com
|
||||
COMMENT= Minimalistic window manager for X11 based on evilwm
|
||||
|
||||
LICENSE= BSD2CLAUSE
|
||||
LICENSE= ISCL
|
||||
|
||||
LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig
|
||||
LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
|
||||
libfreetype.so:print/freetype2
|
||||
|
||||
USES= pkgconfig:build
|
||||
USE_XORG= x11 xft xinerama xrandr
|
||||
USES= pkgconfig shebangfix
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= chneukirchen
|
||||
USE_XORG= x11 xft xinerama xrandr
|
||||
|
||||
PLIST_FILES= bin/cwm \
|
||||
bin/cwm-migrate-config.pl \
|
||||
man/man1/cwm.1.gz \
|
||||
man/man5/cwmrc.5.gz
|
||||
SHEBANG_FILES= migrate-config.pl
|
||||
|
||||
.include <bsd.port.options.mk>
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} 's@/usr/X11R6@${LOCALBASE}@' ${WRKSRC}/cwmrc.5
|
||||
@${REINPLACE_CMD} -e 's@strlcpy.o strlcat.o@@' \
|
||||
-e 's@strtonum.o@@' ${WRKSRC}/Makefile
|
||||
.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1100072
|
||||
@${REINPLACE_CMD} 's@reallocarray.o@@' ${WRKSRC}/Makefile
|
||||
.endif
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/cwm ${STAGEDIR}${PREFIX}/bin
|
||||
${INSTALL_SCRIPT} ${WRKSRC}/migrate-config.pl \
|
||||
${STAGEDIR}${PREFIX}/bin/cwm-migrate-config.pl
|
||||
${INSTALL_MAN} ${WRKSRC}/cwm.1 ${STAGEDIR}${MAN1PREFIX}/man/man1
|
||||
${INSTALL_MAN} ${WRKSRC}/cwmrc.5 ${STAGEDIR}${MAN5PREFIX}/man/man5
|
||||
|
||||
|
@ -1,2 +1,3 @@
|
||||
SHA256 (chneukirchen-cwm-v5.6_GH0.tar.gz) = 006320bb1716cc0f93bac5634dcccd01f21d468263b5fc9d1be2dd11078a0625
|
||||
SIZE (chneukirchen-cwm-v5.6_GH0.tar.gz) = 50799
|
||||
TIMESTAMP = 1505255816
|
||||
SHA256 (chneukirchen-cwm-v5.6-201-g5a46349_GH0.tar.gz) = 0ef72de4dcffc5d1ea848d8e1e24884ae6436147c042f56166d996f28d46ebb8
|
||||
SIZE (chneukirchen-cwm-v5.6-201-g5a46349_GH0.tar.gz) = 51003
|
||||
|
@ -1,11 +0,0 @@
|
||||
--- Makefile.orig 2015-03-26 00:34:30 UTC
|
||||
+++ Makefile
|
||||
@@ -16,7 +16,7 @@ OBJS= calmwm.o screen.o xmalloc.o clien
|
||||
|
||||
CPPFLAGS+= `pkg-config --cflags fontconfig x11 xft xinerama xrandr`
|
||||
|
||||
-CFLAGS?= -Wall -O2 -g -D_GNU_SOURCE
|
||||
+CFLAGS?= -Wall -g -pthread
|
||||
|
||||
LDFLAGS+= `pkg-config --libs fontconfig x11 xft xinerama xrandr`
|
||||
|
@ -1,11 +0,0 @@
|
||||
--- kbfunc.c.orig 2015-03-26 00:09:51 UTC
|
||||
+++ kbfunc.c
|
||||
@@ -324,7 +324,7 @@ kbfunc_ssh(struct client_ctx *cc, union
|
||||
struct menu_q menuq;
|
||||
FILE *fp;
|
||||
char *buf, *lbuf, *p;
|
||||
- char hostbuf[HOST_NAME_MAX+1];
|
||||
+ char hostbuf[_POSIX_HOST_NAME_MAX+1];
|
||||
char path[PATH_MAX];
|
||||
int l;
|
||||
size_t len;
|
@ -2,7 +2,4 @@ cwm is a window manager for X11 initially inspired by evilwm. cwm has several
|
||||
novel features, including the ability to search for windows. it features a
|
||||
very simple and attractive aesthetic.
|
||||
|
||||
This port is based on OpenBSD's continued work on cwm, as development on the
|
||||
project seems to have halted.
|
||||
|
||||
WWW: http://monkey.org/~marius/pages/?page=cwm
|
||||
WWW: https://github.com/chneukirchen/cwm
|
||||
|
Loading…
Reference in New Issue
Block a user