New port: astro/sofa: Set of algorithms and procedures used in fundamental astronomy

This commit is contained in:
Yuri Victorovich 2018-07-26 02:40:15 +00:00
parent 4ac0d69814
commit 7c7f0b8241
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=475343
5 changed files with 69 additions and 0 deletions

View File

@ -103,6 +103,7 @@
SUBDIR += saoimage
SUBDIR += sextractor
SUBDIR += siril
SUBDIR += sofa
SUBDIR += sscalc
SUBDIR += stardates
SUBDIR += starplot

28
astro/sofa/Makefile Normal file
View File

@ -0,0 +1,28 @@
# $FreeBSD$
PORTNAME= sofa
DISTVERSION= 20180130
CATEGORIES= astro devel
MASTER_SITES= http://www.iausofa.org/${DISTVERSION:C/(....)(....)/\\1_\\2/}_C/
DISTNAME= ${PORTNAME}_c-${DISTVERSION}
MAINTAINER= yuri@FreeBSD.org
COMMENT= Set of algorithms and procedures used in fundamental astronomy
LICENSE= SOFA
LICENSE_NAME= SOFA Software License
LICENSE_FILE= ${WRKDIR}/sofa/20180130/c/doc/copyr.lis
LICENSE_PERMS= dist-mirror no-dist-sell pkg-mirror no-pkg-sell auto-accept
MAKEFILE= makefile
USE_LDCONFIG= yes
WRKSRC= ${WRKDIR}/${PORTNAME}/${DISTVERSION}/c/src
BINARY_ALIAS= gcc=cc
MAKE_ARGS= CFLAGF="-c ${CFLAGS} -fPIC" INSTALL_DIR=${STAGEDIR}${PREFIX}
PLIST_FILES= include/sofa.h \
include/sofam.h \
lib/libsofa_c.so
.include <bsd.port.mk>

3
astro/sofa/distinfo Normal file
View File

@ -0,0 +1,3 @@
TIMESTAMP = 1532570296
SHA256 (sofa_c-20180130.tar.gz) = de09807198c977e1c58ea1d0c79c40bdafef84f2072eab586a7ac246334796db
SIZE (sofa_c-20180130.tar.gz) = 1820345

View File

@ -0,0 +1,20 @@
--- makefile.orig 2018-07-26 02:04:00 UTC
+++ makefile
@@ -77,7 +77,7 @@ INSTALL_DIRS = $(SOFA_LIB_DIR) $(SOFA_IN
# Name the SOFA/C library in its source and target locations.
-SOFA_LIB_NAME = libsofa_c.a
+SOFA_LIB_NAME = libsofa_c.so
SOFA_LIB = $(SOFA_LIB_DIR)$(SOFA_LIB_NAME)
# Name the SOFA/C testbed in its source and target locations.
@@ -380,7 +380,7 @@ $(INSTALL_DIRS):
# Build the library.
$(SOFA_LIB_NAME): $(SOFA_OBS)
- ar ru $(SOFA_LIB_NAME) $?
+ $(CC) -shared $(LDFLAGS) -o $(SOFA_LIB_NAME) $?
# Install the header files.
$(SOFA_INC) : $(INSTALL_DIRS) $(SOFA_INC_NAMES)

17
astro/sofa/pkg-descr Normal file
View File

@ -0,0 +1,17 @@
The SOFA Collection consists of libraries of routines in ANSI C. There is a
suite of vector/matrix routines and various utilities that underpin the
astronomy algorithms, which include routines for the following:
* Astrometry
* Calendars
* Time Scales
* Ecliptic Coordinates
* Earth Rotation and Sidereal Time
* Ephemerides (medium precision)
* Fundamental Arguments
* Galactic Coordinates
* Geocentric/Geodetic Transformations
* Precession, Nutation and Polar Motion
* Star Catalog Conversion
WWW: http://www.iausofa.org