The patch was totally rewritten by the maintainer:
. update to the new version 3.2.3; . fix package building/installing/deinstalling; . remove BROKEN. PR: 107803 Submitted by: bsam (me) Approved by: pirjyk (maintainer)
This commit is contained in:
parent
94b87b5985
commit
7c51c5d5f1
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=184599
@ -6,7 +6,7 @@
|
||||
#
|
||||
|
||||
PORTNAME= psgconf
|
||||
PORTVERSION= 3.2.1
|
||||
PORTVERSION= 3.2.3
|
||||
CATEGORIES= sysutils
|
||||
MASTER_SITES= ftp://ftp-dev.cites.uiuc.edu/pub/psgconf/
|
||||
|
||||
@ -21,8 +21,6 @@ BUILD_DEPENDS= ${SITE_PERL}/Config/Objective.pm:${PORTSDIR}/devel/p5-Config-Obje
|
||||
${SITE_PERL}/${PERL_ARCH}/version.pm:${PORTSDIR}/devel/p5-version \
|
||||
${SITE_PERL}/Text/Diff.pm:${PORTSDIR}/textproc/p5-Text-Diff
|
||||
|
||||
BROKEN= Leaves behind files on deinstall
|
||||
|
||||
PERL_CONFIGURE= YES
|
||||
|
||||
MAN1= psgconf.1
|
||||
@ -58,6 +56,7 @@ MAN3= PSGConf.3 \
|
||||
PSGConf::Action::GenerateFile::etc_services.3 \
|
||||
PSGConf::Action::GenerateFile::etc_shadow.3 \
|
||||
PSGConf::Action::GenerateFile::etc_system.3 \
|
||||
PSGConf::Action::GenerateFile::etc_user_attr.3 \
|
||||
PSGConf::Action::GenerateFile::ftpaccess.3 \
|
||||
PSGConf::Action::GenerateFile::hosts.3 \
|
||||
PSGConf::Action::GenerateFile::hosts_allow.3 \
|
||||
@ -191,6 +190,7 @@ IGNORE= requires perl 5.6 or newer
|
||||
.endif
|
||||
|
||||
PKGINSTALL= ${WRKSRC}/postinstall
|
||||
PKGDEINSTALL= ${WRKSRC}/postinstall
|
||||
|
||||
post-patch:
|
||||
${FIND} ${WRKSRC} -name "*.orig" -delete
|
||||
|
@ -1,3 +1,3 @@
|
||||
MD5 (psgconf-3.2.1.tar.gz) = d9be38204425f72c611b7a0c51540b35
|
||||
SHA256 (psgconf-3.2.1.tar.gz) = a4a8d31871dc653e359804431534593be807ece10edf8bbcd4dd0074ed988b92
|
||||
SIZE (psgconf-3.2.1.tar.gz) = 234015
|
||||
MD5 (psgconf-3.2.3.tar.gz) = 59da41ee9c9fe2a97fd9920b86e43974
|
||||
SHA256 (psgconf-3.2.3.tar.gz) = ee95a3956bdfc8fee6a69e7b2cce830179c324413ca20cc0e9dbe9d9ea4540ed
|
||||
SIZE (psgconf-3.2.3.tar.gz) = 238061
|
||||
|
@ -1,12 +1,22 @@
|
||||
--- ./Makefile.PL.orig Wed Feb 18 14:44:59 2004
|
||||
+++ ./Makefile.PL Wed Feb 18 14:45:16 2004
|
||||
@@ -20,7 +20,7 @@
|
||||
--- ./Makefile.PL.orig Mon Jun 26 22:05:42 2006
|
||||
+++ ./Makefile.PL Thu Feb 1 09:40:51 2007
|
||||
@@ -18,8 +18,8 @@
|
||||
|
||||
my ($etc_dir, $share_dir);
|
||||
|
||||
-$etc_dir = '/etc';
|
||||
+$etc_dir = '$(PREFIX)/etc';
|
||||
-$share_dir = '/usr/local/share/psgconf';
|
||||
+$etc_dir = '$(PREFIX)/etc';
|
||||
+$share_dir = '$(PREFIX)/share/psgconf';
|
||||
|
||||
GetOptions(
|
||||
'etcdir=s' => \$etc_dir,
|
||||
@@ -39,7 +39,7 @@
|
||||
$(CP) files/rc.shutdown $(DESTDIR)$(SHARE_DIR)/files
|
||||
$(CP) files/magic $(DESTDIR)$(SHARE_DIR)/files
|
||||
|
||||
- $(SH) MAKE=$(MAKE) ROOT_PATH=$(DESTDIR) ETC_DIR=$(ETC_DIR) ./postinstall
|
||||
+# $(SH) MAKE=$(MAKE) ROOT_PATH=$(DESTDIR) ETC_DIR=$(ETC_DIR) ./postinstall
|
||||
|
||||
svr4pkg:
|
||||
$(MAKE) DESTDIR=$(DESTDIR) install
|
||||
|
@ -1,15 +1,33 @@
|
||||
--- ./lib/PSGConf.pm.orig Wed May 3 08:55:41 2006
|
||||
+++ ./lib/PSGConf.pm Thu May 4 10:21:24 2006
|
||||
@@ -34,7 +34,7 @@
|
||||
--- ./lib/PSGConf.pm.orig Sat Sep 23 13:44:35 2006
|
||||
+++ ./lib/PSGConf.pm Thu Jan 11 11:15:45 2007
|
||||
@@ -14,6 +14,7 @@
|
||||
|
||||
use strict;
|
||||
|
||||
+use File::Basename;
|
||||
use File::Copy;
|
||||
use File::Path;
|
||||
use File::stat;
|
||||
@@ -34,8 +35,8 @@
|
||||
my %defaults = (
|
||||
config_dir => '/usr/local/share/psgconf/config',
|
||||
files_dir => '/usr/local/share/psgconf/files',
|
||||
- modules_file => '/etc/psgconf_modules',
|
||||
- tmpdir => "/var/tmp/$0.$$",
|
||||
+ modules_file => '/usr/local/etc/psgconf_modules',
|
||||
tmpdir => "/var/tmp/psgconf.$$",
|
||||
+ tmpdir => '/var/tmp/' . basename $0 . ".$$",
|
||||
verbose => 0,
|
||||
do_fix => 0,
|
||||
@@ -678,7 +678,7 @@
|
||||
restart_daemons => 1,
|
||||
@@ -62,6 +63,7 @@
|
||||
|
||||
### Set from the environment variables if
|
||||
### not set on the command line.
|
||||
+ $0 = basename $0;
|
||||
$self->{tmpdir} = $ENV{'PSGCONF_TMPDIR'} . "/$0.$$"
|
||||
if ( !defined $self->{tmpdir} &&
|
||||
defined $ENV{'PSGCONF_TMPDIR'} &&
|
||||
@@ -677,7 +679,7 @@
|
||||
=item modules_file
|
||||
|
||||
Full path to B<psgconf> modules file. Default is
|
||||
|
18
sysutils/psgconf/files/patch-postinstall
Normal file
18
sysutils/psgconf/files/patch-postinstall
Normal file
@ -0,0 +1,18 @@
|
||||
--- ./postinstall.orig Wed Oct 25 08:25:58 2006
|
||||
+++ ./postinstall Wed Feb 7 13:11:34 2007
|
||||
@@ -13,6 +13,7 @@
|
||||
|
||||
DATE=`date +%Y-%m-%d`
|
||||
PKG_NAME=psgconf
|
||||
+HOSTNAME=`uname -n`
|
||||
|
||||
# ROOT_PATH is the relocatable start of the psgconf tree.
|
||||
# Ala the root_path that is used in pkgadd(8) on Solaris.
|
||||
@@ -128,7 +129,6 @@
|
||||
echo "Generating a default ${ROOT_PATH}${ETC_DIR}/psg.conf file";
|
||||
|
||||
# FIXME: Need to figure out the default network interface...
|
||||
- HOSTNAME=`uname -n`
|
||||
sed -e "s/^#hostname.*$/hostname \"$HOSTNAME\";/" \
|
||||
< ${SRC_CONF} \
|
||||
> ${ROOT_PATH}${ETC_DIR}/psg.conf
|
@ -1,5 +1,3 @@
|
||||
@unexec cmp %D/etc/psg.conf.sample %D/etc/psg.conf && rm %D/etc/psg.conf
|
||||
@unexec cmp %D/etc/psgconf_modules.sample %D/etc/psgconf_modules && rm %D/etc/psgconf_modules
|
||||
etc/psg.conf.sample
|
||||
etc/psgconf_modules.sample
|
||||
sbin/ConfigFile2Storable
|
||||
@ -57,6 +55,7 @@ sbin/platform-name
|
||||
%%SITE_PERL%%/PSGConf/Action/GenerateFile/etc_services.pm
|
||||
%%SITE_PERL%%/PSGConf/Action/GenerateFile/etc_shadow.pm
|
||||
%%SITE_PERL%%/PSGConf/Action/GenerateFile/etc_system.pm
|
||||
%%SITE_PERL%%/PSGConf/Action/GenerateFile/etc_user_attr.pm
|
||||
%%SITE_PERL%%/PSGConf/Action/GenerateFile/ftpaccess.pm
|
||||
%%SITE_PERL%%/PSGConf/Action/GenerateFile/hosts.pm
|
||||
%%SITE_PERL%%/PSGConf/Action/GenerateFile/hosts_allow.pm
|
||||
|
Loading…
Reference in New Issue
Block a user