Update to version 2.6.8; enable concurrent installs.

PR:		217203
Submitted by:	"John W. O'Brien" <john@saltant.com>
mintainer timeout.
This commit is contained in:
Dmitry Sivachenko 2017-03-13 09:23:04 +00:00
parent 78e65dba70
commit 7c3b81aea6
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=436046
4 changed files with 8 additions and 112 deletions

View File

@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= markdown
PORTVERSION= 2.6.5
PORTVERSION= 2.6.8
CATEGORIES= textproc python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@ -15,12 +15,13 @@ LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE.md
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}nose>0:devel/py-nose \
${PYTHON_PKGNAMEPREFIX}coverage>0:devel/py-coverage \
${PYTHON_PKGNAMEPREFIX}pytidylib>0:textproc/py-pytidylib \
${PYTHON_PKGNAMEPREFIX}pygments>0:textproc/py-pygments \
${PYTHON_PKGNAMEPREFIX}yaml>0:devel/py-yaml
USES= python
USE_PYTHON= distutils autoplist
USE_PYTHON= distutils concurrent autoplist
NO_ARCH= yes

View File

@ -1,2 +1,3 @@
SHA256 (Markdown-2.6.5.tar.gz) = 8d94cf6273606f76753fcb1324623792b3738c7612c2b180c85cc5e88642e560
SIZE (Markdown-2.6.5.tar.gz) = 301781
TIMESTAMP = 1487426908
SHA256 (Markdown-2.6.8.tar.gz) = 0ac8a81e658167da95d063a9279c9c1b2699f37c7c4153256a458b3a43860e33
SIZE (Markdown-2.6.8.tar.gz) = 307330

View File

@ -1,106 +0,0 @@
From 81b724cfec03634c0bcd88b1bccb5936872d04e2 Mon Sep 17 00:00:00 2001
From: Waylan Limberg <waylan.limberg@icloud.com>
Date: Thu, 28 Jan 2016 22:09:56 -0500
Subject: [PATCH] Enabled pygments based tests.
Added pygments to test-requirements and updated codehiliting tests to
only test partial output as output differs depending on Pygments version.
Fixes #453
https://github.com/waylan/Python-Markdown/issues/453
---
test-requirements.txt | 3 ++-
tests/test_extensions.py | 47 ++++++++++++-----------------------------------
2 files changed, 14 insertions(+), 36 deletions(-)
diff --git tests/test_extensions.py b/tests/test_extensions.py
index 38f0be3..72ce212 100644
--- tests/test_extensions.py
+++ tests/test_extensions.py
@@ -134,12 +134,7 @@ def testLinenumsFalse(self):
md = markdown.Markdown(
extensions=[markdown.extensions.codehilite.CodeHiliteExtension(linenums=False)])
if self.has_pygments:
- self.assertEqual(
- md.convert(text),
- '<div class="codehilite">'
- '<pre><span class="c"># A Code Comment</span>\n'
- '</pre></div>'
- )
+ self.assertTrue(md.convert(text).startswith('<div class="codehilite"><pre><span'))
else:
self.assertEqual(
md.convert(text),
@@ -187,12 +182,7 @@ def testLinenumsNoneWithColon(self):
extensions=[markdown.extensions.codehilite.CodeHiliteExtension(linenums=None)]
)
if self.has_pygments:
- self.assertEqual(
- md.convert(text),
- '<div class="codehilite">'
- '<pre><span class="c"># A Code Comment</span>\n'
- '</pre></div>'
- )
+ self.assertTrue(md.convert(text).startswith('<div class="codehilite"><pre><span'))
else:
self.assertEqual(
md.convert(text),
@@ -202,19 +192,16 @@ def testLinenumsNoneWithColon(self):
def testHighlightLinesWithColon(self):
# Test with hl_lines delimited by single or double quotes.
- text0 = '\t:::Python hl_lines="2"\n\t#line 1\n\t#line 2\n\t#line 3'
- text1 = "\t:::Python hl_lines='2'\n\t#line 1\n\t#line 2\n\t#line 3"
+ text0 = '\t:::Python hl_lines="1"\n\t#line 1\n\t#line 2\n\t#line 3'
+ text1 = "\t:::Python hl_lines='1'\n\t#line 1\n\t#line 2\n\t#line 3"
for text in (text0, text1):
md = markdown.Markdown(extensions=['markdown.extensions.codehilite'])
if self.has_pygments:
- self.assertEqual(
- md.convert(text),
- '<div class="codehilite"><pre>'
- '<span class="c">#line 1</span>\n'
- '<span class="hll"><span class="c">#line 2</span>\n</span>'
- '<span class="c">#line 3</span>\n'
- '</pre></div>'
+ self.assertTrue(
+ md.convert(text).startswith(
+ '<div class="codehilite"><pre><span class="hll"'
+ )
)
else:
self.assertEqual(
@@ -333,13 +320,8 @@ def testFencedCodeWithHighlightLines(self):
)
if self.has_pygments:
- self.assertEqual(
- md.convert(text),
- '<div class="codehilite"><pre>'
- '<span class="hll">line 1\n</span>'
- 'line 2\n'
- '<span class="hll">line 3\n</span>'
- '</pre></div>'
+ self.assertTrue(
+ md.convert(text).startswith('<div class="codehilite"><pre><span class="hll"')
)
else:
self.assertEqual(
@@ -372,13 +354,8 @@ def testFencedLanguageAndHighlightLines(self):
]
)
if self.has_pygments:
- self.assertEqual(
- md.convert(text),
- '<div class="codehilite"><pre>'
- '<span class="hll"><span class="c">#line 1</span>\n</span>'
- '<span class="c">#line 2</span>\n'
- '<span class="hll"><span class="c">#line 3</span>\n</span>'
- '</pre></div>'
+ self.assertTrue(
+ md.convert(text).startswith('<div class="codehilite"><pre><span class="hll"')
)
else:
self.assertEqual(

View File

@ -1,6 +1,6 @@
--- setup.py.orig 2016-02-20 06:59:25 UTC
--- setup.py.orig 2017-01-04 05:33:56 UTC
+++ setup.py
@@ -268,5 +268,6 @@ setup(
@@ -270,5 +270,6 @@ setup(
'Topic :: Software Development :: Libraries :: Python Modules',
'Topic :: Text Processing :: Filters',
'Topic :: Text Processing :: Markup :: HTML'