- Update to 0.9.9 of ccaudio2
Approved by: miwi (mentor)
This commit is contained in:
parent
64116badc3
commit
7c362c4bc0
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=208534
@ -1,33 +1,32 @@
|
||||
# New ports collection makefile for: ccaudio
|
||||
# Date created: 26 July 2000
|
||||
# Whom: David Sugar <dyfet@gnu.org>
|
||||
# New ports collection makefile for: ccaudio2
|
||||
# Date created: 13 February 2008
|
||||
# Whom: gahr
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= ccaudio
|
||||
PORTVERSION= 1.2.0
|
||||
PORTNAME= ccaudio2
|
||||
PORTVERSION= 0.9.9
|
||||
CATEGORIES= audio
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= gnutelephony
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
MAINTAINER= gahr@FreeBSD.org
|
||||
COMMENT= C++ class framework for manipulating audio files
|
||||
|
||||
LIB_DEPENDS= ccgnu2:${PORTSDIR}/devel/commoncpp
|
||||
|
||||
BROKEN= fails to compile
|
||||
CONFLICTS= ccaudio-[0-9]*
|
||||
|
||||
USE_AUTOTOOLS= libtool:15
|
||||
USE_GNOME= gnometarget
|
||||
GNU_CONFIGURE= yes
|
||||
USE_GCC= 3.4+
|
||||
USE_LDCONFIG= yes
|
||||
|
||||
MAN1= audiotool.1 tonetool.1
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e \
|
||||
's|<stdint\.h>|<stdlib.h>|g' ${WRKSRC}/src/dtmf.cpp
|
||||
@${REINPLACE_CMD} -e \
|
||||
's|@CXXFLAGS@|& $$(g_711_CXXFLAGS)|' ${WRKSRC}/dso/Makefile.in
|
||||
${REINPLACE_CMD} -e 's|$$(libdir)/pkgconfig|${PREFIX}/libdata/pkgconfig|' \
|
||||
${WRKSRC}/Makefile.in
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1,3 +1,3 @@
|
||||
MD5 (ccaudio-1.2.0.tar.gz) = 919210cf0d917fbb7813d2cbf2c1e941
|
||||
SHA256 (ccaudio-1.2.0.tar.gz) = 6805fe04a3281fbcc66d247f63f6def5db042c7cf55fd7a5b3b783de4999c387
|
||||
SIZE (ccaudio-1.2.0.tar.gz) = 343071
|
||||
MD5 (ccaudio2-0.9.9.tar.gz) = 3db94fb9e73c6b43d7adb9561e143057
|
||||
SHA256 (ccaudio2-0.9.9.tar.gz) = 363315ac72ebad6803f556d0ea3bbf2b0b80a649c44fca53a5d4b85cca54a50d
|
||||
SIZE (ccaudio2-0.9.9.tar.gz) = 426462
|
||||
|
@ -1,11 +0,0 @@
|
||||
--- src/audiofile.cpp.orig Mon Jul 31 17:13:02 2006
|
||||
+++ src/audiofile.cpp Mon Jul 31 17:13:20 2006
|
||||
@@ -38,6 +38,8 @@
|
||||
// whether to permit this exception to apply to your modifications.
|
||||
// If you do not wish that, delete this exception notice.
|
||||
|
||||
+#include <sys/types.h>
|
||||
+#include <sys/stat.h>
|
||||
#include <cc++/config.h>
|
||||
#include <cc++/strchar.h>
|
||||
#include <cc++/export.h>
|
@ -1,6 +1,6 @@
|
||||
ccaudio offers a portable framework for developing applications which
|
||||
access audio files. This library is optimized for DSP frame presentation
|
||||
and for merging audio from multiple sources. Support is provided for many
|
||||
common and popular sound file formats such as .au, .wav/RIFF, etc.
|
||||
GNU ccAudio2 is a stand-alone portable C++ class framework for manipulating
|
||||
audio data. This library is optimized for DSP frame presentation and for
|
||||
merging audio from multiple sources. Support is provided for many common
|
||||
and popular sound file formats such as .au, .wav/RIFF, etc.
|
||||
|
||||
WWW: http://www.gnutelephony.org/
|
||||
|
@ -1,10 +1,14 @@
|
||||
include/cc++2/cc++/audio.h
|
||||
lib/ccaudio1/g.711
|
||||
lib/libccaudio1-1.2.so
|
||||
lib/libccaudio1-1.2.so.0
|
||||
lib/libccaudio1.a
|
||||
lib/libccaudio1.la
|
||||
lib/libccaudio1.so
|
||||
@dirrmtry include/cc++2/cc++
|
||||
@dirrmtry include/cc++2
|
||||
@dirrmtry lib/ccaudio1
|
||||
include/cc++/audio2.h
|
||||
lib/ccaudio2-0.9/adpcm.codec
|
||||
lib/ccaudio2-0.9/g.711.codec
|
||||
lib/ccaudio2-0.9/oki.codec
|
||||
lib/libccaudio2-0.9.so
|
||||
lib/libccaudio2-0.9.so.0
|
||||
lib/libccaudio2.a
|
||||
lib/libccaudio2.la
|
||||
lib/libccaudio2.so
|
||||
libdata/pkgconfig/libccaudio2.pc
|
||||
bin/audiotool
|
||||
bin/tonetool
|
||||
@dirrmtry include/cc++
|
||||
@dirrm lib/ccaudio2-0.9
|
||||
|
Loading…
Reference in New Issue
Block a user