Use MAKE_ARGS & libtool 15

This commit is contained in:
Volker Stolz 2005-05-18 18:03:47 +00:00
parent 1b2fcc8241
commit 7bda937f26
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=135567
5 changed files with 4 additions and 34 deletions

View File

@ -26,12 +26,13 @@ USE_GNOME= esound lthack
USE_GL= yes
USE_REINPLACE= yes
USE_GMAKE= yes
USE_LIBTOOL_VER=13
USE_LIBTOOL_VER=15
CONFIGURE_ENV= EROOT="${X11BASE}/share/enlightenment" \
EBIN="${X11BASE}/bin" \
CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
LDFLAGS="-L${LOCALBASE}/lib -lintl ${PTHREAD_LIBS}"
CONFIGURE_ARGS= --enable-fsstd
MAKE_ARGS= SUBDIRS="epplets debian"
.include <bsd.port.pre.mk>

View File

@ -1,11 +0,0 @@
--- Makefile.in.orig Thu Nov 6 07:09:39 2003
+++ Makefile.in Mon Dec 8 02:20:28 2003
@@ -107,7 +107,7 @@
AUTOMAKE_OPTIONS = foreign
-SUBDIRS = api epplets debian
+SUBDIRS = epplets debian
EXTRA_DIST = autogen.sh epplets.spec
ACLOCAL_M4 = $(top_srcdir)/aclocal.m4

View File

@ -20,11 +20,12 @@ USE_X_PREFIX= yes
USE_GNOME= imlib
USE_GL= yes
USE_GMAKE= yes
USE_INC_LIBTOOL_VER=13
USE_LIBTOOL_VER=15
CONFIGURE_ENV= EROOT="${X11BASE}/share/enlightenment" \
EBIN="${X11BASE}/bin" \
CPPFLAGS="${CPPFLAGS}" \
LDFLAGS="${LDFLAGS}"
MAKE_ARGS= SUBDIRS="api debian"
INSTALLS_SHLIB= yes
CPPFLAGS= -I${LOCALBASE}/include -I${X11BASE}/include ${PTHREAD_CFLAGS}

View File

@ -1,11 +0,0 @@
--- Makefile.in.orig Thu Nov 6 07:09:39 2003
+++ Makefile.in Mon Dec 8 02:20:28 2003
@@ -107,7 +107,7 @@
AUTOMAKE_OPTIONS = foreign
-SUBDIRS = api epplets debian
+SUBDIRS = api debian
EXTRA_DIST = autogen.sh epplets.spec
ACLOCAL_M4 = $(top_srcdir)/aclocal.m4

View File

@ -1,10 +0,0 @@
--- configure.orig Tue Aug 26 12:12:44 2003
+++ configure Mon Dec 8 02:20:46 2003
@@ -5414,6 +5414,7 @@
# This can be used to rebuild libtool when needed
LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
+$ac_aux_dir/ltconfig $LIBTOOL_DEPS
# Always use our own libtool.
LIBTOOL='$(SHELL) $(top_builddir)/libtool'