Fix build with -fno-common
While here regenerate the patch files as requested by portlint and add two library dependencies as requested by stage-qa.
This commit is contained in:
parent
1ed7ff4bc1
commit
7bd7d47528
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=547521
@ -2,7 +2,7 @@
|
||||
|
||||
PORTNAME?= openvas8-manager
|
||||
PORTVERSION?= 6.0.11
|
||||
PORTREVISION= 2
|
||||
PORTREVISION= 3
|
||||
CATEGORIES= security
|
||||
MASTER_SITES?= http://wald.intevation.org/frs/download.php/2445/
|
||||
DISTNAME= ${PORTNAME:S/${OPENVAS_VER}//}-${PORTVERSION}
|
||||
@ -18,7 +18,10 @@ BUILD_DEPENDS= p5-SQL-Translator>=0:databases/p5-SQL-Translator
|
||||
LIB_DEPENDS= libgnutls.so:security/gnutls \
|
||||
libgpgme.so:security/gpgme \
|
||||
libgcrypt.so:security/libgcrypt \
|
||||
libopenvas_base.so:security/openvas${OPENVAS_VER}-libraries
|
||||
libopenvas_base.so:security/openvas${OPENVAS_VER}-libraries \
|
||||
libassuan.so:security/libassuan \
|
||||
libgpg-error.so:security/libgpg-error
|
||||
|
||||
RUN_DEPENDS:= ${BUILD_DEPENDS} \
|
||||
wget:ftp/wget
|
||||
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- CMakeLists.txt 2017-06-21 05:04:50.000000000 -0500
|
||||
+++ CMakeLists.txt 2017-08-04 00:45:04.904399000 -0500
|
||||
@@ -153,7 +153,7 @@
|
||||
--- CMakeLists.txt.orig 2017-06-21 10:04:50 UTC
|
||||
+++ CMakeLists.txt
|
||||
@@ -153,7 +153,7 @@ if (NOT LIBDIR)
|
||||
endif (NOT LIBDIR)
|
||||
|
||||
if (NOT LOCALSTATEDIR)
|
||||
@ -9,7 +9,7 @@
|
||||
endif (NOT LOCALSTATEDIR)
|
||||
|
||||
if (NOT DATADIR)
|
||||
@@ -196,6 +196,8 @@
|
||||
@@ -196,6 +196,8 @@ set (OPENVAS_CA_CERTIFICATE "${OPENVAS_STATE_DIR}
|
||||
|
||||
set (OPENVAS_NVT_DIR "${OPENVAS_STATE_DIR}/plugins/")
|
||||
|
||||
@ -18,7 +18,7 @@
|
||||
message ("-- Install prefix: ${CMAKE_INSTALL_PREFIX}")
|
||||
|
||||
## Dependency checks
|
||||
@@ -284,7 +286,7 @@
|
||||
@@ -284,7 +286,7 @@ configure_file (tools/openvas-migrate-to-postgres.in t
|
||||
|
||||
## Program
|
||||
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- src/CMakeLists.txt 2015-12-08 02:09:32.000000000 -0500
|
||||
+++ src/CMakeLists.txt 2017-08-04 00:48:57.665021000 -0500
|
||||
@@ -66,7 +66,7 @@
|
||||
--- src/CMakeLists.txt.orig 2015-12-08 07:09:32 UTC
|
||||
+++ src/CMakeLists.txt
|
||||
@@ -66,7 +66,7 @@ add_library (otp STATIC otp.c)
|
||||
## Program
|
||||
|
||||
add_executable (openvasmd openvasmd.c ompd.c)
|
||||
@ -9,7 +9,7 @@
|
||||
|
||||
set_target_properties (openvasmd PROPERTIES LINKER_LANGUAGE C)
|
||||
|
||||
@@ -159,7 +159,7 @@
|
||||
@@ -159,7 +159,7 @@ install (TARGETS openvasmd
|
||||
|
||||
if (BACKEND STREQUAL POSTGRESQL)
|
||||
install (TARGETS manage-pg-server
|
||||
|
@ -1,5 +1,5 @@
|
||||
--- src/manage_sql.c 2017-06-19 08:14:58.000000000 -0500
|
||||
+++ src/manage_sql.c 2017-08-05 19:47:05.407323000 -0500
|
||||
--- src/manage_sql.c.orig 2017-06-19 13:14:58 UTC
|
||||
+++ src/manage_sql.c
|
||||
@@ -58,6 +58,7 @@
|
||||
#include <unistd.h>
|
||||
#include <sys/time.h>
|
||||
@ -8,7 +8,16 @@
|
||||
|
||||
#include <openvas/base/openvas_string.h>
|
||||
#include <openvas/base/openvas_file.h>
|
||||
@@ -950,7 +951,7 @@
|
||||
@@ -97,7 +98,7 @@ manage_scap_loaded ();
|
||||
/**
|
||||
* @brief Flag to force authentication to succeed. For scheduled tasks.
|
||||
*/
|
||||
-int authenticate_allow_all;
|
||||
+extern int authenticate_allow_all;
|
||||
|
||||
const char *threat_message_type (const char *);
|
||||
|
||||
@@ -950,7 +951,7 @@ iso_time_internal (time_t *epoch_time, const char **ab
|
||||
static char time_string[100];
|
||||
|
||||
tm = localtime (epoch_time);
|
||||
@ -17,7 +26,7 @@
|
||||
{
|
||||
if (strftime (time_string, 98, "%FT%TZ", tm) == 0)
|
||||
return NULL;
|
||||
@@ -24386,7 +24387,7 @@
|
||||
@@ -24386,7 +24387,7 @@ report_port_count (report_t report)
|
||||
{
|
||||
return sql_int ("SELECT count (DISTINCT port) FROM results"
|
||||
" WHERE report = %llu AND port != ''"
|
||||
@ -26,7 +35,7 @@
|
||||
report);
|
||||
}
|
||||
|
||||
@@ -24401,7 +24402,7 @@
|
||||
@@ -24401,7 +24402,7 @@ prognostic_host_port_count (report_t report, const cha
|
||||
{
|
||||
return sql_int ("SELECT count (DISTINCT port) FROM results"
|
||||
" WHERE report = %llu AND host = '%s'"
|
||||
@ -35,7 +44,7 @@
|
||||
report,
|
||||
host);
|
||||
}
|
||||
@@ -33237,7 +33238,7 @@
|
||||
@@ -33237,7 +33238,7 @@ init_otp_pref_iterator (iterator_t* iterator,
|
||||
" WHERE config_preferences.config = %llu"
|
||||
" AND config_preferences.type = '%s'"
|
||||
" AND (config_preferences.name = nvt_preferences.name"
|
||||
@ -44,7 +53,7 @@
|
||||
" AND config_preferences.name != 'max_checks'"
|
||||
" AND config_preferences.name != 'max_hosts'"
|
||||
" UNION"
|
||||
@@ -43502,12 +43503,12 @@
|
||||
@@ -43502,12 +43503,12 @@ modify_schedule (const char *schedule_id, const char *
|
||||
if (duration == -1)
|
||||
duration_string = NULL;
|
||||
else
|
||||
@ -59,7 +68,7 @@
|
||||
|
||||
if ((period_months == -1) || (period_months == 0))
|
||||
{
|
||||
@@ -43519,12 +43520,12 @@
|
||||
@@ -43519,12 +43520,12 @@ modify_schedule (const char *schedule_id, const char *
|
||||
else
|
||||
{
|
||||
period_months_string = g_strdup ("0");
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- src/omp.c.orig 2016-02-26 13:38:52 UTC
|
||||
--- src/omp.c.orig 2017-06-21 07:16:17 UTC
|
||||
+++ src/omp.c
|
||||
@@ -16340,11 +16340,11 @@ omp_xml_handle_end_element (/*@unused@*/
|
||||
@@ -16424,11 +16424,11 @@ omp_xml_handle_end_element (/*@unused@*/ GMarkupParseC
|
||||
"<timezone_abbrev>%s</timezone_abbrev>",
|
||||
iso,
|
||||
(next_time == 0 ? "over" : iso_time_tz (&next_time, timezone, NULL)),
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- src/openvasmd.c 2017-06-16 03:06:07.000000000 -0500
|
||||
+++ src/openvasmd.c 2017-08-03 13:21:58.536708000 -0500
|
||||
@@ -634,7 +634,7 @@
|
||||
--- src/openvasmd.c.orig 2017-06-16 08:06:07 UTC
|
||||
+++ src/openvasmd.c
|
||||
@@ -634,7 +634,7 @@ cleanup ()
|
||||
}
|
||||
#endif /* LOG */
|
||||
tracef (" Exiting.\n");
|
||||
@ -9,7 +9,7 @@
|
||||
|
||||
/* Tear down authentication system conf, if any. */
|
||||
openvas_auth_tear_down ();
|
||||
@@ -887,7 +887,7 @@
|
||||
@@ -887,7 +887,7 @@ update_or_rebuild_nvt_cache (int update_nvt_cache, int
|
||||
break;
|
||||
case -2:
|
||||
g_critical ("%s: database is wrong version\n", __FUNCTION__);
|
||||
@ -18,7 +18,7 @@
|
||||
exit (EXIT_FAILURE);
|
||||
break;
|
||||
case -3:
|
||||
@@ -895,7 +895,7 @@
|
||||
@@ -895,7 +895,7 @@ update_or_rebuild_nvt_cache (int update_nvt_cache, int
|
||||
case -1:
|
||||
default:
|
||||
g_critical ("%s: failed to initialise OMP daemon\n", __FUNCTION__);
|
||||
@ -27,7 +27,7 @@
|
||||
exit (EXIT_FAILURE);
|
||||
}
|
||||
|
||||
@@ -905,7 +905,7 @@
|
||||
@@ -905,7 +905,7 @@ update_or_rebuild_nvt_cache (int update_nvt_cache, int
|
||||
{
|
||||
g_critical ("%s: failed to register `atexit' cleanup function\n",
|
||||
__FUNCTION__);
|
||||
@ -36,7 +36,7 @@
|
||||
exit (EXIT_FAILURE);
|
||||
}
|
||||
|
||||
@@ -1234,6 +1234,7 @@
|
||||
@@ -1234,6 +1234,7 @@ manager_listen (const char *address_str, const char *p
|
||||
struct sockaddr_storage address;
|
||||
struct sockaddr_in *addr4 = (struct sockaddr_in *) &address;
|
||||
struct sockaddr_in6 *addr6 = (struct sockaddr_in6 *) &address;
|
||||
@ -44,7 +44,7 @@
|
||||
int port, optval;
|
||||
|
||||
if (!address_str)
|
||||
@@ -1262,11 +1263,13 @@
|
||||
@@ -1262,11 +1263,13 @@ manager_listen (const char *address_str, const char *p
|
||||
{
|
||||
address.ss_family = AF_INET6;
|
||||
addr6->sin6_port = port;
|
||||
@ -58,7 +58,7 @@
|
||||
}
|
||||
else
|
||||
{
|
||||
@@ -1297,7 +1300,7 @@
|
||||
@@ -1297,7 +1300,7 @@ manager_listen (const char *address_str, const char *p
|
||||
return -1;
|
||||
}
|
||||
|
||||
@ -67,7 +67,7 @@
|
||||
== -1)
|
||||
{
|
||||
g_warning ("Failed to bind manager socket: %s", strerror (errno));
|
||||
@@ -1556,25 +1559,25 @@
|
||||
@@ -1556,25 +1559,25 @@ main (int argc, char** argv)
|
||||
switch (manage_optimize (log_config, database, optimize))
|
||||
{
|
||||
case 0:
|
||||
@ -98,7 +98,7 @@
|
||||
return EXIT_FAILURE;
|
||||
}
|
||||
return EXIT_SUCCESS;
|
||||
@@ -1612,7 +1615,7 @@
|
||||
@@ -1612,7 +1615,7 @@ main (int argc, char** argv)
|
||||
scanner_ca_pub, scanner_key_pub,
|
||||
scanner_key_priv);
|
||||
g_free (stype);
|
||||
@ -107,7 +107,7 @@
|
||||
switch (ret)
|
||||
{
|
||||
case 0:
|
||||
@@ -1664,7 +1667,7 @@
|
||||
@@ -1664,7 +1667,7 @@ main (int argc, char** argv)
|
||||
stype, scanner_ca_pub, scanner_key_pub,
|
||||
scanner_key_priv);
|
||||
g_free (stype);
|
||||
@ -116,7 +116,7 @@
|
||||
switch (ret)
|
||||
{
|
||||
case 0:
|
||||
@@ -1694,22 +1697,22 @@
|
||||
@@ -1694,22 +1697,22 @@ main (int argc, char** argv)
|
||||
switch (manage_create_user (log_config, database, create_user, role))
|
||||
{
|
||||
case 0:
|
||||
@ -143,7 +143,7 @@
|
||||
return EXIT_FAILURE;
|
||||
}
|
||||
return EXIT_SUCCESS;
|
||||
@@ -1723,32 +1726,32 @@
|
||||
@@ -1723,32 +1726,32 @@ main (int argc, char** argv)
|
||||
switch (manage_delete_user (log_config, database, delete_user))
|
||||
{
|
||||
case 0:
|
||||
@ -182,7 +182,7 @@
|
||||
return EXIT_FAILURE;
|
||||
}
|
||||
}
|
||||
@@ -1759,22 +1762,22 @@
|
||||
@@ -1759,22 +1762,22 @@ main (int argc, char** argv)
|
||||
switch (manage_get_users (log_config, database, role))
|
||||
{
|
||||
case 0:
|
||||
@ -209,7 +209,7 @@
|
||||
return EXIT_FAILURE;
|
||||
}
|
||||
}
|
||||
@@ -1783,7 +1786,7 @@
|
||||
@@ -1783,7 +1786,7 @@ main (int argc, char** argv)
|
||||
{
|
||||
/* List the users and then exit. */
|
||||
int ret = manage_get_scanners (log_config, database);
|
||||
@ -218,7 +218,7 @@
|
||||
switch (ret)
|
||||
{
|
||||
case 0:
|
||||
@@ -1806,7 +1809,7 @@
|
||||
@@ -1806,7 +1809,7 @@ main (int argc, char** argv)
|
||||
{
|
||||
/* List the slaves and then exit. */
|
||||
int ret = manage_get_slaves (log_config, database);
|
||||
@ -227,7 +227,7 @@
|
||||
switch (ret)
|
||||
{
|
||||
case 0:
|
||||
@@ -1831,7 +1834,7 @@
|
||||
@@ -1831,7 +1834,7 @@ main (int argc, char** argv)
|
||||
|
||||
/* Delete the scanner and then exit. */
|
||||
ret = manage_delete_scanner (log_config, database, delete_scanner);
|
||||
@ -236,7 +236,7 @@
|
||||
switch (ret)
|
||||
{
|
||||
case 0:
|
||||
@@ -1859,7 +1862,7 @@
|
||||
@@ -1859,7 +1862,7 @@ main (int argc, char** argv)
|
||||
|
||||
/* Delete the scanner and then exit. */
|
||||
ret = manage_verify_scanner (log_config, database, verify_scanner);
|
||||
@ -245,7 +245,7 @@
|
||||
switch (ret)
|
||||
{
|
||||
case 0:
|
||||
@@ -1894,26 +1897,26 @@
|
||||
@@ -1894,26 +1897,26 @@ main (int argc, char** argv)
|
||||
switch (manage_set_password (log_config, database, user, new_password))
|
||||
{
|
||||
case 0:
|
||||
@ -277,7 +277,7 @@
|
||||
return EXIT_FAILURE;
|
||||
}
|
||||
}
|
||||
@@ -1996,24 +1999,24 @@
|
||||
@@ -1996,24 +1999,24 @@ main (int argc, char** argv)
|
||||
case -2:
|
||||
g_critical ("%s: database is wrong version\n", __FUNCTION__);
|
||||
fprintf (stderr, "Decryption failed.\n");
|
||||
@ -306,7 +306,7 @@
|
||||
return EXIT_SUCCESS;
|
||||
}
|
||||
|
||||
@@ -2027,24 +2030,24 @@
|
||||
@@ -2027,24 +2030,24 @@ main (int argc, char** argv)
|
||||
case -2:
|
||||
g_critical ("%s: database is wrong version\n", __FUNCTION__);
|
||||
fprintf (stderr, "Decryption failed.\n");
|
||||
@ -335,7 +335,7 @@
|
||||
return EXIT_SUCCESS;
|
||||
}
|
||||
|
||||
@@ -2116,12 +2119,12 @@
|
||||
@@ -2116,12 +2119,12 @@ main (int argc, char** argv)
|
||||
g_critical ("%s: failed to fork into background: %s\n",
|
||||
__FUNCTION__,
|
||||
strerror (errno));
|
||||
@ -350,7 +350,7 @@
|
||||
exit (EXIT_SUCCESS);
|
||||
break;
|
||||
}
|
||||
@@ -2137,25 +2140,25 @@
|
||||
@@ -2137,25 +2140,25 @@ main (int argc, char** argv)
|
||||
break;
|
||||
case -2:
|
||||
g_critical ("%s: database is wrong version\n", __FUNCTION__);
|
||||
@ -380,7 +380,7 @@
|
||||
exit (EXIT_FAILURE);
|
||||
}
|
||||
|
||||
@@ -2165,7 +2168,7 @@
|
||||
@@ -2165,7 +2168,7 @@ main (int argc, char** argv)
|
||||
{
|
||||
g_critical ("%s: failed to register `atexit' cleanup function\n",
|
||||
__FUNCTION__);
|
||||
|
@ -1,5 +1,5 @@
|
||||
--- src/sql_pg.c 2017-08-04 00:41:59.376627000 -0500
|
||||
+++ src/sql_pg.c 2017-08-04 00:42:16.863937000 -0500
|
||||
--- src/sql_pg.c.orig 2015-12-08 07:09:33 UTC
|
||||
+++ src/sql_pg.c
|
||||
@@ -27,12 +27,12 @@
|
||||
#include "tracef.h"
|
||||
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- tools/greenbone-scapdata-sync.in 2015-12-08 02:09:31.000000000 -0500
|
||||
+++ tools/greenbone-scapdata-sync.in 2017-08-05 22:00:27.817110000 -0500
|
||||
@@ -297,7 +297,7 @@
|
||||
--- tools/greenbone-scapdata-sync.in.orig 2015-12-08 07:09:31 UTC
|
||||
+++ tools/greenbone-scapdata-sync.in
|
||||
@@ -297,7 +297,7 @@ is_feed_current () {
|
||||
then
|
||||
log_err "Could not determine credentials, aborting synchronization."
|
||||
rm -rf $FEED_INFO_TEMP_DIR
|
||||
@ -9,7 +9,7 @@
|
||||
fi
|
||||
|
||||
# --protocol=29 is a workaround for a known bug in rsync 3.0.3
|
||||
@@ -321,12 +321,12 @@
|
||||
@@ -321,12 +321,12 @@ is_feed_current () {
|
||||
then
|
||||
log_err "rsync failed, aborting synchronization."
|
||||
rm -rf $FEED_INFO_TEMP_DIR
|
||||
@ -24,7 +24,7 @@
|
||||
fi
|
||||
|
||||
FEED_VERSION_SERVER=`cat $FEED_INFO_TEMP_DIR/timestamp`
|
||||
@@ -335,7 +335,7 @@
|
||||
@@ -335,7 +335,7 @@ is_feed_current () {
|
||||
then
|
||||
log_err "Could not determine server feed version."
|
||||
rm -rf $FEED_INFO_TEMP_DIR
|
||||
@ -33,7 +33,7 @@
|
||||
fi
|
||||
|
||||
# Check against FEED_VERSION
|
||||
@@ -962,11 +962,11 @@
|
||||
@@ -962,11 +962,11 @@ update_scap_db_private () {
|
||||
then
|
||||
for ovalfile in $oval_files_sorted_private
|
||||
do
|
||||
@ -47,7 +47,7 @@
|
||||
|
||||
if [ 1 = "$REBUILD_OVAL" ]
|
||||
then
|
||||
@@ -1068,8 +1068,8 @@
|
||||
@@ -1068,8 +1068,8 @@ update_scap_db_private () {
|
||||
fi
|
||||
|
||||
# TODO: This is not quite accurate as it uses the timestamp of the non-private data.
|
||||
@ -58,7 +58,7 @@
|
||||
reset_sql_tries
|
||||
until [ "$try_sql" -eq 0 ]
|
||||
do
|
||||
@@ -1090,12 +1090,12 @@
|
||||
@@ -1090,12 +1090,12 @@ update_scap_db() {
|
||||
CPEBASE="$SCAP_DIR/official-cpe-dictionary_v2.2.xml"
|
||||
if [ -e $CPEBASE ]
|
||||
then
|
||||
@ -73,7 +73,7 @@
|
||||
if [ "0" -ne "$SPLIT_PART_SIZE" ] && [ "$filesize" -gt $(($SPLIT_PART_SIZE * 1024)) ]
|
||||
then
|
||||
log_info "File is larger than ${SPLIT_PART_SIZE}k. Splitting into multiple parts"
|
||||
@@ -1152,13 +1152,13 @@
|
||||
@@ -1152,13 +1152,13 @@ update_scap_db() {
|
||||
then
|
||||
for cvefile in `ls $SCAP_DIR/nvdcve-2.0-*.xml`
|
||||
do
|
||||
@ -89,7 +89,7 @@
|
||||
if [ "0" -ne "$SPLIT_PART_SIZE" ] && [ "$filesize" -gt $(($SPLIT_PART_SIZE * 1024)) ]
|
||||
then
|
||||
log_info "File is larger than ${SPLIT_PART_SIZE}k. Splitting into multiple parts"
|
||||
@@ -1228,11 +1228,11 @@
|
||||
@@ -1228,11 +1228,11 @@ update_scap_db() {
|
||||
|
||||
for ovalfile in $oval_files_sorted
|
||||
do
|
||||
@ -103,7 +103,7 @@
|
||||
|
||||
if [ 1 = "$REBUILD_OVAL" ]
|
||||
then
|
||||
@@ -1284,7 +1284,7 @@
|
||||
@@ -1284,7 +1284,7 @@ update_scap_db() {
|
||||
update_cvss
|
||||
update_placeholders
|
||||
|
||||
@ -112,7 +112,7 @@
|
||||
|
||||
reset_sql_tries
|
||||
until [ "$try_sql" -eq 0 ]
|
||||
@@ -1469,7 +1469,7 @@
|
||||
@@ -1469,7 +1469,7 @@ then
|
||||
exit 1
|
||||
fi
|
||||
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- tools/openvas-scapdata-sync.in 2017-05-02 02:32:45.000000000 -0500
|
||||
+++ tools/openvas-scapdata-sync.in 2017-08-05 22:40:11.310734000 -0500
|
||||
@@ -63,7 +63,7 @@
|
||||
--- tools/openvas-scapdata-sync.in.orig 2017-05-02 07:32:45 UTC
|
||||
+++ tools/openvas-scapdata-sync.in
|
||||
@@ -63,7 +63,7 @@ fi
|
||||
|
||||
# Delay between retries
|
||||
if [ -z "$SQL_RETRY_DELAY" ]; then
|
||||
@ -9,7 +9,7 @@
|
||||
fi
|
||||
|
||||
TIMESTAMP="$SCAP_DIR/timestamp"
|
||||
@@ -885,11 +885,11 @@
|
||||
@@ -885,11 +885,11 @@ update_sec_db_private () {
|
||||
then
|
||||
for ovalfile in $oval_files_sorted_private
|
||||
do
|
||||
@ -23,7 +23,7 @@
|
||||
|
||||
if [ 1 = "$REBUILD_OVAL" ]
|
||||
then
|
||||
@@ -958,7 +958,7 @@
|
||||
@@ -958,7 +958,7 @@ update_sec_db_private () {
|
||||
DIR_STR_LENGTH=$((`echo "$SCAP_DIR" | wc -c` + 1))
|
||||
|
||||
oval_files_shortened=""
|
||||
@ -32,7 +32,7 @@
|
||||
then
|
||||
for ovalfile in $oval_files_sorted_private
|
||||
do
|
||||
@@ -968,7 +968,7 @@
|
||||
@@ -968,7 +968,7 @@ update_sec_db_private () {
|
||||
fi
|
||||
|
||||
oval_files_clause=""
|
||||
@ -41,7 +41,7 @@
|
||||
then
|
||||
oval_files_clause="AND (xml_file NOT IN ($oval_files_shortened))"
|
||||
fi
|
||||
@@ -993,7 +993,7 @@
|
||||
@@ -993,7 +993,7 @@ update_sec_db_private () {
|
||||
fi
|
||||
|
||||
# TODO: This is not quite accurate as it uses the timestamp of the non-private data.
|
||||
@ -50,7 +50,7 @@
|
||||
|
||||
reset_sql_tries
|
||||
until [ "$try_sql" -eq 0 ]
|
||||
@@ -1012,13 +1012,13 @@
|
||||
@@ -1012,13 +1012,13 @@ update_sec_db () {
|
||||
CPEBASE="$SCAP_DIR/official-cpe-dictionary_v2.2.xml"
|
||||
if [ -e $CPEBASE ]
|
||||
then
|
||||
@ -66,7 +66,7 @@
|
||||
if [ "0" -ne "$SPLIT_PART_SIZE" ] && [ "$filesize" -gt $(($SPLIT_PART_SIZE * 1024)) ]
|
||||
then
|
||||
echo "[i] File is larger than ${SPLIT_PART_SIZE}k. Splitting into multiple parts"
|
||||
@@ -1075,13 +1075,13 @@
|
||||
@@ -1075,13 +1075,13 @@ update_sec_db () {
|
||||
then
|
||||
for cvefile in `ls $SCAP_DIR/nvdcve-2.0-*.xml`
|
||||
do
|
||||
@ -82,7 +82,7 @@
|
||||
if [ "0" -ne "$SPLIT_PART_SIZE" ] && [ "$filesize" -gt $(($SPLIT_PART_SIZE * 1024)) ]
|
||||
then
|
||||
echo "[i] File is larger than ${SPLIT_PART_SIZE}k. Splitting into multiple parts"
|
||||
@@ -1151,11 +1151,11 @@
|
||||
@@ -1151,11 +1151,11 @@ update_sec_db () {
|
||||
|
||||
for ovalfile in $oval_files_sorted
|
||||
do
|
||||
@ -96,7 +96,7 @@
|
||||
|
||||
if [ 1 = "$REBUILD_OVAL" ]
|
||||
then
|
||||
@@ -1206,7 +1206,7 @@
|
||||
@@ -1206,7 +1206,7 @@ update_sec_db () {
|
||||
update_cvss
|
||||
update_placeholders
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user