Add scim 0.99.2, smart Common Input Method platform.

PR:		ports/67133
Submitted by:	Jie Gao	<gaoj@cpsc.ucalgary.ca>
Somepart by:	me
This commit is contained in:
Vanilla I. Shu 2004-07-02 22:35:29 +00:00
parent 950f06a04d
commit 7bd1ef9e0e
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=112809
7 changed files with 229 additions and 0 deletions

View File

@ -512,6 +512,7 @@
SUBDIR += sarep
SUBDIR += sary
SUBDIR += saxon
SUBDIR += scim
SUBDIR += scr2txt
SUBDIR += scrollkeeper
SUBDIR += sdf

50
textproc/scim/Makefile Normal file
View File

@ -0,0 +1,50 @@
# New ports collection makefile for: scim
# Date created: 20 May 2004
# Whom: Jie Gao <gaoj@cpsc.ucalgary.ca>
#
# $FreeBSD$
#
PORTNAME= scim
PORTVERSION= 0.99.2
CATEGORIES= textproc
MASTER_SITES= http://freedesktop.org/~suzhe/sources/
MAINTAINER= gaoj@cpsc.ucalgary.ca
COMMENT= Smart Common Input Method platform
USE_GNOME= gtk20 gconf2 lthack
USE_X_PREFIX= yes
USE_ICONV= yes
USE_GMAKE= yes
USE_REINPLACE= yes
INSTALLS_SHLIB= yes
USE_LIBTOOL_VER= 15
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -lintl" \
PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LIBS="${PTHREAD_LIBS}"
.include <bsd.port.pre.mk>
.if ${OSVERSION} <= 499999
BROKEN= "4.x lacks C99 compliant wctypes implementation"
.endif
# Pay attention to the quotes usage below
post-patch:
${REINPLACE_CMD} 's/,.GB2312"/,.GB2312,.eucCN"/g' \
${WRKSRC}/src/scim_utility.cpp
post-configure:
${REINPLACE_CMD} '/^pkgconfigdir/s|$$(libdir)|$${exec_prefix}/libdata|' \
${WRKSRC}/Makefile
${REINPLACE_CMD} '/^scim_setup_LDFLAGS/s|=|= ${PTHREAD_LIBS}|g' \
${WRKSRC}/extras/setup/Makefile
post-install:
@${CAT} ${PKGMESSAGE}
@${ECHO} To display this message again, type make post-install
.include <bsd.port.post.mk>

2
textproc/scim/distinfo Normal file
View File

@ -0,0 +1,2 @@
MD5 (scim-0.99.2.tar.gz) = 0c63b30d1ec1a6e9668305ad2bdfd0c5
SIZE (scim-0.99.2.tar.gz) = 1954220

View File

@ -0,0 +1,51 @@
--- ltmain.sh.orig Sat Dec 6 14:47:45 2003
+++ ltmain.sh Tue Dec 9 14:09:01 2003
@@ -1280,7 +1280,7 @@
esac
elif test "X$arg" = "X-lc_r"; then
case $host in
- *-*-openbsd* | *-*-freebsd*)
+ *-*-openbsd* | *-*-freebsd4*)
# Do not include libc_r directly, use -pthread flag.
continue
;;
@@ -1290,8 +1290,16 @@
continue
;;
+ -pthread)
+ compile_command="$compile_command -pthread"
+ finalize_command="$finalize_command -pthread"
+ compiler_flags="$compiler_flags -pthread"
+ continue
+ ;;
+
-module)
module=yes
+ build_old_libs=no
continue
;;
@@ -3000,6 +3008,9 @@
# problems, so we reset it completely
verstring=
;;
+ *-*-freebsd*)
+ # FreeBSD doesn't need this...
+ ;;
*)
verstring="0.0"
;;
@@ -5428,10 +5439,12 @@
fi
# Install the pseudo-library for information purposes.
+ if /usr/bin/false; then
name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
instname="$dir/$name"i
$show "$install_prog $instname $destdir/$name"
$run eval "$install_prog $instname $destdir/$name" || exit $?
+ fi
# Maybe install the static library, too.
test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"

5
textproc/scim/pkg-descr Normal file
View File

@ -0,0 +1,5 @@
Smart Common Input Method platform, in short SCIM, is a development platform
to make Input Method developers live easier. It has very clear architecture
and very simple programming interface.
WWW: http://freedesktop.org/~suzhe/

21
textproc/scim/pkg-message Normal file
View File

@ -0,0 +1,21 @@
------------------------------------------------------------------------------
The installation of SCIM has finished. Please note this port is only a common
framework for input methods and does not contain any actual input methods.
In the ports collection the following input method components for SCIM are
available:
Chinese:
chinese/scim-tables Table based input methods: Array30, CangJie, Cantonese,
Dayi, Erbi, EZ, Jyutping, Simplex, Wubi, Ziranma, ZhuYin
chinese/scim-chinese Smart pinyin
Korean:
korean/scim-tables Table based input methods: Hangul, Hanja
Japanese:
japanese/scim-tables Table based input methods: HIRAGANA, KATAKANA, Nippon
As a common rule, set XMODIFIERS to '@im=SCIM' and use `scim -d' to start the
scim daemon.
------------------------------------------------------------------------------

99
textproc/scim/pkg-plist Normal file
View File

@ -0,0 +1,99 @@
bin/scim
bin/scim-config-agent
bin/scim-make-table
bin/scim-setup
@unexec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-uninstall-rule %D/etc/gconf/schemas/scim.schemas >/dev/null || /usr/bin/true
etc/gconf/schemas/scim.schemas
etc/scim/config
etc/scim/global
include/scim-1.0/gtk/scimkeyselection.h
include/scim-1.0/gtk/scimstringview.h
include/scim-1.0/gtk/scimtrayicon.h
include/scim-1.0/scim.h
include/scim-1.0/scim_attribute.h
include/scim-1.0/scim_backend.h
include/scim-1.0/scim_bind.h
include/scim-1.0/scim_config_base.h
include/scim-1.0/scim_config_module.h
include/scim-1.0/scim_config_path.h
include/scim-1.0/scim_connection.h
include/scim-1.0/scim_debug.h
include/scim-1.0/scim_event.h
include/scim-1.0/scim_exception.h
include/scim-1.0/scim_frontend.h
include/scim-1.0/scim_frontend_module.h
include/scim-1.0/scim_global_config.h
include/scim-1.0/scim_iconv.h
include/scim-1.0/scim_imengine.h
include/scim-1.0/scim_imengine_module.h
include/scim-1.0/scim_lookup_table.h
include/scim-1.0/scim_module.h
include/scim-1.0/scim_object.h
include/scim-1.0/scim_panel.h
include/scim-1.0/scim_pointer.h
include/scim-1.0/scim_property.h
include/scim-1.0/scim_signals.h
include/scim-1.0/scim_slot.h
include/scim-1.0/scim_socket.h
include/scim-1.0/scim_socket_transaction.h
include/scim-1.0/scim_types.h
include/scim-1.0/scim_utility.h
lib/libscim-1.0.a
lib/libscim-1.0.so
lib/libscim-1.0.so.1
lib/libscim-gtkutils-1.0.a
lib/libscim-gtkutils-1.0.so
lib/libscim-gtkutils-1.0.so.1
lib/gtk-2.0/immodules/im-scim.so
lib/scim-1.0/1.0.0/Config/gconf.so
lib/scim-1.0/1.0.0/Config/simple.so
lib/scim-1.0/1.0.0/Config/socket.so
lib/scim-1.0/1.0.0/FrontEnd/socket.so
lib/scim-1.0/1.0.0/FrontEnd/x11.so
lib/scim-1.0/1.0.0/IMEngine/rawcode.so
lib/scim-1.0/1.0.0/IMEngine/socket.so
lib/scim-1.0/1.0.0/IMEngine/table.so
lib/scim-1.0/1.0.0/SetupUI/panel-gtk-setup.so
lib/scim-1.0/1.0.0/SetupUI/table-imengine-setup.so
lib/scim-1.0/1.0.0/SetupUI/x11-frontend-setup.so
libdata/pkgconfig/scim-gtkutils.pc
libdata/pkgconfig/scim.pc
libexec/scim-launcher
libexec/scim-panel-gtk
share/applications/scim-setup.desktop
share/control-center-2.0/capplets/scim-setup.desktop
share/locale/zh_CN/LC_MESSAGES/scim.mo
share/locale/zh_TW/LC_MESSAGES/scim.mo
share/pixmaps/scim-setup.png
share/scim/icons/down.png
share/scim/icons/full-letter.png
share/scim/icons/full-punct.png
share/scim/icons/half-letter.png
share/scim/icons/half-punct.png
share/scim/icons/help.png
share/scim/icons/keyboard.png
share/scim/icons/left.png
share/scim/icons/pin-down.png
share/scim/icons/pin-up.png
share/scim/icons/rawcode.png
share/scim/icons/right.png
share/scim/icons/setup.png
share/scim/icons/table.png
share/scim/icons/trademark.png
share/scim/icons/up.png
@dirrm etc/scim
@dirrm include/scim-1.0/gtk
@dirrm include/scim-1.0
@dirrm lib/gtk-2.0/immodules
@dirrm lib/scim-1.0/1.0.0/Config
@dirrm lib/scim-1.0/1.0.0/FrontEnd
@dirrm lib/scim-1.0/1.0.0/IMEngine
@dirrm lib/scim-1.0/1.0.0/SetupUI
@dirrm lib/scim-1.0/1.0.0
@dirrm lib/scim-1.0
@dirrm share/control-center-2.0/capplets
@dirrm share/control-center-2.0
@dirrm share/pixmaps
@dirrm share/scim/icons
@dirrm share/scim
@exec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-install-rule %D/etc/gconf/schemas/scim.schemas >/dev/null || /usr/bin/true