Add psiconv 0.8.2, a conversion utility to convert Psion 5(MX) files into
other formats.
This commit is contained in:
parent
3b412b94ee
commit
7b60d61ac7
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=46583
@ -34,6 +34,7 @@
|
||||
SUBDIR += p5-Text-Iconv
|
||||
SUBDIR += p5-Unicode-Map8
|
||||
SUBDIR += p5-Unicode-String
|
||||
SUBDIR += psiconv
|
||||
SUBDIR += recode
|
||||
SUBDIR += ruby-dump.rb
|
||||
SUBDIR += ruby-iconv
|
||||
|
24
converters/psiconv/Makefile
Normal file
24
converters/psiconv/Makefile
Normal file
@ -0,0 +1,24 @@
|
||||
# New ports collection makefile for: libiconv
|
||||
# Date created: 21 August 2001
|
||||
# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= psiconv
|
||||
PORTVERSION= 0.8.2
|
||||
CATEGORIES= converters devel
|
||||
MASTER_SITES= http://huizen.dds.nl/~frodol/psiconv/
|
||||
|
||||
MAINTAINER= gnome@FreeBSD.org
|
||||
|
||||
LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
|
||||
|
||||
INSTALLS_SHLIB= yes
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --with-imagemagick=no
|
||||
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
|
||||
LDFLAGS="-L${LOCALBASE}/lib -lgnugetopt"
|
||||
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
|
||||
|
||||
.include <bsd.port.mk>
|
1
converters/psiconv/distinfo
Normal file
1
converters/psiconv/distinfo
Normal file
@ -0,0 +1 @@
|
||||
MD5 (psiconv-0.8.2.tar.gz) = 76af8dca6bd52a46821aea9fb5dcf4fe
|
28
converters/psiconv/files/patch-formats::html_links.sh
Normal file
28
converters/psiconv/files/patch-formats::html_links.sh
Normal file
@ -0,0 +1,28 @@
|
||||
|
||||
$FreeBSD$
|
||||
|
||||
--- formats/html_links.sh 2001/08/21 13:34:26 1.1
|
||||
+++ formats/html_links.sh 2001/08/21 13:37:05
|
||||
@@ -1,8 +1,8 @@
|
||||
#!/bin/sh
|
||||
|
||||
-function generate_links
|
||||
+generate_links()
|
||||
{
|
||||
- local index_file name file lineno
|
||||
+ #local index_file name file lineno
|
||||
|
||||
index_file="$1"
|
||||
|
||||
@@ -17,9 +17,9 @@
|
||||
eval "$command"
|
||||
}
|
||||
|
||||
-function generate_headers
|
||||
+generate_headers()
|
||||
{
|
||||
- local index_file name this_file
|
||||
+ #local index_file name this_file
|
||||
|
||||
index_file="$1"
|
||||
this_file=`echo $2 | sed 's,.*/,,' | sed 's,\..*$,,'`
|
16
converters/psiconv/files/patch-formats::index_html.sh
Normal file
16
converters/psiconv/files/patch-formats::index_html.sh
Normal file
@ -0,0 +1,16 @@
|
||||
|
||||
$FreeBSD$
|
||||
|
||||
--- formats/index_html.sh 2001/08/21 13:34:31 1.1
|
||||
+++ formats/index_html.sh 2001/08/21 13:36:00
|
||||
@@ -1,8 +1,8 @@
|
||||
#!/bin/sh
|
||||
|
||||
-function make_targets_file
|
||||
+make_targets_file()
|
||||
{
|
||||
- local file line line_nr error targets_file files
|
||||
+ #local file line line_nr error targets_file files
|
||||
|
||||
targets_file="$1"
|
||||
shift
|
18
converters/psiconv/files/patch-ltmain.sh
Normal file
18
converters/psiconv/files/patch-ltmain.sh
Normal file
@ -0,0 +1,18 @@
|
||||
|
||||
$FreeBSD$
|
||||
|
||||
--- ltmain.sh 2001/07/03 12:57:52 1.1
|
||||
+++ ltmain.sh 2001/07/03 12:58:32
|
||||
@@ -4175,10 +4175,12 @@
|
||||
fi
|
||||
|
||||
# Install the pseudo-library for information purposes.
|
||||
+ if false; then
|
||||
name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
|
||||
instname="$dir/$name"i
|
||||
$show "$install_prog $instname $destdir/$name"
|
||||
$run eval "$install_prog $instname $destdir/$name" || exit $?
|
||||
+ fi
|
||||
|
||||
# Maybe install the static library, too.
|
||||
test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
|
1
converters/psiconv/pkg-comment
Normal file
1
converters/psiconv/pkg-comment
Normal file
@ -0,0 +1 @@
|
||||
A conversion utility to convert Psion 5(MX) files into other formats
|
10
converters/psiconv/pkg-descr
Normal file
10
converters/psiconv/pkg-descr
Normal file
@ -0,0 +1,10 @@
|
||||
Psiconv is a file conversion utility that converts between Psion 5(MX) files
|
||||
and more commonly-used *nux file formats. It can read Psion Word, TextEd,
|
||||
Sketch, MBM, and Clipart files, and outputs HTML 3.2, HTML 4, ASCII, and
|
||||
almost any graphical format. The libpsiconv library can also read Sheet files
|
||||
and output Word and TextEd files for use in other programs. Included is full
|
||||
documentation on several Psion 5(MX) file formats. This information is not
|
||||
available from Psion (it has been reverse-engineered from Psion files), and
|
||||
it's free for anybody to use.
|
||||
|
||||
WWW: http://huizen.dds.nl/~frodol/psiconv/
|
15
converters/psiconv/pkg-plist
Normal file
15
converters/psiconv/pkg-plist
Normal file
@ -0,0 +1,15 @@
|
||||
bin/psiconv
|
||||
include/psiconv/buffer.h
|
||||
include/psiconv/common.h
|
||||
include/psiconv/data.h
|
||||
include/psiconv/error.h
|
||||
include/psiconv/general.h
|
||||
include/psiconv/generate.h
|
||||
include/psiconv/generate_routines.h
|
||||
include/psiconv/list.h
|
||||
include/psiconv/parse.h
|
||||
include/psiconv/parse_routines.h
|
||||
lib/libpsiconv.a
|
||||
lib/libpsiconv.so
|
||||
lib/libpsiconv.so.7
|
||||
@dirrm include/psiconv
|
Loading…
Reference in New Issue
Block a user