Xfractint - The Unix port of fractint, devel version

Fractint is an IBM PC program to generate fractals, and was written by
the Stone Soup Group.

The UNIX port was done by Ken Shirriff and modified by Scott D. Boyd.

WWW: http://www.fractint.org

PR:		ports/138637
Submitted by:	onemda at gmail.com
This commit is contained in:
Greg Larkin 2010-01-27 21:43:41 +00:00
parent e39635a955
commit 7b57233073
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=248713
21 changed files with 377 additions and 0 deletions

View File

@ -932,6 +932,7 @@
SUBDIR += xfig-devel
SUBDIR += xfpovray
SUBDIR += xfractint
SUBDIR += xfractint-devel
SUBDIR += xglurbules
SUBDIR += xgrasp
SUBDIR += xli

View File

@ -0,0 +1,41 @@
# New ports collection makefile for: xfractint-devel
# Date created: 8 Sep 2009
# Whom: onemda@gmail.com
#
# $FreeBSD$
#
PORTNAME= xfractint
PORTVERSION= 20.04p09
CATEGORIES= graphics
MASTER_SITES= http://www.fractint.org/ftp/current/linux/ \
http://twegner.dyndns.org/fractint/ftp/current/linux/
PKGNAMESUFFIX= -devel
DISTNAME= ${PORTNAME}-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= The Unix port of fractint, devel version
USE_GMAKE= yes
USE_GZIP= yes
USE_XORG= x11
ALL_TARGET= ${PORTNAME}
MAN1= ${PORTNAME}${PKGNAMESUFFIX}.1
DATADIR= ${PREFIX}/share/${PORTNAME}${PKGNAMESUFFIX}
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/xfractint ${PREFIX}/bin/${PORTNAME}${PKGNAMESUFFIX}
@${INSTALL_MAN} ${WRKSRC}/unix/xfractint.man ${PREFIX}/man/man1/${MAN1}
@${MKDIR} ${DATADIR}
@${CP} ${WRKSRC}/fractint.hlp ${DATADIR}
@${CP} ${WRKSRC}/sstools.ini ${DATADIR}
@${CP} -R ${WRKSRC}/formulas ${DATADIR}
@${CP} -R ${WRKSRC}/ifs ${DATADIR}
@${CP} -R ${WRKSRC}/lsystem ${DATADIR}
@${CP} -R ${WRKSRC}/maps ${DATADIR}
@${CP} -R ${WRKSRC}/pars ${DATADIR}
.include <bsd.port.mk>

View File

@ -0,0 +1,3 @@
MD5 (xfractint-20.04p09.tar.gz) = 098e5ef480a8e30146a977213b2c3a2d
SHA256 (xfractint-20.04p09.tar.gz) = 296e6da82a81210b2d9ccde0eb15059d27f561f23ef1221f39fbefe48ebe5d69
SIZE (xfractint-20.04p09.tar.gz) = 1333141

View File

@ -0,0 +1,58 @@
--- ./Makefile.orig 2008-09-25 20:55:39.000000000 -0400
+++ ./Makefile 2010-01-27 13:52:46.000000000 -0500
@@ -27,8 +27,8 @@
# SRCDIR should be a path to the directory that will hold fractint.hlp
# SRCDIR should also hold the .par, .frm, etc. files
-SRCDIR = $(DESTDIR)/share/xfractint
-SHRDIR = $(PREFIX)/share/xfractint
+SRCDIR = $(PREFIX)/share/xfractint-devel
+SHRDIR = $(PREFIX)/share/xfractint-devel
# BINDIR is where you put your X11 binaries
BINDIR = $(DESTDIR)/bin
# MANDIR is where you put your chapter 1 man pages
@@ -116,22 +116,18 @@
#For Solaris, use CFLAGS = -I. -I/usr/openwin/include $(DEFINES) -g
#If you have the nasm assembler on your system add -DNASM to CFLAGS
-ifeq ($(AS),/usr/bin/nasm)
-CFLAGS = -I$(HFD) $(DEFINES) -g -DBIG_ANSI_C -DLINUX -DNASM -fno-builtin
#CFLAGS = -I. -D_CONST $(DEFINES)
#CFLAGS = -I$(HFD) $(DEFINES) -g -DBIG_ANSI_C -DLINUX \
# -march=$(ARCH) -DNASM -fno-builtin
#CFLAGS = -I. $(DEFINES) -g -DBIG_ANSI_C -DLINUX -Os -DNASM -fno-builtin
-else
-CFLAGS = -I$(HFD) $(DEFINES) -g -DBIG_ANSI_C -DLINUX -fno-builtin
+CFLAGS += -I$(PREFIX)/include -I$(HFD) $(DEFINES) -g -DBIG_ANSI_C -DLINUX -fno-builtin
#CFLAGS = -I$(HFD) $(DEFINES) -g -DBIG_ANSI_C -DLINUX \
# -march=$(ARCH) -fno-builtin
#CFLAGS = -I. $(DEFINES) -g -DBIG_ANSI_C -DLINUX -Os -fno-builtin
-endif
# Gcc is often the only compiler that works for this
# For HPUX, use CC = cc -Aa -D_HPUX_SOURCE
@@ -140,7 +136,6 @@
# For Sun Solaris 2.x w/SparcCompilerC (cc), use CC = cc.
# For Sun Solaris 2.x w/GNU gcc, use CC = gcc
#CC = gcc
-CC = /usr/bin/gcc
# For HPUX, use LIBS = -L/usr/lib/X11R4 -lX11 -lm -lcurses -ltermcap
# For AIX or OSF/1, add -lbsd
@@ -152,11 +147,7 @@
# LIBS = -L/usr/X11R6/lib -lX11 -lm -lncurses
# LIBS = -lX11 -lm -lcurses
-ifeq ($(ARCH),athlon64)
-LIBS = -L/usr/X11R6/lib64 -lX11 -lm
-else
-LIBS = -L/usr/X11R6/lib -lX11 -lm
-endif
+LIBS = -L${PREFIX}/lib -lX11 -lm
ifeq ($(NCURSES),-DNCURSES)
LIBS += -lncurses

View File

@ -0,0 +1,12 @@
--- ./common/biginit.c.orig 2008-09-18 21:58:09.000000000 -0400
+++ ./common/biginit.c 2010-01-27 13:52:46.000000000 -0500
@@ -7,7 +7,9 @@
*/
#include <string.h>
+#ifndef BIG_ANSI_C
#include <malloc.h>
+#endif
/* see Fractint.c for a description of the "include" hierarchy */
#include "port.h"
#include "prototyp.h"

View File

@ -0,0 +1,11 @@
--- ./common/fractalb.c.orig 2008-09-17 21:52:35.000000000 -0400
+++ ./common/fractalb.c 2010-01-27 13:52:46.000000000 -0500
@@ -10,7 +10,7 @@
#include <string.h>
#ifdef __TURBOC__
#include <alloc.h>
-#elif !defined(__386BSD__)
+#elif !defined(BIG_ANSI_C)
#include <malloc.h>
#endif
/* see Fractint.c for a description of the "include" hierarchy */

View File

@ -0,0 +1,11 @@
--- ./common/fractals.c.orig 2008-09-17 21:52:35.000000000 -0400
+++ ./common/fractals.c 2010-01-27 13:52:46.000000000 -0500
@@ -41,7 +41,7 @@
#include <string.h>
#ifdef __TURBOC__
#include <alloc.h>
-#elif !defined(__386BSD__)
+#elif !defined(BIG_ANSI_C)
#include <malloc.h>
#endif
/* see Fractint.c for a description of the "include" hierarchy */

View File

@ -0,0 +1,11 @@
--- ./common/frasetup.c.orig 2004-11-23 08:13:37.000000000 -0500
+++ ./common/frasetup.c 2010-01-27 13:52:46.000000000 -0500
@@ -2,7 +2,7 @@
#include <string.h>
#ifdef __TURBOC__
#include <alloc.h>
-#elif !defined(__386BSD__)
+#elif !defined(BIG_ANSI_C)
#include <malloc.h>
#endif
/* see Fractint.c for a description of the "include" hierarchy */

View File

@ -0,0 +1,11 @@
--- ./common/lsys.c.orig 2005-12-21 21:15:40.000000000 -0500
+++ ./common/lsys.c 2010-01-27 13:52:46.000000000 -0500
@@ -2,7 +2,7 @@
#include <string.h>
#ifdef __TURBOC__
#include <alloc.h>
-#else
+#elif !defined(BIG_ANSI_C)
#include <malloc.h>
#endif

View File

@ -0,0 +1,11 @@
--- ./common/lsysf.c.orig 2004-11-23 08:13:37.000000000 -0500
+++ ./common/lsysf.c 2010-01-27 13:52:46.000000000 -0500
@@ -1,7 +1,7 @@
#include <string.h>
#ifdef __TURBOC__
#include <alloc.h>
-#else
+#elif !defined(BIG_ANSI_C)
#include <malloc.h>
#endif

View File

@ -0,0 +1,9 @@
--- ./common/memory.c.orig 2006-12-17 12:06:05.000000000 -0500
+++ ./common/memory.c 2010-01-27 13:52:46.000000000 -0500
@@ -1,6 +1,5 @@
#include <string.h>
#include <limits.h>
-#include <malloc.h>
#if (!defined(XFRACT) && !defined(WINFRACT))
#include <io.h>

View File

@ -0,0 +1,10 @@
--- ./common/miscres.c.orig 2007-05-02 20:32:43.000000000 -0400
+++ ./common/miscres.c 2010-01-27 13:52:46.000000000 -0500
@@ -5,7 +5,6 @@
#include <string.h>
#include <ctype.h>
#include <time.h>
-#include <malloc.h>
#ifndef XFRACT
#include <io.h>

View File

@ -0,0 +1,11 @@
--- ./common/prompts1.c.orig 2008-08-04 21:44:54.000000000 -0400
+++ ./common/prompts1.c 2010-01-27 13:52:46.000000000 -0500
@@ -12,7 +12,7 @@
#endif
#ifdef __TURBOC__
#include <alloc.h>
-#elif !defined(__386BSD__)
+#elif !defined(BIG_ANSI_C)
#include <malloc.h>
#endif

View File

@ -0,0 +1,20 @@
--- ./common/prompts2.c.orig 2008-02-17 11:10:04.000000000 -0500
+++ ./common/prompts2.c 2010-01-27 13:52:46.000000000 -0500
@@ -12,7 +12,7 @@
#ifdef DIRENT
#include <dirent.h>
-#elif !defined(__SVR4)
+#elif !defined(__SVR4) && !defined(__FreeBSD__)
#include <sys/dir.h>
#else
#include <dirent.h>
@@ -24,7 +24,7 @@
#endif
#ifdef __TURBOC__
#include <alloc.h>
-#elif !defined(__386BSD__)
+#elif !defined(BIG_ANSI_C)
#include <malloc.h>
#endif

View File

@ -0,0 +1,21 @@
--- ./common/soi.c.orig 2004-11-23 08:13:37.000000000 -0500
+++ ./common/soi.c 2010-01-27 13:52:46.000000000 -0500
@@ -13,7 +13,9 @@
*/
#include <time.h>
#include <string.h>
+#ifndef BIG_ANSI_C
#include <malloc.h>
+#endif
#include "port.h"
#include "prototyp.h"
@@ -21,7 +23,7 @@
#define FABS(x) fabsl(x)
/* the following needs to be changed back to frexpl once the portability
issue has been addressed JCO */
-#ifndef XFRACT
+#ifndef __FreeBSD__
#define FREXP(x,y) frexpl(x,y)
#else
#define FREXP(x,y) frexp(x,y)

View File

@ -0,0 +1,12 @@
--- ./common/soi1.c.orig 2004-11-23 08:13:37.000000000 -0500
+++ ./common/soi1.c 2010-01-27 13:52:46.000000000 -0500
@@ -13,7 +13,9 @@
*/
#include <time.h>
#include <string.h>
+#ifndef BIG_ANSI_C
#include <malloc.h>
+#endif
#include "port.h"
#include "prototyp.h"

View File

@ -0,0 +1,20 @@
--- ./headers/port.h.orig 2008-02-17 17:26:16.000000000 -0500
+++ ./headers/port.h 2010-01-27 13:52:46.000000000 -0500
@@ -44,7 +44,7 @@
/* If endian.h is not present, it can be handled in the code below, */
/* but if you have this file, it can make it more fool proof. */
#if (defined(XFRACT) && !defined(__sun))
-#if defined(sgi)
+#if defined(sgi) || defined(__FreeBSD__)
#include <sys/endian.h>
#else
#include <endian.h>
@@ -319,7 +319,7 @@
/* HP-UX support long doubles and allows them to be read in with */
/* scanf(), but does not support the functions sinl, cosl, fabsl, etc. */
/* CAE added this 26Jan95 so it would compile (altered by Wes to new macro) */
-#ifdef _HPUX_SOURCE
+#if defined _HPUX_SOURCE || defined (__FreeBSD__)
#define DO_NOT_USE_LONG_DOUBLE
#endif

View File

@ -0,0 +1,11 @@
--- ./unix/general.c.orig 2008-04-11 10:36:28.000000000 -0400
+++ ./unix/general.c 2010-01-27 13:52:46.000000000 -0500
@@ -317,7 +317,7 @@
static struct timeval delay;
delay.tv_sec = delaytime/1000;
delay.tv_usec = (delaytime%1000)*1000;
-#if defined( __SVR4) || defined(LINUX)
+#if defined( __SVR4) || defined(LINUX) || defined(__FreeBSD__)
(void) select(0, (fd_set *) 0, (fd_set *) 0, (fd_set *) 0, &delay);
#else
(void) select(0, (int *) 0, (int *) 0, (int *) 0, &delay);

View File

@ -0,0 +1,20 @@
--- ./unix/unixscr.c.orig 2008-05-03 13:52:03.000000000 -0400
+++ ./unix/unixscr.c 2010-01-27 13:52:46.000000000 -0500
@@ -54,7 +54,7 @@
#define FNDELAY O_NDELAY
#endif
#endif
-#ifdef __SVR4
+#if defined (__SVR4) || defined(__FreeBSD__)
# include <sys/filio.h>
# define FNDELAY O_NONBLOCK
#endif
@@ -339,7 +339,7 @@
initdacbox();
if (!simple_input) {
- signal(SIGINT,(SignalHandler)goodbye);
+ signal(SIGINT,(sig_t)goodbye);
}
signal(SIGFPE, fpe_handler);
/*

View File

@ -0,0 +1,8 @@
Xfractint - The Unix port of fractint, devel version
Fractint is an IBM PC program to generate fractals, and was written by
the Stone Soup Group.
The UNIX port was done by Ken Shirriff and modified by Scott D. Boyd.
WWW: http://www.fractint.org

View File

@ -0,0 +1,65 @@
bin/xfractint-devel
%%DATADIR%%/fractint.hlp
%%DATADIR%%/sstools.ini
%%DATADIR%%/formulas/fract001.frm
%%DATADIR%%/formulas/fract002.frm
%%DATADIR%%/formulas/fract003.frm
%%DATADIR%%/formulas/fract196.frm
%%DATADIR%%/formulas/fract200.frm
%%DATADIR%%/formulas/fract_sy.frm
%%DATADIR%%/formulas/fractint.frm
%%DATADIR%%/formulas/ikenaga.frm
%%DATADIR%%/formulas/julitile.frm
%%DATADIR%%/formulas/new_if.frm
%%DATADIR%%/formulas/newton.frm
%%DATADIR%%/ifs/fract205.ifs
%%DATADIR%%/ifs/fractint.ifs
%%DATADIR%%/lsystem/fract205.l
%%DATADIR%%/lsystem/fractint.l
%%DATADIR%%/lsystem/penrose.l
%%DATADIR%%/lsystem/tiling.l
%%DATADIR%%/maps/altern.map
%%DATADIR%%/maps/blues.map
%%DATADIR%%/maps/chroma.map
%%DATADIR%%/maps/default.map
%%DATADIR%%/maps/defaultw.map
%%DATADIR%%/maps/firestrm.map
%%DATADIR%%/maps/froth3.map
%%DATADIR%%/maps/froth316.map
%%DATADIR%%/maps/froth6.map
%%DATADIR%%/maps/froth616.map
%%DATADIR%%/maps/gamma1.map
%%DATADIR%%/maps/gamma2.map
%%DATADIR%%/maps/glasses1.map
%%DATADIR%%/maps/glasses2.map
%%DATADIR%%/maps/goodega.map
%%DATADIR%%/maps/green.map
%%DATADIR%%/maps/grey.map
%%DATADIR%%/maps/grid.map
%%DATADIR%%/maps/headache.map
%%DATADIR%%/maps/landscap.map
%%DATADIR%%/maps/lyapunov.map
%%DATADIR%%/maps/neon.map
%%DATADIR%%/maps/paintjet.map
%%DATADIR%%/maps/royal.map
%%DATADIR%%/maps/topo.map
%%DATADIR%%/maps/volcano.map
%%DATADIR%%/pars/cellular.par
%%DATADIR%%/pars/demo.par
%%DATADIR%%/pars/fract18.par
%%DATADIR%%/pars/fract19.par
%%DATADIR%%/pars/fract200.par
%%DATADIR%%/pars/fract205.par
%%DATADIR%%/pars/fractint.par
%%DATADIR%%/pars/icons.par
%%DATADIR%%/pars/lyapunov.par
%%DATADIR%%/pars/music.par
%%DATADIR%%/pars/newphoen.par
%%DATADIR%%/pars/orbits.par
%%DATADIR%%/pars/phoenix.par
@dirrm %%DATADIR%%/formulas
@dirrm %%DATADIR%%/ifs
@dirrm %%DATADIR%%/lsystem
@dirrm %%DATADIR%%/maps
@dirrm %%DATADIR%%/pars
@dirrm %%DATADIR%%