- Update sysutils/backuppc to 3.3.2
- Initialize options helpers PR: 216875 Submitted by: moiseev@mezonplus.ru Approved by: mat (mentor) Differential Revision: https://reviews.freebsd.org/D9472
This commit is contained in:
parent
0b3d360a40
commit
7b04f2e848
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=433557
@ -2,8 +2,7 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= backuppc
|
||||
PORTVERSION= 3.3.1
|
||||
PORTREVISION= 4
|
||||
PORTVERSION= 3.3.2
|
||||
CATEGORIES= sysutils
|
||||
MASTER_SITES= SF
|
||||
DISTNAME= BackupPC-${PORTVERSION}
|
||||
@ -54,33 +53,17 @@ RRDTOOL_DESC= Use RRDTool to generate pool statistic graphs
|
||||
SMBCLIENT_DESC= Samba client
|
||||
XML_RSS_DESC= Perl extension to manage RSS files
|
||||
|
||||
.include <bsd.port.options.mk>
|
||||
|
||||
.if ${PORT_OPTIONS:MARCHIVE_ZIP}
|
||||
RUN_DEPENDS+= p5-Archive-Zip>=0:archivers/p5-Archive-Zip
|
||||
.endif
|
||||
.if ${PORT_OPTIONS:MCOMPRESS_ZLIB}
|
||||
RUN_DEPENDS+= p5-IO-Compress>=0:archivers/p5-IO-Compress
|
||||
.endif
|
||||
.if ${PORT_OPTIONS:MFILE_RSYNCP}
|
||||
RUN_DEPENDS+= p5-File-RsyncP>=0:net/p5-File-RsyncP
|
||||
.endif
|
||||
.if ${PORT_OPTIONS:MNMBLOOKUP}
|
||||
RUN_DEPENDS+= nmblookup:net/samba-nmblookup
|
||||
.endif
|
||||
.if ${PORT_OPTIONS:MRRDTOOL}
|
||||
RUN_DEPENDS+= rrdtool:databases/rrdtool
|
||||
.endif
|
||||
.if ${PORT_OPTIONS:MRRD_GRAPHS} || ${PORT_OPTIONS:MRRDTOOL}
|
||||
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-bin-BackupPC \
|
||||
${FILESDIR}/extra-patch-lib-BackupPC-CGI-GeneralInfo.pm
|
||||
.endif
|
||||
.if ${PORT_OPTIONS:MSMBCLIENT}
|
||||
RUN_DEPENDS+= smbclient:net/samba-smbclient
|
||||
.endif
|
||||
.if ${PORT_OPTIONS:MXML_RSS}
|
||||
RUN_DEPENDS+= p5-XML-RSS>=0:textproc/p5-XML-RSS
|
||||
.endif
|
||||
ARCHIVE_ZIP_RUN_DEPENDS= p5-Archive-Zip>=0:archivers/p5-Archive-Zip
|
||||
COMPRESS_ZLIB_RUN_DEPENDS= p5-IO-Compress>=0:archivers/p5-IO-Compress
|
||||
FILE_RSYNCP_RUN_DEPENDS= p5-File-RsyncP>=0:net/p5-File-RsyncP
|
||||
NMBLOOKUP_RUN_DEPENDS= nmblookup:net/samba-nmblookup
|
||||
RRDTOOL_RUN_DEPENDS= rrdtool:databases/rrdtool
|
||||
SMBCLIENT_RUN_DEPENDS= smbclient:net/samba-smbclient
|
||||
XML_RSS_RUN_DEPENDS= p5-XML-RSS>=0:textproc/p5-XML-RSS
|
||||
RRD_GRAPHS_EXTRA_PATCHES= ${FILESDIR}/extra-patch-bin-BackupPC \
|
||||
${FILESDIR}/extra-patch-lib-BackupPC-CGI-GeneralInfo.pm
|
||||
RRDTOOL_EXTRA_PATCHES= ${FILESDIR}/extra-patch-bin-BackupPC \
|
||||
${FILESDIR}/extra-patch-lib-BackupPC-CGI-GeneralInfo.pm
|
||||
|
||||
pre-patch:
|
||||
@${CP} ${WRKSRC}/configure.pl ${WRKSRC}/update.pl
|
||||
|
@ -1,2 +1,3 @@
|
||||
SHA256 (BackupPC-3.3.1.tar.gz) = c9cc4aec28a7474a68d40f4bc460ff15140e05c96900c7f98ff3ef06c4f6ae4c
|
||||
SIZE (BackupPC-3.3.1.tar.gz) = 556461
|
||||
TIMESTAMP = 1486366929
|
||||
SHA256 (BackupPC-3.3.2.tar.gz) = fbade2c8d8039297e826a75d2c39d5ac9a6f66e0c84c0cf8c4cef0bcf64d2152
|
||||
SIZE (BackupPC-3.3.2.tar.gz) = 557300
|
||||
|
@ -1,8 +0,0 @@
|
||||
--- doc/BackupPC.pod.orig 2014-05-13 17:40:09.000000000 +0400
|
||||
+++ doc/BackupPC.pod 2014-05-13 17:40:27.000000000 +0400
|
||||
@@ -1,3 +1,5 @@
|
||||
+=encoding ISO8859-1
|
||||
+
|
||||
=head1 BackupPC Introduction
|
||||
|
||||
This documentation describes BackupPC version 3.3.0,
|
@ -1,11 +0,0 @@
|
||||
--- lib/BackupPC/CGI/Browse.pm.orig 2016-05-14 07:28:52 UTC
|
||||
+++ lib/BackupPC/CGI/Browse.pm
|
||||
@@ -65,7 +65,7 @@ sub action
|
||||
#
|
||||
# default to the newest backup
|
||||
#
|
||||
- if ( !defined($In{num}) && defined(@Backups) && @Backups > 0 ) {
|
||||
+ if ( !defined($In{num}) && @Backups > 0 ) {
|
||||
$i = @Backups - 1;
|
||||
$num = $Backups[$i]{num};
|
||||
}
|
@ -1,20 +0,0 @@
|
||||
--- lib/BackupPC/Lib.pm.orig 2016-11-08 08:08:02 UTC
|
||||
+++ lib/BackupPC/Lib.pm
|
||||
@@ -1261,7 +1261,7 @@ sub cmdVarSubstitute
|
||||
#
|
||||
# Replace scalar variables first
|
||||
#
|
||||
- $arg =~ s[\${(\w+)}(\+?)]{
|
||||
+ $arg =~ s[\$\{(\w+)}(\+?)]{
|
||||
exists($vars->{$1}) && ref($vars->{$1}) ne "ARRAY"
|
||||
? ($2 eq "+" ? $bpc->shellEscape($vars->{$1}) : $vars->{$1})
|
||||
: "\${$1}$2"
|
||||
@@ -1270,7 +1270,7 @@ sub cmdVarSubstitute
|
||||
# Now replicate any array arguments; this just works for just one
|
||||
# array var in each argument.
|
||||
#
|
||||
- if ( $arg =~ m[(.*)\${(\w+)}(\+?)(.*)] && ref($vars->{$2}) eq "ARRAY" ) {
|
||||
+ if ( $arg =~ m[(.*)\$\{(\w+)}(\+?)(.*)] && ref($vars->{$2}) eq "ARRAY" ) {
|
||||
my $pre = $1;
|
||||
my $var = $2;
|
||||
my $esc = $3;
|
@ -1,33 +1,12 @@
|
||||
--- lib/BackupPC/Xfer/Smb.pm.orig 2016-06-04 10:42:02 UTC
|
||||
--- lib/BackupPC/Xfer/Smb.pm.orig 2017-02-06 08:40:41 UTC
|
||||
+++ lib/BackupPC/Xfer/Smb.pm
|
||||
@@ -217,7 +217,7 @@ sub readOutput
|
||||
# This section is highly dependent on the version of smbclient.
|
||||
# If you upgrade Samba, make sure that these regexp are still valid.
|
||||
#
|
||||
- if ( /^\s*(-?\d+) \(\s*\d+[.,]\d kb\/s\) (.*)$/ ) {
|
||||
+ if ( /^\s*(-?\d+) \(\s*\d+[.,]\d kb\/s\) (.*)$/ || /^tar:(\d+)\s+\+\+\+ (.*)$/ ) {
|
||||
my $sambaFileSize = $1;
|
||||
my $pcFileName = $2;
|
||||
(my $fileName = $pcFileName) =~ s/\\/\//g;
|
||||
@@ -230,7 +230,9 @@ sub readOutput
|
||||
$t->{byteCnt} += $2;
|
||||
$t->{fileCnt}++;
|
||||
$t->{XferLOG}->write(\"$_\n") if ( $t->{logLevel} >= 1 );
|
||||
- } elsif ( /^\s*tar: dumped \d+ files/ ) {
|
||||
+ } elsif ( /^\s*tar: dumped \d+ files/
|
||||
+ || /Total bytes received: \d+/i
|
||||
+ || /tar_process done, err = 0/ ) {
|
||||
@@ -242,7 +242,8 @@ sub readOutput
|
||||
$t->{xferOK} = 1;
|
||||
$t->{byteCnt} = $1;
|
||||
$t->{XferLOG}->write(\"$_\n") if ( $t->{logLevel} >= 0 );
|
||||
- } elsif ( /^\s*tar: restored \d+ files/ ) {
|
||||
+ } elsif ( /^\s*tar: restored \d+ files/
|
||||
+ || /^\s*tar:\d+\s*tar_process done, err = 0/ ) {
|
||||
$t->{xferOK} = 1;
|
||||
$t->{XferLOG}->write(\"$_\n") if ( $t->{logLevel} >= 0 );
|
||||
} elsif ( /^\s*tar: restored \d+ files/ ) {
|
||||
@@ -270,6 +272,10 @@ sub readOutput
|
||||
} elsif ( /^\s*directory \\/i ) {
|
||||
$t->{XferLOG}->write(\"$_\n") if ( $t->{logLevel} >= 2 );
|
||||
} elsif ( /smb: \\>/
|
||||
+ || /^tar:\d+\s/
|
||||
+ || /^ NTLMSSP_/
|
||||
+ || /^GENSEC backend /
|
||||
+ || /^doing parameter /
|
||||
|| /^\s*added interface/i
|
||||
|| /^\s*tarmode is now/i
|
||||
|| /^\s*Total bytes written/i
|
||||
} elsif ( /^\s*read_socket_with_timeout: timeout read. /i ) {
|
||||
|
@ -9,14 +9,3 @@
|
||||
} elsif ( $host ne "" ) {
|
||||
if ( !defined($In{num}) ) {
|
||||
# get the latest LOG file
|
||||
@@ -136,6 +136,10 @@ sub action
|
||||
}
|
||||
$s =~ s/[\n\r]+//g;
|
||||
if ( $s =~ /smb: \\>/
|
||||
+ || $s =~ /^tar:\d+\s/
|
||||
+ || $s =~ /^ NTLMSSP_/
|
||||
+ || $s =~ /^GENSEC backend /
|
||||
+ || $s =~ /^doing parameter /
|
||||
|| $s =~ /^\s*(\d+) \(\s*\d+\.\d kb\/s\) (.*)$/
|
||||
|| $s =~ /^tar: dumped \d+ files/
|
||||
|| $s =~ /^\s*added interface/i
|
||||
|
@ -177,7 +177,7 @@
|
||||
- #
|
||||
- # Install new CSS file, making a backup copy if necessary
|
||||
- #
|
||||
- my $cssBackup = "$DestDir$Conf{CgiImageDir}/BackupPC_stnd.css.pre-3.3.1";
|
||||
- my $cssBackup = "$DestDir$Conf{CgiImageDir}/BackupPC_stnd.css.pre-3.3.2";
|
||||
- if ( -f "$DestDir$Conf{CgiImageDir}/BackupPC_stnd.css" && !-f $cssBackup ) {
|
||||
- rename("$DestDir$Conf{CgiImageDir}/BackupPC_stnd.css", $cssBackup);
|
||||
- }
|
||||
|
@ -18,8 +18,4 @@
|
||||
restore command to 5 ('-d 5') in the main configuration, for instance
|
||||
|
||||
$Conf{SmbClientRestoreCmd} = '$smbClientPath \\\\$host\\$shareName $I_option -U $userName -E -d 5 -c tarmode\\ full -Tx -';
|
||||
|
||||
and set in the each host's configuration
|
||||
|
||||
$Conf{BackupZeroFilesIsFatal} = '0';
|
||||
==========================================================================
|
||||
|
Loading…
Reference in New Issue
Block a user