New port: games/bomberclone

This game is a clone of the game Atomic Bomber Man.
	Supports single user and network multiplayer mode.
This commit is contained in:
Edwin Groothuis 2003-05-08 23:11:35 +00:00
parent 8a678de2f2
commit 7ac265356e
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=80474
9 changed files with 133 additions and 0 deletions

View File

@ -39,6 +39,7 @@
SUBDIR += bnetd
SUBDIR += bogged
SUBDIR += bomb
SUBDIR += bomberclone
SUBDIR += bomberinstinct
SUBDIR += bombermaze
SUBDIR += braincurses

View File

@ -0,0 +1,44 @@
# New ports collection makefile for: bomberclone
# Date created: 5 May 2003
# Whom: Edwin Groothuis
#
# $FreeBSD$
#
PORTNAME= bomberclone
PORTVERSION= 0.9.7
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
DISTFILES= ${PORTNAME}-${PORTVERSION}.tgz \
${PORTNAME}-data-0.5.tgz
MAINTAINER= edwin@mavetju.org
COMMENT= Reimplementation of Atomic Bomber Man
BUILD_DEPENDS= sdl11-config:${PORTSDIR}/devel/sdl12
LIB_DEPENDS= SDL_mixer.2:${PORTSDIR}/audio/sdl_mixer \
SDL_image.10:${PORTSDIR}/graphics/sdl_image
GNU_CONFIGURE= yes
USE_XLIB= yes
USE_REINPLACE= yes
USE_REINPLACE= yes
USE_GMAKE= yes
SDL_CONFIG= ${LOCALBASE}/bin/sdl11-config
CONFIGURE_ARGS= --target=""
CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}" \
LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}" \
CXXFLAGS="${PTHREAD_CFLAGS} -I${X11BASE}/include"
post-extract:
${RM} -r ${WRKDIR}/data/bomberclone.gfx/CVS
post-patch:
${REINPLACE_CMD} -e 's,@@LOCALBASE@@,${LOCALBASE},' \
${WRKSRC}/src/configuration.c
post-install:
${CP} -R ${WRKDIR}/data/bomberclone.gfx ${PREFIX}/share
.include <bsd.port.mk>

View File

@ -0,0 +1,2 @@
MD5 (bomberclone-0.9.7.tgz) = b0fe1de4b1297269a7213da135cd695f
MD5 (bomberclone-data-0.5.tgz) = 07303fd3e4090a7bdf0c042fb8647604

View File

@ -0,0 +1,11 @@
--- Makefile.in.orig Thu May 8 23:23:43 2003
+++ Makefile.in Thu May 8 23:23:52 2003
@@ -83,7 +83,7 @@
SUBDIRS = src
-bomberclonedocdir = ${prefix}/doc/bomberclone
+bomberclonedocdir = ${prefix}/share/doc/bomberclone
bomberclonedoc_DATA = \
README\
COPYING\

View File

@ -0,0 +1,10 @@
--- src/bomberclone.h.orig Mon Apr 28 06:56:46 2003
+++ src/bomberclone.h Fri May 2 17:30:29 2003
@@ -10,6 +10,7 @@
#include <unistd.h>
#include <fcntl.h>
#include <sys/types.h>
+#include <sys/time.h>
#include <time.h>
#include <ctype.h>
#ifdef _WIN32

View File

@ -0,0 +1,20 @@
--- src/configuration.c.orig Mon Apr 28 06:56:46 2003
+++ src/configuration.c Thu May 8 23:27:11 2003
@@ -5,6 +5,8 @@
#ifdef _WIN32
#include <winsock.h>
#else
+#include <sys/types.h>
+#include <sys/time.h>
#include <sys/socket.h>
#endif
@@ -51,7 +53,7 @@
gfx.bpp = 16;
bman.fieldsize.x = 25;
bman.fieldsize.y = 17;
- sprintf (bman.datapath, "data/bomberclone.gfx");
+ sprintf (bman.datapath, "@@LOCALBASE@@/share/bomberclone.gfx");
};
int

View File

@ -0,0 +1,10 @@
--- src/udp.c.orig Mon Apr 28 06:56:46 2003
+++ src/udp.c Fri May 2 17:30:03 2003
@@ -10,6 +10,7 @@
#include <fcntl.h>
#include <sys/types.h>
#include <time.h>
+#include <sys/time.h>
#ifdef _WIN32
#include <winsock.h>
#else

View File

@ -0,0 +1,4 @@
This game is a clone of the game Atomic Bomber Man.
Supports single user and network multiplayer mode.
WWW: http://bomberclone.sourceforge.net/

View File

@ -0,0 +1,31 @@
bin/bomberclone
share/doc/bomberclone/README
share/doc/bomberclone/COPYING
share/doc/bomberclone/AUTHORS
share/doc/bomberclone/ChangeLog
share/doc/bomberclone/INSTALL
share/doc/bomberclone/NEWS
share/doc/bomberclone/TODO
@dirrm share/doc/bomberclone
share/bomberclone.gfx/background.bmp
share/bomberclone.gfx/block.bmp
share/bomberclone.gfx/bomb.bmp
share/bomberclone.gfx/fieldbomb.bmp
share/bomberclone.gfx/fielddeath.bmp
share/bomberclone.gfx/fieldfire.bmp
share/bomberclone.gfx/fieldshoe.bmp
share/bomberclone.gfx/fire.bmp
share/bomberclone.gfx/font.bmp
share/bomberclone.gfx/font1.bmp
share/bomberclone.gfx/logo.bmp
share/bomberclone.gfx/logo1.bmp
share/bomberclone.gfx/menuselect.bmp
share/bomberclone.gfx/player0.bmp
share/bomberclone.gfx/player1.bmp
share/bomberclone.gfx/player2.bmp
share/bomberclone.gfx/player3.bmp
share/bomberclone.gfx/player4.bmp
share/bomberclone.gfx/stone.bmp
share/bomberclone.gfx/playersick.bmp
@dirrm share/bomberclone.gfx