textproc/py-pyexcel-xls: Add py-pyexcel-xls 0.6.2
pyexcel-xls is a tiny wrapper library to read, manipulate and write data in xls format and it can read xlsx and xlsm fromat. You are likely to use it with pyexcel. WWW: https://github.com/pyexcel/pyexcel-xls
This commit is contained in:
parent
1807856ac1
commit
7ab6a568f3
@ -1373,6 +1373,7 @@
|
||||
SUBDIR += py-pyexcel-ezodf
|
||||
SUBDIR += py-pyexcel-io
|
||||
SUBDIR += py-pyexcel-ods3
|
||||
SUBDIR += py-pyexcel-xls
|
||||
SUBDIR += py-pygccxml
|
||||
SUBDIR += py-pygments
|
||||
SUBDIR += py-pygments-25
|
||||
|
24
textproc/py-pyexcel-xls/Makefile
Normal file
24
textproc/py-pyexcel-xls/Makefile
Normal file
@ -0,0 +1,24 @@
|
||||
# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
|
||||
|
||||
PORTNAME= pyexcel-xls
|
||||
PORTVERSION= 0.6.2
|
||||
CATEGORIES= textproc python
|
||||
MASTER_SITES= CHEESESHOP
|
||||
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
||||
|
||||
MAINTAINER= sunpoet@FreeBSD.org
|
||||
COMMENT= Read, manipulate and write data in xls format
|
||||
|
||||
LICENSE= BSD3CLAUSE
|
||||
LICENSE_FILE= ${WRKSRC}/LICENSE
|
||||
|
||||
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyexcel-io>=0.6.2:textproc/py-pyexcel-io@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}xlrd>=0:textproc/py-xlrd@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}xlwt>=0:textproc/py-xlwt@${PY_FLAVOR}
|
||||
|
||||
USES= python:3.6+
|
||||
USE_PYTHON= autoplist concurrent distutils
|
||||
|
||||
NO_ARCH= yes
|
||||
|
||||
.include <bsd.port.mk>
|
3
textproc/py-pyexcel-xls/distinfo
Normal file
3
textproc/py-pyexcel-xls/distinfo
Normal file
@ -0,0 +1,3 @@
|
||||
TIMESTAMP = 1625585436
|
||||
SHA256 (pyexcel-xls-0.6.2.tar.gz) = 2fbf66e8df88051eaaa9745be433903d18db819ddd3a987c992ead1d68b7feb5
|
||||
SIZE (pyexcel-xls-0.6.2.tar.gz) = 54339
|
11
textproc/py-pyexcel-xls/files/patch-setup.py
Normal file
11
textproc/py-pyexcel-xls/files/patch-setup.py
Normal file
@ -0,0 +1,11 @@
|
||||
--- setup.py.orig 2020-12-12 22:34:25 UTC
|
||||
+++ setup.py
|
||||
@@ -69,7 +69,7 @@ PYTHON_REQUIRES = ">=3.6"
|
||||
|
||||
INSTALL_REQUIRES = [
|
||||
"pyexcel-io>=0.6.2",
|
||||
- "xlrd<2",
|
||||
+ "xlrd",
|
||||
"xlwt",
|
||||
]
|
||||
SETUP_COMMANDS = {}
|
5
textproc/py-pyexcel-xls/pkg-descr
Normal file
5
textproc/py-pyexcel-xls/pkg-descr
Normal file
@ -0,0 +1,5 @@
|
||||
pyexcel-xls is a tiny wrapper library to read, manipulate and write data in xls
|
||||
format and it can read xlsx and xlsm fromat. You are likely to use it with
|
||||
pyexcel.
|
||||
|
||||
WWW: https://github.com/pyexcel/pyexcel-xls
|
Loading…
Reference in New Issue
Block a user