- Update to 4.0.
- Trim old-style header. - Add LICENSE. - Use shebangfix. - Replace pathname lookups in the scripts with fixed pathnames.
This commit is contained in:
parent
0fc3b42483
commit
7a823705e4
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=319560
@ -1,30 +1,28 @@
|
||||
# New ports collection makefile for: gdt
|
||||
# Date created: Sun, Apr 29 2007
|
||||
# Whom: Hiroki Sato <hrs@FreeBSD.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= gdt
|
||||
PORTVERSION= 3.0.5
|
||||
PORTVERSION= 4.0
|
||||
CATEGORIES= cad
|
||||
MASTER_SITES= SF/gds2/gds2/GDT-${PORTVERSION}
|
||||
MASTER_SITES= SF/gds2/gds2/
|
||||
DISTNAME= ${PORTNAME:U}-${PORTVERSION}
|
||||
|
||||
MAINTAINER= hrs@FreeBSD.org
|
||||
COMMENT= GDS2/GDT format translator
|
||||
|
||||
LICENSE= GPLv2
|
||||
|
||||
USE_PERL5_RUN= yes
|
||||
USES= shebangfix
|
||||
SHEBANG_FILES= Examples/gdsinfo Examples/scalegds
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME:U}-${PORTVERSION}
|
||||
PLIST_FILES= bin/gdsinfo bin/gds2gdt bin/gdt2gds bin/scalegds
|
||||
|
||||
post-patch:
|
||||
${REINPLACE_CMD} 's,^#!/usr/bin/perl,#!${PERL},' \
|
||||
${WRKSRC}/Examples/gdsinfo \
|
||||
${WRKSRC}/Examples/scalegds
|
||||
${REINPLACE_CMD} -e 's,%%PREFIX%%,${PREFIX},' \
|
||||
${WRKSRC}/Examples/gdsinfo ${WRKSRC}/Examples/scalegds
|
||||
|
||||
pre-build:
|
||||
${CP} ${FILESDIR}/Makefile ${WRKSRC}
|
||||
${INSTALL_DATA} ${FILESDIR}/Makefile ${WRKSRC}
|
||||
|
||||
post-install:
|
||||
${INSTALL_SCRIPT} \
|
||||
|
@ -1,2 +1,2 @@
|
||||
SHA256 (GDT-3.0.5.tar.gz) = 92e92d0a5a19f5d6626aca2d0f62ba1814afdce007e16e4d57d2071ddf33a8d3
|
||||
SIZE (GDT-3.0.5.tar.gz) = 45556
|
||||
SHA256 (GDT-4.0.tar.gz) = 3c1247aa1a8044002edc5db10136a0c9befbf0f49f8c86643189051090ef5fcb
|
||||
SIZE (GDT-4.0.tar.gz) = 46937
|
||||
|
@ -1,12 +1,14 @@
|
||||
--- Examples/gdsinfo.orig Sun Apr 29 15:54:57 2007
|
||||
+++ Examples/gdsinfo Sun Apr 29 15:55:08 2007
|
||||
@@ -75,9 +75,6 @@
|
||||
--- Examples/gdsinfo.orig 2008-06-20 02:04:27.000000000 +0900
|
||||
+++ Examples/gdsinfo 2013-05-30 10:54:47.000000000 +0900
|
||||
@@ -75,10 +75,7 @@
|
||||
$topCellNames =~ s/\s+/ /g;
|
||||
|
||||
# help find gds2gdt
|
||||
-my $uname_s = `/bin/uname -s`; # OS name
|
||||
-chomp $uname_s;
|
||||
-$ENV{'PATH'} = "/bin:/usr/bin:/user/ic/gnu/$uname_s/bin:".$ENV{'PATH'};
|
||||
my $gds2gdt = which("gds2gdt");
|
||||
-my $gds2gdt = which("gds2gdt");
|
||||
+my $gds2gdt = '%%PREFIX%%/bin/gds2gdt';
|
||||
unless ($gds2gdt)
|
||||
{
|
||||
die $REVERSE_RED.ERROR."$COLOR_RESET unable to find gds2gdt in \$PATH";
|
||||
|
41
cad/gdt/files/patch-Examples-scalegds
Normal file
41
cad/gdt/files/patch-Examples-scalegds
Normal file
@ -0,0 +1,41 @@
|
||||
--- Examples/scalegds.orig 2013-05-30 10:59:09.000000000 +0900
|
||||
+++ Examples/scalegds 2013-05-30 10:58:01.000000000 +0900
|
||||
@@ -72,18 +72,14 @@
|
||||
|
||||
my ($sec,$min,$hour,$mday,$mon,$year,$wday,$yday,$isdst) = localtime(time);
|
||||
$mon++; $year += 1900;
|
||||
-# help find gds2gdt
|
||||
-my $uname_s = `/bin/uname -s`; # OS name
|
||||
-chomp $uname_s;
|
||||
-$ENV{'PATH'} = "/bin:/usr/bin:/user/ic/gnu/$uname_s/bin:".$ENV{'PATH'};
|
||||
|
||||
-my $gds2gdt = which("gds2gdt");
|
||||
+my $gds2gdt = '%%PREFIX%%/bin/gds2gdt';
|
||||
unless ($gds2gdt)
|
||||
{
|
||||
die $REVERSE_RED.ERROR."$COLOR_RESET unable to find gds2gdt in \$PATH";
|
||||
}
|
||||
|
||||
-my $gdt2gds = which("gdt2gds");
|
||||
+my $gdt2gds = '%%PREFIX%%/bin/gdt2gds';
|
||||
unless ($gdt2gds)
|
||||
{
|
||||
die $REVERSE_RED.ERROR."$COLOR_RESET unable to find gdt2gds in \$PATH";
|
||||
@@ -135,7 +131,7 @@
|
||||
|
||||
if ($inputFile =~ m/\.(gz|Z)$/)
|
||||
{
|
||||
- my $zcat = which("zcat");
|
||||
+ my $zcat = '/usr/bin/zcat';
|
||||
unless ($zcat)
|
||||
{
|
||||
die $REVERSE_RED.ERROR."$COLOR_RESET unable to find zcat in \$PATH";
|
||||
@@ -145,7 +141,7 @@
|
||||
}
|
||||
elsif ($inputFile =~ m/\.bz2$/)
|
||||
{
|
||||
- my $bzcat = which("bzcat");
|
||||
+ my $bzcat = '/usr/bin/bzcat';
|
||||
unless ($bzcat)
|
||||
{
|
||||
die $REVERSE_RED.ERROR."$COLOR_RESET unable to find bzcat in \$PATH";
|
Loading…
Reference in New Issue
Block a user