update: 2.4h to 2.4m
This commit is contained in:
parent
bcc3edf977
commit
7a6c6b0bd9
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=22905
@ -1,13 +1,13 @@
|
||||
# New ports collection makefile for: blt
|
||||
# Version required: 2.4f
|
||||
# Date created: 22 September 1998
|
||||
# Version required: 2.4m
|
||||
# Date created: 04 November 1999
|
||||
# Whom: Kenjiro Cho <kjc@csl.sony.co.jp>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
DISTNAME= BLT2.4h
|
||||
PKGNAME= blt-2.4h
|
||||
DISTNAME= BLT2.4m
|
||||
PKGNAME= blt-2.4m
|
||||
CATEGORIES= x11-toolkits tk80
|
||||
MASTER_SITES= ftp://ftp.tcltk.com/pub/blt/
|
||||
|
||||
@ -15,12 +15,12 @@ MAINTAINER= kjc@csl.sony.co.jp
|
||||
|
||||
LIB_DEPENDS= tk80.1:${PORTSDIR}/x11-toolkits/tk80
|
||||
|
||||
WRKSRC= ${WRKDIR}/blt2.4h
|
||||
WRKSRC= ${WRKDIR}/blt2.4m
|
||||
GNU_CONFIGURE= yes
|
||||
MANN= BLT.n barchart.n bgexec.n bitmap.n bltdebug.n busy.n \
|
||||
dragdrop.n eps.n graph.n htext.n hierbox.n spline.n \
|
||||
stripchart.n table.n tabset.n tile.n vector.n watch.n winop.n \
|
||||
beep.n cutbuffer.n
|
||||
MANN= BLT.n barchart.n beep.n bgexec.n bitmap.n \
|
||||
bltdebug.n busy.n cutbuffer.n dragdrop.n eps.n \
|
||||
graph.n hierbox.n htext.n spline.n stripchart.n \
|
||||
table.n tabset.n tile.n vector.n watch.n winop.n
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
|
@ -1 +1 @@
|
||||
MD5 (BLT2.4h.tar.gz) = b4cceb1851b8f04fccac99caeaa36245
|
||||
MD5 (BLT2.4m.tar.gz) = 4c7040b1863024101cbf1f7cc958bdb4
|
||||
|
@ -1,59 +1,70 @@
|
||||
--- configure.orig Fri Mar 5 08:21:28 1999
|
||||
+++ configure Mon Apr 12 14:21:22 1999
|
||||
@@ -2301,6 +2301,9 @@
|
||||
$blt_cv_tcl_lib \
|
||||
$prefix/lib \
|
||||
$exec_prefix/lib \
|
||||
+ /usr/local/lib/tcl8.0 \
|
||||
+ /usr/local/lib/tcl7.6 \
|
||||
+ /usr/local/lib/tcl7.5 \
|
||||
/usr/local/tcl/lib \
|
||||
/usr/local/tcl/tcl8.0/lib \
|
||||
/usr/local/tcl/tcl7.6/lib \
|
||||
@@ -2340,6 +2343,9 @@
|
||||
$blt_cv_tk_lib \
|
||||
$prefix/lib \
|
||||
$exec_prefix/lib \
|
||||
+ /usr/local/lib/tk8.0 \
|
||||
+ /usr/local/lib/tk4.2 \
|
||||
+ /usr/local/lib/tk4.1 \
|
||||
/usr/local/tcl/lib \
|
||||
/usr/local/tcl/tk8.0/lib \
|
||||
/usr/local/tcl/tk4.2/lib \
|
||||
@@ -2433,6 +2439,13 @@
|
||||
tclLibDir=${TCL_PREFIX}/lib
|
||||
tkLibDir=${TK_PREFIX}/lib
|
||||
|
||||
+case $target in
|
||||
+ *-freebsd*)
|
||||
+ tclIncSpec="-I${TCL_PREFIX}/include/tcl${TCL_MAJOR_VERSION}.${TCL_MINOR_VERSION}"
|
||||
+ tkIncSpec="-I${TK_PREFIX}/include/tk${TK_MAJOR_VERSION}.${TK_MINOR_VERSION}"
|
||||
+ ;;
|
||||
+esac
|
||||
+
|
||||
itclLibSpec=""
|
||||
itclIncSpec=""
|
||||
itclSuffix=""
|
||||
@@ -2451,7 +2464,7 @@
|
||||
tkLibSpec=${TK_LIB_SPEC}
|
||||
--- configure.orig Thu Nov 4 04:57:32 1999
|
||||
+++ configure Thu Nov 4 18:03:55 1999
|
||||
@@ -1093,7 +1093,7 @@
|
||||
#
|
||||
# 1. command line (--with-cflags)
|
||||
# 2. cached variable ($blt_cv_prog_cflags)
|
||||
-# 3. set to "-O6" if using gcc ($BLT_HAVE_GCC)
|
||||
+# 3. set to "-O2" if using gcc ($BLT_HAVE_GCC)
|
||||
# 4. otherwise, default to "-O"
|
||||
#
|
||||
echo $ac_n "checking default compiler flags""... $ac_c" 1>&6
|
||||
@@ -1103,7 +1103,7 @@
|
||||
elif test "x${blt_cv_prog_cflags}" != "x" ; then
|
||||
CFLAGS=${blt_cv_prog_cflags}
|
||||
elif test "${BLT_HAVE_GCC}" = "yes" ; then
|
||||
- CFLAGS=-O6
|
||||
+ CFLAGS=-O2
|
||||
else
|
||||
CFLAGS=-O
|
||||
fi
|
||||
@@ -2443,6 +2443,9 @@
|
||||
if test "x$tclConfigFile" = "x" ; then
|
||||
for dir in \
|
||||
`ls -dr /usr/local/tcl/tcl[7-9].[0-9]* 2>/dev/null` \
|
||||
+ /usr/local/lib/tcl8.2 \
|
||||
+ /usr/local/lib/tcl8.1 \
|
||||
+ /usr/local/lib/tcl8.0 \
|
||||
/usr/local/tcl \
|
||||
/usr/local \
|
||||
/usr
|
||||
@@ -2543,6 +2546,9 @@
|
||||
if test "x$tkConfigFile" = "x" ; then
|
||||
for dir in \
|
||||
`ls -dr /usr/local/tcl/tcl[7-9].[0-9]* 2>/dev/null` \
|
||||
+ /usr/local/lib/tk8.2 \
|
||||
+ /usr/local/lib/tk8.1 \
|
||||
+ /usr/local/lib/tk8.0 \
|
||||
/usr/local/tcl \
|
||||
/usr/local \
|
||||
${x_libraries} \
|
||||
@@ -2602,7 +2608,14 @@
|
||||
TK_LIB_DIR=${TK_PREFIX}/lib
|
||||
|
||||
case $target in
|
||||
- *-sunos4*|NetBSD-*|FreeBSD-*|OpenBSD-*)
|
||||
+ *-freebsd*)
|
||||
+ TCL_INC_DIR=${TCL_PREFIX}/include/tcl${TCL_VERSION}
|
||||
+ TK_INC_DIR=${TK_PREFIX}/include/tk${TK_VERSION}
|
||||
+ ;;
|
||||
+esac
|
||||
+
|
||||
+case $target in
|
||||
+ *-freebsd*|*-sunos4*|NetBSD-*|FreeBSD-*|OpenBSD-*)
|
||||
tclLib="-ltcl${TCL_MAJOR_VERSION}${TCL_MINOR_VERSION}${itclSuffix}"
|
||||
tkLib="-ltk${TK_MAJOR_VERSION}${TK_MINOR_VERSION}${itclSuffix}"
|
||||
TCL_LIB_SPEC="-ltcl${TCL_MAJOR_VERSION}${TCL_MINOR_VERSION}"
|
||||
TK_LIB_SPEC="-ltk${TK_MAJOR_VERSION}${TK_MINOR_VERSION}"
|
||||
;;
|
||||
@@ -3170,7 +3183,13 @@
|
||||
@@ -3348,7 +3361,13 @@
|
||||
if test "$test_ok" = yes; then
|
||||
SHLIB_CFLAGS="-fpic"
|
||||
SHLIB_LD="ld"
|
||||
- SHLIB_LD_FLAGS="-Bshareable -x"
|
||||
+ if test `objformat` = "elf"; then
|
||||
+ SHLIB_LD_FLAGS="-Bshareable -x -soname \$@"
|
||||
+ SHLIB_SUFFIX=".so.${bltMajor}"
|
||||
+ SHLIB_SUFFIX=".so.${BLT_MAJOR_VERSION}"
|
||||
+ else
|
||||
+ SHLIB_LD_FLAGS="-Bshareable -x"
|
||||
+ SHLIB_SUFFIX=".so.${bltMajor}.${bltMinor}"
|
||||
+ SHLIB_SUFFIX=".so.${BLT_MAJOR_VERSION}.${BLT_MINOR_VERSION}"
|
||||
+ fi
|
||||
fi
|
||||
;;
|
||||
|
@ -1,4 +1,4 @@
|
||||
This is version 2.4f of the BLT library. BLT is an extension to the Tk
|
||||
This is version 2.4m of the BLT library. BLT is an extension to the Tk
|
||||
toolkit, adding new widgets, geometry managers, and miscellaneous
|
||||
commands. It does not require any patching of the Tcl or Tk source
|
||||
files.
|
||||
|
@ -4,14 +4,15 @@ include/blt.h
|
||||
lib/libBLT.a
|
||||
lib/libBLT24.a
|
||||
lib/libBLT24.so
|
||||
lib/libBLT24.so.2.4
|
||||
lib/libBLT24.so.2
|
||||
@exec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -m %D/lib
|
||||
@unexec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -R
|
||||
lib/blt2.4/bltCanvEps.pro
|
||||
lib/blt2.4/bltDnd.tcl
|
||||
lib/blt2.4/bltGraph.pro
|
||||
lib/blt2.4/bltDnd.tcl
|
||||
lib/blt2.4/bltDragdrop.tcl
|
||||
lib/blt2.4/bltGraph.tcl
|
||||
lib/blt2.4/bltHier.tcl
|
||||
lib/blt2.4/bltHierbox.tcl
|
||||
lib/blt2.4/bltTabset.tcl
|
||||
lib/blt2.4/pkgIndex.tcl
|
||||
lib/blt2.4/tclIndex
|
||||
@ -20,70 +21,89 @@ lib/blt2.4/dd_protocols/dd-file.tcl
|
||||
lib/blt2.4/dd_protocols/dd-number.tcl
|
||||
lib/blt2.4/dd_protocols/dd-text.tcl
|
||||
lib/blt2.4/dd_protocols/tclIndex
|
||||
lib/blt2.4/demos/_barchart2.tcl
|
||||
lib/blt2.4/demos/_bgtest.tcl
|
||||
lib/blt2.4/demos/_demo.tcl
|
||||
lib/blt2.4/demos/_graph1.tcl
|
||||
lib/blt2.4/demos/_graph2.tcl
|
||||
lib/blt2.4/demos/_graph3.tcl
|
||||
lib/blt2.4/demos/_graph5.tcl
|
||||
lib/blt2.4/demos/_patterns.tcl
|
||||
lib/blt2.4/demos/_ps.tcl
|
||||
lib/blt2.4/demos/barchart1
|
||||
lib/blt2.4/demos/barchart2
|
||||
lib/blt2.4/demos/barchart3
|
||||
lib/blt2.4/demos/barchart4
|
||||
lib/blt2.4/demos/barchart5
|
||||
lib/blt2.4/demos/bgexec1
|
||||
lib/blt2.4/demos/bgexec2
|
||||
lib/blt2.4/demos/bgexec3
|
||||
lib/blt2.4/demos/bgexec4
|
||||
lib/blt2.4/demos/bitmap
|
||||
lib/blt2.4/demos/busy1
|
||||
lib/blt2.4/demos/calendar
|
||||
lib/blt2.4/demos/dragdrop1
|
||||
lib/blt2.4/demos/dragdrop2
|
||||
lib/blt2.4/demos/eps
|
||||
lib/blt2.4/demos/form
|
||||
lib/blt2.4/demos/graph1
|
||||
lib/blt2.4/demos/graph2
|
||||
lib/blt2.4/demos/graph3
|
||||
lib/blt2.4/demos/graph4
|
||||
lib/blt2.4/demos/graph5
|
||||
lib/blt2.4/demos/graph6
|
||||
lib/blt2.4/demos/graph7
|
||||
lib/blt2.4/demos/hier1
|
||||
lib/blt2.4/demos/hier2
|
||||
lib/blt2.4/demos/hier3
|
||||
lib/blt2.4/demos/hier4
|
||||
lib/blt2.4/demos/barchart1.tcl
|
||||
lib/blt2.4/demos/barchart2.tcl
|
||||
lib/blt2.4/demos/barchart3.tcl
|
||||
lib/blt2.4/demos/barchart4.tcl
|
||||
lib/blt2.4/demos/barchart5.tcl
|
||||
lib/blt2.4/demos/bgexec1.tcl
|
||||
lib/blt2.4/demos/bgexec2.tcl
|
||||
lib/blt2.4/demos/bgexec3.tcl
|
||||
lib/blt2.4/demos/bgexec4.tcl
|
||||
lib/blt2.4/demos/bitmap.tcl
|
||||
lib/blt2.4/demos/busy1.tcl
|
||||
lib/blt2.4/demos/dragdrop1.tcl
|
||||
lib/blt2.4/demos/dragdrop2.tcl
|
||||
lib/blt2.4/demos/eps.tcl
|
||||
lib/blt2.4/demos/graph1.tcl
|
||||
lib/blt2.4/demos/graph2.tcl
|
||||
lib/blt2.4/demos/graph3.tcl
|
||||
lib/blt2.4/demos/graph4.tcl
|
||||
lib/blt2.4/demos/graph5.tcl
|
||||
lib/blt2.4/demos/graph6.tcl
|
||||
lib/blt2.4/demos/graph7.tcl
|
||||
lib/blt2.4/demos/hierbox1.tcl
|
||||
lib/blt2.4/demos/hierbox2.tcl
|
||||
lib/blt2.4/demos/hierbox3.tcl
|
||||
lib/blt2.4/demos/hierbox4.tcl
|
||||
lib/blt2.4/demos/htext.txt
|
||||
lib/blt2.4/demos/htext1
|
||||
lib/blt2.4/demos/page.tcl
|
||||
lib/blt2.4/demos/spline
|
||||
lib/blt2.4/demos/stripchart1
|
||||
lib/blt2.4/demos/tabset1
|
||||
lib/blt2.4/demos/tabset2
|
||||
lib/blt2.4/demos/tabset3
|
||||
lib/blt2.4/demos/tabset4
|
||||
lib/blt2.4/demos/bitmaps/eyes.bm
|
||||
lib/blt2.4/demos/bitmaps/face
|
||||
lib/blt2.4/demos/bitmaps/fc_left
|
||||
lib/blt2.4/demos/bitmaps/fc_left1
|
||||
lib/blt2.4/demos/bitmaps/fc_left1m
|
||||
lib/blt2.4/demos/bitmaps/fc_leftm
|
||||
lib/blt2.4/demos/bitmaps/fc_mid
|
||||
lib/blt2.4/demos/bitmaps/fc_midm
|
||||
lib/blt2.4/demos/bitmaps/fc_right
|
||||
lib/blt2.4/demos/bitmaps/fc_right1
|
||||
lib/blt2.4/demos/bitmaps/fc_right1m
|
||||
lib/blt2.4/demos/bitmaps/fc_rightm
|
||||
lib/blt2.4/demos/bitmaps/greenback
|
||||
lib/blt2.4/demos/htext1.tcl
|
||||
lib/blt2.4/demos/spline.tcl
|
||||
lib/blt2.4/demos/stripchart1.tcl
|
||||
lib/blt2.4/demos/tabset1.tcl
|
||||
lib/blt2.4/demos/tabset2.tcl
|
||||
lib/blt2.4/demos/tabset3.tcl
|
||||
lib/blt2.4/demos/tabset4.tcl
|
||||
lib/blt2.4/demos/winop1.tcl
|
||||
lib/blt2.4/demos/bitmaps/face.xbm
|
||||
lib/blt2.4/demos/bitmaps/greenback.xbm
|
||||
lib/blt2.4/demos/bitmaps/hobbes.xbm
|
||||
lib/blt2.4/demos/bitmaps/hobbes_mask.xbm
|
||||
lib/blt2.4/demos/bitmaps/sharky.bm
|
||||
lib/blt2.4/demos/bitmaps/xbob.bm
|
||||
lib/blt2.4/demos/bitmaps/sharky.xbm
|
||||
lib/blt2.4/demos/bitmaps/xbob.xbm
|
||||
lib/blt2.4/demos/bitmaps/fish/left.xbm
|
||||
lib/blt2.4/demos/bitmaps/fish/left1.xbm
|
||||
lib/blt2.4/demos/bitmaps/fish/left1m.xbm
|
||||
lib/blt2.4/demos/bitmaps/fish/leftm.xbm
|
||||
lib/blt2.4/demos/bitmaps/fish/mid.xbm
|
||||
lib/blt2.4/demos/bitmaps/fish/midm.xbm
|
||||
lib/blt2.4/demos/bitmaps/fish/right.xbm
|
||||
lib/blt2.4/demos/bitmaps/fish/right1.xbm
|
||||
lib/blt2.4/demos/bitmaps/fish/right1m.xbm
|
||||
lib/blt2.4/demos/bitmaps/fish/rightm.xbm
|
||||
lib/blt2.4/demos/bitmaps/hand/hand01.xbm
|
||||
lib/blt2.4/demos/bitmaps/hand/hand01m.xbm
|
||||
lib/blt2.4/demos/bitmaps/hand/hand02.xbm
|
||||
lib/blt2.4/demos/bitmaps/hand/hand02m.xbm
|
||||
lib/blt2.4/demos/bitmaps/hand/hand03.xbm
|
||||
lib/blt2.4/demos/bitmaps/hand/hand03m.xbm
|
||||
lib/blt2.4/demos/bitmaps/hand/hand04.xbm
|
||||
lib/blt2.4/demos/bitmaps/hand/hand04m.xbm
|
||||
lib/blt2.4/demos/bitmaps/hand/hand05.xbm
|
||||
lib/blt2.4/demos/bitmaps/hand/hand05m.xbm
|
||||
lib/blt2.4/demos/bitmaps/hand/hand06.xbm
|
||||
lib/blt2.4/demos/bitmaps/hand/hand06m.xbm
|
||||
lib/blt2.4/demos/bitmaps/hand/hand07.xbm
|
||||
lib/blt2.4/demos/bitmaps/hand/hand07m.xbm
|
||||
lib/blt2.4/demos/bitmaps/hand/hand08.xbm
|
||||
lib/blt2.4/demos/bitmaps/hand/hand08m.xbm
|
||||
lib/blt2.4/demos/bitmaps/hand/hand09.xbm
|
||||
lib/blt2.4/demos/bitmaps/hand/hand09m.xbm
|
||||
lib/blt2.4/demos/bitmaps/hand/hand10.xbm
|
||||
lib/blt2.4/demos/bitmaps/hand/hand10m.xbm
|
||||
lib/blt2.4/demos/bitmaps/hand/hand11.xbm
|
||||
lib/blt2.4/demos/bitmaps/hand/hand11m.xbm
|
||||
lib/blt2.4/demos/bitmaps/hand/hand12.xbm
|
||||
lib/blt2.4/demos/bitmaps/hand/hand12m.xbm
|
||||
lib/blt2.4/demos/bitmaps/hand/hand13.xbm
|
||||
lib/blt2.4/demos/bitmaps/hand/hand13m.xbm
|
||||
lib/blt2.4/demos/bitmaps/hand/hand14.xbm
|
||||
lib/blt2.4/demos/bitmaps/hand/hand14m.xbm
|
||||
lib/blt2.4/demos/images/blt98.gif
|
||||
lib/blt2.4/demos/images/buckskin.gif
|
||||
lib/blt2.4/demos/images/chalk.gif
|
||||
lib/blt2.4/demos/images/close.gif
|
||||
lib/blt2.4/demos/images/close2.gif
|
||||
lib/blt2.4/demos/images/clouds.gif
|
||||
lib/blt2.4/demos/images/corrugated_metal.gif
|
||||
lib/blt2.4/demos/images/folder.gif
|
||||
@ -95,15 +115,37 @@ lib/blt2.4/demos/images/mini-filemgr.gif
|
||||
lib/blt2.4/demos/images/mini-ofolder.gif
|
||||
lib/blt2.4/demos/images/mini-windows.gif
|
||||
lib/blt2.4/demos/images/ofolder.gif
|
||||
lib/blt2.4/demos/images/open.gif
|
||||
lib/blt2.4/demos/images/open2.gif
|
||||
lib/blt2.4/demos/images/out.ps
|
||||
lib/blt2.4/demos/images/qv100.t.gif
|
||||
lib/blt2.4/demos/images/rain.gif
|
||||
lib/blt2.4/demos/images/sample.gif
|
||||
lib/blt2.4/demos/images/smblue_rock.gif
|
||||
lib/blt2.4/demos/images/stopsign.gif
|
||||
lib/blt2.4/demos/images/tan_paper.gif
|
||||
lib/blt2.4/demos/images/tan_paper2.gif
|
||||
lib/blt2.4/demos/images/txtrflag.gif
|
||||
lib/blt2.4/demos/scripts/barchart2.tcl
|
||||
lib/blt2.4/demos/scripts/bgtest.tcl
|
||||
lib/blt2.4/demos/scripts/clone.tcl
|
||||
lib/blt2.4/demos/scripts/demo.tcl
|
||||
lib/blt2.4/demos/scripts/globe.tcl
|
||||
lib/blt2.4/demos/scripts/graph1.tcl
|
||||
lib/blt2.4/demos/scripts/graph2.tcl
|
||||
lib/blt2.4/demos/scripts/graph3.tcl
|
||||
lib/blt2.4/demos/scripts/graph5.tcl
|
||||
lib/blt2.4/demos/scripts/graph8.tcl
|
||||
lib/blt2.4/demos/scripts/page.tcl
|
||||
lib/blt2.4/demos/scripts/patterns.tcl
|
||||
lib/blt2.4/demos/scripts/ps.tcl
|
||||
lib/blt2.4/demos/scripts/send.tcl
|
||||
lib/blt2.4/demos/scripts/stipples.tcl
|
||||
lib/blt2.4/demos/scripts/xcolors.tcl
|
||||
@dirrm lib/blt2.4/demos/scripts
|
||||
@dirrm lib/blt2.4/demos/images
|
||||
@dirrm lib/blt2.4/demos/bitmaps/hand
|
||||
@dirrm lib/blt2.4/demos/bitmaps/fish
|
||||
@dirrm lib/blt2.4/demos/bitmaps
|
||||
@dirrm lib/blt2.4/demos
|
||||
@dirrm lib/blt2.4/dd_protocols
|
||||
|
Loading…
Reference in New Issue
Block a user