Resurrect this port.
Requested by: Piet Delport <pjdelport@gmail.com>
This commit is contained in:
parent
246ec6f46b
commit
7a5498b471
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=289333
43
sysutils/curly/Makefile
Normal file
43
sysutils/curly/Makefile
Normal file
@ -0,0 +1,43 @@
|
||||
# New ports collection makefile for: curly
|
||||
# Date created: Nov 1 2002
|
||||
# Whom: Stephen Gunn <csg@fedex.com>, <csg@waterspout.com>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= curly
|
||||
PORTVERSION= 3.4
|
||||
CATEGORIES= sysutils
|
||||
MASTER_SITES= ftp://ftp.physics.purdue.edu/pub/pundits/ \
|
||||
http://www.komquats.com/distfiles/ \
|
||||
http://people.freebsd.org/~cy/distfiles/
|
||||
|
||||
DISTNAME= xapply-${PORTVERSION}
|
||||
EXTRACT_SUFX= .tgz
|
||||
|
||||
MAINTAINER= cy@FreeBSD.org
|
||||
COMMENT= Generalize listed filenames to csh-extended glob patterns
|
||||
|
||||
BUILD_DEPENDS= makeme:${PORTSDIR}/devel/msrc0 \
|
||||
mkcmd:${PORTSDIR}/devel/mkcmd
|
||||
|
||||
MAKE_FLAGS=
|
||||
MAKEFILE=
|
||||
MAN1= ${PORTNAME}.1
|
||||
MLINKS= ${PORTNAME}.1 un${PORTNAME}.1
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's,CFLAGS=,CFLAGS+=,' -e 's,^DEBUG,#DEBUG,'\
|
||||
-e 's,gcc,${CC},' ${WRKSRC}/bin/curly/Make.host
|
||||
|
||||
do-build:
|
||||
( cd ${WRKSRC}/bin/${PORTNAME} && ${SETENV} ${MAKE_ENV} makeme \
|
||||
${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${ALL_TARGET} )
|
||||
|
||||
do-install:
|
||||
( cd ${WRKSRC}/bin/curly && ${SETENV} ${MAKENV} makeme \
|
||||
${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${INSTALL_TARGET} )
|
||||
${INSTALL_MAN} ${WRKSRC}/bin/${PORTNAME}/${PORTNAME}.man \
|
||||
${PREFIX}/man/man1/${PORTNAME}.1
|
||||
|
||||
.include <bsd.port.mk>
|
2
sysutils/curly/distinfo
Normal file
2
sysutils/curly/distinfo
Normal file
@ -0,0 +1,2 @@
|
||||
SHA256 (xapply-3.4.tgz) = 68b9408310da0270d763a2c1c2beeadbbccef857bf5d00312748a1de8a5ea445
|
||||
SIZE (xapply-3.4.tgz) = 31354
|
13
sysutils/curly/files/patch-machine.h
Normal file
13
sysutils/curly/files/patch-machine.h
Normal file
@ -0,0 +1,13 @@
|
||||
$FreeBSD$
|
||||
|
||||
--- bin/curly/machine.h.orig Wed Nov 13 08:08:13 2002
|
||||
+++ bin/curly/machine.h Wed Nov 13 08:08:48 2002
|
||||
@@ -19,7 +19,7 @@
|
||||
#endif
|
||||
|
||||
#if !defined(NEED_MALLOC_EXTERN)
|
||||
-#define NEED_MALLOC_EXTERN (!USE_MALLOC_H && !defined(NEXT2) && !defined(IRIX) && !defined(BSDI))
|
||||
+#define NEED_MALLOC_EXTERN (!USE_MALLOC_H && !defined(NEXT2) && !defined(IRIX) && !defined(BSDI) && !defined(FREEBSD))
|
||||
#endif
|
||||
|
||||
#if !defined(USE_STDLIB)
|
2
sysutils/curly/pkg-descr
Normal file
2
sysutils/curly/pkg-descr
Normal file
@ -0,0 +1,2 @@
|
||||
Curly filters a list of filenames to a greatest-common-denominator
|
||||
glob pattern used by most shells.
|
2
sysutils/curly/pkg-plist
Normal file
2
sysutils/curly/pkg-plist
Normal file
@ -0,0 +1,2 @@
|
||||
bin/curly
|
||||
bin/uncurly
|
Loading…
Reference in New Issue
Block a user