irc/darkbot - The talking IRC Bot!
Darkbot is a very smart IRC bot with a very fast algorithm for an auto-responder database. More information about Darkbot can be found on http://darkbot.sourceforge.net/ PR: ports/48847 Submitted by: A. Gabriel <backslash@BSDCode.org>
This commit is contained in:
parent
48dd9981c1
commit
7a39ef13a0
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=77906
@ -5,6 +5,7 @@
|
||||
SUBDIR += blackened
|
||||
SUBDIR += bnc
|
||||
SUBDIR += bobot++
|
||||
SUBDIR += darkbot
|
||||
SUBDIR += dcc
|
||||
SUBDIR += dircproxy
|
||||
SUBDIR += epic4
|
||||
|
28
irc/darkbot/Makefile
Normal file
28
irc/darkbot/Makefile
Normal file
@ -0,0 +1,28 @@
|
||||
# Ports collection makefile for: Darkbot
|
||||
# Date created: 24 February 2003
|
||||
# Whom: A. Gabriel <backslash@BSDCode.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= darkbot
|
||||
PORTVERSION= 6f6_r6
|
||||
CATEGORIES= irc
|
||||
MASTER_SITES= http://darkbot.sourceforge.net/archive/unix/ \
|
||||
http://www.BSDCode.org/port/
|
||||
|
||||
MAINTAINER= backslash@BSDCode.org
|
||||
COMMENT= IRC talking bot with a very fast algorithm for its database
|
||||
|
||||
PLIST= ${WRKDIR}/plist
|
||||
|
||||
MAN1= darkbot.1
|
||||
MANCOMPRESSED= yes
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
IS_INTERACTIVE= yes
|
||||
|
||||
pre-install:
|
||||
${CAT} ${MASTERDIR}/pkg-plist | ${SED} -e "s,/usr/local,${LOCALBASE},g" > ${PLIST}
|
||||
|
||||
.include <bsd.port.mk>
|
1
irc/darkbot/distinfo
Normal file
1
irc/darkbot/distinfo
Normal file
@ -0,0 +1 @@
|
||||
MD5 (darkbot-6f6_r6.tar.gz) = 8b27e94dafc967dee89938be67a7d8cb
|
30
irc/darkbot/files/patch-Makefile
Normal file
30
irc/darkbot/files/patch-Makefile
Normal file
@ -0,0 +1,30 @@
|
||||
--- Makefile.orig Tue Apr 1 00:14:41 2003
|
||||
+++ Makefile Tue Apr 1 00:23:28 2003
|
||||
@@ -23,14 +23,15 @@
|
||||
|
||||
ALL_SRC = darkbot.c
|
||||
|
||||
-BASE_DIR = /usr/local/
|
||||
+BASE_DIR = ${PREFIX}/
|
||||
|
||||
all: ; ${CC} ${CFLAGS} ${ALL_SRC} -o ${EXE_NAME};
|
||||
chmod +x ./configure;
|
||||
|
||||
install: ; cp darkbot ${BASE_DIR}bin/;
|
||||
- mkdir ${BASE_DIR}etc/darkbot/; mkdir ${BASE_DIR}etc/darkbot/logs/;
|
||||
- mkdir ${BASE_DIR}etc/darkbot/dat/;
|
||||
+ -mkdir ${BASE_DIR}etc/darkbot/;
|
||||
+ -mkdir ${BASE_DIR}etc/darkbot/logs/;
|
||||
+ -mkdir ${BASE_DIR}etc/darkbot/dat/;
|
||||
cp dat/* ${BASE_DIR}etc/darkbot/dat/; chmod +x ./.runonce; ./.runonce;
|
||||
cp configure config; chmod -x ./config;
|
||||
cp ./config ${BASE_DIR}etc/darkbot/;
|
||||
@@ -38,7 +39,7 @@
|
||||
echo "cd /usr/local/etc/darkbot/;/bin/sh config" >> \
|
||||
${BASE_DIR}etc/darkbot/configure;
|
||||
chmod +x ${BASE_DIR}etc/darkbot/configure;
|
||||
- cp ./darkbot.1.gz /usr/local/man/man1/;
|
||||
+ cp ./darkbot.1.gz ${BASE_DIR}man/man1/;
|
||||
|
||||
debug: ; ${CC} ${DFLAGS} ${ALL_SRC} -o ${EXE_NAME}; cat .debug ; gdb ${EXE_NAME}
|
||||
|
2
irc/darkbot/pkg-comment
Normal file
2
irc/darkbot/pkg-comment
Normal file
@ -0,0 +1,2 @@
|
||||
IRC talking bot with a very fast algorithm for its database (auto-responds
|
||||
on given masks).
|
11
irc/darkbot/pkg-descr
Normal file
11
irc/darkbot/pkg-descr
Normal file
@ -0,0 +1,11 @@
|
||||
Originally created by Jason Hamilton as an aid for help
|
||||
channels to answer repeated questions from its virtually
|
||||
unlimited database, it has became a very popular talking
|
||||
robot in a generic sense, being used all over IRC networks
|
||||
for different purposes and in 18 languages. Data can be
|
||||
added to it and managed dynamically online or edited in
|
||||
its database files offline.
|
||||
|
||||
WWW: http://darkbot.sourceforge.net/
|
||||
|
||||
--backslash <backslash@BSDCode.org>
|
9
irc/darkbot/pkg-plist
Normal file
9
irc/darkbot/pkg-plist
Normal file
@ -0,0 +1,9 @@
|
||||
bin/darkbot
|
||||
etc/darkbot/dat/info2.db
|
||||
etc/darkbot/dat/deop.ini
|
||||
etc/darkbot/dat/perform.ini
|
||||
etc/darkbot/dat/permbans.db
|
||||
etc/darkbot/dat/random.ini
|
||||
etc/darkbot/dat/randomstuff.ini
|
||||
etc/darkbot/dat/seen.db
|
||||
@unexec rm -rf /usr/local/etc/darkbot/ /usr/local/bin/darkbot*
|
Loading…
Reference in New Issue
Block a user