graphics/vulkan-loader: update to 1.2.192

Changes:	https://github.com/KhronosGroup/Vulkan-Loader/compare/v1.2.191...v1.2.192
Reported by:	portscout
This commit is contained in:
Jan Beich 2021-09-15 16:41:50 +00:00
parent 396101a7b4
commit 79f3c80d76
7 changed files with 55 additions and 20 deletions

View File

@ -1,7 +1,6 @@
PORTNAME= vulkan-loader
DISTVERSIONPREFIX= v
DISTVERSION= 1.2.191
PORTREVISION= 1
DISTVERSION= 1.2.192
CATEGORIES= graphics devel
MAINTAINER= jbeich@FreeBSD.org
@ -38,5 +37,10 @@ XLIB_CMAKE_BOOL= BUILD_WSI_XLIB_SUPPORT
post-patch:
# _XOPEN_SOURCE enforces X/Open-compliance but alloca isn't there
@${REINPLACE_CMD} '/_XOPEN_SOURCE/d' ${WRKSRC}/loader/CMakeLists.txt
# Extract (snapshot) version from the port
@${REINPLACE_CMD} -e '/find_.*Git/d' \
-e '/BRANCH/s/--unknown--/main/' \
-e '/TAG/s/--unknown--/${DISTVERSIONFULL}/' \
${WRKSRC}/CMakeLists.txt
.include <bsd.port.mk>

View File

@ -1,3 +1,3 @@
TIMESTAMP = 1631139753
SHA256 (KhronosGroup-Vulkan-Loader-v1.2.191_GH0.tar.gz) = f884765bc5a2fb5f6f810adfe5cb53ffe5541f2b423d13e1953205fd2028deff
SIZE (KhronosGroup-Vulkan-Loader-v1.2.191_GH0.tar.gz) = 1512057
TIMESTAMP = 1631724110
SHA256 (KhronosGroup-Vulkan-Loader-v1.2.192_GH0.tar.gz) = 5af8057836c9624ccd9408c038ec693ab464758183243133c91bb1a6ed64d950
SIZE (KhronosGroup-Vulkan-Loader-v1.2.192_GH0.tar.gz) = 1517086

View File

@ -0,0 +1,11 @@
--- loader/allocation.h.orig 2021-09-15 16:41:50 UTC
+++ loader/allocation.h
@@ -39,7 +39,7 @@ void loader_device_heap_free(const struct loader_devic
void *loader_device_heap_realloc(const struct loader_device *device, void *pMemory, size_t orig_size, size_t size,
VkSystemAllocationScope alloc_scope);
-#if defined(__linux__) || defined(__APPLE__) || defined(__Fuchsia__) || defined(__QNXNTO__)
+#if defined(__unix__) || defined(__APPLE__) || defined(__Fuchsia__) || defined(__QNXNTO__)
#define loader_stack_alloc(size) alloca(size)
#elif defined(_WIN32)
#define loader_stack_alloc(size) _alloca(size)

View File

@ -1,18 +1,18 @@
--- loader/loader.c.orig 2021-04-29 17:49:58 UTC
+++ loader/loader.c
@@ -253,7 +253,7 @@ void *loader_device_heap_realloc(const struct loader_d
}
--- loader/get_environment.c.orig 2021-09-15 16:41:50 UTC
+++ loader/get_environment.c
@@ -31,7 +31,7 @@
#include "log.h"
// Environment variables
-#if defined(__linux__) || defined(__APPLE__) || defined(__Fuchsia__) || defined(__QNXNTO__)
+#if defined(__unix__) || defined(__APPLE__) || defined(__Fuchsia__) || defined(__QNXNTO__)
static inline bool IsHighIntegrity() {
return geteuid() != getuid() || getegid() != getgid();
@@ -267,7 +267,7 @@ static inline char *loader_getenv(const char *name, co
bool is_high_integrity() { return geteuid() != getuid() || getegid() != getgid(); }
@@ -43,7 +43,7 @@ char *loader_getenv(const char *name, const struct loa
}
static inline char *loader_secure_getenv(const char *name, const struct loader_instance *inst) {
char *loader_secure_getenv(const char *name, const struct loader_instance *inst) {
-#if defined(__APPLE__)
+#if !defined(__linux__)
// Apple does not appear to have a secure getenv implementation.

View File

@ -0,0 +1,11 @@
--- loader/get_environment.h.orig 2021-09-15 16:41:50 UTC
+++ loader/get_environment.h
@@ -35,7 +35,7 @@
char *loader_getenv(const char *name, const struct loader_instance *inst);
void loader_free_getenv(char *val, const struct loader_instance *inst);
-#if defined(WIN32) || defined(__linux__) || defined(__APPLE__) || defined(__Fuchsia__) || defined(__QNXNTO__)
+#if defined(WIN32) || defined(__unix__) || defined(__APPLE__) || defined(__Fuchsia__) || defined(__QNXNTO__)
bool is_high_integrity();

View File

@ -1,15 +1,24 @@
--- loader/vk_loader_platform.h.orig 2021-04-20 16:45:05 UTC
--- loader/vk_loader_platform.h.orig 2021-09-15 16:41:50 UTC
+++ loader/vk_loader_platform.h
@@ -35,7 +35,7 @@
#include "vulkan/vk_platform.h"
#include "vulkan/vk_sdk_platform.h"
@@ -37,7 +37,7 @@
#include "dlopen_fuchsia.h"
#endif // defined(__Fuchsia__)
-#if defined(__linux__) || defined(__APPLE__) || defined(__Fuchsia__) || defined(__QNXNTO__)
+#if defined(__unix__) || defined(__APPLE__) || defined(__Fuchsia__) || defined(__QNXNTO__)
#include <unistd.h>
// Note: The following file is for dynamic loading:
#include <dlfcn.h>
@@ -97,7 +97,7 @@
// Override layer information
#define VK_OVERRIDE_LAYER_NAME "VK_LAYER_LUNARG_override"
-#if defined(__linux__) || defined(__APPLE__) || defined(__Fuchsia__) || defined(__QNXNTO__)
+#if defined(__unix__) || defined(__APPLE__) || defined(__Fuchsia__) || defined(__QNXNTO__)
/* Linux-specific common code: */
// Headers:
@@ -120,6 +120,26 @@ static inline char *loader_platform_executable_path(ch
// VK Library Filenames, Paths, etc.:
@@ -168,6 +168,26 @@ static inline char *loader_platform_executable_path(ch
int ret = proc_pidpath(pid, buffer, size);
if (ret <= 0) return NULL;
buffer[ret] = '\0';

View File

@ -1,4 +1,4 @@
lib/libvulkan.so
lib/libvulkan.so.1
lib/libvulkan.so.1.2.191
lib/libvulkan.so.1.2.192
libdata/pkgconfig/vulkan.pc