Remove graphics/libwpcg per deprecation note.
This commit is contained in:
parent
3f4313519c
commit
79ee44e978
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=243295
1
MOVED
1
MOVED
@ -4189,3 +4189,4 @@ audio/xmms-uade|audio/uade|2009-10-18|decoupled from xmms
|
||||
net-p2p/mute-net-gui|net-p2p/mute-net|2009-10-19|Broken for extensive period of time and unmaintained
|
||||
net-p2p/mute-net-text|net-p2p/mute-net|2009-10-19|Broken for extensive period of time and unmaintained
|
||||
archivers/zlib||2009-10-19|Removed
|
||||
graphics/libwpcg||2009-10-25|Unmaintained upstream, depends on an old version of GCC, lacks a maintainer, and not used by anything else
|
||||
|
@ -457,7 +457,6 @@
|
||||
SUBDIR += libvisual04
|
||||
SUBDIR += libvisual04-plugins
|
||||
SUBDIR += libwmf
|
||||
SUBDIR += libwpcg
|
||||
SUBDIR += libwpg
|
||||
SUBDIR += libx3dtk
|
||||
SUBDIR += linplasma
|
||||
|
@ -1,28 +0,0 @@
|
||||
# ex:ts=8
|
||||
# Ports collection makefile for: libWPCG
|
||||
# Date Created: Nov 18, 2002
|
||||
# Whom: ijliao
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= libwpcg
|
||||
PORTVERSION= 0.9.3
|
||||
PORTREVISION= 3
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= http://www.paassen.tmfweb.nl/
|
||||
DISTNAME= libWPCG-${PORTVERSION}
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= A basic 2D/3D computer graphics library which uses OpenGL
|
||||
|
||||
DEPRECATED= depends on old version of GCC, no maintainer, not used by any other port
|
||||
EXPIRATION_DATE=2009-10-13
|
||||
|
||||
USE_GCC= 3.4
|
||||
USE_GL= glut
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
|
||||
LDFLAGS="-L${LOCALBASE}/lib -lGL -lGLU -lglut"
|
||||
|
||||
.include <bsd.port.mk>
|
@ -1,3 +0,0 @@
|
||||
MD5 (libWPCG-0.9.3.tar.gz) = 044fb8c90bdf78e18b79de331ec7fb07
|
||||
SHA256 (libWPCG-0.9.3.tar.gz) = a4c1547f1774992048968e576c8f96706c8b1d42d689c4ee22e99e843619198b
|
||||
SIZE (libWPCG-0.9.3.tar.gz) = 393664
|
@ -1,11 +0,0 @@
|
||||
--- WP_Terrain.C.orig Thu Aug 19 15:07:13 2004
|
||||
+++ WP_Terrain.C Thu Aug 19 15:07:26 2004
|
||||
@@ -29,7 +29,7 @@
|
||||
{
|
||||
//creates a random 3D terrain
|
||||
|
||||
- WP_Vertex **height_map = new (WP_Vertex*)[height];
|
||||
+ WP_Vertex **height_map = new WP_Vertex*[height];
|
||||
if (!height_map)
|
||||
{
|
||||
cerr << "Unable to allocate memory for height_map" << endl;
|
@ -1 +0,0 @@
|
||||
A basic 2D/3D computer graphics library which uses OpenGL
|
@ -1,76 +0,0 @@
|
||||
include/OPCODE-1.2/OPC_AABB.h
|
||||
include/OPCODE-1.2/OPC_AABBCollider.h
|
||||
include/OPCODE-1.2/OPC_AABBTree.h
|
||||
include/OPCODE-1.2/OPC_BVTCache.h
|
||||
include/OPCODE-1.2/OPC_BoundingSphere.h
|
||||
include/OPCODE-1.2/OPC_BoxBoxOverlap.h
|
||||
include/OPCODE-1.2/OPC_Collider.h
|
||||
include/OPCODE-1.2/OPC_Common.h
|
||||
include/OPCODE-1.2/OPC_Container.h
|
||||
include/OPCODE-1.2/OPC_FPU.h
|
||||
include/OPCODE-1.2/OPC_HPoint.h
|
||||
include/OPCODE-1.2/OPC_Matrix3x3.h
|
||||
include/OPCODE-1.2/OPC_Matrix4x4.h
|
||||
include/OPCODE-1.2/OPC_MemoryMacros.h
|
||||
include/OPCODE-1.2/OPC_Model.h
|
||||
include/OPCODE-1.2/OPC_OBB.h
|
||||
include/OPCODE-1.2/OPC_OBBCollider.h
|
||||
include/OPCODE-1.2/OPC_OptimizedTree.h
|
||||
include/OPCODE-1.2/OPC_Plane.h
|
||||
include/OPCODE-1.2/OPC_PlanesAABBOverlap.h
|
||||
include/OPCODE-1.2/OPC_PlanesCollider.h
|
||||
include/OPCODE-1.2/OPC_PlanesTriOverlap.h
|
||||
include/OPCODE-1.2/OPC_Point.h
|
||||
include/OPCODE-1.2/OPC_Preprocessor.h
|
||||
include/OPCODE-1.2/OPC_Ray.h
|
||||
include/OPCODE-1.2/OPC_RayAABBOverlap.h
|
||||
include/OPCODE-1.2/OPC_RayCollider.h
|
||||
include/OPCODE-1.2/OPC_RayTriOverlap.h
|
||||
include/OPCODE-1.2/OPC_Settings.h
|
||||
include/OPCODE-1.2/OPC_SphereAABBOverlap.h
|
||||
include/OPCODE-1.2/OPC_SphereCollider.h
|
||||
include/OPCODE-1.2/OPC_SphereTriOverlap.h
|
||||
include/OPCODE-1.2/OPC_TreeBuilders.h
|
||||
include/OPCODE-1.2/OPC_TreeCollider.h
|
||||
include/OPCODE-1.2/OPC_TriBoxOverlap.h
|
||||
include/OPCODE-1.2/OPC_TriTriOverlap.h
|
||||
include/OPCODE-1.2/OPC_Triangle.h
|
||||
include/OPCODE-1.2/OPC_Types.h
|
||||
include/OPCODE-1.2/OPC_VolumeCollider.h
|
||||
include/OPCODE-1.2/Opcode.h
|
||||
include/OPCODE-1.2/Stdafx.h
|
||||
include/WPCG/WPCG.h
|
||||
include/WPCG/WP_2D.h
|
||||
include/WPCG/WP_AnimationManager.h
|
||||
include/WPCG/WP_Camera.h
|
||||
include/WPCG/WP_Color.h
|
||||
include/WPCG/WP_Def.h
|
||||
include/WPCG/WP_Endian.h
|
||||
include/WPCG/WP_GLState.h
|
||||
include/WPCG/WP_Image.h
|
||||
include/WPCG/WP_Init.h
|
||||
include/WPCG/WP_Light.h
|
||||
include/WPCG/WP_Line2D.h
|
||||
include/WPCG/WP_Material.h
|
||||
include/WPCG/WP_Math.h
|
||||
include/WPCG/WP_Matrix2D.h
|
||||
include/WPCG/WP_Matrix3D.h
|
||||
include/WPCG/WP_Model.h
|
||||
include/WPCG/WP_ObjectManager.h
|
||||
include/WPCG/WP_Point2D.h
|
||||
include/WPCG/WP_Point3D.h
|
||||
include/WPCG/WP_Quad.h
|
||||
include/WPCG/WP_RGBA.h
|
||||
include/WPCG/WP_Ray2D.h
|
||||
include/WPCG/WP_Ray3D.h
|
||||
include/WPCG/WP_SkyBox.h
|
||||
include/WPCG/WP_Terrain.h
|
||||
include/WPCG/WP_TextureManager.h
|
||||
include/WPCG/WP_Triangle.h
|
||||
include/WPCG/WP_Vector2D.h
|
||||
include/WPCG/WP_Vector3D.h
|
||||
include/WPCG/WP_Vertex.h
|
||||
lib/libOPCODE.a
|
||||
lib/libWPCG.a
|
||||
@dirrm include/WPCG
|
||||
@dirrm include/OPCODE-1.2
|
Loading…
Reference in New Issue
Block a user