x11/phosh: remove incomplete port
pkg-descr said "Currently, only useful for developers." Phosh itself has many features stubbed and also depends on GNOME/Wayland which isn't supported on FreeBSD yet. Avoid confusing users by putting the port out of misery.
This commit is contained in:
parent
bd9c84a2c7
commit
79c3c08148
1
MOVED
1
MOVED
@ -16339,3 +16339,4 @@ sysutils/ansible28|sysutils/ansible|2021-05-21|Has expired: Upstream support end
|
||||
devel/omnisharp-server||2021-05-23|Dead upstream, no depends in ports tree
|
||||
devel/py-jupyter_client|devel/py-jupyter-client|2021-05-26|Rename to match upstream naming
|
||||
textproc/gi-docgen|textproc/py-gi-docgen|2021-05-27|Follow standard python port conventions
|
||||
x11/phosh||2021-05-29|Incomplete
|
||||
|
@ -256,7 +256,6 @@
|
||||
SUBDIR += p5-XTerm-Conf
|
||||
SUBDIR += pcdm
|
||||
SUBDIR += perwindowlayoutd
|
||||
SUBDIR += phosh
|
||||
SUBDIR += pipeglade
|
||||
SUBDIR += pixman
|
||||
SUBDIR += plank
|
||||
|
@ -1,42 +0,0 @@
|
||||
PORTNAME= phosh
|
||||
DISTVERSIONPREFIX= v
|
||||
DISTVERSION= 0.10.2
|
||||
CATEGORIES= x11
|
||||
|
||||
MAINTAINER= jbeich@FreeBSD.org
|
||||
COMMENT= Pure Wayland shell prototype for mobile devices
|
||||
|
||||
LICENSE= GPLv3+
|
||||
LICENSE_FILE= ${WRKSRC}/COPYING
|
||||
|
||||
BUILD_DEPENDS= wayland-protocols>=1.12:graphics/wayland-protocols
|
||||
LIB_DEPENDS= libfeedback-0.0.so:accessibility/feedbackd \
|
||||
libpulse-mainloop-glib.so:audio/pulseaudio \
|
||||
libwayland-client.so:graphics/wayland \
|
||||
libgcr-ui-3.so:security/gcr \
|
||||
libpolkit-agent-1.so:sysutils/polkit \
|
||||
libupower-glib.so:sysutils/upower \
|
||||
libhandy-1.so:x11-toolkits/libhandy
|
||||
RUN_DEPENDS= phoc:x11-wm/phoc \
|
||||
gnome-session:x11/gnome-session \
|
||||
${LOCALBASE}/share/glib-2.0/schemas/org.gnome.shell.gschema.xml:x11/gnome-shell
|
||||
|
||||
USES= compiler:c11 gettext gnome meson pkgconfig python:build shebangfix
|
||||
USE_GITLAB= yes
|
||||
USE_GNOME= cairo gdkpixbuf2 gnomedesktop3
|
||||
GL_SITE= https://source.puri.sm
|
||||
GL_ACCOUNT= Librem5
|
||||
GL_COMMIT= cf35b4dae97db3b33369134ff9b3b082ac3dff72
|
||||
GL_TUPLE= https://gitlab.gnome.org:GNOME:libgnome-volume-control:ae1a34aafce7026b8c0f65a43c9192d756fe1057:gvc/subprojects/gvc
|
||||
SHEBANG_FILES= build-aux/post_install.py
|
||||
MESON_ARGS= -Dgvc:alsa=false
|
||||
GLIB_SCHEMAS= 00_sm.puri.Phosh.gschema.override \
|
||||
sm.puri.phosh.enums.xml \
|
||||
sm.puri.phosh.gschema.xml
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's/bash -l/sh -/' \
|
||||
-e 's,/etc,${PREFIX}&,' \
|
||||
${WRKSRC}/data/phosh.in
|
||||
|
||||
.include <bsd.port.mk>
|
@ -1,5 +0,0 @@
|
||||
TIMESTAMP = 1619702440
|
||||
SHA256 (Librem5-phosh-cf35b4dae97db3b33369134ff9b3b082ac3dff72_GL0.tar.gz) = 4c8abad0329ed7d0d35949a75df897db4c2fc4b90f9ba80e259225847b61bd9b
|
||||
SIZE (Librem5-phosh-cf35b4dae97db3b33369134ff9b3b082ac3dff72_GL0.tar.gz) = 432343
|
||||
SHA256 (GNOME-libgnome-volume-control-ae1a34aafce7026b8c0f65a43c9192d756fe1057_GL0.tar.gz) = afc9a7c7fd6de8252430878a753b4dbfd09033a54055e4020ced3d26609143ee
|
||||
SIZE (GNOME-libgnome-volume-control-ae1a34aafce7026b8c0f65a43c9192d756fe1057_GL0.tar.gz) = 45164
|
@ -1,17 +0,0 @@
|
||||
Don't use Linux-only types in otherwise portable code.
|
||||
|
||||
../src/system-prompter.c:25:8: error: unknown type name 'ulong'
|
||||
static ulong owner_id;
|
||||
^
|
||||
|
||||
--- src/system-prompter.c.orig 2020-08-03 08:10:28 UTC
|
||||
+++ src/system-prompter.c
|
||||
@@ -22,7 +22,7 @@
|
||||
* wide modal #PhoshSystemPrompt dialogs
|
||||
*/
|
||||
static GcrSystemPrompter *_prompter;
|
||||
-static ulong owner_id;
|
||||
+static gulong owner_id;
|
||||
static gboolean registered_prompter;
|
||||
static gboolean acquired_prompter;
|
||||
|
@ -1,143 +0,0 @@
|
||||
NetworkManager is Linux-only. FreeBSD has many alternatives but none
|
||||
implements libnm-compatible API required by Phosh and GNOME.
|
||||
|
||||
meson.build:134:0: ERROR: Dependency "libnm" not found, tried pkgconfig
|
||||
|
||||
--- meson.build.orig 2020-12-18 14:53:37 UTC
|
||||
+++ meson.build
|
||||
@@ -131,11 +131,11 @@ libhandy_dep = dependency('libhandy-1',
|
||||
fallback: ['libhandy', 'libhandy_dep'],
|
||||
default_options: ['introspection=disabled']
|
||||
)
|
||||
-libnm_dep = dependency('libnm', version: '>= 1.14')
|
||||
+libnm_dep = dependency('libnm', version: '>= 1.14', required: false)
|
||||
libpolkit_agent_dep = dependency('polkit-agent-1', version: '>= 0.105')
|
||||
# TODO: make optional for elogind?
|
||||
libsystemd_dep = dependency('libsystemd', version: '>= 241')
|
||||
-network_agent_dep = dependency('libsecret-1')
|
||||
+network_agent_dep = dependency('libsecret-1', required: false)
|
||||
upower_glib_dep = dependency('upower-glib', version: '>=0.99.1')
|
||||
wayland_client_dep = dependency('wayland-client', version: '>=1.14')
|
||||
wayland_protos_dep = dependency('wayland-protocols', version: '>=1.12')
|
||||
--- src/meson.build.orig 2021-04-29 13:20:40 UTC
|
||||
+++ src/meson.build
|
||||
@@ -58,8 +58,6 @@ libphosh_tool_sources = [
|
||||
'app-list-model.h',
|
||||
'background.c',
|
||||
'background.h',
|
||||
- 'connectivity-info.c',
|
||||
- 'connectivity-info.h',
|
||||
'end-session-dialog.c',
|
||||
'end-session-dialog.h',
|
||||
'hks-info.c',
|
||||
@@ -131,8 +129,6 @@ libphosh_sources = [
|
||||
'bt-info.h',
|
||||
'bt-manager.c',
|
||||
'bt-manager.h',
|
||||
- 'contrib/shell-network-agent.c',
|
||||
- 'contrib/shell-network-agent.h',
|
||||
'fader.c',
|
||||
'fader.h',
|
||||
'feedbackinfo.c',
|
||||
@@ -153,8 +149,6 @@ libphosh_sources = [
|
||||
'lockscreen.h',
|
||||
'monitor-manager.c',
|
||||
'monitor-manager.h',
|
||||
- 'network-auth-prompt.c',
|
||||
- 'network-auth-prompt.h',
|
||||
'osk-manager.c',
|
||||
'osk-manager.h',
|
||||
'panel.c',
|
||||
@@ -195,10 +189,6 @@ libphosh_sources = [
|
||||
'torch-manager.h',
|
||||
'toplevel.c',
|
||||
'toplevel.h',
|
||||
- 'wifiinfo.c',
|
||||
- 'wifiinfo.h',
|
||||
- 'wifimanager.c',
|
||||
- 'wifimanager.h',
|
||||
'wwaninfo.c',
|
||||
'wwaninfo.h',
|
||||
phosh_settings_sources,
|
||||
--- src/shell.c.orig 2021-02-09 20:00:21 UTC
|
||||
+++ src/shell.c
|
||||
@@ -29,7 +29,6 @@
|
||||
#include "background-manager.h"
|
||||
#include "bt-info.h"
|
||||
#include "bt-manager.h"
|
||||
-#include "connectivity-info.h"
|
||||
#include "docked-info.h"
|
||||
#include "docked-manager.h"
|
||||
#include "fader.h"
|
||||
@@ -62,7 +61,6 @@
|
||||
#include "torch-manager.h"
|
||||
#include "torch-info.h"
|
||||
#include "util.h"
|
||||
-#include "wifiinfo.h"
|
||||
#include "wwaninfo.h"
|
||||
#include "wwan/phosh-wwan-ofono.h"
|
||||
#include "wwan/phosh-wwan-mm.h"
|
||||
@@ -105,7 +103,6 @@ typedef struct
|
||||
PhoshIdleManager *idle_manager;
|
||||
PhoshOskManager *osk_manager;
|
||||
PhoshToplevelManager *toplevel_manager;
|
||||
- PhoshWifiManager *wifi_manager;
|
||||
PhoshPolkitAuthAgent *polkit_auth_agent;
|
||||
PhoshScreenSaverManager *screen_saver_manager;
|
||||
PhoshNotifyManager *notify_manager;
|
||||
@@ -351,7 +348,6 @@ phosh_shell_dispose (GObject *object)
|
||||
g_clear_object (&priv->notify_manager);
|
||||
g_clear_object (&priv->screen_saver_manager);
|
||||
g_clear_object (&priv->polkit_auth_agent);
|
||||
- g_clear_object (&priv->wifi_manager);
|
||||
g_clear_object (&priv->toplevel_manager);
|
||||
g_clear_object (&priv->osk_manager);
|
||||
g_clear_object (&priv->idle_manager);
|
||||
@@ -510,7 +506,6 @@ type_setup (void)
|
||||
{
|
||||
g_type_ensure (PHOSH_TYPE_BATTERY_INFO);
|
||||
g_type_ensure (PHOSH_TYPE_BT_INFO);
|
||||
- g_type_ensure (PHOSH_TYPE_CONNECTIVITY_INFO);
|
||||
g_type_ensure (PHOSH_TYPE_DOCKED_INFO);
|
||||
g_type_ensure (PHOSH_TYPE_FEEDBACK_INFO);
|
||||
g_type_ensure (PHOSH_TYPE_MEDIA_PLAYER);
|
||||
@@ -518,7 +513,6 @@ type_setup (void)
|
||||
g_type_ensure (PHOSH_TYPE_ROTATE_INFO);
|
||||
g_type_ensure (PHOSH_TYPE_SETTINGS);
|
||||
g_type_ensure (PHOSH_TYPE_TORCH_INFO);
|
||||
- g_type_ensure (PHOSH_TYPE_WIFI_INFO);
|
||||
g_type_ensure (PHOSH_TYPE_WWAN_INFO);
|
||||
}
|
||||
|
||||
@@ -869,21 +863,6 @@ phosh_shell_get_monitor_manager (PhoshShell *self)
|
||||
return priv->monitor_manager;
|
||||
}
|
||||
|
||||
-
|
||||
-PhoshWifiManager *
|
||||
-phosh_shell_get_wifi_manager (PhoshShell *self)
|
||||
-{
|
||||
- PhoshShellPrivate *priv;
|
||||
-
|
||||
- g_return_val_if_fail (PHOSH_IS_SHELL (self), NULL);
|
||||
- priv = phosh_shell_get_instance_private (self);
|
||||
-
|
||||
- if (!priv->wifi_manager)
|
||||
- priv->wifi_manager = phosh_wifi_manager_new ();
|
||||
-
|
||||
- g_return_val_if_fail (PHOSH_IS_WIFI_MANAGER (priv->wifi_manager), NULL);
|
||||
- return priv->wifi_manager;
|
||||
-}
|
||||
|
||||
|
||||
PhoshBtManager *
|
||||
--- tests/meson.build.orig 2020-08-03 08:10:28 UTC
|
||||
+++ tests/meson.build
|
||||
@@ -57,7 +57,6 @@ tests = [
|
||||
'activity',
|
||||
'app-grid-button',
|
||||
'app-list-model',
|
||||
- 'connectivity-info',
|
||||
'favourite-model',
|
||||
'media-player',
|
||||
'notification',
|
@ -1,77 +0,0 @@
|
||||
(e)logind is Linux-only. FreeBSD supports libseat but it has a different API.
|
||||
|
||||
--- meson.build.orig 2020-12-18 14:53:37 UTC
|
||||
+++ meson.build
|
||||
@@ -134,7 +134,7 @@ libhandy_dep = dependency('libhandy-1',
|
||||
libnm_dep = dependency('libnm', version: '>= 1.14', required: false)
|
||||
libpolkit_agent_dep = dependency('polkit-agent-1', version: '>= 0.105')
|
||||
# TODO: make optional for elogind?
|
||||
-libsystemd_dep = dependency('libsystemd', version: '>= 241')
|
||||
+libsystemd_dep = dependency('libsystemd', version: '>= 241', required: false)
|
||||
network_agent_dep = dependency('libsecret-1', required: false)
|
||||
upower_glib_dep = dependency('upower-glib', version: '>=0.99.1')
|
||||
wayland_client_dep = dependency('wayland-client', version: '>=1.14')
|
||||
--- src/util.c.orig 2020-12-18 14:53:37 UTC
|
||||
+++ src/util.c
|
||||
@@ -9,8 +9,6 @@
|
||||
#include "util.h"
|
||||
#include <gtk/gtk.h>
|
||||
|
||||
-#include <systemd/sd-login.h>
|
||||
-
|
||||
/* Just wraps gtk_widget_destroy so we can use it with g_clear_pointer */
|
||||
void
|
||||
phosh_cp_widget_destroy (void *widget)
|
||||
@@ -97,51 +95,5 @@ phosh_munge_app_id (const char *app_id)
|
||||
gboolean
|
||||
phosh_find_systemd_session (char **session_id)
|
||||
{
|
||||
- int n_sessions;
|
||||
-
|
||||
- g_auto (GStrv) sessions = NULL;
|
||||
- char *session;
|
||||
- int i;
|
||||
-
|
||||
- n_sessions = sd_uid_get_sessions (getuid (), 0, &sessions);
|
||||
-
|
||||
- if (n_sessions < 0) {
|
||||
- g_debug ("Failed to get sessions for user %d", getuid ());
|
||||
- return FALSE;
|
||||
- }
|
||||
-
|
||||
- session = NULL;
|
||||
- for (i = 0; i < n_sessions; i++) {
|
||||
- int r;
|
||||
- g_autofree char *type = NULL;
|
||||
- g_autofree char *desktop = NULL;
|
||||
-
|
||||
- r = sd_session_get_desktop (sessions[i], &desktop);
|
||||
- if (r < 0) {
|
||||
- g_debug ("Couldn't get desktop for session '%s': %s",
|
||||
- sessions[i], strerror (-r));
|
||||
- continue;
|
||||
- }
|
||||
-
|
||||
- if (g_strcmp0 (desktop, "phosh") != 0)
|
||||
- continue;
|
||||
-
|
||||
- r = sd_session_get_type (sessions[i], &type);
|
||||
- if (r < 0) {
|
||||
- g_debug ("Couldn't get type for session '%s': %s",
|
||||
- sessions[i], strerror (-r));
|
||||
- continue;
|
||||
- }
|
||||
-
|
||||
- if (g_strcmp0 (type, "wayland") != 0)
|
||||
- continue;
|
||||
-
|
||||
- session = sessions[i];
|
||||
- break;
|
||||
- }
|
||||
-
|
||||
- if (session != NULL)
|
||||
- *session_id = g_strdup (session);
|
||||
-
|
||||
- return session != NULL;
|
||||
+ return FALSE;
|
||||
}
|
@ -1,75 +0,0 @@
|
||||
rfkill API differs between Linux and FreeBSD.
|
||||
|
||||
src/hks-manager.c:18:10: fatal error: 'linux/rfkill.h' file not found
|
||||
#include <linux/rfkill.h>
|
||||
^~~~~~~~~~~~~~~~
|
||||
|
||||
--- src/meson.build.orig 2021-04-29 13:20:40 UTC
|
||||
+++ src/meson.build
|
||||
@@ -63,9 +61,5 @@
|
||||
'end-session-dialog.c',
|
||||
'end-session-dialog.h',
|
||||
- 'hks-info.c',
|
||||
- 'hks-info.h',
|
||||
- 'hks-manager.c',
|
||||
- 'hks-manager.h',
|
||||
'docked-info.c',
|
||||
'docked-info.h',
|
||||
'docked-manager.c',
|
||||
--- src/shell.c.orig 2021-04-29 13:20:40 UTC
|
||||
+++ src/shell.c
|
||||
@@ -36,7 +36,6 @@
|
||||
#include "feedbackinfo.h"
|
||||
#include "feedback-manager.h"
|
||||
#include "gnome-shell-manager.h"
|
||||
-#include "hks-info.h"
|
||||
#include "home.h"
|
||||
#include "idle-manager.h"
|
||||
#include "keyboard-events.h"
|
||||
@@ -124,7 +123,6 @@ typedef struct
|
||||
PhoshTorchManager *torch_manager;
|
||||
PhoshModeManager *mode_manager;
|
||||
PhoshDockedManager *docked_manager;
|
||||
- PhoshHksManager *hks_manager;
|
||||
PhoshKeyboardEvents *keyboard_events;
|
||||
PhoshLocationManager *location_manager;
|
||||
PhoshGnomeShellManager *gnome_shell_manager;
|
||||
@@ -352,7 +350,6 @@ phosh_shell_dispose (GObject *object)
|
||||
/* dispose managers in opposite order of declaration */
|
||||
g_clear_object (&priv->screenshot_manager);
|
||||
g_clear_object (&priv->location_manager);
|
||||
- g_clear_object (&priv->hks_manager);
|
||||
g_clear_object (&priv->docked_manager);
|
||||
g_clear_object (&priv->mode_manager);
|
||||
g_clear_object (&priv->torch_manager);
|
||||
@@ -534,7 +531,6 @@ type_setup (void)
|
||||
g_type_ensure (PHOSH_TYPE_CONNECTIVITY_INFO);
|
||||
g_type_ensure (PHOSH_TYPE_DOCKED_INFO);
|
||||
g_type_ensure (PHOSH_TYPE_FEEDBACK_INFO);
|
||||
- g_type_ensure (PHOSH_TYPE_HKS_INFO);
|
||||
g_type_ensure (PHOSH_TYPE_LOCATION_INFO);
|
||||
g_type_ensure (PHOSH_TYPE_MEDIA_PLAYER);
|
||||
g_type_ensure (PHOSH_TYPE_QUICK_SETTING);
|
||||
@@ -1039,22 +1035,6 @@ phosh_shell_get_docked_manager (PhoshShell *self)
|
||||
|
||||
g_return_val_if_fail (PHOSH_IS_DOCKED_MANAGER (priv->docked_manager), NULL);
|
||||
return priv->docked_manager;
|
||||
-}
|
||||
-
|
||||
-
|
||||
-PhoshHksManager *
|
||||
-phosh_shell_get_hks_manager (PhoshShell *self)
|
||||
-{
|
||||
- PhoshShellPrivate *priv;
|
||||
-
|
||||
- g_return_val_if_fail (PHOSH_IS_SHELL (self), NULL);
|
||||
- priv = phosh_shell_get_instance_private (self);
|
||||
-
|
||||
- if (!priv->hks_manager)
|
||||
- priv->hks_manager = phosh_hks_manager_new ();
|
||||
-
|
||||
- g_return_val_if_fail (PHOSH_IS_HKS_MANAGER (priv->hks_manager), NULL);
|
||||
- return priv->hks_manager;
|
||||
}
|
||||
|
||||
|
@ -1,13 +0,0 @@
|
||||
Phosh aims to be a Wayland shell for mobile phones. Currently, only
|
||||
useful for developers.
|
||||
|
||||
Features:
|
||||
- a lockscreen
|
||||
- brightness control and nighlight
|
||||
- the gcr system-prompter interface
|
||||
- acting as a polkit auth agent
|
||||
- enough of org.gnome.Mutter.DisplayConfig to make gnome-settings-daemon happy
|
||||
- a homebutton that toggles a simple favorites menu
|
||||
- status icons for battery, wwan and wifi (WARNING: network is N/A on FreeBSD)
|
||||
|
||||
WWW: https://source.puri.sm/Librem5/phosh
|
@ -1,47 +0,0 @@
|
||||
bin/phosh
|
||||
bin/phosh-osk-stub
|
||||
libexec/phosh
|
||||
share/applications/sm.puri.OSK0.desktop
|
||||
share/applications/sm.puri.Phosh.desktop
|
||||
share/gnome-session/sessions/phosh.session
|
||||
share/locale/am/LC_MESSAGES/phosh.mo
|
||||
share/locale/ar/LC_MESSAGES/phosh.mo
|
||||
share/locale/bg/LC_MESSAGES/phosh.mo
|
||||
share/locale/ca/LC_MESSAGES/phosh.mo
|
||||
share/locale/cs/LC_MESSAGES/phosh.mo
|
||||
share/locale/da/LC_MESSAGES/phosh.mo
|
||||
share/locale/de/LC_MESSAGES/phosh.mo
|
||||
share/locale/el/LC_MESSAGES/phosh.mo
|
||||
share/locale/en_GB/LC_MESSAGES/phosh.mo
|
||||
share/locale/eo/LC_MESSAGES/phosh.mo
|
||||
share/locale/es/LC_MESSAGES/phosh.mo
|
||||
share/locale/es_ES/LC_MESSAGES/phosh.mo
|
||||
share/locale/eu/LC_MESSAGES/phosh.mo
|
||||
share/locale/fa/LC_MESSAGES/phosh.mo
|
||||
share/locale/fi/LC_MESSAGES/phosh.mo
|
||||
share/locale/fr/LC_MESSAGES/phosh.mo
|
||||
share/locale/fur/LC_MESSAGES/phosh.mo
|
||||
share/locale/he/LC_MESSAGES/phosh.mo
|
||||
share/locale/ht/LC_MESSAGES/phosh.mo
|
||||
share/locale/hu/LC_MESSAGES/phosh.mo
|
||||
share/locale/id/LC_MESSAGES/phosh.mo
|
||||
share/locale/it/LC_MESSAGES/phosh.mo
|
||||
share/locale/ja/LC_MESSAGES/phosh.mo
|
||||
share/locale/ko/LC_MESSAGES/phosh.mo
|
||||
share/locale/la/LC_MESSAGES/phosh.mo
|
||||
share/locale/nb/LC_MESSAGES/phosh.mo
|
||||
share/locale/nl/LC_MESSAGES/phosh.mo
|
||||
share/locale/pl/LC_MESSAGES/phosh.mo
|
||||
share/locale/pt/LC_MESSAGES/phosh.mo
|
||||
share/locale/pt_BR/LC_MESSAGES/phosh.mo
|
||||
share/locale/ro/LC_MESSAGES/phosh.mo
|
||||
share/locale/ru/LC_MESSAGES/phosh.mo
|
||||
share/locale/sk/LC_MESSAGES/phosh.mo
|
||||
share/locale/sr/LC_MESSAGES/phosh.mo
|
||||
share/locale/sv/LC_MESSAGES/phosh.mo
|
||||
share/locale/tr/LC_MESSAGES/phosh.mo
|
||||
share/locale/uk/LC_MESSAGES/phosh.mo
|
||||
share/locale/zh_Hans_CN/LC_MESSAGES/phosh.mo
|
||||
share/locale/zh_TW/LC_MESSAGES/phosh.mo
|
||||
%%DATADIR%%/phoc.ini
|
||||
share/wayland-sessions/phosh.desktop
|
Loading…
Reference in New Issue
Block a user