- Update to 0.0.3

PR:		ports/114778
Submitted by:	Thomas Abthorpe <thomas@goodking.ca>
This commit is contained in:
Pav Lucistnik 2007-07-22 00:58:42 +00:00
parent 2dfce3236b
commit 79be66c4ed
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=196027
8 changed files with 59 additions and 66 deletions

View File

@ -6,12 +6,11 @@
#
PORTNAME= spandsp
DISTVERSION= 0.0.2pre26
DISTVERSION= 0.0.3
CATEGORIES= comms
MASTER_SITES= http://www.soft-switch.org/downloads/spandsp/ \
http://www.soft-switch.org/downloads/spandsp/old/ \
${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= pav
http://www.soft-switch.org/downloads/spandsp/old/
EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= Fax DSP library for Asterisk

View File

@ -1,3 +1,3 @@
MD5 (spandsp-0.0.2pre26.tar.gz) = 2b28a75b1d7c49616534bd7264317241
SHA256 (spandsp-0.0.2pre26.tar.gz) = 57ac136a61974eb6c8cfd81bab14a514a04a3be8c513cc1682524ec4082d0fc8
SIZE (spandsp-0.0.2pre26.tar.gz) = 1417752
MD5 (spandsp-0.0.3.tgz) = 6ea33941985fbf94b5f79dc3255ad925
SHA256 (spandsp-0.0.3.tgz) = 368467b757736aef99e19f68e4ed50012b555ef18445b4ad7e47da8c1c353118
SIZE (spandsp-0.0.3.tgz) = 1667197

View File

@ -1,14 +1,11 @@
$FreeBSD$
--- src/Makefile.in.orig
+++ src/Makefile.in
@@ -195,9 +195,9 @@
--- src/Makefile.in.orig Sat Mar 31 08:39:20 2007
+++ src/Makefile.in Fri Jul 20 11:50:18 2007
@@ -213,9 +213,9 @@
sharedstatedir = @sharedstatedir@
sysconfdir = @sysconfdir@
target_alias = @target_alias@
-AM_CFLAGS = -std=c99
+#AM_CFLAGS = -std=c99
-AM_CFLAGS = $(COMP_VENDOR_CFLAGS)
+#AM_CFLAGS = $(COMP_VENDOR_CFLAGS)
MAINTAINERCLEANFILES = Makefile.in
-INCLUDES = -I$(top_builddir)
+#INCLUDES = -I$(top_builddir)

View File

@ -1,13 +1,15 @@
$FreeBSD$
--- src/awgn.c
+++ src/awgn.c
@@ -51,6 +51,7 @@
#include <stdio.h>
#include <inttypes.h>
#include <math.h>
+#include <tgmath.h>
--- src/awgn.c.orig Sun Nov 19 09:07:24 2006
+++ src/awgn.c Fri Jul 20 11:59:50 2007
@@ -48,12 +48,8 @@
#include <stdlib.h>
#include <inttypes.h>
-#if defined(HAVE_TGMATH_H)
#include <tgmath.h>
-#endif
-#if defined(HAVE_MATH_H)
#include <math.h>
-#endif
#include "spandsp/telephony.h"
#include "spandsp/dc_restore.h"
#include "spandsp/awgn.h"

View File

@ -1,21 +0,0 @@
$FreeBSD$
--- src/t31.c
+++ src/t31.c
@@ -81,14 +81,7 @@
.pulse_dial = FALSE,
.double_escape = FALSE,
.adaptive_receive = FALSE,
- .s_regs[0] = 0,
- .s_regs[3] = '\r',
- .s_regs[4] = '\n',
- .s_regs[5] = '\b',
- .s_regs[6] = 1,
- .s_regs[7] = 60,
- .s_regs[8] = 5,
- .s_regs[10] = 0
+ .s_regs = { 0, 0, 0, '\r', '\n', '\b', 1, 60, 5, 0, 0 }
}
};

View File

@ -1,13 +1,15 @@
$FreeBSD$
--- src/tone_generate.c
+++ src/tone_generate.c
@@ -39,6 +39,7 @@
--- src/tone_generate.c.orig Sat Mar 3 05:40:33 2007
+++ src/tone_generate.c Fri Jul 20 12:03:07 2007
@@ -37,12 +37,8 @@
#include <stdio.h>
#include <time.h>
#include <fcntl.h>
+#include <tgmath.h>
-#if defined(HAVE_TGMATH_H)
#include <tgmath.h>
-#endif
-#if defined(HAVE_MATH_H)
#include <math.h>
-#endif
#include "spandsp/telephony.h"
#include "spandsp/dc_restore.h"

View File

@ -1,13 +1,15 @@
$FreeBSD$
--- src/v17tx.c
+++ src/v17tx.c
@@ -39,6 +39,7 @@
--- src/v17tx.c.orig Sun Mar 18 05:43:50 2007
+++ src/v17tx.c Fri Jul 20 12:05:16 2007
@@ -35,12 +35,8 @@
#include <inttypes.h>
#include <stdlib.h>
#include <string.h>
-#if defined(HAVE_TGMATH_H)
#include <tgmath.h>
-#endif
-#if defined(HAVE_MATH_H)
#include <math.h>
+#include <tgmath.h>
-#endif
#include "spandsp/telephony.h"
#include "spandsp/logging.h"

View File

@ -1,42 +1,53 @@
include/spandsp.h
include/spandsp/adsi.h
include/spandsp/alaw_ulaw.h
include/spandsp/arctan2.h
include/spandsp/async.h
include/spandsp/at_interpreter.h
include/spandsp/awgn.h
include/spandsp/bell_r2_mf.h
include/spandsp/bert.h
include/spandsp/biquad.h
include/spandsp/bit_operations.h
include/spandsp/bitstream.h
include/spandsp/complex.h
include/spandsp/complex_filters.h
include/spandsp/complex_vector_float.h
include/spandsp/dc_restore.h
include/spandsp/dds.h
include/spandsp/ec_disable_tone.h
include/spandsp/dtmf.h
include/spandsp/echo.h
include/spandsp/fax.h
include/spandsp/fir.h
include/spandsp/fsk.h
include/spandsp/g168models.h
include/spandsp/g711.h
include/spandsp/g722.h
include/spandsp/g726.h
include/spandsp/gsm0610.h
include/spandsp/hdlc.h
include/spandsp/ima_adpcm.h
include/spandsp/logging.h
include/spandsp/mmx.h
include/spandsp/lpc10.h
include/spandsp/modem_connect_tones.h
include/spandsp/modem_echo.h
include/spandsp/noise.h
include/spandsp/oki_adpcm.h
include/spandsp/oss.h
include/spandsp/playout.h
include/spandsp/plc.h
include/spandsp/power_meter.h
include/spandsp/queue.h
include/spandsp/schedule.h
include/spandsp/sig_tone.h
include/spandsp/silence_gen.h
include/spandsp/super_tone_rx.h
include/spandsp/super_tone_tx.h
include/spandsp/t30.h
include/spandsp/t30_fcf.h
include/spandsp/t31.h
include/spandsp/t35.h
include/spandsp/t38_core.h
include/spandsp/t38_gateway.h
include/spandsp/t38_terminal.h
include/spandsp/t4.h
include/spandsp/telephony.h
include/spandsp/time_scale.h
@ -53,7 +64,8 @@ include/spandsp/v29tx.h
include/spandsp/v42.h
include/spandsp/v42bis.h
include/spandsp/v8.h
include/spandsp/vector.h
include/spandsp/vector_float.h
include/spandsp/vector_int.h
lib/libspandsp.a
lib/libspandsp.la
lib/libspandsp.so