- Update to 0.4.12

PR:		ports/73078
Submitted by:	KATO Tsuguru <tkato432@yahoo.com>
This commit is contained in:
Pav Lucistnik 2004-10-25 22:48:23 +00:00
parent a7b7083efb
commit 79b850817d
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=120187
6 changed files with 31 additions and 31 deletions

View File

@ -6,21 +6,23 @@
#
PORTNAME= libflash
PORTVERSION= 0.4.10
PORTVERSION= 0.4.12
CATEGORIES= graphics
MASTER_SITES= http://www.swift-tools.net/Flash/
DISTNAME= flash-${PORTVERSION}
EXTRACT_SUFX= .tgz
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= gplflash
DISTNAME= gplflash-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= GPL Flash (TM) Library
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg
LIB_DEPENDS= mad.2:${PORTSDIR}/audio/libmad \
jpeg.9:${PORTSDIR}/graphics/jpeg
WRKSRC= ${WRKDIR}/${DISTNAME}/Lib
WRKSRC= ${WRKDIR}/${DISTNAME}/lib
USE_BZIP2= yes
INSTALLS_SHLIB= yes
MAKEFILE= ${FILESDIR}/Makefile
MAKE_ARGS= NOPROFILE=true
pre-build:
${CP} ${FILESDIR}/Makefile ${WRKSRC}/
.include <bsd.port.mk>

View File

@ -1,2 +1,2 @@
MD5 (flash-0.4.10.tgz) = 1473f085c599d8076fa866cd91e11598
SIZE (flash-0.4.10.tgz) = 358995
MD5 (gplflash-0.4.12.tar.bz2) = 7d53803486b255665a80cd834ee3c463
SIZE (gplflash-0.4.12.tar.bz2) = 378727

View File

@ -7,7 +7,7 @@ CXXFLAGS+= -fno-rtti -DXP_UNIX \
-I${LOCALBASE}/include \
-DCHECK_TEXT_PLAIN
LDADD= -lz \
-L${LOCALBASE}/lib -ljpeg
-L${LOCALBASE}/lib -ljpeg -lmad
SRCS= adpcm.cc bitmap.cc button.cc character.cc cxform.cc \
displaylist.cc flash.cc font.cc graphic.cc graphic16.cc \
graphic24.cc graphic32.cc matrix.cc movie.cc \

View File

@ -1,15 +1,23 @@
--- sound.cc.orig Thu Sep 2 00:10:03 1999
+++ sound.cc Wed Jul 24 06:04:56 2002
@@ -26,7 +26,12 @@
#include <fcntl.h>
#include <sys/ioctl.h>
--- sound.cc.orig Sat Oct 16 03:16:19 2004
+++ sound.cc Sat Oct 23 17:44:05 2004
@@ -20,7 +20,7 @@
// Author : Olivier Debon <odebon@club-internet.fr>
//
-#if ! defined(__linux__)
+#if ! defined(__linux__) && ! defined(__FreeBSD__)
#warning no sound support for your OS in lib/sound.cc
#define NOSOUND
#endif
@@ -33,6 +33,11 @@
#ifndef NOSOUND
#ifdef __linux__
#include <linux/soundcard.h>
+#else
+#ifdef __FreeBSD__
+#include <sys/param.h>
+#include <sys/soundcard.h>
+#else
#include <linux/soundcard.h>
+#endif
#endif
#endif
#ifdef RCSID

View File

@ -1,10 +0,0 @@
--- shape.cc.orig Fri Jul 12 07:55:33 2002
+++ shape.cc Fri Jul 12 07:56:13 2002
@@ -21,6 +21,7 @@
//
#include "swf.h"
+#include <math.h>
#ifdef RCSID
static char *rcsid = "$Id: shape.cc,v 1.5 1999/09/10 13:08:52 ode Exp $";

View File

@ -5,4 +5,4 @@ The core of the library is a graphic renderer that is portable is to
be reused in applications that need to play Flash (TM) movies.
Author: Olivier Debon <olivier@debon.net>
WWW: http://www.swift-tools.net/Flash/
WWW: http://gplflash.sourceforge.net/