Graphite is a package that can be used to create "smart fonts" capable of
displaying writing systems with various complex behaviors, such as: * contextual shaping * ligatures * reordering * split glyphs * bidirectionality * stacking diacritics * complex positioning WWW: http://scripts.sil.org/RenderingGraphite
This commit is contained in:
parent
8457e90924
commit
79ac946b88
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=289599
@ -299,6 +299,7 @@
|
||||
SUBDIR += gracula
|
||||
SUBDIR += grads
|
||||
SUBDIR += grafx2
|
||||
SUBDIR += graphite2
|
||||
SUBDIR += graphopt
|
||||
SUBDIR += graphviz
|
||||
SUBDIR += grx
|
||||
|
26
graphics/graphite2/Makefile
Normal file
26
graphics/graphite2/Makefile
Normal file
@ -0,0 +1,26 @@
|
||||
# New ports collection makefile for: graphite2
|
||||
# Date created: 2012-01-22
|
||||
# Whom: Baptiste Daroussin <bapt@FreeBSD.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= graphite2
|
||||
PORTVERSION= 1.0.3
|
||||
CATEGORIES= graphics print
|
||||
MASTER_SITES= SF/silgraphite/${PORTNAME}
|
||||
EXTRACT_SUFX= .tgz
|
||||
|
||||
MAINTAINER= bapt@FreeBSD.org
|
||||
COMMENT= Rendering capabilities for complex non-Roman writing systems
|
||||
|
||||
USE_GNOME= gnomehack
|
||||
USE_CMAKE= yes
|
||||
USE_ICONV= yes
|
||||
USE_LDCONFIG= yes
|
||||
LDFLAGS+= -L${LOCALBASE}/lib -liconv
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's,/pkgconfig,data/pkgconfig,g' ${WRKSRC}/CMakeLists.txt
|
||||
|
||||
.include <bsd.port.mk>
|
2
graphics/graphite2/distinfo
Normal file
2
graphics/graphite2/distinfo
Normal file
@ -0,0 +1,2 @@
|
||||
SHA256 (graphite2-1.0.3.tgz) = 643c5307a3fdc31754a18c8c1398d4036a107e4bdc03d9a265fcadfc85d4a07a
|
||||
SIZE (graphite2-1.0.3.tgz) = 4352127
|
11
graphics/graphite2/files/patch-gr2fonttest__gr2FontTest.cpp
Normal file
11
graphics/graphite2/files/patch-gr2fonttest__gr2FontTest.cpp
Normal file
@ -0,0 +1,11 @@
|
||||
--- ./gr2fonttest/gr2FontTest.cpp.orig 2011-09-22 17:30:02.000000000 +0200
|
||||
+++ ./gr2fonttest/gr2FontTest.cpp 2012-01-22 10:24:33.468384204 +0100
|
||||
@@ -176,7 +176,7 @@
|
||||
#ifdef WIN32
|
||||
const char * pText = reinterpret_cast<char*>(pIn);
|
||||
#else
|
||||
- char * pText = reinterpret_cast<char*>(pIn);
|
||||
+ const char * pText = reinterpret_cast<char*>(pIn);
|
||||
#endif
|
||||
// It seems to be necessary to include the trailing null to prevent
|
||||
// stray characters appearing with utf16
|
12
graphics/graphite2/pkg-descr
Normal file
12
graphics/graphite2/pkg-descr
Normal file
@ -0,0 +1,12 @@
|
||||
Graphite is a package that can be used to create "smart fonts" capable of
|
||||
displaying writing systems with various complex behaviors, such as:
|
||||
|
||||
* contextual shaping
|
||||
* ligatures
|
||||
* reordering
|
||||
* split glyphs
|
||||
* bidirectionality
|
||||
* stacking diacritics
|
||||
* complex positioning
|
||||
|
||||
WWW: http://scripts.sil.org/RenderingGraphite
|
13
graphics/graphite2/pkg-plist
Normal file
13
graphics/graphite2/pkg-plist
Normal file
@ -0,0 +1,13 @@
|
||||
%%DATADIR%%/graphite2-release.cmake
|
||||
%%DATADIR%%/graphite2.cmake
|
||||
bin/comparerenderer
|
||||
bin/gr2fonttest
|
||||
include/graphite2/Font.h
|
||||
include/graphite2/Segment.h
|
||||
include/graphite2/Types.h
|
||||
lib/libgraphite2.so
|
||||
lib/libgraphite2.so.2.0.0
|
||||
libdata/pkgconfig/graphite2.pc
|
||||
@dirrmtry libdata/pkgconfig
|
||||
@dirrmtry include/graphite2
|
||||
@dirrmtry %%DATADIR%%
|
Loading…
Reference in New Issue
Block a user