- Update to 2.8.4

Tested via:	exp-run
Approved by:	kde@ implicit
This commit is contained in:
Martin Wilke 2011-02-25 01:32:03 +00:00
parent 5ab5cec0a3
commit 799c0ed0f7
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=269630
6 changed files with 24 additions and 28 deletions

View File

@ -6,7 +6,7 @@
#
PORTNAME= cmake
PORTVERSION= 2.8.3
PORTVERSION= 2.8.4
CATEGORIES= devel
MASTER_SITES= http://www.${PORTNAME}.org/files/v${PORTVERSION:C/\.[[:digit:]]+$//}/
PKGNAMESUFFIX= -gui
@ -25,12 +25,6 @@ MAN1= cmake-gui.1
BUILD_WRKSRC= ${WRKSRC}/Source/QtDialog
INSTALL_WRKSRC= ${BUILD_WRKSRC}
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 700042
CMAKE_USE_PTHREAD= yes
.endif
post-patch:
@(${FIND} ${WRKSRC}/Modules -name "*.cmake" -print0; \
${FIND} ${WRKSRC}/Tests -name "CMakeLists.txt" -print0 ) | \
@ -48,4 +42,4 @@ post-install:
${MKDIR} ${MANPREFIX}/man/man1
${INSTALL_MAN} ${WRKSRC}/cmake-gui.1 ${MANPREFIX}/man/man1
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View File

@ -1,2 +1,2 @@
SHA256 (cmake-2.8.3.tar.gz) = 689ed02786b5cefa5515c7716784ee82a82e8ece6be5a3d629ac3cc0c05fc288
SIZE (cmake-2.8.3.tar.gz) = 5436543
SHA256 (cmake-2.8.4.tar.gz) = d97ea9f807f5407030d4f7246accc26addc520c9ee3897c4582eba3da49253cc
SIZE (cmake-2.8.4.tar.gz) = 5477628

View File

@ -6,8 +6,7 @@
#
PORTNAME= cmake
PORTVERSION= 2.8.3
PORTREVISION= 1
PORTVERSION= 2.8.4
CATEGORIES= devel
MASTER_SITES= http://www.${PORTNAME}.org/files/v${PORTVERSION:C/\.[[:digit:]]+$//}/

View File

@ -1,2 +1,2 @@
SHA256 (cmake-2.8.3.tar.gz) = 689ed02786b5cefa5515c7716784ee82a82e8ece6be5a3d629ac3cc0c05fc288
SIZE (cmake-2.8.3.tar.gz) = 5436543
SHA256 (cmake-2.8.4.tar.gz) = d97ea9f807f5407030d4f7246accc26addc520c9ee3897c4582eba3da49253cc
SIZE (cmake-2.8.4.tar.gz) = 5477628

View File

@ -1,11 +0,0 @@
--- Modules/FindPythonInterp.cmake.orig 2010-11-03 20:58:27.000000000 +0100
+++ Modules/FindPythonInterp.cmake 2010-11-17 10:51:18.700039887 +0100
@@ -20,7 +20,7 @@
# License text for the above reference.)
FIND_PROGRAM(PYTHON_EXECUTABLE
- NAMES python2.7 python2.6 python2.5 python2.4 python2.3 python2.2 python2.1 python2.0 python1.6 python1.5 python
+ NAMES python python2.7 python2.6 python2.5 python2.4 python2.3 python2.2 python2.1 python2.0 python1.6 python1.5
PATHS
[HKEY_LOCAL_MACHINE\\SOFTWARE\\Python\\PythonCore\\2.7\\InstallPath]
[HKEY_LOCAL_MACHINE\\SOFTWARE\\Python\\PythonCore\\2.6\\InstallPath]

View File

@ -10,6 +10,7 @@ bin/ctest
%%DATADIR%%/Modules/CMakeASMCompiler.cmake.in
%%DATADIR%%/Modules/CMakeASMInformation.cmake
%%DATADIR%%/Modules/CMakeASM_MASMInformation.cmake
%%DATADIR%%/Modules/CMakeASM_NASMInformation.cmake
%%DATADIR%%/Modules/CMakeAddNewLanguage.txt
%%DATADIR%%/Modules/CMakeBackwardCompatibilityC.cmake
%%DATADIR%%/Modules/CMakeBackwardCompatibilityCXX.cmake
@ -30,6 +31,7 @@ bin/ctest
%%DATADIR%%/Modules/CMakeDetermineASM-ATTCompiler.cmake
%%DATADIR%%/Modules/CMakeDetermineASMCompiler.cmake
%%DATADIR%%/Modules/CMakeDetermineASM_MASMCompiler.cmake
%%DATADIR%%/Modules/CMakeDetermineASM_NASMCompiler.cmake
%%DATADIR%%/Modules/CMakeDetermineCCompiler.cmake
%%DATADIR%%/Modules/CMakeDetermineCXXCompiler.cmake
%%DATADIR%%/Modules/CMakeDetermineCompilerABI.cmake
@ -71,6 +73,7 @@ bin/ctest
%%DATADIR%%/Modules/CMakeTestASM-ATTCompiler.cmake
%%DATADIR%%/Modules/CMakeTestASMCompiler.cmake
%%DATADIR%%/Modules/CMakeTestASM_MASMCompiler.cmake
%%DATADIR%%/Modules/CMakeTestASM_NASMCompiler.cmake
%%DATADIR%%/Modules/CMakeTestCCompiler.cmake
%%DATADIR%%/Modules/CMakeTestCXXCompiler.cmake
%%DATADIR%%/Modules/CMakeTestCompilerCommon.cmake
@ -136,6 +139,9 @@ bin/ctest
%%DATADIR%%/Modules/CheckVariableExists.cmake
%%DATADIR%%/Modules/Compiler/Clang-C.cmake
%%DATADIR%%/Modules/Compiler/Clang-CXX.cmake
%%DATADIR%%/Modules/Compiler/Cray-C.cmake
%%DATADIR%%/Modules/Compiler/Cray-CXX.cmake
%%DATADIR%%/Modules/Compiler/Cray-Fortran.cmake
%%DATADIR%%/Modules/Compiler/G95-Fortran.cmake
%%DATADIR%%/Modules/Compiler/GNU-C.cmake
%%DATADIR%%/Modules/Compiler/GNU-CXX.cmake
@ -150,6 +156,7 @@ bin/ctest
%%DATADIR%%/Modules/Compiler/MIPSpro-C.cmake
%%DATADIR%%/Modules/Compiler/MIPSpro-CXX.cmake
%%DATADIR%%/Modules/Compiler/MIPSpro-Fortran.cmake
%%DATADIR%%/Modules/Compiler/NAG-Fortran.cmake
%%DATADIR%%/Modules/Compiler/PGI-C.cmake
%%DATADIR%%/Modules/Compiler/PGI-CXX.cmake
%%DATADIR%%/Modules/Compiler/PGI-Fortran.cmake
@ -158,6 +165,9 @@ bin/ctest
%%DATADIR%%/Modules/Compiler/PathScale-CXX.cmake
%%DATADIR%%/Modules/Compiler/PathScale-Fortran.cmake
%%DATADIR%%/Modules/Compiler/PathScale.cmake
%%DATADIR%%/Modules/Compiler/SCO-C.cmake
%%DATADIR%%/Modules/Compiler/SCO-CXX.cmake
%%DATADIR%%/Modules/Compiler/SCO.cmake
%%DATADIR%%/Modules/Compiler/SunPro-C.cmake
%%DATADIR%%/Modules/Compiler/SunPro-CXX.cmake
%%DATADIR%%/Modules/Compiler/SunPro-Fortran.cmake
@ -369,12 +379,14 @@ bin/ctest
%%DATADIR%%/Modules/Platform/CYGWIN-GNU-CXX.cmake
%%DATADIR%%/Modules/Platform/CYGWIN-GNU-Fortran.cmake
%%DATADIR%%/Modules/Platform/CYGWIN-GNU.cmake
%%DATADIR%%/Modules/Platform/CYGWIN-windres.cmake
%%DATADIR%%/Modules/Platform/CYGWIN.cmake
%%DATADIR%%/Modules/Platform/Catamount.cmake
%%DATADIR%%/Modules/Platform/Darwin-GNU-C.cmake
%%DATADIR%%/Modules/Platform/Darwin-GNU-CXX.cmake
%%DATADIR%%/Modules/Platform/Darwin-GNU-Fortran.cmake
%%DATADIR%%/Modules/Platform/Darwin-GNU.cmake
%%DATADIR%%/Modules/Platform/Darwin-NAG-Fortran.cmake
%%DATADIR%%/Modules/Platform/Darwin-VisualAge-C.cmake
%%DATADIR%%/Modules/Platform/Darwin-VisualAge-CXX.cmake
%%DATADIR%%/Modules/Platform/Darwin-XL-C.cmake
@ -409,6 +421,7 @@ bin/ctest
%%DATADIR%%/Modules/Platform/Linux-Intel-CXX.cmake
%%DATADIR%%/Modules/Platform/Linux-Intel-Fortran.cmake
%%DATADIR%%/Modules/Platform/Linux-Intel.cmake
%%DATADIR%%/Modules/Platform/Linux-NAG-Fortran.cmake
%%DATADIR%%/Modules/Platform/Linux-PGI-C.cmake
%%DATADIR%%/Modules/Platform/Linux-PGI-CXX.cmake
%%DATADIR%%/Modules/Platform/Linux-PGI-Fortran.cmake
@ -453,15 +466,16 @@ bin/ctest
%%DATADIR%%/Modules/Platform/Windows-GNU-CXX.cmake
%%DATADIR%%/Modules/Platform/Windows-GNU-Fortran.cmake
%%DATADIR%%/Modules/Platform/Windows-GNU.cmake
%%DATADIR%%/Modules/Platform/Windows-Intel-C.cmake
%%DATADIR%%/Modules/Platform/Windows-Intel-CXX.cmake
%%DATADIR%%/Modules/Platform/Windows-Intel-Fortran.cmake
%%DATADIR%%/Modules/Platform/Windows-Intel.cmake
%%DATADIR%%/Modules/Platform/Windows-NMcl.cmake
%%DATADIR%%/Modules/Platform/Windows-cl.cmake
%%DATADIR%%/Modules/Platform/Windows-cl.cmake.in
%%DATADIR%%/Modules/Platform/Windows-df.cmake
%%DATADIR%%/Modules/Platform/Windows-g++.cmake
%%DATADIR%%/Modules/Platform/Windows-icl.cmake
%%DATADIR%%/Modules/Platform/Windows-ifort.cmake
%%DATADIR%%/Modules/Platform/Windows-wcl386.cmake
%%DATADIR%%/Modules/Platform/Windows-windres.cmake
%%DATADIR%%/Modules/Platform/Windows.cmake
%%DATADIR%%/Modules/Platform/WindowsPaths.cmake
%%DATADIR%%/Modules/Platform/Xenix.cmake