- Update to 4.52

- Use USERS/GROUPS
- Remove support for FreeBSD 5.x/6.x
- Cosmetic changes
This commit is contained in:
Ryan Steinmetz 2012-02-25 16:15:12 +00:00
parent dcb4d0dd9e
commit 799302962a
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=292225
9 changed files with 19 additions and 161 deletions

View File

@ -6,7 +6,7 @@
#
PORTNAME= stunnel
PORTVERSION= 4.43
PORTVERSION= 4.52
CATEGORIES= security
MASTER_SITES= ftp://ftp.stunnel.org/stunnel/%SUBDIR%/ \
http://mirrors.zerg.biz/stunnel/%SUBDIR%/ \
@ -27,6 +27,7 @@ LICENSE_COMB= dual
USE_AUTOTOOLS= libtool
USE_RC_SUBR= stunnel
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --localstatedir=/var/tmp \
@ -36,15 +37,21 @@ CONFIGURE_ARGS= --localstatedir=/var/tmp \
MAN8= stunnel.8 stunnel.fr.8 stunnel.pl.8
.endif
OPTIONS= FORK "use the fork(3) threading model" off \
PTHREAD "use the pthread(3) threading model (default)" on \
UCONTEXT "use the ucontext(3) threading model" off \
IPV6 "enable IPv6 support" off \
LIBWRAP "use TCP wrappers" on \
SSL_PORT "use OpenSSL from the Ports Collection" on
OPTIONS= FORK "Ese the fork(3) threading model" off \
PTHREAD "Ese the pthread(3) threading model (default)" on \
UCONTEXT "Ese the ucontext(3) threading model" off \
IPV6 "Enable IPv6 support" off \
LIBWRAP "Use TCP wrappers" on \
SSL_PORT "Use OpenSSL from the Ports Collection" off
.include <bsd.port.options.mk>
STUNNEL_USER?= stunnel
STUNNEL_GROUP?= stunnel
USERS= ${STUNNEL_USER}
GROUPS= ${STUNNEL_GROUP}
.if defined(WITH_SSL_PORT)
USE_OPENSSL= YES
WITH_OPENSSL_PORT= yes
@ -93,6 +100,8 @@ post-patch:
${REINPLACE_CMD} -E -e 's|\$$\(prefix\)/var/run/stunnel/stunnel.pid|$$(localstatedir)/stunnel.pid|' \
${WRKSRC}/src/Makefile.in
@${FIND} ${WRKSRC} -type f -name Makefile.in | ${XARGS} ${REINPLACE_CMD} -E -e 's,@(ACLOCAL|AUTO(MAKE|CONF|HEADER))@,/usr/bin/true,'
@${REINPLACE_CMD} -E -e 's|install-confDATA install-data-local|install-confDATA|g' \
${WRKSRC}/tools/Makefile.in
.ifdef(NOPORTDOCS)
@${REINPLACE_CMD} -E -e 's/ install-docDATA/ /; s/^(SUBDIRS.+)doc/\1/' \
${WRKSRC}/Makefile.in
@ -101,8 +110,6 @@ post-patch:
.endif
post-install:
@${SETENV} PKG_PREFIX=${PREFIX} ${SH} \
${PKGINSTALL} ${PKGNAME} POST-INSTALL
@${ECHO} ""
@${ECHO} "**************************************************************************"
@${ECHO} "To create and install a new certificate, type \"make cert\""
@ -110,13 +117,6 @@ post-install:
@${ECHO} "And don't forget to check out the FAQ at http://www.stunnel.org/"
@${ECHO} "**************************************************************************"
@${ECHO} ""
@${ECHO} "*********************** WARNING! WARNING! WARNING! ***********************"
@${ECHO} "The stunnel startup script has been converted to rc_subr"
@${ECHO} "format now. You have to set at least the stunnel_enable"
@${ECHO} "variable, and maybe also stunnel_config and stunnel_pidfile,"
@${ECHO} "if you want stunnel to be started automatically at boot time!"
@${ECHO} "**************************************************************************"
@${ECHO} ""
cert:
@${ECHO} ""
@ -126,23 +126,4 @@ cert:
@${ECHO} ""
@(cd ${WRKSRC}/tools/; make install-data-local)
.if !defined(WITH_STUNNEL_SSL_ENGINE)
EXTRA_PATCHES= ${FILESDIR}/ssl-noengine.patch
pre-patch:
@${ECHO} "*************************************************************************"
@${ECHO} "Note: you have to explicitly define WITH_STUNNEL_SSL_ENGINE to activate"
@${ECHO} "the OpenSSL ENGINE code on FreeBSD 5.x or 6.x."
@${ECHO} "There are known reliability issues with stunnel and the OpenSSL ENGINE"
@${ECHO} "code, so you are advised not to enable it."
@${ECHO} "*************************************************************************"
.else
pre-patch:
@${ECHO} "*************************************************************************"
@${ECHO} "Note: you have defined WITH_STUNNEL_SSL_ENGINE. Now stunnel will activate"
@${ECHO} "the OpenSSL ENGINE code even on FreeBSD 5.x."
@${ECHO} "There are known reliability issues with stunnel and the OpenSSL ENGINE"
@${ECHO} "code. You have enabled it at your own risk."
@${ECHO} "*************************************************************************"
.endif
.include <bsd.port.post.mk>

View File

@ -1,2 +1,2 @@
SHA256 (stunnel-4.43.tar.gz) = 93a002d9e1652d7684756af75b44b00f99aa93574e8a5a2e69f88656221d5ce2
SIZE (stunnel-4.43.tar.gz) = 559555
SHA256 (stunnel-4.52.tar.gz) = 7c78c178074e9b96331518a9c309d2e95ca9ad6e0338a96d5ab8ad47fde4347c
SIZE (stunnel-4.52.tar.gz) = 526886

View File

@ -1,17 +0,0 @@
Description: Do not install the sample stunnel.pem file.
This is handled by the FreeBSD port's Makefile.
Forwarded: not-needed
Author: Peter Pentchev <roam@FreeBSD.org>
Last-Update: 2011-06-28
--- tools/Makefile.in.orig
+++ tools/Makefile.in
@@ -373,7 +373,7 @@
info-am:
-install-data-am: install-confDATA install-data-local \
+install-data-am: install-confDATA \
install-examplesDATA
install-dvi: install-dvi-am

View File

@ -1,16 +0,0 @@
Description: Fix a typo (cuves -> curves)
Forwarded: no
Author: Peter Pentchev <roam@FreeBSD.org>
Last-Update: 2011-09-07
--- doc/stunnel.8.orig
+++ doc/stunnel.8
@@ -382,7 +382,7 @@
.IX Item "curve = nid"
specify \s-1ECDH\s0 curve name
.Sp
-To get a list of supported cuves use:
+To get a list of supported curves use:
.Sp
.Vb 1
\& openssl ecparam \-list_curves

View File

@ -1,16 +0,0 @@
Description: Fix a typo (cuves -> curves)
Forwarded: no
Author: Peter Pentchev <roam@FreeBSD.org>
Last-Update: 2011-08-01
--- doc/stunnel.html.orig
+++ doc/stunnel.html
@@ -423,7 +423,7 @@
<dd>
<p>specify ECDH curve name</p>
-<p>To get a list of supported cuves use:</p>
+<p>To get a list of supported curves use:</p>
<pre>
openssl ecparam -list_curves</pre>
<p>default: prime256v1</p>

View File

@ -1,17 +0,0 @@
Description: Build on FreeBSD versions of OpenSSL < 0.9.8b.
Forwarded: not-needed
Author: Peter Pentchev <roam@FreeBSD.org>
Last-Update: 2011-08-01
--- src/common.h.orig
+++ src/common.h
@@ -342,9 +342,6 @@
#define OPENSSL_THREAD_DEFINES
#include <openssl/opensslconf.h>
-#if !defined(OPENSSL_THREADS) && defined(USE_PTHREAD)
-#error OpenSSL library compiled without thread support
-#endif /* !OPENSSL_THREADS && USE_PTHREAD */
#include <openssl/lhash.h>
#include <openssl/ssl.h>

View File

@ -1,16 +0,0 @@
Description: Disable the OpenSSL engine support for the FreeBSD port.
Forwaded: not-needed
Author: Peter Pentchev <roam@FreeBSD.org>
Last-Update: 2011-06-28
--- src/ssl.c.orig
+++ src/ssl.c
@@ -258,6 +258,8 @@
}
static char *init_engine(void) {
+ s_log(LOG_ERR, "This version of stunnel was compiled WITHOUT support for OpenSSL hardware engines! If you need this functionality, rebuild the FreeBSD port with the WITH_STUNNEL_SSL_ENGINE option set to 'yes'; contact Peter Pentchev <roam@FreeBSD.org> for details.");
+ exit(1);
if(engine_initialized)
return NULL; /* OK */
engine_initialized=1;

View File

@ -8,4 +8,4 @@ stunnel can be used to add SSL functionality to commonly
used inetd daemons like POP-2, POP-3 and IMAP servers
without any changes in the programs' code.
WWW: http://stunnel.mirt.net/
WWW: http://stunnel.org/

View File

@ -1,41 +0,0 @@
#! /bin/sh
#
# $FreeBSD$
# taken from devel/perforce
PATH=/bin:/usr/sbin
STUNNEL_USER=${STUNNEL_USER:-stunnel}
STUNNEL_GROUP=${STUNNEL_GROUP:-stunnel}
case $2 in
POST-INSTALL)
USER=${STUNNEL_USER}
GROUP=${STUNNEL_GROUP}
if pw group show "${GROUP}" 2>/dev/null; then
echo "You already have a group \"${GROUP}\", so I will use it."
else
if pw groupadd -g 341 -n ${GROUP} ; then
echo "Added group \"${GROUP}\"."
else
echo "Adding group \"${GROUP}\" failed..."
exit 1
fi
fi
if pw user show "${USER}" 2>/dev/null; then
echo "You already have a user \"${USER}\", so I will use it."
else
if pw useradd -u 341 -n ${USER} -g ${GROUP} -h - \
-d /nonexistent -c "stunnel Daemon" -s /sbin/nologin
then
echo "Added user \"${USER}\"."
else
echo "Adding user \"${USER}\" failed..."
exit 1
fi
fi
;;
esac