- Rename security/qtkeychain to qtkeychain-qt5, update to 0.5.0 and make it use Qt5

- Add slave port qtkeychain-qt4
- Make deskutils/owncloudclient link against qtkeychain-qt5
- Update owncloudclient comment and pkg-descr

PR:		198785
Submitted by:	6yearold at gmail.com (security/qtkeychain maintainer)
This commit is contained in:
Guido Falsi 2015-05-24 21:03:19 +00:00
parent a73b338c83
commit 7941f4cb00
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=387341
15 changed files with 70 additions and 123 deletions

1
MOVED
View File

@ -7593,3 +7593,4 @@ net-mgmt/glpi-plugins-tracker-server|net-mgmt/glpi-plugins-fusioninventory-serve
science/rubygem-netcdf|science/rubygem-ruby-netcdf|2015-05-24|Rename to match our rubygems naming
security/rubygem-rc4|security/rubygem-ruby-rc4|2015-05-24|Rename to match our rubygems naming
print/rubygem-colortools|print/rubygem-color-tools|2015-05-24|Rename to match our rubygems naming
security/qtkeychain|security/qtkeychain-qt5|2015-05-24|Renamed to indicate supported QT version

View File

@ -3,31 +3,28 @@
PORTNAME= owncloudclient
PORTVERSION= 1.8.0
PORTREVISION= 1
CATEGORIES= deskutils
MASTER_SITES= http://download.owncloud.com/desktop/stable/
MAINTAINER= ports@FreeBSD.org
COMMENT= Qt based sync client for OwnCloud
COMMENT= OwnCloud Desktop Syncing Client
LICENSE= GPLv2
LIB_DEPENDS= libinotify.so:${PORTSDIR}/devel/libinotify \
libqtkeychain.so:${PORTSDIR}/security/qtkeychain \
libneon.so:${PORTSDIR}/www/neon
libqt5keychain.so:${PORTSDIR}/security/qtkeychain-qt5
USES= cmake:outsource compiler:c++11-lib gmake pkgconfig tar:bzip2
USE_QT4= corelib dbus gui network qtestlib webkit xml \
linguisttools_build moc_build qmake_build rcc_build uic_build \
sql-sqlite3_run
USE_QT5= buildtools_build core dbus gui linguist_build network qmake_build webkit xml
USE_OPENSSL= yes
USE_SQLITE= 3
CMAKE_ARGS= -DBUILD_WITH_QT4:BOOL=ON \
CMAKE_ARGS= -DBUILD_WITH_QT4:BOOL=OFF \
-DCMAKE_INSTALL_MANDIR:STRING=man \
-DWITH_STACK_PROTECTOR:BOOL=OFF
USE_LDCONFIG= yes
INSTALLS_ICONS= yes
CFLAGS+= -I${WRKSRC}/csync/src/httpbf/src -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
OPTIONS_DEFINE= DOCS
@ -36,6 +33,8 @@ DOCS_BUILD_DEPENDS= sphinx-build:${PORTSDIR}/textproc/py-sphinx
DOCS_USE= tex=dvipsk:build,latex:build
DOCS_CMAKE_ON= -DWITH_DOC:BOOL=ON
PLIST_SUB= VERSION=${PORTVERSION}
.include <bsd.port.options.mk>
.if ${OPSYS} != FreeBSD || ${OSVERSION} < 1000015

View File

@ -1,4 +1,4 @@
Owncloudclient is a tool to synchronize files from ownCloud Server with your
computer. It uses OCSync as its syncing backend.
The ownCloud Desktop Client is a tool to synchronize files
from ownCloud Server with your computer.
WWW: https://github.com/owncloud/client

View File

@ -1,7 +1,6 @@
bin/owncloud
bin/owncloudcmd
@sample etc/ownCloud/sync-exclude.lst.sample
include/httpbf.h
include/owncloudsync/creds/abstractcredentials.h
include/owncloudsync/creds/httpcredentials.h
include/owncloudsync/mirall/account.h
@ -12,10 +11,9 @@ include/owncloudsync/mirall/syncengine.h
include/owncloudsync/mirall/syncfileitem.h
include/owncloudsync/mirall/syncjournaldb.h
include/owncloudsync/mirall/syncresult.h
lib/libhttpbf.a
lib/libowncloudsync.so
lib/libowncloudsync.so.0
lib/libowncloudsync.so.1.8.0
lib/libowncloudsync.so.%%VERSION%%
lib/owncloud/libocsync.so
lib/owncloud/libocsync.so.0
lib/owncloud/libocsync.so.0.2.1

View File

@ -858,7 +858,8 @@
SUBDIR += py-zope.security
SUBDIR += py-zope.securitypolicy
SUBDIR += py-zope.session
SUBDIR += qtkeychain
SUBDIR += qtkeychain-qt4
SUBDIR += qtkeychain-qt5
SUBDIR += quantis
SUBDIR += quantis-kmod
SUBDIR += racoon2

View File

@ -0,0 +1,7 @@
# $FreeBSD$
PKGNAMESUFFIX= -qt4
MASTERDIR= ${.CURDIR}/../qtkeychain-qt5
.include "${MASTERDIR}/Makefile"

View File

@ -0,0 +1,34 @@
# $FreeBSD$
PORTNAME= qtkeychain
PORTVERSION= 0.5.0
DISTVERSIONPREFIX= v
CATEGORIES= security
PKGNAMESUFFIX?= -qt5
MAINTAINER= 6yearold@gmail.com
COMMENT= Platform independent Qt API for storing passwords
LICENSE= BSD2CLAUSE
USE_GITHUB= yes
GH_ACCOUNT= frankosterfeld
USES= cmake
USE_LDCONFIG= yes
PLIST_SUB+= VERSION=${PORTVERSION}
.if defined(PKGNAMESUFFIX) && ${PKGNAMESUFFIX} == "-qt4"
CONFLICTS_INSTALL= qtkeychain-qt5-[0-9]*
CMAKE_ARGS+= -DBUILD_WITH_QT4=YES
USE_QT4= corelib dbus linguisttools_build moc_build rcc_build qmake_build
PLIST= ${PKGDIR}/pkg-plist.qt4
PLIST_SUB+= PLIST_QT_PREFIX_UPCASE=Qt PLIST_QT_PREFIX=qt
.else
CONFLICTS_INSTALL= qtkeychain-qt4-[0-9]*
USE_QT5= core dbus linguisttools_build buildtools_build qmake_build
PLIST= ${PKGDIR}/pkg-plist.qt5
PLIST_SUB+= PLIST_QT_PREFIX_UPCASE=Qt5 PLIST_QT_PREFIX=qt5
.endif
.include <bsd.port.mk>

View File

@ -0,0 +1,2 @@
SHA256 (frankosterfeld-qtkeychain-v0.5.0_GH0.tar.gz) = e62d7ae9c8ae04784d8a5d0f213aaa22f1c02427e800ce88739e997f499bb514
SIZE (frankosterfeld-qtkeychain-v0.5.0_GH0.tar.gz) = 18422

View File

@ -6,7 +6,6 @@ lib/cmake/QtKeychain/QtKeychainLibraryDepends-%%CMAKE_BUILD_TYPE%%.cmake
lib/cmake/QtKeychain/QtKeychainLibraryDepends.cmake
lib/libqtkeychain.so
lib/libqtkeychain.so.0
lib/libqtkeychain.so.0.1.0
@dirrm lib/cmake/QtKeychain
@dirrmtry lib/cmake
@dirrm include/qtkeychain
lib/libqtkeychain.so.%%VERSION%%
%%QT_L10NDIR%%/qtkeychain_de.qm
%%QT_L10NDIR%%/qtkeychain_ro.qm

View File

@ -0,0 +1,11 @@
include/qt5keychain/keychain.h
include/qt5keychain/qkeychain_export.h
lib/cmake/Qt5Keychain/Qt5KeychainConfig.cmake
lib/cmake/Qt5Keychain/Qt5KeychainConfigVersion.cmake
lib/cmake/Qt5Keychain/Qt5KeychainLibraryDepends-%%CMAKE_BUILD_TYPE%%.cmake
lib/cmake/Qt5Keychain/Qt5KeychainLibraryDepends.cmake
lib/libqt5keychain.so
lib/libqt5keychain.so.0
lib/libqt5keychain.so.%%VERSION%%
%%QT_L10NDIR%%/qtkeychain_de.qm
%%QT_L10NDIR%%/qtkeychain_ro.qm

View File

@ -1,22 +0,0 @@
# $FreeBSD$
PORTNAME= qtkeychain
PORTVERSION= 0.1.0
DISTVERSIONPREFIX= v
PORTREVISION= 1
CATEGORIES= security
MAINTAINER= 6yearold@gmail.com
COMMENT= Platform independent Qt API for storing passwords
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/COPYING
USE_GITHUB= yes
GH_ACCOUNT= frankosterfeld
USES= cmake
USE_QT4= corelib dbus moc_build qmake_build rcc_build
USE_LDCONFIG= yes
.include <bsd.port.mk>

View File

@ -1,2 +0,0 @@
SHA256 (frankosterfeld-qtkeychain-v0.1.0_GH0.tar.gz) = 1a9a8906792a500586c3119865786664474ee42d0b10295d4d6b505e764ae192
SIZE (frankosterfeld-qtkeychain-v0.1.0_GH0.tar.gz) = 12826

View File

@ -1,70 +0,0 @@
--- CMakeLists.txt.orig 2013-01-16 18:02:17 UTC
+++ CMakeLists.txt
@@ -11,32 +11,32 @@ set(QTKEYCHAIN_SOVERSION 0)
set(CMAKE_MODULE_PATH "${CMAKE_MODULE_PATH}" "${PROJECT_SOURCE_DIR}/cmake/Modules")
include(GNUInstallDirs)
-# try Qt5 first, and prefer that if found
-find_package(Qt5Core QUIET)
-if (Qt5Core_FOUND)
- if(UNIX AND NOT APPLE)
- find_package(Qt5DBus REQUIRED)
- include_directories(${Qt5DBus_INCLUDE_DIRS})
- set(QTDBUS_LIBRARIES ${Qt5DBus_LIBRARIES})
- macro(qt_add_dbus_interface)
- qt5_add_dbus_interface(${ARGN})
- endmacro()
- endif()
- macro(qt_wrap_cpp)
- qt5_wrap_cpp(${ARGN})
- endmacro()
-
- set(QTCORE_LIBRARIES ${Qt5Core_LIBRARIES})
- include_directories(${Qt5Core_INCLUDE_DIRS})
-
- if (Qt5_POSITION_INDEPENDENT_CODE)
- if (CMAKE_VERSION VERSION_LESS 2.8.9) # TODO remove once we increase the cmake requirement
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fPIC")
- else()
- set(CMAKE_POSITION_INDEPENDENT_CODE ON)
- endif()
- endif()
-else()
+# Force Qt4
+#find_package(Qt5Core QUIET)
+#if (Qt5Core_FOUND)
+# if(UNIX AND NOT APPLE)
+# find_package(Qt5DBus REQUIRED)
+# include_directories(${Qt5DBus_INCLUDE_DIRS})
+# set(QTDBUS_LIBRARIES ${Qt5DBus_LIBRARIES})
+# macro(qt_add_dbus_interface)
+# qt5_add_dbus_interface(${ARGN})
+# endmacro()
+# endif()
+# macro(qt_wrap_cpp)
+# qt5_wrap_cpp(${ARGN})
+# endmacro()
+#
+# set(QTCORE_LIBRARIES ${Qt5Core_LIBRARIES})
+# include_directories(${Qt5Core_INCLUDE_DIRS})
+#
+# if (Qt5_POSITION_INDEPENDENT_CODE)
+# if (CMAKE_VERSION VERSION_LESS 2.8.9) # TODO remove once we increase the cmake requirement
+# set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fPIC")
+# else()
+# set(CMAKE_POSITION_INDEPENDENT_CODE ON)
+# endif()
+# endif()
+#else()
if(UNIX AND NOT APPLE)
find_package(Qt4 COMPONENTS QtCore QtDBus REQUIRED)
macro(qt_add_dbus_interface)
@@ -51,7 +51,7 @@ else()
endif()
include_directories(${QT_INCLUDES})
set(QTCORE_LIBRARIES ${QT_QTCORE_LIBRARY})
-endif()
+#endif()
include_directories(${CMAKE_CURRENT_BINARY_DIR})

View File

@ -1,11 +0,0 @@
--- _keychain_dbus.cpp 2013-03-25 20:32:44.801564594 +0400
+++ keychain_dbus.cpp 2013-03-25 20:32:49.811561714 +0400
@@ -10,7 +10,7 @@
#include <QSettings>
-#include <auto_ptr.h>
+#include <memory>
using namespace QKeychain;