upgrade to 1.2.1
PR: 43699 Submitted by: Ports Fury
This commit is contained in:
parent
8828b18fa6
commit
79411e6ced
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=67491
@ -6,25 +6,26 @@
|
||||
#
|
||||
|
||||
PORTNAME= feh
|
||||
PORTVERSION= 1.1.1
|
||||
PORTVERSION= 1.2.1
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= http://www.linuxbrit.co.uk/downloads/
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
|
||||
LIB_DEPENDS= Imlib2.1:${PORTSDIR}/graphics/imlib2
|
||||
LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt \
|
||||
giblib.1:${PORTSDIR}/graphics/giblib
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
USE_PERL5= yes
|
||||
USE_X_PREFIX= yes
|
||||
CONFIGURE_ENV= CPPFLAGS="-I${X11BASE}/include" \
|
||||
LIBS="-L${X11BASE}/lib"
|
||||
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-portbld-freebsd${OSREL}
|
||||
USE_PERL5= yes
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
|
||||
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
|
||||
LDFLAGS="-L${LOCALBASE}/lib -lgnugetopt"
|
||||
|
||||
MAN1= feh.1
|
||||
|
||||
.if defined(NOPORTDOCS)
|
||||
MAKE_ENV= NO_DOC=yes
|
||||
.endif
|
||||
|
||||
MAN1= feh.1
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1 +1 @@
|
||||
MD5 (feh-1.1.1.tar.gz) = f4f3785ae2c8e710b7b5ba2a1ac9786a
|
||||
MD5 (feh-1.2.1.tar.gz) = fed4e041940822f86a6539b8a1e353fb
|
||||
|
@ -1,19 +0,0 @@
|
||||
--- src/imlib.c.orig Sun Jan 13 15:03:52 2002
|
||||
+++ src/imlib.c Sat Jan 26 10:58:25 2002
|
||||
@@ -34,6 +34,7 @@
|
||||
#include <netinet/in.h>
|
||||
#include <arpa/inet.h>
|
||||
#include <netdb.h>
|
||||
+#include <stdio.h>
|
||||
|
||||
Display *disp = NULL;
|
||||
Visual *vis = NULL;
|
||||
@@ -758,7 +759,7 @@
|
||||
feh_imlib_free_image(old);
|
||||
feh_reload_image(w, 1);
|
||||
} else {
|
||||
- wprintf("failed to load image from disk to edit it in place\n");
|
||||
+ printf("failed to load image from disk to edit it in place\n");
|
||||
}
|
||||
|
||||
D_RETURN_(4);
|
@ -1,30 +1,25 @@
|
||||
@comment $FreeBSD$
|
||||
bin/cam
|
||||
bin/feh
|
||||
bin/gen_cam_menu.sh
|
||||
bin/feh
|
||||
%%PORTDOCS%%share/doc/feh/AUTHORS
|
||||
%%PORTDOCS%%share/doc/feh/ChangeLog
|
||||
%%PORTDOCS%%share/doc/feh/README
|
||||
%%PORTDOCS%%share/doc/feh/TODO
|
||||
share/feh/fonts/20thcent.ttf
|
||||
share/feh/fonts/cinema.ttf
|
||||
share/feh/fonts/droid.ttf
|
||||
share/feh/fonts/goodtime.ttf
|
||||
share/feh/fonts/grunge.ttf
|
||||
share/feh/fonts/joystix.ttf
|
||||
share/feh/fonts/morpheus.ttf
|
||||
share/feh/fonts/notepad.ttf
|
||||
share/feh/fonts/soulpapa.ttf
|
||||
share/feh/fonts/black.style
|
||||
share/feh/fonts/menu.style
|
||||
share/feh/fonts/yudit.ttf
|
||||
share/feh/images/about.png
|
||||
share/feh/images/menubg.png
|
||||
share/feh/images/menubg_aluminium.png
|
||||
share/feh/images/menubg_aqua.png
|
||||
share/feh/images/menubg_black.png
|
||||
share/feh/images/menubg_britney.png
|
||||
share/feh/images/menubg_brushed.png
|
||||
share/feh/images/menubg_chrome.png
|
||||
share/feh/images/menubg_pastel.png
|
||||
share/feh/images/menubg_wood.png
|
||||
%%PORTDOCS%%@dirrm share/doc/feh
|
||||
@dirrm share/feh/fonts
|
||||
@dirrm share/feh/images
|
||||
@dirrm share/feh/fonts
|
||||
@dirrm share/feh
|
||||
%%PORTDOCS%%@dirrm share/doc/feh
|
||||
|
Loading…
Reference in New Issue
Block a user