Update to latest version (1.3.9)

Fixes building with gcc >= 2.8.1

PR:		21337
Submitted by:	maintainer (with the help of Ports Fury)
This commit is contained in:
Ade Lovett 2000-09-18 16:11:09 +00:00
parent a87c59f352
commit 79393d7752
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=32814
6 changed files with 152 additions and 16 deletions

View File

@ -6,32 +6,26 @@
#
PORTNAME= xsidplay
PORTVERSION= 1.3.8
PORTVERSION= 1.3.9
CATEGORIES= audio emulators
MASTER_SITES= http://www.geocities.com/SiliconValley/Lakes/5147/sidplay/packages/ \
http://www.freenix.no/~anders/
DISTNAME= ${PORTNAME}-1_3_8
EXTRACT_SUFX= _tar.gz
DISTNAME= ${PORTNAME}-${PORTVERSION:S/./_/g}
EXTRACT_SUFX= .tgz
MAINTAINER= anders@fix.no
BUILD_DEPENDS= sidplay:${PORTSDIR}/audio/sidplay
LIB_DEPENDS= sidplay.1:${PORTSDIR}/audio/libsidplay
GNU_CONFIGURE= YES
USE_GMAKE= YES
USE_QT= YES
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include \
-I${LOCALBASE}/include/sidplay" \
LDFLAGS=-L${LOCALBASE}/lib
-I${X11BASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
WRKSRC= ${WRKDIR}/${PKGNAME}
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 400000
BROKEN= "Doesn't build with gcc >= 2.8.1"
.endif
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/xsidplay ${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/src/xsidplay ${PREFIX}/bin
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View File

@ -1 +1 @@
MD5 (xsidplay-1_3_8_tar.gz) = 9b22b10115323f87fd208a798b5252f1
MD5 (xsidplay-1_3_9.tgz) = 0899624e144c6b686d69d7396689e8c5

View File

@ -0,0 +1,36 @@
--- src/HVSCDialogData.cpp.orig Fri Oct 9 09:08:24 1998
+++ src/HVSCDialogData.cpp Tue Sep 12 04:02:45 2000
@@ -109,9 +109,30 @@
browseBtn = new QPushButton( this, "BrowseButton" );
browseBtn->setGeometry( 320, 32, 70, 30 );
{
- QColorGroup normal( QColor( QRgb(0) ), QColor( QRgb(11862015) ), QColor( QRgb(16777215) ), QColor( QRgb(6316128) ), QColor( QRgb(10789024) ), QColor( QRgb(0) ), QColor( QRgb(16777215) ) );
- QColorGroup disabled( QColor( QRgb(8421504) ), QColor( QRgb(12632256) ), QColor( QRgb(16777215) ), QColor( QRgb(6316128) ), QColor( QRgb(10789024) ), QColor( QRgb(8421504) ), QColor( QRgb(12632256) ) );
- QColorGroup active( QColor( QRgb(0) ), QColor( QRgb(8505544) ), QColor( QRgb(16777215) ), QColor( QRgb(6316128) ), QColor( QRgb(10789024) ), QColor( QRgb(0) ), QColor( QRgb(16777215) ) );
+ QColorGroup normal(
+ QColor( (unsigned int)0 ),
+ QColor( (unsigned int)11862015 ),
+ QColor( (unsigned int)16777215 ),
+ QColor( (unsigned int)6316128 ),
+ QColor( (unsigned int)10789024 ),
+ QColor( (unsigned int)0 ),
+ QColor( (unsigned int)16777215 ) );
+ QColorGroup disabled(
+ QColor( (unsigned int)8421504 ),
+ QColor( (unsigned int)12632256 ),
+ QColor( (unsigned int)16777215 ),
+ QColor( (unsigned int)6316128 ),
+ QColor( (unsigned int)10789024 ),
+ QColor( (unsigned int)8421504 ),
+ QColor( (unsigned int)12632256 ) );
+ QColorGroup active(
+ QColor( (unsigned int)0 ),
+ QColor( (unsigned int)8505544 ),
+ QColor( (unsigned int)16777215 ),
+ QColor( (unsigned int)6316128 ),
+ QColor( (unsigned int)10789024 ),
+ QColor( (unsigned int)0 ),
+ QColor( (unsigned int)16777215 ) );
QPalette palette( normal, disabled, active );
browseBtn->setPalette( palette );
}

View File

@ -0,0 +1,36 @@
--- src/MainDialog.cpp.orig Sat Jul 3 12:57:28 1999
+++ src/MainDialog.cpp Tue Sep 12 03:47:31 2000
@@ -152,9 +152,30 @@
timeLCD->setMode( QLCDNumber::DEC );
timeLCD->setSegmentStyle( QLCDNumber::Filled );
{
- QColorGroup normal( QColor( QRgb(0) ), QColor( QRgb(11513755) ), QColor( QRgb(16777215) ), QColor( QRgb(6316128) ), QColor( QRgb(10789024) ), QColor( QRgb(0) ), QColor( QRgb(16777215) ) );
- QColorGroup disabled( QColor( QRgb(8421504) ), QColor( QRgb(12632256) ), QColor( QRgb(16777215) ), QColor( QRgb(6316128) ), QColor( QRgb(10789024) ), QColor( QRgb(8421504) ), QColor( QRgb(12632256) ) );
- QColorGroup active( QColor( QRgb(0) ), QColor( QRgb(12632256) ), QColor( QRgb(16777215) ), QColor( QRgb(6316128) ), QColor( QRgb(10789024) ), QColor( QRgb(0) ), QColor( QRgb(16777215) ) );
+ QColorGroup normal(
+ QColor( (unsigned int)0 ),
+ QColor( (unsigned int)11513755 ),
+ QColor( (unsigned int)16777215 ),
+ QColor( (unsigned int)6316128 ),
+ QColor( (unsigned int)10789024 ),
+ QColor( (unsigned int)0 ),
+ QColor( (unsigned int)16777215 ) );
+ QColorGroup disabled(
+ QColor( (unsigned int)8421504 ),
+ QColor( (unsigned int)12632256 ),
+ QColor( (unsigned int)16777215 ),
+ QColor( (unsigned int)6316128 ),
+ QColor( (unsigned int)10789024 ),
+ QColor( (unsigned int)8421504 ),
+ QColor( (unsigned int)12632256 ) );
+ QColorGroup active(
+ QColor( (unsigned int)0 ),
+ QColor( (unsigned int)12632256 ),
+ QColor( (unsigned int)16777215 ),
+ QColor( (unsigned int)6316128 ),
+ QColor( (unsigned int)10789024 ),
+ QColor( (unsigned int)0 ),
+ QColor( (unsigned int)16777215 ) );
QPalette palette( normal, disabled, active );
timeLCD->setPalette( palette );
}

View File

@ -0,0 +1,70 @@
--- src/MainDialogData.cpp.orig Mon Dec 14 06:50:51 1998
+++ src/MainDialogData.cpp Tue Sep 12 03:57:49 2000
@@ -43,9 +43,30 @@
songLCD = new QLCDNumber( this, "LCDNumber_2" );
songLCD->setGeometry( 90, 35, 40, 30 );
{
- QColorGroup normal( QColor( QRgb(0) ), QColor( QRgb(11513755) ), QColor( QRgb(16777215) ), QColor( QRgb(6316128) ), QColor( QRgb(10789024) ), QColor( QRgb(0) ), QColor( QRgb(16777215) ) );
- QColorGroup disabled( QColor( QRgb(8421504) ), QColor( QRgb(12632256) ), QColor( QRgb(16777215) ), QColor( QRgb(6316128) ), QColor( QRgb(10789024) ), QColor( QRgb(8421504) ), QColor( QRgb(12632256) ) );
- QColorGroup active( QColor( QRgb(0) ), QColor( QRgb(12632256) ), QColor( QRgb(16777215) ), QColor( QRgb(6316128) ), QColor( QRgb(10789024) ), QColor( QRgb(0) ), QColor( QRgb(16777215) ) );
+ QColorGroup normal(
+ QColor( (unsigned int)0 ),
+ QColor( (unsigned int)11513755 ),
+ QColor( (unsigned int)16777215 ),
+ QColor( (unsigned int)6316128 ),
+ QColor( (unsigned int)10789024 ),
+ QColor( (unsigned int)0 ),
+ QColor( (unsigned int)16777215 ) );
+ QColorGroup disabled(
+ QColor( (unsigned int)8421504 ),
+ QColor( (unsigned int)12632256 ),
+ QColor( (unsigned int)16777215 ),
+ QColor( (unsigned int)6316128 ),
+ QColor( (unsigned int)10789024 ),
+ QColor( (unsigned int)8421504 ),
+ QColor( (unsigned int)12632256 ) );
+ QColorGroup active(
+ QColor( (unsigned int)0 ),
+ QColor( (unsigned int)12632256 ),
+ QColor( (unsigned int)16777215 ),
+ QColor( (unsigned int)6316128 ),
+ QColor( (unsigned int)10789024 ),
+ QColor( (unsigned int)0 ),
+ QColor( (unsigned int)16777215 ) );
QPalette palette( normal, disabled, active );
songLCD->setPalette( palette );
}
@@ -58,9 +79,30 @@
timeLCD = new TimeLCD( this, "TimeLCD_1" );
timeLCD->setGeometry( 10, 35, 75, 30 );
{
- QColorGroup normal( QColor( QRgb(0) ), QColor( QRgb(11513755) ), QColor( QRgb(16777215) ), QColor( QRgb(6316128) ), QColor( QRgb(10789024) ), QColor( QRgb(0) ), QColor( QRgb(16777215) ) );
- QColorGroup disabled( QColor( QRgb(8421504) ), QColor( QRgb(12632256) ), QColor( QRgb(16777215) ), QColor( QRgb(6316128) ), QColor( QRgb(10789024) ), QColor( QRgb(8421504) ), QColor( QRgb(12632256) ) );
- QColorGroup active( QColor( QRgb(0) ), QColor( QRgb(12632256) ), QColor( QRgb(16777215) ), QColor( QRgb(6316128) ), QColor( QRgb(10789024) ), QColor( QRgb(0) ), QColor( QRgb(16777215) ) );
+ QColorGroup normal(
+ QColor( (unsigned int)0 ),
+ QColor( (unsigned int)11513755 ),
+ QColor( (unsigned int)16777215 ),
+ QColor( (unsigned int)6316128 ),
+ QColor( (unsigned int)10789024 ),
+ QColor( (unsigned int)0 ),
+ QColor( (unsigned int)16777215 ) );
+ QColorGroup disabled(
+ QColor( (unsigned int)8421504 ),
+ QColor( (unsigned int)12632256 ),
+ QColor( (unsigned int)16777215 ),
+ QColor( (unsigned int)6316128 ),
+ QColor( (unsigned int)10789024 ),
+ QColor( (unsigned int)8421504 ),
+ QColor( (unsigned int)12632256 ) );
+ QColorGroup active(
+ QColor( (unsigned int)0 ),
+ QColor( (unsigned int)12632256 ),
+ QColor( (unsigned int)16777215 ),
+ QColor( (unsigned int)6316128 ),
+ QColor( (unsigned int)10789024 ),
+ QColor( (unsigned int)0 ),
+ QColor( (unsigned int)16777215 ) );
QPalette palette( normal, disabled, active );
timeLCD->setPalette( palette );
}

View File

@ -4,4 +4,4 @@ SID) and the Micro Processor Unit (MOS 6510) of the Commodore 64. Listen
to all those SID-tunes you remember so well again.
WWW: http://www.geocities.com/SiliconValley/Lakes/5147/
HVSC: http://home.freeuk.net/wazzaw/HVSC/
HVSC: http://www.hvsc.c64.org/