Update to version 3.2
PR: ports/70408 Submitted by: Ports Fury
This commit is contained in:
parent
ce67932ae8
commit
78ca5dbe86
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=116173
@ -5,7 +5,7 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= khacc
|
||||
PORTVERSION= 3.0
|
||||
PORTVERSION= 3.2
|
||||
CATEGORIES= finance
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= qhacc
|
||||
@ -13,12 +13,14 @@ MASTER_SITE_SUBDIR= qhacc
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= Simple KDE-base financial manager
|
||||
|
||||
LIB_DEPENDS= qhacc.3:${PORTSDIR}/finance/qhacc
|
||||
RUN_DEPENDS= bash:${PORTSDIR}/shells/bash2
|
||||
LIB_DEPENDS= qhacc.4:${PORTSDIR}/finance/qhacc
|
||||
RUN_DEPENDS= bash:${PORTSDIR}/shells/bash
|
||||
|
||||
USE_KDELIBS_VER= 3
|
||||
USE_REINPLACE= yes
|
||||
USE_PERL5_BUILD= yes
|
||||
USE_GMAKE= yes
|
||||
WANT_AUTOMAKE_VER= 18
|
||||
WANT_AUTOCONF_VER= 259
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
|
||||
CONFIGURE_ARGS= --with-qhacc-config=${X11BASE}/bin
|
||||
@ -28,9 +30,14 @@ MAKE_ARGS= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOMAKE="${TRUE}" \
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e \
|
||||
@${PERL} -pi -e \
|
||||
's|%%LOCALBASE%%|${LOCALBASE}|g' ${WRKSRC}/khacc/khacc.in
|
||||
@${REINPLACE_CMD} -e 's|-pedantic||g ; \
|
||||
s|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
|
||||
|
||||
pre-configure:
|
||||
@cd ${CONFIGURE_WRKSRC} \
|
||||
&& ${SETENV} ${AUTOTOOLS_ENV} ${AUTOMAKE} ${AUTOMAKE_ARGS} \
|
||||
&& ${PERL} admin/am_edit \
|
||||
&& ${SETENV} ${AUTOTOOLS_ENV} ${AUTOCONF} ${AUTOCONF_ARGS} \
|
||||
&& ${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g' configure
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
@ -1,2 +1,2 @@
|
||||
MD5 (khacc-3.0.tar.gz) = 4a38ba5ed2d7f135eb05769e979f8d75
|
||||
SIZE (khacc-3.0.tar.gz) = 762634
|
||||
MD5 (khacc-3.2.tar.gz) = 7983b23cf7b278a52b57b9cc9d86d888
|
||||
SIZE (khacc-3.2.tar.gz) = 675357
|
||||
|
@ -1,19 +0,0 @@
|
||||
--- configure.orig Sun Jan 11 00:08:11 2004
|
||||
+++ configure Thu Jan 15 21:26:41 2004
|
||||
@@ -24223,6 +24223,8 @@
|
||||
|
||||
ac_config_files="$ac_config_files doc/en/Makefile"
|
||||
|
||||
+ ac_config_files="$ac_config_files khacc/khacc"
|
||||
+
|
||||
ac_config_files="$ac_config_files khacc/Makefile"
|
||||
|
||||
ac_config_files="$ac_config_files khacc/pixmaps/Makefile"
|
||||
@@ -24789,6 +24791,7 @@
|
||||
"Makefile" ) CONFIG_FILES="$CONFIG_FILES Makefile" ;;
|
||||
"doc/Makefile" ) CONFIG_FILES="$CONFIG_FILES doc/Makefile" ;;
|
||||
"doc/en/Makefile" ) CONFIG_FILES="$CONFIG_FILES doc/en/Makefile" ;;
|
||||
+ "khacc/khacc" ) CONFIG_FILES="$CONFIG_FILES khacc/khacc" ;;
|
||||
"khacc/Makefile" ) CONFIG_FILES="$CONFIG_FILES khacc/Makefile" ;;
|
||||
"khacc/pixmaps/Makefile" ) CONFIG_FILES="$CONFIG_FILES khacc/pixmaps/Makefile" ;;
|
||||
"khacc/sounds/Makefile" ) CONFIG_FILES="$CONFIG_FILES khacc/sounds/Makefile" ;;
|
148
finance/khacc/files/patch-khacc::Makefile.am
Normal file
148
finance/khacc/files/patch-khacc::Makefile.am
Normal file
@ -0,0 +1,148 @@
|
||||
--- khacc/Makefile.am.orig Thu Jun 17 05:20:16 2004
|
||||
+++ khacc/Makefile.am Thu Aug 12 03:25:03 2004
|
||||
@@ -50,7 +50,7 @@
|
||||
|
||||
# set the include path for X, qt and KDE
|
||||
|
||||
-khacc_METASOURCES = AUTO
|
||||
+khacc_gui_METASOURCES = AUTO
|
||||
|
||||
INCLUDES = $(QHACCINCDIR) $(all_includes)
|
||||
khacc_gui_INCLUDES = $(INCLUDES)
|
||||
@@ -58,7 +58,6 @@
|
||||
# the library search path.
|
||||
khacc_gui_LDFLAGS = $(all_libraries) $(KDE_RPATH) $(QHACCLIBDIR) -lqhaccext
|
||||
|
||||
-khacc_gui_CXXFLAGS = -g -O2
|
||||
rcdir = $(kde_datadir)/khacc
|
||||
rc_DATA = khaccui.rc
|
||||
|
||||
@@ -68,128 +67,3 @@
|
||||
$(XGETTEXT) $$LIST -o $(podir)/khacc.pot; \
|
||||
fi
|
||||
|
||||
-qhaccwidget.moc: qhaccwidget.h
|
||||
- $(MOC) $(srcdir)/qhaccwidget.h -o qhaccwidget.moc
|
||||
-
|
||||
-qhaccview.moc: qhaccview.h
|
||||
- $(MOC) $(srcdir)/qhaccview.h -o qhaccview.moc
|
||||
-
|
||||
-qhaccacctchsr.moc: qhaccacctchsr.h
|
||||
- $(MOC) $(srcdir)/qhaccacctchsr.h -o qhaccacctchsr.moc
|
||||
-
|
||||
-qhaccacctbox.moc: qhaccacctbox.h
|
||||
- $(MOC) $(srcdir)/qhaccacctbox.h -o qhaccacctbox.moc
|
||||
-
|
||||
-qhaccacctboxchsr.moc: qhaccacctboxchsr.h
|
||||
- $(MOC) $(srcdir)/qhaccacctboxchsr.h -o qhaccacctboxchsr.moc
|
||||
-
|
||||
-transeditor.moc: transeditor.h
|
||||
- $(MOC) $(srcdir)/transeditor.h -o transeditor.moc
|
||||
-
|
||||
-qhaccrecwin.moc: qhaccrecwin.h
|
||||
- $(MOC) $(srcdir)/qhaccrecwin.h -o qhaccrecwin.moc
|
||||
-
|
||||
-qhacclineedits.moc: qhacclineedits.h
|
||||
- $(MOC) $(srcdir)/qhacclineedits.h -o qhacclineedits.moc
|
||||
-
|
||||
-qhaccdialogs.moc: qhaccdialogs.h
|
||||
- $(MOC) $(srcdir)/qhaccdialogs.h -o qhaccdialogs.moc
|
||||
-
|
||||
-qhacclistview.moc: qhacclistview.h
|
||||
- $(MOC) $(srcdir)/qhacclistview.h -o qhacclistview.moc
|
||||
-
|
||||
-qhaccgrwin.moc: qhaccgrwin.h
|
||||
- $(MOC) $(srcdir)/qhaccgrwin.h -o qhaccgrwin.moc
|
||||
-
|
||||
-qhaccsubsetwin.moc: qhaccsubsetwin.h
|
||||
- $(MOC) $(srcdir)/qhaccsubsetwin.h -o qhaccsubsetwin.moc
|
||||
-
|
||||
-qhaccjrnlchsr.moc: qhaccjrnlchsr.h
|
||||
- $(MOC) $(srcdir)/qhaccjrnlchsr.h -o qhaccjrnlchsr.moc
|
||||
-
|
||||
-splitdialog.moc: splitdialog.h
|
||||
- $(MOC) $(srcdir)/splitdialog.h -o splitdialog.moc
|
||||
-
|
||||
-khaccsounder.moc: khaccsounder.h
|
||||
- $(MOC) $(srcdir)/khaccsounder.h -o khaccsounder.moc
|
||||
-
|
||||
-qhaccacctdlg.moc: qhaccacctdlg.h
|
||||
- $(MOC) $(srcdir)/qhaccacctdlg.h -o qhaccacctdlg.moc
|
||||
-
|
||||
-qhaccprefdlg.moc: qhaccprefdlg.h
|
||||
- $(MOC) $(srcdir)/qhaccprefdlg.h -o qhaccprefdlg.moc
|
||||
-
|
||||
-$(srcdir)/qhaccwidget.cpp: qhaccwidget.moc
|
||||
-$(srcdir)/qhaccview.cpp: qhaccview.moc
|
||||
-$(srcdir)/qhaccacctchsr.cpp: qhaccacctchsr.moc
|
||||
-$(srcdir)/qhaccacctbox.cpp: qhaccacctbox.moc
|
||||
-$(srcdir)/qhaccacctboxchsr.cpp: qhaccacctboxchsr.moc
|
||||
-$(srcdir)/transeditor.cpp: transeditor.moc
|
||||
-$(srcdir)/qhaccrecwin.cpp: qhaccrecwin.moc
|
||||
-$(srcdir)/qhacclineedits.cpp: qhacclineedits.moc
|
||||
-$(srcdir)/qhaccdialogs.cpp: qhaccdialogs.moc
|
||||
-$(srcdir)/qhacclistview.cpp: qhacclistview.moc
|
||||
-$(srcdir)/qhaccgrwin.cpp: qhaccgrwin.moc
|
||||
-$(srcdir)/qhaccsubsetwin.cpp: qhaccsubsetwin.moc
|
||||
-$(srcdir)/qhaccjrnlchsr.cpp: qhaccjrnlchsr.moc
|
||||
-$(srcdir)/splitdialog.cpp: splitdialog.moc
|
||||
-$(srcdir)/khaccsounder.cpp: khaccsounder.moc
|
||||
-$(srcdir)/qhaccacctdlg.cpp: qhaccacctdlg.moc
|
||||
-$(srcdir)/qhaccprefdlg.cpp: qhaccprefdlg.moc
|
||||
-
|
||||
-qhaccwidget.$(OBJEXT): $(srcdir)/qhaccwidget.cpp qhaccwidget.h
|
||||
- $(CXXCOMPILE) -c $<
|
||||
-
|
||||
-qhaccview.$(OBJEXT): $(srcdir)/qhaccview.cpp qhaccview.h
|
||||
- $(CXXCOMPILE) -c $<
|
||||
-
|
||||
-qhaccacctchsr.$(OBJEXT): $(srcdir)/qhaccacctchsr.cpp qhaccacctchsr.h
|
||||
- $(CXXCOMPILE) -c $<
|
||||
-
|
||||
-qhaccacctbox.$(OBJEXT): $(srcdir)/qhaccacctbox.cpp qhaccacctbox.h
|
||||
- $(CXXCOMPILE) -c $<
|
||||
-
|
||||
-qhaccacctboxchsr.$(OBJEXT): $(srcdir)/qhaccacctboxchsr.cpp qhaccacctboxchsr.h
|
||||
- $(CXXCOMPILE) -c $<
|
||||
-
|
||||
-transeditor.$(OBJEXT): $(srcdir)/transeditor.cpp transeditor.h
|
||||
- $(CXXCOMPILE) -c $<
|
||||
-
|
||||
-qhaccrecwin.$(OBJEXT): $(srcdir)/qhaccrecwin.cpp qhaccrecwin.h
|
||||
- $(CXXCOMPILE) -c $<
|
||||
-
|
||||
-qhacclineedits.$(OBJEXT): $(srcdir)/qhacclineedits.cpp qhacclineedits.h
|
||||
- $(CXXCOMPILE) -c $<
|
||||
-
|
||||
-qhaccdialogs.$(OBJEXT): $(srcdir)/qhaccdialogs.cpp qhaccdialogs.h
|
||||
- $(CXXCOMPILE) -c $<
|
||||
-
|
||||
-qhacclistview.$(OBJEXT): $(srcdir)/qhacclistview.cpp qhacclistview.h
|
||||
- $(CXXCOMPILE) -c $<
|
||||
-
|
||||
-qhaccgrwin.$(OBJEXT): $(srcdir)/qhaccgrwin.cpp qhaccgrwin.h
|
||||
- $(CXXCOMPILE) -c $<
|
||||
-
|
||||
-qhaccsubsetwin.$(OBJEXT): $(srcdir)/qhaccsubsetwin.cpp qhaccsubsetwin.h
|
||||
- $(CXXCOMPILE) -c $<
|
||||
-
|
||||
-qhaccjrnlchsr.$(OBJEXT): $(srcdir)/qhaccjrnlchsr.cpp qhaccjrnlchsr.h
|
||||
- $(CXXCOMPILE) -c $<
|
||||
-
|
||||
-splitdialog.$(OBJEXT): $(srcdir)/splitdialog.cpp splitdialog.h
|
||||
- $(CXXCOMPILE) -c $<
|
||||
-
|
||||
-khaccsounder.$(OBJEXT): $(srcdir)/khaccsounder.cpp khaccsounder.h
|
||||
- $(CXXCOMPILE) -c $<
|
||||
-
|
||||
-qhaccacctdlg.$(OBJEXT): $(srcdir)/qhaccacctdlg.cpp qhaccacctdlg.h
|
||||
- $(CXXCOMPILE) -c $<
|
||||
-
|
||||
-qhaccprefdlg.$(OBJEXT): $(srcdir)/qhaccprefdlg.cpp qhaccprefdlg.h
|
||||
- $(CXXCOMPILE) -c $<
|
||||
-
|
||||
-clean:
|
||||
- rm -f *.o *.core core *~ khacc$(EXEEXT) .*~ *.moc
|
||||
-
|
||||
-distclean-local:
|
||||
- rm -f *.o *.core core *~ khacc$(EXEEXT) .*~ *.moc
|
File diff suppressed because it is too large
Load Diff
@ -6,7 +6,7 @@
|
||||
#
|
||||
|
||||
PORTNAME= qhacc
|
||||
PORTVERSION= 3.0
|
||||
PORTVERSION= 3.2
|
||||
CATEGORIES= finance
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= ${PORTNAME}
|
||||
@ -14,13 +14,14 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= Simple QT-based financial manager
|
||||
|
||||
RUN_DEPENDS= bash:${PORTSDIR}/shells/bash2
|
||||
RUN_DEPENDS= bash:${PORTSDIR}/shells/bash
|
||||
|
||||
USE_QT_VER= 3
|
||||
USE_X_PREFIX= yes
|
||||
USE_REINPLACE= yes
|
||||
USE_GMAKE= yes
|
||||
USE_AUTOCONF_VER= 259
|
||||
USE_LIBTOOL_VER= 15
|
||||
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
|
||||
CONFIGURE_ARGS= --with-qt-moc=${QT_PREFIX}/bin \
|
||||
--with-qt-libs=${QT_PREFIX}/lib
|
||||
@ -89,8 +90,7 @@ post-install:
|
||||
@${MKDIR} ${DOCSDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/docs/*.html ${DOCSDIR}
|
||||
@${MKDIR} ${EXAMPLESDIR}
|
||||
.for file in accounts accounttypes jobs journals namedtrans preferences \
|
||||
splits transactions
|
||||
.for file in accounts jobs journals namedtrans preferences splits transactions
|
||||
${INSTALL_DATA} ${WRKSRC}/contrib/easysetup/${file} ${EXAMPLESDIR}
|
||||
.endfor
|
||||
.endif
|
||||
|
@ -1,2 +1,2 @@
|
||||
MD5 (qhacc-3.0.tar.gz) = d31ddfd0a37b81781a6fd8c1287f093a
|
||||
SIZE (qhacc-3.0.tar.gz) = 524020
|
||||
MD5 (qhacc-3.2.tar.gz) = 72285666fa719d43516203420faaaa22
|
||||
SIZE (qhacc-3.2.tar.gz) = 647439
|
||||
|
@ -1,11 +1,11 @@
|
||||
--- Makefile.in.orig Sat Jan 31 10:47:17 2004
|
||||
+++ Makefile.in Mon Feb 9 01:03:14 2004
|
||||
@@ -158,7 +158,7 @@
|
||||
--- Makefile.in.orig Sun Aug 1 07:28:55 2004
|
||||
+++ Makefile.in Thu Aug 12 03:09:51 2004
|
||||
@@ -206,7 +206,7 @@
|
||||
sharedstatedir = @sharedstatedir@
|
||||
sysconfdir = @sysconfdir@
|
||||
target_alias = @target_alias@
|
||||
-SUBDIRS = lib src plugins contrib docs qm
|
||||
+SUBDIRS = lib src plugins
|
||||
|
||||
EXTRA_DIST = AUTHORS NEWS COPYING README ChangeLog THANKS FILE_FORMAT TODO \
|
||||
INSTALL UPGRADE
|
||||
|
||||
|
@ -1,10 +0,0 @@
|
||||
--- lib/plugins.h.orig Thu Dec 4 22:21:26 2003
|
||||
+++ lib/plugins.h Fri Dec 5 13:35:31 2003
|
||||
@@ -20,6 +20,7 @@
|
||||
#ifndef PLUGINS_H
|
||||
#define PLUGINS_H
|
||||
|
||||
+#include <memory>
|
||||
#include <vector>
|
||||
|
||||
#include <qstring.h>
|
@ -1,11 +1,11 @@
|
||||
--- lib/qhacc.cpp.orig Sun Sep 28 01:08:13 2003
|
||||
+++ lib/qhacc.cpp Sun Nov 2 10:53:38 2003
|
||||
@@ -31,7 +31,7 @@
|
||||
#include "plugins.h"
|
||||
#include "qhacc.moc"
|
||||
|
||||
-#include <math.h>
|
||||
+#include <cmath>
|
||||
|
||||
#include <qdir.h>
|
||||
#include <qfile.h>
|
||||
--- lib/qhacc.cpp.orig Thu Jul 8 07:06:55 2004
|
||||
+++ lib/qhacc.cpp Thu Aug 12 03:10:59 2004
|
||||
@@ -55,7 +55,7 @@
|
||||
#include "localfileplugin.h"
|
||||
#include "qhacc.moc"
|
||||
|
||||
-#include <math.h>
|
||||
+#include <cmath>
|
||||
|
||||
//const int QHacc::ROLLOVER=( int )std::pow( ( double )10, QC::DECIMALS );
|
||||
const int QHacc::ROLLOVER=100;
|
||||
|
@ -1,10 +0,0 @@
|
||||
--- lib/qhacc.h.orig Thu Dec 4 22:21:26 2003
|
||||
+++ lib/qhacc.h Fri Dec 5 13:24:01 2003
|
||||
@@ -23,6 +23,7 @@
|
||||
#include "tableops.h"
|
||||
#include "resultset.h"
|
||||
|
||||
+#include <memory>
|
||||
#include <vector>
|
||||
|
||||
#include <qfont.h>
|
@ -1,10 +0,0 @@
|
||||
--- lib/qhacctable.h.orig Thu Dec 4 22:21:26 2003
|
||||
+++ lib/qhacctable.h Fri Dec 5 13:27:08 2003
|
||||
@@ -23,6 +23,7 @@
|
||||
#include "tableops.h"
|
||||
#include "resultset.h"
|
||||
|
||||
+#include <memory>
|
||||
#include <vector>
|
||||
|
||||
#include <qlist.h>
|
@ -1,33 +0,0 @@
|
||||
--- ltmain.sh.orig Thu Mar 13 01:25:30 2003
|
||||
+++ ltmain.sh Mon Aug 18 02:14:24 2003
|
||||
@@ -1043,7 +1043,7 @@
|
||||
# These systems don't actually have a C library (as such)
|
||||
test "X$arg" = "X-lc" && continue
|
||||
;;
|
||||
- *-*-openbsd*)
|
||||
+ *-*-openbsd* | *-*-freebsd*)
|
||||
# Do not include libc due to us having libc/libc_r.
|
||||
test "X$arg" = "X-lc" && continue
|
||||
;;
|
||||
@@ -2441,7 +2441,7 @@
|
||||
*-*-netbsd*)
|
||||
# Don't link with libc until the a.out ld.so is fixed.
|
||||
;;
|
||||
- *-*-openbsd*)
|
||||
+ *-*-openbsd* | *-*-freebsd*)
|
||||
# Do not include libc due to us having libc/libc_r.
|
||||
;;
|
||||
*)
|
||||
@@ -4210,10 +4210,12 @@
|
||||
fi
|
||||
|
||||
# Install the pseudo-library for information purposes.
|
||||
+ if /usr/bin/false; then
|
||||
name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
|
||||
instname="$dir/$name"i
|
||||
$show "$install_prog $instname $destdir/$name"
|
||||
$run eval "$install_prog $instname $destdir/$name" || exit $?
|
||||
+ fi
|
||||
|
||||
# Maybe install the static library, too.
|
||||
test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
|
@ -1,6 +1,6 @@
|
||||
--- plugins/mysql/Makefile.in.orig Fri Dec 5 00:32:03 2003
|
||||
+++ plugins/mysql/Makefile.in Fri Dec 5 23:04:22 2003
|
||||
@@ -77,8 +77,8 @@
|
||||
--- plugins/mysql/Makefile.in.orig Sun Aug 1 07:28:58 2004
|
||||
+++ plugins/mysql/Makefile.in Thu Aug 12 14:39:19 2004
|
||||
@@ -129,8 +129,8 @@
|
||||
LN_S = @LN_S@
|
||||
LTLIBOBJS = @LTLIBOBJS@
|
||||
MAKEINFO = @MAKEINFO@
|
||||
@ -11,21 +11,19 @@
|
||||
MYSQL_FALSE = @MYSQL_FALSE@
|
||||
MYSQL_TRUE = @MYSQL_TRUE@
|
||||
OBJEXT = @OBJEXT@
|
||||
@@ -167,13 +167,13 @@
|
||||
|
||||
@@ -225,11 +225,11 @@
|
||||
@MYSQL_TRUE@exportdir = $(pidir)/export
|
||||
@MYSQL_TRUE@libmysqlio_la_SOURCES = mysqlplugin.cpp mysqlplugin.h
|
||||
@MYSQL_TRUE@RELEASE = 2:0:0
|
||||
|
||||
-@MYSQL_TRUE@libmysqlio_la_LIBADD = -l$(QHACCQT) -lnativedbio
|
||||
+@MYSQL_TRUE@libmysqlio_la_LIBADD = -l$(QHACCQT) -lmysqlclient -lnativedbio
|
||||
|
||||
-@MYSQL_TRUE@INCLUDES = $(all_includes) -I$(QTINCDIR) -I$(top_srcdir)/lib
|
||||
-@MYSQL_TRUE@AM_LDFLAGS = -L$(QTLIBDIR) -L$(top_builddir)/lib $(MYSQLLIBS)
|
||||
+@MYSQL_TRUE@libmysqlio_la_LIBADD = -l$(QHACCQT) -lmysqlclient -lnativedbio
|
||||
+@MYSQL_TRUE@INCLUDES = $(all_includes) -I$(QTINCDIR) -I$(MYSQLINCDIR) -I$(top_srcdir)/lib
|
||||
+@MYSQL_TRUE@AM_LDFLAGS = -L$(QTLIBDIR) -L$(MYSQLLIBDIR) -L$(top_builddir)/lib
|
||||
@MYSQL_TRUE@LDADD =
|
||||
|
||||
-@MYSQL_TRUE@AM_CXXFLAGS = -O2 -Wall -g -Wnon-virtual-dtor -Wno-long-long -Wundef -W -Wpointer-arith -Wwrite-strings -Wcast-align -Wconversion -fPIC $(MYSQLFLAGS)
|
||||
+@MYSQL_TRUE@AM_CXXFLAGS = -O2 -Wall -g -Wnon-virtual-dtor -Wno-long-long -Wundef -W -Wpointer-arith -Wwrite-strings -Wcast-align -Wconversion -fPIC
|
||||
|
||||
@MYSQL_TRUE@libmysqlio_la_LDFLAGS = -version-info $(RELEASE)
|
||||
subdir = plugins/mysql
|
||||
all: all-am
|
||||
|
||||
|
@ -1,16 +1,15 @@
|
||||
--- src/Makefile.in.orig Sat Feb 14 22:19:19 2004
|
||||
+++ src/Makefile.in Fri Feb 20 13:31:57 2004
|
||||
@@ -177,10 +177,10 @@
|
||||
--- src/Makefile.in.orig Sun Aug 1 07:29:01 2004
|
||||
+++ src/Makefile.in Thu Aug 12 14:42:06 2004
|
||||
@@ -255,9 +255,9 @@
|
||||
noinst_HEADERS = qhaccview.h qhaccrecwin.h qhaccdialogs.h qhaccacctchsr.h transeditor.h qhaccwidget.h qhaccgrwin.h qhaccsubsetwin.h qhaccjrnlchsr.h qhacccli.h qhacclineedits.h splitdialog.h copystore.h guiconstants.h qhacclistview.h qhaccacctbox.h qhaccacctboxchsr.h qhaccacctdlg.h qhaccprefdlg.h
|
||||
EXTRA_DIST = lupdate.info
|
||||
|
||||
SUBDIRS = pixmaps
|
||||
-INCLUDES = $(all_includes) -I$(QTINCDIR) -I$(top_srcdir)/lib
|
||||
+INCLUDES = -I$(top_srcdir)/lib $(all_includes) -I$(QTINCDIR)
|
||||
|
||||
-qhacc_gui_LDFLAGS = -L$(QTLIBDIR) -L$(top_builddir)/lib $(LDFLAGS) -L.
|
||||
-qhacc_cli_LDFLAGS = -L$(QTLIBDIR) -L$(top_builddir)/lib $(LDFLAGS) -L.
|
||||
+qhacc_gui_LDFLAGS = -L$(top_builddir)/lib -L. -L$(QTLIBDIR) $(LDFLAGS)
|
||||
+qhacc_cli_LDFLAGS = -L$(top_builddir)/lib -L. -L$(QTLIBDIR) $(LDFLAGS)
|
||||
+INCLUDES = -I$(top_srcdir)/lib $(all_includes) -I$(QTINCDIR)
|
||||
+qhacc_gui_LDFLAGS = -L$(top_builddir)/lib -L. -L$(QTLIBDIR) $(LDFLAGS)
|
||||
+qhacc_cli_LDFLAGS = -L$(top_builddir)/lib -L. -L$(QTLIBDIR) $(LDFLAGS)
|
||||
|
||||
#qhacc_gui_LDADD = -l$(QHACCQT) -lqhacc -lqhaccutils -lmpatrol -lbfd -liberty
|
||||
qhacc_gui_LDADD = -l$(QHACCQT) -lqhacc -lqhaccutils
|
||||
qhacc_cli_LDADD = -l$(QHACCQT) -lqhacc -lqhaccutils -lqhaccext
|
||||
|
@ -3,6 +3,7 @@ bin/qhacc-cli
|
||||
bin/qhacc-config
|
||||
bin/qhacc-gui
|
||||
include/localfileplugin.h
|
||||
include/plugininfo.h
|
||||
include/plugins.h
|
||||
include/qhacc.h
|
||||
include/qhaccconstants.h
|
||||
@ -19,7 +20,7 @@ lib/libacct.so
|
||||
lib/libacct.so.1
|
||||
lib/libarcio.a
|
||||
lib/libarcio.so
|
||||
lib/libarcio.so.1
|
||||
lib/libarcio.so.2
|
||||
lib/libaves.a
|
||||
lib/libaves.so
|
||||
lib/libaves.so.1
|
||||
@ -31,10 +32,10 @@ lib/libbudget.so
|
||||
lib/libbudget.so.1
|
||||
lib/libcliimpio.a
|
||||
lib/libcliimpio.so
|
||||
lib/libcliimpio.so.1
|
||||
lib/libcliimpio.so.2
|
||||
lib/libdbbase.a
|
||||
lib/libdbbase.so
|
||||
lib/libdbbase.so.3
|
||||
lib/libdbbase.so.4
|
||||
lib/libdeltas.a
|
||||
lib/libdeltas.so
|
||||
lib/libdeltas.so.1
|
||||
@ -46,10 +47,10 @@ lib/libdoublelinegraph.so
|
||||
lib/libdoublelinegraph.so.1
|
||||
lib/libextprgio.a
|
||||
lib/libextprgio.so
|
||||
lib/libextprgio.so.1
|
||||
lib/libextprgio.so.2
|
||||
lib/libfiledbio.a
|
||||
lib/libfiledbio.so
|
||||
lib/libfiledbio.so.3
|
||||
lib/libfiledbio.so.4
|
||||
lib/libgraphbase.a
|
||||
lib/libgraphbase.so
|
||||
lib/libgraphbase.so.1
|
||||
@ -58,7 +59,7 @@ lib/libjournal.so
|
||||
lib/libjournal.so.1
|
||||
%%SQLITE%%lib/liblfsqliteio.a
|
||||
%%SQLITE%%lib/liblfsqliteio.so
|
||||
%%SQLITE%%lib/liblfsqliteio.so.1
|
||||
%%SQLITE%%lib/liblfsqliteio.so.2
|
||||
%%MYSQL%%lib/libmysqlio.a
|
||||
%%MYSQL%%lib/libmysqlio.so
|
||||
%%MYSQL%%lib/libmysqlio.so.2
|
||||
@ -70,13 +71,13 @@ lib/libmonthlygraph.so
|
||||
lib/libmonthlygraph.so.1
|
||||
lib/libnativedbio.a
|
||||
lib/libnativedbio.so
|
||||
lib/libnativedbio.so.3
|
||||
lib/libnativedbio.so.4
|
||||
lib/libpayee.a
|
||||
lib/libpayee.so
|
||||
lib/libpayee.so.1
|
||||
%%PGSQL%%lib/libpsqlio.a
|
||||
%%PGSQL%%lib/libpsqlio.so
|
||||
%%PGSQL%%lib/libpsqlio.so.1
|
||||
%%PGSQL%%lib/libpsqlio.so.2
|
||||
lib/libpiegraph.a
|
||||
lib/libpiegraph.so
|
||||
lib/libpiegraph.so.1
|
||||
@ -85,16 +86,16 @@ lib/libprofitloss.so
|
||||
lib/libprofitloss.so.1
|
||||
lib/libqhacc.a
|
||||
lib/libqhacc.so
|
||||
lib/libqhacc.so.3
|
||||
lib/libqhacc.so.4
|
||||
lib/libqhaccext.a
|
||||
lib/libqhaccext.so
|
||||
lib/libqhaccext.so.3
|
||||
lib/libqhaccext.so.4
|
||||
lib/libqhaccutils.a
|
||||
lib/libqhaccutils.so
|
||||
lib/libqhaccutils.so.3
|
||||
lib/libqhaccutils.so.4
|
||||
lib/libqifio.a
|
||||
lib/libqifio.so
|
||||
lib/libqifio.so.1
|
||||
lib/libqifio.so.2
|
||||
lib/libsinglebargraph.a
|
||||
lib/libsinglebargraph.so
|
||||
lib/libsinglebargraph.so.1
|
||||
@ -103,7 +104,7 @@ lib/libsinglelinegraph.so
|
||||
lib/libsinglelinegraph.so.1
|
||||
%%SQLITE%%lib/libsqliteio.a
|
||||
%%SQLITE%%lib/libsqliteio.so
|
||||
%%SQLITE%%lib/libsqliteio.so.1
|
||||
%%SQLITE%%lib/libsqliteio.so.2
|
||||
lib/libtbal.a
|
||||
lib/libtbal.so
|
||||
lib/libtbal.so.1
|
||||
@ -112,10 +113,10 @@ lib/libtrans.so
|
||||
lib/libtrans.so.1
|
||||
lib/libupgradeio.a
|
||||
lib/libupgradeio.so
|
||||
lib/libupgradeio.so.1
|
||||
lib/libupgradeio.so.2
|
||||
lib/libxmlio.a
|
||||
lib/libxmlio.so
|
||||
lib/libxmlio.so.1
|
||||
lib/libxmlio.so.2
|
||||
lib/qhacc/plugins/db/libextprgio.so
|
||||
%%SQLITE%%lib/qhacc/plugins/db/liblfsqliteio.so
|
||||
%%MYSQL%%lib/qhacc/plugins/db/libmysqlio.so
|
||||
@ -166,7 +167,6 @@ lib/qhacc/qhacc_es_ES.qm
|
||||
%%PORTDOCS%%%%DOCSDIR%%/primer.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/using.html
|
||||
%%PORTDOCS%%%%EXAMPLESDIR%%/accounts
|
||||
%%PORTDOCS%%%%EXAMPLESDIR%%/accounttypes
|
||||
%%PORTDOCS%%%%EXAMPLESDIR%%/jobs
|
||||
%%PORTDOCS%%%%EXAMPLESDIR%%/journals
|
||||
%%PORTDOCS%%%%EXAMPLESDIR%%/namedtrans
|
||||
|
Loading…
Reference in New Issue
Block a user