o/ One more time, we're gonna fix four-ehehex, oh yeah, all right o/
PR: ports/106982 Submitted by: KATO Tsuguru <tkato432@yahoo.com>
This commit is contained in:
parent
357a2f0ed5
commit
78c9ed8ab3
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=180325
@ -48,6 +48,11 @@ CONFIGURE_ENV+= ac_cv_prog_HAVE_DOXYGEN="false"
|
||||
PLIST_SUB+= DOCS="@comment "
|
||||
.endif
|
||||
|
||||
.if ${OSVERSION} < 500000
|
||||
CONFIGURE_ENV+= ac_cv_func_clock_gettime=no
|
||||
CFLAGS+= -Duintmax_t=uintptr_t
|
||||
.endif
|
||||
|
||||
.if (${OSVERSION} > 500000 ) && (${OSVERSION} < 502102 )
|
||||
BROKEN= Does not compile
|
||||
.endif
|
||||
@ -81,8 +86,4 @@ post-patch:
|
||||
post-build:
|
||||
@${RM} -f ${WRKSRC}/doc/reference/html/dir__2F*
|
||||
|
||||
.if ${OSVERSION} < 500000
|
||||
BROKEN= Does not compile on 4.x
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
14
audio/jack/files/patch-example-clients_lsp.c
Normal file
14
audio/jack/files/patch-example-clients_lsp.c
Normal file
@ -0,0 +1,14 @@
|
||||
--- example-clients/lsp.c.orig Fri May 26 11:45:08 2006
|
||||
+++ example-clients/lsp.c Thu Dec 7 16:58:45 2006
|
||||
@@ -120,9 +120,9 @@
|
||||
ports = jack_get_ports (client, NULL, NULL, 0);
|
||||
|
||||
for (i = 0; ports[i]; ++i) {
|
||||
- printf ("%s\n", ports[i]);
|
||||
-
|
||||
jack_port_t *port = jack_port_by_name (client, ports[i]);
|
||||
+
|
||||
+ printf ("%s\n", ports[i]);
|
||||
|
||||
if (show_con) {
|
||||
if ((connections = jack_port_get_all_connections (client, jack_port_by_name(client, ports[i]))) != 0) {
|
Loading…
Reference in New Issue
Block a user