Fix problems with ROM-dump.
PR: 14363 Submitted by: maintainer
This commit is contained in:
parent
f4ae4997ff
commit
78c405bf64
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=23369
@ -6,25 +6,27 @@
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
DISTNAME= STonX-0.6.7-epsilon
|
||||
DISTNAME= STonX-0.6.7-epsilon
|
||||
PKGNAME= stonx-0.6.7e
|
||||
CATEGORIES= emulators
|
||||
MASTER_SITES= ftp://ftp.complang.tuwien.ac.at/pub/nino/stonx-current/
|
||||
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} tos.img
|
||||
CATEGORIES= emulators
|
||||
MASTER_SITES= ftp://ftp.complang.tuwien.ac.at/pub/nino/stonx-current/
|
||||
|
||||
MAINTAINER= tr@freebsd.mayn.de
|
||||
MAINTAINER= treif@mayn.de
|
||||
|
||||
BROKEN="fetch"
|
||||
|
||||
RESTRICTED= "tos.img is Copyrighted"
|
||||
RESTRICTED= "tos.img is copyrighted"
|
||||
NO_PACKAGE= ${RESTRICTED}
|
||||
|
||||
IGNOREFILES= tos.img
|
||||
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
|
||||
TOSIMG= tos.img
|
||||
USE_X_PREFIX= yes
|
||||
HAS_CONFIGURE= yes
|
||||
|
||||
# Source building
|
||||
#
|
||||
pre-fetch:
|
||||
@if [ ! -f ${DISTDIR}/${TOSIMG} ]; then \
|
||||
${ECHO} "Please get a ROM dump from your AtariST and"; \
|
||||
${ECHO} "put it as \"${TOSIMG}\" in \"${DISTDIR}\" manually."; \
|
||||
exit 1; \
|
||||
fi
|
||||
|
||||
pre-build:
|
||||
${CP} ${DISTDIR}/tos.img ${WRKSRC}
|
||||
|
||||
@ -34,8 +36,8 @@ post-build:
|
||||
# Installing
|
||||
#
|
||||
BINDIR= ${PREFIX}/bin
|
||||
LIBDIR= ${PREFIX}/lib/STonX
|
||||
FNTDIR= ${X11BASE}/lib/X11/fonts/misc
|
||||
LIBDIR= ${PREFIX}/lib/X11/STonX
|
||||
FNTDIR= ${PREFIX}/lib/X11/fonts/misc
|
||||
|
||||
DATA= tos.img cartridge.img Keysyms Keysyms.G atari/FLOPPY-4MB \
|
||||
atari/bench1.pas atari/bench1.prg atari/final.tos
|
||||
@ -58,20 +60,25 @@ do-install:
|
||||
@${ECHO_MSG} "===> Installing data"
|
||||
@${MKDIR} ${LIBDIR}
|
||||
.for f in ${DATA}
|
||||
@${INSTALL_DATA} ${WRKSRC}/$f ${LIBDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/$f ${LIBDIR}
|
||||
.endfor
|
||||
|
||||
@${ECHO_MSG} "===> Installing fonts"
|
||||
.for f in ${FONTS}
|
||||
@${INSTALL_DATA} ${WRKSRC}/data/$f ${FNTDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/data/$f ${FNTDIR}
|
||||
@${GZIP_CMD} ${FNTDIR}/$f
|
||||
.endfor
|
||||
@mkfontdir ${FNTDIR}
|
||||
|
||||
.if !defined(NOPORTDOCS)
|
||||
@${ECHO_MSG} "===> Installing docs"
|
||||
@${MKDIR} ${LIBDIR}/docs
|
||||
.for f in ${DOCS}
|
||||
@${INSTALL_DATA} ${WRKSRC}/docs/$f ${LIBDIR}/docs
|
||||
${INSTALL_DATA} ${WRKSRC}/docs/$f ${LIBDIR}/docs
|
||||
.endfor
|
||||
.endif
|
||||
|
||||
post-install:
|
||||
${X11BASE}/bin/mkfontdir ${FNTDIR}
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
11
emulators/stonx/files/patch-aa
Normal file
11
emulators/stonx/files/patch-aa
Normal file
@ -0,0 +1,11 @@
|
||||
--- Makefile.in.orig Sat Oct 16 19:24:54 1999
|
||||
+++ Makefile.in Sat Oct 16 19:25:26 1999
|
||||
@@ -28,7 +28,7 @@
|
||||
#XLIBS=@X_LIBS@ -lvgagl -lvga
|
||||
#SFLAGS=-DUSE_SVGALIB
|
||||
|
||||
-STONXDIR=/usr/local/lib/STonX
|
||||
+STONXDIR=${PREFIX}/lib/X11/STonX
|
||||
DEF= @def@ -DINLINE=@inline@ -DSTONXDIR=\"$(STONXDIR)\"
|
||||
|
||||
# Compiler
|
@ -1,20 +1,26 @@
|
||||
bin/stonx
|
||||
bin/stonx.bin
|
||||
lib/STonX/FLOPPY-4MB
|
||||
lib/STonX/Keysyms
|
||||
lib/STonX/Keysyms.G
|
||||
lib/STonX/bench1.pas
|
||||
lib/STonX/bench1.prg
|
||||
lib/STonX/cartridge.img
|
||||
lib/STonX/final.tos
|
||||
lib/STonX/tos.img
|
||||
lib/STonX/docs/COPYING
|
||||
lib/STonX/docs/DEBUGGING
|
||||
lib/STonX/docs/FONTS
|
||||
lib/STonX/docs/INSTALL
|
||||
lib/STonX/docs/PROGRAMS
|
||||
lib/STonX/docs/README
|
||||
lib/STonX/docs/RELEASE_NOTES
|
||||
lib/STonX/docs/TOS-VERSIONS
|
||||
@dirrm lib/STonX/docs
|
||||
@dirrm lib/STonX
|
||||
lib/X11/STonX/FLOPPY-4MB
|
||||
lib/X11/STonX/Keysyms
|
||||
lib/X11/STonX/Keysyms.G
|
||||
lib/X11/STonX/bench1.pas
|
||||
lib/X11/STonX/bench1.prg
|
||||
lib/X11/STonX/cartridge.img
|
||||
lib/X11/STonX/final.tos
|
||||
lib/X11/STonX/tos.img
|
||||
lib/X11/fonts/misc/System0-iso.pcf.gz
|
||||
lib/X11/fonts/misc/System0.pcf.gz
|
||||
lib/X11/fonts/misc/System1-iso.pcf.gz
|
||||
lib/X11/fonts/misc/System1.pcf.gz
|
||||
lib/X11/fonts/misc/System2-iso.pcf.gz
|
||||
lib/X11/fonts/misc/System2.pcf.gz
|
||||
lib/X11/STonX/docs/COPYING
|
||||
lib/X11/STonX/docs/DEBUGGING
|
||||
lib/X11/STonX/docs/FONTS
|
||||
lib/X11/STonX/docs/INSTALL
|
||||
lib/X11/STonX/docs/PROGRAMS
|
||||
lib/X11/STonX/docs/README
|
||||
lib/X11/STonX/docs/RELEASE_NOTES
|
||||
lib/X11/STonX/docs/TOS-VERSIONS
|
||||
@dirrm lib/X11/STonX/docs
|
||||
@dirrm lib/X11/STonX
|
||||
|
Loading…
Reference in New Issue
Block a user