MFH: r513815

net-im/uTox: Update to 0.17.1

- Take maintainership

Changes:	https://github.com/uTox/uTox/releases/tag/v0.17.1
PR:		240721
Approved by:	portmaster@BSDforge.com (maintainer timeout, 14 days)

Approved by:	ports-secteam blanket
This commit is contained in:
Tobias Kortkamp 2019-10-05 07:00:09 +00:00
parent 863c1fa2fe
commit 78a4c3d2a5
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/branches/2019Q4/; revision=513816
4 changed files with 39 additions and 53 deletions

View File

@ -1,45 +1,55 @@
# $FreeBSD$
PORTNAME= uTox
DISTVERSION= 0.17.0
DISTVERSION= 0.17.1
DISTVERSIONSUFFIX= -full
PORTREVISION= 7
CATEGORIES= net-im net-p2p
MASTER_SITES= https://github.com/uTox/uTox/releases/download/v${PORTVERSION}/
MASTER_SITES= https://github.com/uTox/uTox/releases/download/v${DISTVERSION}/
MAINTAINER= portmaster@BSDforge.com
PATCH_SITES= https://github.com/uTox/uTox/commit/
PATCHFILES= 37271f991c590a533781b66e9036e9b66dfbbf1b.patch:-p1
MAINTAINER= tobik@FreeBSD.org
COMMENT= Lightweight Tox client
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
BROKEN_aarch64= fails to compile: endian.h:68:20: too many arguments provided to function-like macro invocation
BROKEN_armv6= fails to compile: endian.h:68:20: too many arguments provided to function-like macro invocation
BROKEN_armv7= fails to compile: endian.h:68:20: too many arguments provided to function-like macro invocation
BROKEN_aarch64= fails to compile: endian.h:68:20: too many arguments provided to function-like macro invocation
BROKEN_armv6= fails to compile: endian.h:68:20: too many arguments provided to function-like macro invocation
BROKEN_armv7= fails to compile: endian.h:68:20: too many arguments provided to function-like macro invocation
BUILD_DEPENDS= ${LOCALBASE}/include/linux/videodev2.h:multimedia/v4l_compat \
${LOCALBASE}/include/linux/input.h:devel/evdev-proto
LIB_DEPENDS= libfreetype.so:print/freetype2 \
BUILD_DEPENDS= ${LOCALBASE}/include/linux/input.h:devel/evdev-proto \
${LOCALBASE}/include/linux/videodev2.h:multimedia/v4l_compat
LIB_DEPENDS= libfilteraudio.so:audio/libfilteraudio \
libfontconfig.so:x11-fonts/fontconfig \
libsodium.so:security/libsodium \
libv4lconvert.so:multimedia/libv4l \
libvpx.so:multimedia/libvpx \
libfreetype.so:print/freetype2 \
libopus.so:audio/opus \
libtoxcore.so:net-im/tox
libsodium.so:security/libsodium \
libtoxcore.so:net-im/tox \
libv4lconvert.so:multimedia/libv4l \
libvpx.so:multimedia/libvpx
TEST_DEPENDS= check>=0:devel/check
USES= cmake compiler:c11 desktop-file-utils dos2unix \
openal pkgconfig
USES= cmake compiler:c11 desktop-file-utils openal pkgconfig xorg
USE_XORG= ice sm x11 xext xrender
CMAKE_OFF= ENABLE_LTO
DOS2UNIX_GLOB= *
CMAKE_OFF= ENABLE_LTO ENABLE_TESTS
# Uses ld -b binary without -m
LLD_UNSAFE= yes
WRKSRC= ${WRKDIR}/uTox
OPTIONS_DEFINE= DBUS
OPTIONS_DEFAULT= DBUS
DBUS_CMAKE_BOOL= ENABLE_DBUS
DBUS_LIB_DEPENDS= libdbus-1.so:devel/dbus
DBUS_CMAKE_BOOL= ENABLE_DBUS
do-test:
@cd ${TEST_WRKSRC} && \
${SETENV} ${CONFIGURE_ENV} ${CMAKE_BIN} ${CMAKE_ARGS} \
-DENABLE_TESTS:BOOL=yes ${CMAKE_SOURCE_PATH} && \
${DO_MAKE_BUILD}
@${TEST_WRKSRC}/run_tests.sh
.include <bsd.port.mk>

View File

@ -1,3 +1,5 @@
TIMESTAMP = 1529567839
SHA256 (uTox-0.17.0-full.tar.gz) = 219ae83e9139d3a421c7bb6d03cc3f8953dd36fb8e8b67100d47d92d413e9d46
SIZE (uTox-0.17.0-full.tar.gz) = 3946812
TIMESTAMP = 1569893842
SHA256 (uTox-0.17.1-full.tar.gz) = 6a6d399827f31593f840274b08ed80039c99d5abf0bd6634faf22cc064930460
SIZE (uTox-0.17.1-full.tar.gz) = 3948392
SHA256 (37271f991c590a533781b66e9036e9b66dfbbf1b.patch) = 0ad39545e0ae0f71090934b588e5a2cb2ed13cc041fc70d2b8872df95f048ad0
SIZE (37271f991c590a533781b66e9036e9b66dfbbf1b.patch) = 1163

View File

@ -1,6 +1,6 @@
--- CMakeLists.txt.orig 2018-06-21 08:33:29 UTC
--- CMakeLists.txt.orig 2019-09-21 02:09:21 UTC
+++ CMakeLists.txt
@@ -184,8 +184,7 @@ add_cflag("-fPIC")
@@ -178,8 +178,7 @@ add_cflag("-fPIC")
# Fix GNU stack
if(CMAKE_C_COMPILER_ID MATCHES "GNU")
# Have ld strip the symbols from Release and MinSizeRel build types.
@ -10,7 +10,7 @@
if(LINUX)
# enable Link Time Optimization on gcc (linux only currently)
@@ -220,8 +219,7 @@ elseif(CMAKE_C_COMPILER_ID MATCHES "Clang")
@@ -214,8 +213,7 @@ elseif(CMAKE_C_COMPILER_ID MATCHES "Clang")
endif()
# Have ld strip the symbols from Release and MinSizeRel build types. (-Oz is clang specific)
@ -18,5 +18,5 @@
- set(CMAKE_C_FLAGS_MINSIZEREL "${CMAKE_C_FLAGS_MINSIZEREL} -Oz -s")
+ set(CMAKE_C_FLAGS_MINSIZEREL "${CMAKE_C_FLAGS_MINSIZEREL} -s")
if(NOT ENABLE_ASAN)
if(NOT APPLE)
if(FREEBSD)
set(LIBRARIES ${LIBRARIES} "cxxrt")

View File

@ -1,26 +0,0 @@
Based on:
https://github.com/uTox/uTox/commit/22b183433c37d51867ec4eb55813ac2b1db6477c
--- src/xlib/main.c.orig 2019-02-17 05:10:45 UTC
+++ src/xlib/main.c
@@ -94,6 +94,11 @@ void init_ptt(void) {
#ifdef __linux__
#include <linux/input.h>
+#elif defined(__DragonFly__) || defined(__FreeBSD__)
+#include <linux/input.h>
+#endif
+
+#if defined(__linux__) || defined(__DragonFly__) || defined(__FreeBSD__)
static bool linux_check_ptt(void) {
/* First, we try for direct access to the keyboard. */
int ptt_key = KEY_LEFTCTRL; // TODO allow user to change this...
@@ -146,7 +151,7 @@ bool check_ptt_key(void) {
return true; /* If push to talk is disabled, return true. */
}
-#ifdef __linux__
+#if defined(__linux__) || defined(__DragonFly__) || defined(__FreeBSD__)
return linux_check_ptt();
#else
return bsd_check_ptt();