Add lablgl 0.97, OpenGL interface for Objective Caml.
PR: 33961 Submitted by: Ronald Kuehn <rk@ronald.org>
This commit is contained in:
parent
20750047b8
commit
7847cc63ef
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=62095
@ -151,6 +151,7 @@
|
||||
SUBDIR += kisomandel
|
||||
SUBDIR += kludge3d
|
||||
SUBDIR += kuickshow
|
||||
SUBDIR += lablgl
|
||||
SUBDIR += landscape
|
||||
SUBDIR += lcms
|
||||
SUBDIR += leafpak
|
||||
|
36
graphics/lablgl/Makefile
Normal file
36
graphics/lablgl/Makefile
Normal file
@ -0,0 +1,36 @@
|
||||
# New ports collection makefile for: lablgl
|
||||
# Date created: 13. January 2002
|
||||
# Whom: Ronald Kuehn <rk@ronald.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= lablgl
|
||||
PORTVERSION= 0.97
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= http://wwwfun.kurims.kyoto-u.ac.jp/soft/olabl/dist/ \
|
||||
ftp://ftp.inria.fr/lang/caml-light/bazar-ocaml/
|
||||
|
||||
MAINTAINER= rk@ronald.org
|
||||
|
||||
BUILD_DEPENDS= ocamlc:${PORTSDIR}/lang/ocaml
|
||||
RUN_DEPENDS= ocamlc:${PORTSDIR}/lang/ocaml
|
||||
|
||||
USE_MESA= yes
|
||||
WRKSRC= ${WRKDIR}/lablGL-${PORTVERSION}
|
||||
ALL_TARGET= all opt
|
||||
EXAMPLESDIR= ${PREFIX}/share/examples/ocaml/${PORTNAME}
|
||||
DOCSDIR= ${PREFIX}/share/doc/ocaml/${PORTNAME}
|
||||
|
||||
post-extract:
|
||||
@${CP} ${WRKSRC}/Makefile.config.ex ${WRKSRC}/Makefile.config
|
||||
|
||||
post-install:
|
||||
@${MKDIR} ${EXAMPLESDIR}
|
||||
@${INSTALL_DATA} ${WRKSRC}/examples/* ${EXAMPLESDIR}
|
||||
.if !defined(NO_PORTDOCS)
|
||||
@${MKDIR} ${DOCSDIR}
|
||||
@${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
1
graphics/lablgl/distinfo
Normal file
1
graphics/lablgl/distinfo
Normal file
@ -0,0 +1 @@
|
||||
MD5 (lablgl-0.97.tar.gz) = e084a62ff47492cade8887f3f6b60c5b
|
13
graphics/lablgl/files/patch-aa
Normal file
13
graphics/lablgl/files/patch-aa
Normal file
@ -0,0 +1,13 @@
|
||||
--- Makefile.orig Thu Nov 1 09:44:16 2001
|
||||
+++ Makefile Sun Jan 13 19:27:18 2002
|
||||
@@ -104,8 +104,8 @@
|
||||
|
||||
real-install:
|
||||
if test -d $(INSTALLDIR); then : ; else mkdir -p $(INSTALLDIR); fi
|
||||
- if test `grep -s -c '^$(INSTALLDIR)$$' $(LIBDIR)/ld.conf || :` = 0; \
|
||||
- then echo $(INSTALLDIR) >> $(LIBDIR)/ld.conf; fi
|
||||
+# if test `grep -s -c '^$(INSTALLDIR)$$' $(LIBDIR)/ld.conf || :` = 0; \
|
||||
+# then echo $(INSTALLDIR) >> $(LIBDIR)/ld.conf; fi
|
||||
cp $(MLOBJS:.cmo=.cmi) $(INSTALLDIR)
|
||||
cp $(MLOBJS:.cmo=.mli) $(INSTALLDIR)
|
||||
cp liblablgl.a lablgl.cma libtogl.a togl.cma $(INSTALLDIR)
|
39
graphics/lablgl/files/patch-ab
Normal file
39
graphics/lablgl/files/patch-ab
Normal file
@ -0,0 +1,39 @@
|
||||
--- Makefile.config.orig Sun Jan 13 19:30:59 2002
|
||||
+++ Makefile.config Sun Jan 13 19:44:33 2002
|
||||
@@ -7,22 +7,22 @@
|
||||
##### Adjust these always
|
||||
|
||||
# Where to put the lablgl script
|
||||
-BINDIR = /usr/local/bin
|
||||
+BINDIR = ${PREFIX}/bin
|
||||
|
||||
# Where to find X headers
|
||||
-XINCLUDES = -I/usr/X11R6/include
|
||||
+XINCLUDES = -I${X11BASE}/include
|
||||
# X libs (for broken RTLD_GLOBAL: e.g. FreeBSD 4.0)
|
||||
#XLIBS = -L/usr/X11R6/lib -lXext -lXmu -lX11
|
||||
|
||||
# Where to find Tcl/Tk headers
|
||||
# This must the same version as for LablTk
|
||||
-TKINCLUDES = -I/usr/local/include
|
||||
+TKINCLUDES = -I${LOCALBASE}/include/tcl8.3 -I${LOCALBASE}/include/tk8.3
|
||||
# Tcl/Tk libs (for broken RTLD_GLOBAL: e.g. FreeBSD 4.0)
|
||||
-#TKLIBS = -L/usr/local/lib -ltk83 -ltcl83
|
||||
+TKLIBS = -L${LOCALBASE}/lib -ltk83 -ltcl83
|
||||
|
||||
# Where to find OpenGL/Mesa headers and libraries
|
||||
GLINCLUDES =
|
||||
-GLLIBS = -lGL -lGLU
|
||||
+GLLIBS = -L${X11BASE}/lib -R${X11BASE}/lib -lGL -lGLU -lXmu -lXext
|
||||
# The following libraries may be required (try to add them one at a time)
|
||||
# GLLIBS = -lGL -lGLU -lXmu -lXext -lpthread
|
||||
|
||||
@@ -45,7 +45,7 @@
|
||||
TOGLDIR = Togl
|
||||
|
||||
# C Compiler options
|
||||
-COPTS = -c -O
|
||||
+COPTS = -c ${CFLAGS}
|
||||
|
||||
###### No need to change these
|
||||
|
1
graphics/lablgl/pkg-comment
Normal file
1
graphics/lablgl/pkg-comment
Normal file
@ -0,0 +1 @@
|
||||
OpenGL interface for Objective Caml
|
10
graphics/lablgl/pkg-descr
Normal file
10
graphics/lablgl/pkg-descr
Normal file
@ -0,0 +1,10 @@
|
||||
LablGL is an OpenGL interface for Objective Caml. Since it includes
|
||||
support for the Togl widget, you can comfortably use it with LablTk.
|
||||
|
||||
All of the GL and GLU libraries are available. Read a good book
|
||||
about how to use these. Translating from OpenGL to LablGL is rather
|
||||
straitforward: there is a LablGL function for each OpenGL one. For
|
||||
ease of retrieving, both GL and GLU are cut in smaller modules of
|
||||
related functions.
|
||||
|
||||
Please see ${PREFIX}/share/doc/ocaml/lablgl/README for further information.
|
81
graphics/lablgl/pkg-plist
Normal file
81
graphics/lablgl/pkg-plist
Normal file
@ -0,0 +1,81 @@
|
||||
bin/lablgl
|
||||
lib/ocaml/lablGL/raw.cmi
|
||||
lib/ocaml/lablGL/gluMat.cmi
|
||||
lib/ocaml/lablGL/gluTess.cmi
|
||||
lib/ocaml/lablGL/gluQuadric.cmi
|
||||
lib/ocaml/lablGL/gluNurbs.cmi
|
||||
lib/ocaml/lablGL/gluMisc.cmi
|
||||
lib/ocaml/lablGL/glFunc.cmi
|
||||
lib/ocaml/lablGL/glDraw.cmi
|
||||
lib/ocaml/lablGL/glTex.cmi
|
||||
lib/ocaml/lablGL/glClear.cmi
|
||||
lib/ocaml/lablGL/glPix.cmi
|
||||
lib/ocaml/lablGL/glMisc.cmi
|
||||
lib/ocaml/lablGL/glMat.cmi
|
||||
lib/ocaml/lablGL/glMap.cmi
|
||||
lib/ocaml/lablGL/glList.cmi
|
||||
lib/ocaml/lablGL/glLight.cmi
|
||||
lib/ocaml/lablGL/gl.cmi
|
||||
lib/ocaml/lablGL/togl.cmi
|
||||
lib/ocaml/lablGL/raw.mli
|
||||
lib/ocaml/lablGL/gluMat.mli
|
||||
lib/ocaml/lablGL/gluTess.mli
|
||||
lib/ocaml/lablGL/gluQuadric.mli
|
||||
lib/ocaml/lablGL/gluNurbs.mli
|
||||
lib/ocaml/lablGL/gluMisc.mli
|
||||
lib/ocaml/lablGL/glFunc.mli
|
||||
lib/ocaml/lablGL/glDraw.mli
|
||||
lib/ocaml/lablGL/glTex.mli
|
||||
lib/ocaml/lablGL/glClear.mli
|
||||
lib/ocaml/lablGL/glPix.mli
|
||||
lib/ocaml/lablGL/glMisc.mli
|
||||
lib/ocaml/lablGL/glMat.mli
|
||||
lib/ocaml/lablGL/glMap.mli
|
||||
lib/ocaml/lablGL/glList.mli
|
||||
lib/ocaml/lablGL/glLight.mli
|
||||
lib/ocaml/lablGL/gl.mli
|
||||
lib/ocaml/lablGL/togl.mli
|
||||
lib/ocaml/lablGL/togl.cma
|
||||
lib/ocaml/lablGL/libtogl.a
|
||||
lib/ocaml/lablGL/lablgl.cma
|
||||
lib/ocaml/lablGL/liblablgl.a
|
||||
lib/ocaml/lablGL/lablgltop
|
||||
lib/ocaml/lablGL/dlltogl.so
|
||||
lib/ocaml/lablGL/dlllablgl.so
|
||||
lib/ocaml/lablGL/lablgl.cmxa
|
||||
lib/ocaml/lablGL/gluMat.cmx
|
||||
lib/ocaml/lablGL/gluTess.cmx
|
||||
lib/ocaml/lablGL/gluQuadric.cmx
|
||||
lib/ocaml/lablGL/gluNurbs.cmx
|
||||
lib/ocaml/lablGL/gluMisc.cmx
|
||||
lib/ocaml/lablGL/glFunc.cmx
|
||||
lib/ocaml/lablGL/glDraw.cmx
|
||||
lib/ocaml/lablGL/glTex.cmx
|
||||
lib/ocaml/lablGL/glClear.cmx
|
||||
lib/ocaml/lablGL/glPix.cmx
|
||||
lib/ocaml/lablGL/glMisc.cmx
|
||||
lib/ocaml/lablGL/glMat.cmx
|
||||
lib/ocaml/lablGL/glMap.cmx
|
||||
lib/ocaml/lablGL/glList.cmx
|
||||
lib/ocaml/lablGL/glLight.cmx
|
||||
lib/ocaml/lablGL/gl.cmx
|
||||
lib/ocaml/lablGL/raw.cmx
|
||||
lib/ocaml/lablGL/togl.a
|
||||
lib/ocaml/lablGL/togl.cmxa
|
||||
lib/ocaml/lablGL/lablgl.a
|
||||
lib/ocaml/lablGL/togl.cmx
|
||||
%%PORTDOCS%%share/doc/ocaml/lablgl/README
|
||||
share/examples/ocaml/lablgl/Makefile
|
||||
share/examples/ocaml/lablgl/README
|
||||
share/examples/ocaml/lablgl/checker.ml
|
||||
share/examples/ocaml/lablgl/double.ml
|
||||
share/examples/ocaml/lablgl/gears.ml
|
||||
share/examples/ocaml/lablgl/morph3d.ml
|
||||
share/examples/ocaml/lablgl/planet.ml
|
||||
share/examples/ocaml/lablgl/scene.ml
|
||||
share/examples/ocaml/lablgl/simple.ml
|
||||
share/examples/ocaml/lablgl/tennis.ml
|
||||
share/examples/ocaml/lablgl/texturesurf.ml
|
||||
@dirrm lib/ocaml/lablGL
|
||||
@dirrm share/examples/ocaml/lablgl
|
||||
%%PORTDOCS%%@dirrm share/doc/ocaml/lablgl
|
36
graphics/ocaml-lablgl/Makefile
Normal file
36
graphics/ocaml-lablgl/Makefile
Normal file
@ -0,0 +1,36 @@
|
||||
# New ports collection makefile for: lablgl
|
||||
# Date created: 13. January 2002
|
||||
# Whom: Ronald Kuehn <rk@ronald.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= lablgl
|
||||
PORTVERSION= 0.97
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= http://wwwfun.kurims.kyoto-u.ac.jp/soft/olabl/dist/ \
|
||||
ftp://ftp.inria.fr/lang/caml-light/bazar-ocaml/
|
||||
|
||||
MAINTAINER= rk@ronald.org
|
||||
|
||||
BUILD_DEPENDS= ocamlc:${PORTSDIR}/lang/ocaml
|
||||
RUN_DEPENDS= ocamlc:${PORTSDIR}/lang/ocaml
|
||||
|
||||
USE_MESA= yes
|
||||
WRKSRC= ${WRKDIR}/lablGL-${PORTVERSION}
|
||||
ALL_TARGET= all opt
|
||||
EXAMPLESDIR= ${PREFIX}/share/examples/ocaml/${PORTNAME}
|
||||
DOCSDIR= ${PREFIX}/share/doc/ocaml/${PORTNAME}
|
||||
|
||||
post-extract:
|
||||
@${CP} ${WRKSRC}/Makefile.config.ex ${WRKSRC}/Makefile.config
|
||||
|
||||
post-install:
|
||||
@${MKDIR} ${EXAMPLESDIR}
|
||||
@${INSTALL_DATA} ${WRKSRC}/examples/* ${EXAMPLESDIR}
|
||||
.if !defined(NO_PORTDOCS)
|
||||
@${MKDIR} ${DOCSDIR}
|
||||
@${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
1
graphics/ocaml-lablgl/distinfo
Normal file
1
graphics/ocaml-lablgl/distinfo
Normal file
@ -0,0 +1 @@
|
||||
MD5 (lablgl-0.97.tar.gz) = e084a62ff47492cade8887f3f6b60c5b
|
13
graphics/ocaml-lablgl/files/patch-aa
Normal file
13
graphics/ocaml-lablgl/files/patch-aa
Normal file
@ -0,0 +1,13 @@
|
||||
--- Makefile.orig Thu Nov 1 09:44:16 2001
|
||||
+++ Makefile Sun Jan 13 19:27:18 2002
|
||||
@@ -104,8 +104,8 @@
|
||||
|
||||
real-install:
|
||||
if test -d $(INSTALLDIR); then : ; else mkdir -p $(INSTALLDIR); fi
|
||||
- if test `grep -s -c '^$(INSTALLDIR)$$' $(LIBDIR)/ld.conf || :` = 0; \
|
||||
- then echo $(INSTALLDIR) >> $(LIBDIR)/ld.conf; fi
|
||||
+# if test `grep -s -c '^$(INSTALLDIR)$$' $(LIBDIR)/ld.conf || :` = 0; \
|
||||
+# then echo $(INSTALLDIR) >> $(LIBDIR)/ld.conf; fi
|
||||
cp $(MLOBJS:.cmo=.cmi) $(INSTALLDIR)
|
||||
cp $(MLOBJS:.cmo=.mli) $(INSTALLDIR)
|
||||
cp liblablgl.a lablgl.cma libtogl.a togl.cma $(INSTALLDIR)
|
39
graphics/ocaml-lablgl/files/patch-ab
Normal file
39
graphics/ocaml-lablgl/files/patch-ab
Normal file
@ -0,0 +1,39 @@
|
||||
--- Makefile.config.orig Sun Jan 13 19:30:59 2002
|
||||
+++ Makefile.config Sun Jan 13 19:44:33 2002
|
||||
@@ -7,22 +7,22 @@
|
||||
##### Adjust these always
|
||||
|
||||
# Where to put the lablgl script
|
||||
-BINDIR = /usr/local/bin
|
||||
+BINDIR = ${PREFIX}/bin
|
||||
|
||||
# Where to find X headers
|
||||
-XINCLUDES = -I/usr/X11R6/include
|
||||
+XINCLUDES = -I${X11BASE}/include
|
||||
# X libs (for broken RTLD_GLOBAL: e.g. FreeBSD 4.0)
|
||||
#XLIBS = -L/usr/X11R6/lib -lXext -lXmu -lX11
|
||||
|
||||
# Where to find Tcl/Tk headers
|
||||
# This must the same version as for LablTk
|
||||
-TKINCLUDES = -I/usr/local/include
|
||||
+TKINCLUDES = -I${LOCALBASE}/include/tcl8.3 -I${LOCALBASE}/include/tk8.3
|
||||
# Tcl/Tk libs (for broken RTLD_GLOBAL: e.g. FreeBSD 4.0)
|
||||
-#TKLIBS = -L/usr/local/lib -ltk83 -ltcl83
|
||||
+TKLIBS = -L${LOCALBASE}/lib -ltk83 -ltcl83
|
||||
|
||||
# Where to find OpenGL/Mesa headers and libraries
|
||||
GLINCLUDES =
|
||||
-GLLIBS = -lGL -lGLU
|
||||
+GLLIBS = -L${X11BASE}/lib -R${X11BASE}/lib -lGL -lGLU -lXmu -lXext
|
||||
# The following libraries may be required (try to add them one at a time)
|
||||
# GLLIBS = -lGL -lGLU -lXmu -lXext -lpthread
|
||||
|
||||
@@ -45,7 +45,7 @@
|
||||
TOGLDIR = Togl
|
||||
|
||||
# C Compiler options
|
||||
-COPTS = -c -O
|
||||
+COPTS = -c ${CFLAGS}
|
||||
|
||||
###### No need to change these
|
||||
|
1
graphics/ocaml-lablgl/pkg-comment
Normal file
1
graphics/ocaml-lablgl/pkg-comment
Normal file
@ -0,0 +1 @@
|
||||
OpenGL interface for Objective Caml
|
10
graphics/ocaml-lablgl/pkg-descr
Normal file
10
graphics/ocaml-lablgl/pkg-descr
Normal file
@ -0,0 +1,10 @@
|
||||
LablGL is an OpenGL interface for Objective Caml. Since it includes
|
||||
support for the Togl widget, you can comfortably use it with LablTk.
|
||||
|
||||
All of the GL and GLU libraries are available. Read a good book
|
||||
about how to use these. Translating from OpenGL to LablGL is rather
|
||||
straitforward: there is a LablGL function for each OpenGL one. For
|
||||
ease of retrieving, both GL and GLU are cut in smaller modules of
|
||||
related functions.
|
||||
|
||||
Please see ${PREFIX}/share/doc/ocaml/lablgl/README for further information.
|
81
graphics/ocaml-lablgl/pkg-plist
Normal file
81
graphics/ocaml-lablgl/pkg-plist
Normal file
@ -0,0 +1,81 @@
|
||||
bin/lablgl
|
||||
lib/ocaml/lablGL/raw.cmi
|
||||
lib/ocaml/lablGL/gluMat.cmi
|
||||
lib/ocaml/lablGL/gluTess.cmi
|
||||
lib/ocaml/lablGL/gluQuadric.cmi
|
||||
lib/ocaml/lablGL/gluNurbs.cmi
|
||||
lib/ocaml/lablGL/gluMisc.cmi
|
||||
lib/ocaml/lablGL/glFunc.cmi
|
||||
lib/ocaml/lablGL/glDraw.cmi
|
||||
lib/ocaml/lablGL/glTex.cmi
|
||||
lib/ocaml/lablGL/glClear.cmi
|
||||
lib/ocaml/lablGL/glPix.cmi
|
||||
lib/ocaml/lablGL/glMisc.cmi
|
||||
lib/ocaml/lablGL/glMat.cmi
|
||||
lib/ocaml/lablGL/glMap.cmi
|
||||
lib/ocaml/lablGL/glList.cmi
|
||||
lib/ocaml/lablGL/glLight.cmi
|
||||
lib/ocaml/lablGL/gl.cmi
|
||||
lib/ocaml/lablGL/togl.cmi
|
||||
lib/ocaml/lablGL/raw.mli
|
||||
lib/ocaml/lablGL/gluMat.mli
|
||||
lib/ocaml/lablGL/gluTess.mli
|
||||
lib/ocaml/lablGL/gluQuadric.mli
|
||||
lib/ocaml/lablGL/gluNurbs.mli
|
||||
lib/ocaml/lablGL/gluMisc.mli
|
||||
lib/ocaml/lablGL/glFunc.mli
|
||||
lib/ocaml/lablGL/glDraw.mli
|
||||
lib/ocaml/lablGL/glTex.mli
|
||||
lib/ocaml/lablGL/glClear.mli
|
||||
lib/ocaml/lablGL/glPix.mli
|
||||
lib/ocaml/lablGL/glMisc.mli
|
||||
lib/ocaml/lablGL/glMat.mli
|
||||
lib/ocaml/lablGL/glMap.mli
|
||||
lib/ocaml/lablGL/glList.mli
|
||||
lib/ocaml/lablGL/glLight.mli
|
||||
lib/ocaml/lablGL/gl.mli
|
||||
lib/ocaml/lablGL/togl.mli
|
||||
lib/ocaml/lablGL/togl.cma
|
||||
lib/ocaml/lablGL/libtogl.a
|
||||
lib/ocaml/lablGL/lablgl.cma
|
||||
lib/ocaml/lablGL/liblablgl.a
|
||||
lib/ocaml/lablGL/lablgltop
|
||||
lib/ocaml/lablGL/dlltogl.so
|
||||
lib/ocaml/lablGL/dlllablgl.so
|
||||
lib/ocaml/lablGL/lablgl.cmxa
|
||||
lib/ocaml/lablGL/gluMat.cmx
|
||||
lib/ocaml/lablGL/gluTess.cmx
|
||||
lib/ocaml/lablGL/gluQuadric.cmx
|
||||
lib/ocaml/lablGL/gluNurbs.cmx
|
||||
lib/ocaml/lablGL/gluMisc.cmx
|
||||
lib/ocaml/lablGL/glFunc.cmx
|
||||
lib/ocaml/lablGL/glDraw.cmx
|
||||
lib/ocaml/lablGL/glTex.cmx
|
||||
lib/ocaml/lablGL/glClear.cmx
|
||||
lib/ocaml/lablGL/glPix.cmx
|
||||
lib/ocaml/lablGL/glMisc.cmx
|
||||
lib/ocaml/lablGL/glMat.cmx
|
||||
lib/ocaml/lablGL/glMap.cmx
|
||||
lib/ocaml/lablGL/glList.cmx
|
||||
lib/ocaml/lablGL/glLight.cmx
|
||||
lib/ocaml/lablGL/gl.cmx
|
||||
lib/ocaml/lablGL/raw.cmx
|
||||
lib/ocaml/lablGL/togl.a
|
||||
lib/ocaml/lablGL/togl.cmxa
|
||||
lib/ocaml/lablGL/lablgl.a
|
||||
lib/ocaml/lablGL/togl.cmx
|
||||
%%PORTDOCS%%share/doc/ocaml/lablgl/README
|
||||
share/examples/ocaml/lablgl/Makefile
|
||||
share/examples/ocaml/lablgl/README
|
||||
share/examples/ocaml/lablgl/checker.ml
|
||||
share/examples/ocaml/lablgl/double.ml
|
||||
share/examples/ocaml/lablgl/gears.ml
|
||||
share/examples/ocaml/lablgl/morph3d.ml
|
||||
share/examples/ocaml/lablgl/planet.ml
|
||||
share/examples/ocaml/lablgl/scene.ml
|
||||
share/examples/ocaml/lablgl/simple.ml
|
||||
share/examples/ocaml/lablgl/tennis.ml
|
||||
share/examples/ocaml/lablgl/texturesurf.ml
|
||||
@dirrm lib/ocaml/lablGL
|
||||
@dirrm share/examples/ocaml/lablgl
|
||||
%%PORTDOCS%%@dirrm share/doc/ocaml/lablgl
|
Loading…
Reference in New Issue
Block a user