devel/libphonenumber: update to 8.13.4 release (+)

Changelog:	https://github.com/google/libphonenumber/blob/v8.13.4/release_notes.txt
This commit is contained in:
Dima Panov 2023-01-22 14:24:14 +03:00
parent c714d05f3d
commit 7806934ffe
4 changed files with 24 additions and 16 deletions

View File

@ -1,7 +1,6 @@
PORTNAME= libphonenumber
DISTVERSIONPREFIX= v
DISTVERSION= 8.12.56
PORTREVISION= 3
DISTVERSION= 8.13.4
CATEGORIES= devel
MAINTAINER= kde@FreeBSD.org
@ -24,4 +23,8 @@ CMAKE_ON= USE_STD_MAP
WRKSRC_SUBDIR= cpp
MAKE_JOBS_UNSAFE= yes
PLIST_SUB= SHLIB_FULL=${PORTVERSION:R} SHLIB_SHORT=${PORTVERSION:R:R}
.include <bsd.port.mk>

View File

@ -1,3 +1,3 @@
TIMESTAMP = 1663950424
SHA256 (google-libphonenumber-v8.12.56_GH0.tar.gz) = 51ec355a7e021e282b5b495ab6729dcef310598caba34c7bada41ae7c14ce919
SIZE (google-libphonenumber-v8.12.56_GH0.tar.gz) = 14574363
TIMESTAMP = 1674356278
SHA256 (google-libphonenumber-v8.13.4_GH0.tar.gz) = 7c9d1b7bc3320e1a234bdd9435486bc01fca181d74455e2866af19543289ae6c
SIZE (google-libphonenumber-v8.13.4_GH0.tar.gz) = 14756476

View File

@ -1,19 +1,20 @@
--- CMakeLists.txt.orig 2022-08-04 05:09:57 UTC
--- CMakeLists.txt.orig 2023-01-06 10:17:24 UTC
+++ CMakeLists.txt
@@ -18,7 +18,7 @@ cmake_minimum_required (VERSION 3.11)
@@ -20,7 +20,7 @@ project (libphonenumber VERSION 8.13.0)
# Pick the C++ standard to compile with.
# Abseil currently supports C++11, C++14, and C++17.
-set(CMAKE_CXX_STANDARD 11 CACHE STRING "C++ standard used to compile this project")
+set(CMAKE_CXX_STANDARD 17 CACHE STRING "C++ standard used to compile this project")
set(CMAKE_CXX_STANDARD_REQUIRED ON)
set(CMAKE_POSITION_INDEPENDENT_CODE TRUE)
project (libphonenumber)
@@ -101,6 +101,7 @@ if (${USE_ALTERNATE_FORMATS} STREQUAL "ON")
@@ -106,7 +106,7 @@ endif ()
endif ()
# Find all the required libraries and programs.
-find_package(absl)
+find_package(absl REQUIRED)
if (${USE_BOOST} STREQUAL "ON")
add_definitions ("-DI18N_PHONENUMBERS_USE_BOOST")
if (WIN32)
if(NOT absl_FOUND)
# Overide abseil install rules for subprojects

View File

@ -31,11 +31,15 @@ include/phonenumbers/region_code.h
include/phonenumbers/shortnumberinfo.h
include/phonenumbers/unicodestring.h
include/phonenumbers/utf/unicodetext.h
lib/cmake/libphonenumber/libphonenumber-config-version.cmake
lib/cmake/libphonenumber/libphonenumber-config.cmake
lib/cmake/libphonenumber/libphonenumber-targets-%%CMAKE_BUILD_TYPE%%.cmake
lib/cmake/libphonenumber/libphonenumber-targets.cmake
lib/libgeocoding.a
lib/libgeocoding.so
lib/libgeocoding.so.8
lib/libgeocoding.so.8.12
lib/libgeocoding.so.%%SHLIB_SHORT%%
lib/libgeocoding.so.%%SHLIB_FULL%%
lib/libphonenumber.a
lib/libphonenumber.so
lib/libphonenumber.so.8
lib/libphonenumber.so.8.12
lib/libphonenumber.so.%%SHLIB_SHORT%%
lib/libphonenumber.so.%%SHLIB_FULL%%