devel/apr1: Update APR to 1.6.5

- MySQL 8.0 (port marked "devel") not compatible [1]

PR:		230538 [1]
Reported by:	<please forget me.uk>
Differential Revision:	https://reviews.freebsd.org/D17688
This commit is contained in:
Bernard Spil 2018-10-27 21:46:51 +00:00
parent 00a492aee7
commit 77b5d791a4
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=483173
4 changed files with 15 additions and 10 deletions

View File

@ -3,7 +3,6 @@
PORTNAME= apr
PORTVERSION= ${APR_VERSION}.${APU_VERSION}
PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= APACHE/apr
DISTFILES= apr-${APR_VERSION}.tar.gz \
@ -20,7 +19,7 @@ USES= iconv pathfix libtool cpe
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
APR_VERSION= 1.6.3
APR_VERSION= 1.6.5
APU_VERSION= 1.6.1
CPE_VENDOR= apache
@ -120,6 +119,12 @@ APU_CONF_ARGS+= --with-crypto
APU_CONF_ARGS+= --without-crypto
.endif
.include <bsd.port.pre.mk>
.if ${PORT_OPTIONS:MMYSQL} && ${MYSQL_VER} == 80
BROKEN= Does not build with MySQL 8.0, see https://bz.apache.org/bugzilla/show_bug.cgi?id=62631
.endif
post-extract:
# cleanup files not used on this platform
@${FIND} ${WRKDIR} -type f \( -name 'NWGNU*' -o -name '*.ds?' -o -name '*.dep' -o -name '*.mak' -o -name '*.win' \) -delete
@ -170,4 +175,4 @@ rpfl: configure
${SED} -i '' -E 's|^configure:[0-9]+:|configure:_pid_:|g' ${APR_WRKDIR}/config.log
${SED} -i '' -E 's|^configure:[0-9]+:|configure:_pid_:|g' ${APU_WRKDIR}/config.log
.include <bsd.port.mk>
.include <bsd.port.post.mk>

View File

@ -1,5 +1,5 @@
TIMESTAMP = 1509875572
SHA256 (apr-1.6.3.tar.gz) = 8fdabcc0004216c3588b7dca0f23d104dfe012a47e2bb6f13827534a6ee73aa7
SIZE (apr-1.6.3.tar.gz) = 1072661
TIMESTAMP = 1540370746
SHA256 (apr-1.6.5.tar.gz) = 70dcf9102066a2ff2ffc47e93c289c8e54c95d8dda23b503f9e61bb0cbd2d105
SIZE (apr-1.6.5.tar.gz) = 1073556
SHA256 (apr-util-1.6.1.tar.gz) = b65e40713da57d004123b6319828be7f1273fbc6490e145874ee1177e112c459
SIZE (apr-util-1.6.1.tar.gz) = 554301

View File

@ -1,5 +1,5 @@
--- apr-1.6.3/configure.orig 2015-04-25 12:04:18 UTC
+++ apr-1.6.3/configure
--- apr-1.6.5/configure.orig 2015-04-25 12:04:18 UTC
+++ apr-1.6.5/configure
@@ -6624,11 +6624,7 @@ if test "x$apr_preload_done" != "xyes" ;
apr_lock_method="USE_FLOCK_SERIALIZE"
fi

View File

@ -1,8 +1,8 @@
# upstram PR: https://bz.apache.org/bugzilla/show_bug.cgi?id=59914
# FreeBSD PR: 211430
========================================================================
--- apr-1.6.3/poll/unix/kqueue.c.orig 2015-03-20 01:34:07 UTC
+++ apr-1.6.3/poll/unix/kqueue.c
--- apr-1.6.5/poll/unix/kqueue.c.orig 2015-03-20 01:34:07 UTC
+++ apr-1.6.5/poll/unix/kqueue.c
@@ -25,21 +25,40 @@
#ifdef HAVE_KQUEUE