Add kscope-0.6, a KDE-based front-end to cscope/ctags. It has multiple

project support and provides the sort of interface the cscope full-tty
front-end would provide if it were an X11 interface.

(Note: it does not handle recursively-symlinked directories well.
       This means you, src/sys/<arch>/compile/<KERNEL>/.)

Submitted by:	Frank Mayhar <frank@exit.com>
PR:		ports/65863
This commit is contained in:
Brian Feldman 2004-04-30 03:02:33 +00:00
parent a2a5be2c06
commit 7761770917
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=107997
6 changed files with 86 additions and 0 deletions

View File

@ -347,6 +347,7 @@
SUBDIR += kimwitu++
SUBDIR += korelib
SUBDIR += kprof
SUBDIR += kscope
SUBDIR += kyra
SUBDIR += lbpp
SUBDIR += leaktracer

36
devel/kscope/Makefile Normal file
View File

@ -0,0 +1,36 @@
# New ports collection makefile for: kscope
# Date created: 2004-04-21
# Whom: Frank Mayhar <frank@exit.com>
#
# $FreeBSD$
#
PORTNAME= kscope
PORTVERSION= 0.6
CATEGORIES= devel kde
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR=${PORTNAME}/
MAINTAINER= frank@exit.com
COMMENT= KDE front-end to Cscope
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg
RUN_DEPENDS= exctags:${PORTSDIR}/devel/ctags \
cscope:${PORTSDIR}/devel/cscope
USE_KDELIBS_VER=3
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_REINPLACE= yes
MAKE_ENV= EXTRA_LIBRARIES="-L${LOCALBASE}/lib"
CONFIGURE_ARGS+=--with-extra-includes=${LOCALBASE}/include \
--with-extra-libs=${LOCALBASE}/lib
pre-build:
${REINPLACE_CMD} "s,-pthread,${PTHREAD_LIBS},g" ${WRKSRC}/Makefile
.include <bsd.port.pre.mk>
.include "${PORTSDIR}/x11/kde3/Makefile.kde"
.include <bsd.port.post.mk>

2
devel/kscope/distinfo Normal file
View File

@ -0,0 +1,2 @@
MD5 (kscope-0.6.tar.gz) = 7a273bca1ed74abd1e1e83224c283eb8
SIZE (kscope-0.6.tar.gz) = 992145

View File

@ -0,0 +1,11 @@
--- /homes/fmayhar/kscope-0.5/src/ctagsfrontend.cpp Thu Dec 18 20:58:30 2003
+++ src/ctagsfrontend.cpp Wed Apr 21 13:01:45 2004
@@ -81,7 +81,7 @@
QFileInfo fi(sPath);
if (!fi.exists() || !fi.isFile() || !fi.isExecutable() ||
- fi.fileName() != "ctags") {
+ fi.fileName() != "exctags") {
KMessageBox::error(0, i18n("Ctags cannot be found in the given "
"path"));
return false;

11
devel/kscope/pkg-descr Normal file
View File

@ -0,0 +1,11 @@
From the documentation:
KScope is a source-editing environment for KDE. Primarily, it is a
front-end to the veteran Cscope, a source-code browser originally
developed at Bell XLabs. Cscope works by parsing a set of source files,
creating a cross- reference database, and allowing the user to query
this database. KScope, however, extends the feature-set of Cscope with
a contemporary user Xinterface, editor integration, project management
capabilities, and multiple query result windows.
WWW: http://kscope.sourceforge.net/

25
devel/kscope/pkg-plist Normal file
View File

@ -0,0 +1,25 @@
bin/kscope
share/doc/HTML/en/kscope/project_new.png
share/doc/HTML/en/kscope/query_dlg.png
share/doc/HTML/en/kscope/call_tree.png
share/doc/HTML/en/kscope/project_open.png
share/doc/HTML/en/kscope/main_window.png
share/doc/HTML/en/kscope/pref.png
share/doc/HTML/en/kscope/project_files.png
share/doc/HTML/en/kscope/welcome.png
share/doc/HTML/en/kscope/index.docbook
share/doc/HTML/en/kscope/index.cache.bz2
share/doc/HTML/en/kscope/common
share/icons/locolor/16x16/apps/kscope.png
share/icons/hicolor/32x32/apps/kscope.png
share/icons/locolor/32x32/apps/kscope.png
share/icons/hicolor/16x16/apps/kscope.png
share/applnk/Utilities/kscope.desktop
share/apps/kscope/kscopeui.rc
@unexec rmdir %D/share/icons/locolor/16x16/apps 2>/dev/null || true
@unexec rmdir %D/share/icons/locolor/32x32/apps 2>/dev/null || true
@unexec rmdir %D/share/icons/hicolor/16x16/apps 2>/dev/null || true
@unexec rmdir %D/share/icons/hicolor/32x32/apps 2>/dev/null || true
@unexec rmdir %D/share/applnk/Utilities 2>/dev/null || true
@dirrm share/doc/HTML/en/kscope
@dirrm share/apps/kscope