Import of 3dpong v0.3, a three-dimensional pong game for X11.

PR:		5973
Submitted by:	Andrey Zakhvatov <andy@icc.surw.chel.su>
This commit is contained in:
Matthew Hunt 1998-04-27 03:51:05 +00:00
parent ef24a58036
commit 7701e49637
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=10696
7 changed files with 77 additions and 0 deletions

27
games/3dpong/Makefile Normal file
View File

@ -0,0 +1,27 @@
# New ports collection makefile for: 3dpong
# Version required: 0.3
# Date created: 10 March 1998
# Whom: Andrey Zakhvatov
#
# $Id$
#
DISTNAME= 3dpong.0.3
PKGNAME= 3dpong-0.3
CATEGORIES= games x11
MASTER_SITES= http://zippy.sonoma.edu/kendrick/nbs/unix/x/3dpong/
MAINTAINER= andy@icc.surw.chel.su
MAKEFILE= makefile
USE_X11= yes
WRKSRC= ${WRKDIR}/3dpong
do-install:
@ ${INSTALL_PROGRAM} ${WRKSRC}/3dpong ${PREFIX}/bin
@ ${MKDIR} ${PREFIX}/share/3dpong
@ ${INSTALL_DATA} ${WRKSRC}/sounds/*.au ${PREFIX}/share/3dpong
@ ${MKDIR} ${PREFIX}/share/doc/3dpong
@ ${INSTALL_DATA} ${WRKSRC}/README.txt ${PREFIX}/share/doc/3dpong
.include <bsd.port.mk>

1
games/3dpong/distinfo Normal file
View File

@ -0,0 +1 @@
MD5 (3dpong.0.3.tar.gz) = 4158e42189730d2cebce82689b2677dc

View File

@ -0,0 +1,25 @@
--- makefile.orig Mon Jan 26 17:18:05 1998
+++ makefile Sun Apr 26 23:48:06 1998
@@ -11,11 +11,11 @@
# Makefile user-definable variables
-CC=gcc
+CC+=$(CFLAGS) -I$(X11BASE)/include -DPREFIX=\"${PREFIX}\"
MATHLIB=-lm
# adjust according to target
-XLIB=-lX11
+XLIB=-L$(X11BASE)/lib -lX11
# uncomment for sunos/solaris
#XLIB=-L/usr/openwin/lib -lX11
@@ -43,7 +43,7 @@
# Application:
3dpong: $(OBJECTS)
- $(CC) $(OBJECTS) $(XLIB) $(MATHLIB) -o 3dpong
+ $(CC) $(CFLAGS) $(OBJECTS) $(XLIB) $(MATHLIB) -o 3dpong
chmod 755 3dpong
strip 3dpong

View File

@ -0,0 +1,11 @@
--- 3dpong.c Mon Jan 26 20:33:47 1998
+++ /home/andy/tmp/wrk/3dpong.c Tue Mar 10 20:58:20 1998
@@ -1651,7 +1651,7 @@
if (use_sound == 1)
{
- sprintf(cmd, "/bin/cat sounds/%s.au > /dev/audio &", aufile);
+ sprintf(cmd, "/bin/cat " PREFIX "/share/3dpong/%s.au > /dev/audio &", aufile);
system(cmd);
}

1
games/3dpong/pkg-comment Normal file
View File

@ -0,0 +1 @@
X Window 3D Pong game for 1 or 2 players with a ball and paddles.

5
games/3dpong/pkg-descr Normal file
View File

@ -0,0 +1,5 @@
3D Pong is an X-Window game for 1 or 2 players. It's a 3D game based
on the first arcade game, "Pong." Like "Pong," it's a game played with
a ball and paddles. The object is to hit the ball and get it in the
other player's goal. Use your paddle to deflect the ball and keep it
from getting in your goal.

7
games/3dpong/pkg-plist Normal file
View File

@ -0,0 +1,7 @@
bin/3dpong
share/3dpong/hit.au
share/3dpong/score.au
share/3dpong/wall.au
share/doc/3dpong/README.txt
@dirrm share/3dpong
@dirrm share/doc/3dpong