Upgrade to version 1.1

PR: 27060
Submitted by: MAINTAINER
This commit is contained in:
Kevin Lo 2001-05-07 15:41:33 +00:00
parent f1195ccd55
commit 76f376cc9f
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=42373
10 changed files with 144 additions and 54 deletions

View File

@ -6,7 +6,7 @@
#
PORTNAME= sing
PORTVERSION= 1.0
PORTVERSION= 1.1
CATEGORIES= net security
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@ -15,10 +15,15 @@ EXTRACT_SUFX= .tgz
MAINTAINER= roman@xpert.com
BUILD_DEPENDS= ${LOCALBASE}/lib/libnet.a:${PORTSDIR}/net/libnet \
CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS+= --with-libnet-prefix=${LOCALBASE} --with-libpcap-prefix=/usr
GNU_CONFIGURE= yes
MAN8= sing.8
post-extract:
@${RM} -rf ${WRKSRC}/libpcap*
@${RM} -rf ${WRKSRC}/libpcap-* ;\
${RM} -rf ${WRKSRC}/Libnet-*
.include <bsd.port.mk>

View File

@ -1 +1 @@
MD5 (SING-1.0.tgz) = 0e478a271068eefc6e26e45d236e7694
MD5 (SING-1.1.tgz) = f9f649c4b40174a983601d46e4a3daac

View File

@ -1,24 +1,24 @@
--- Makefile.in.orig Sat Sep 16 13:03:43 2000
+++ Makefile.in Fri Oct 6 01:17:29 2000
@@ -72,7 +72,7 @@
getopt_SOURCES = @getopt_SOURCES@
--- Makefile.in.orig Wed Apr 18 14:11:06 2001
+++ Makefile.in Thu May 3 16:01:19 2001
@@ -76,7 +76,7 @@
libnetdir = @libnetdir@
libpcapdir = @libpcapdir@
-INCLUDES = -I$(includedir) -I$(libpcapdir)
+INCLUDES = -I$(includedir) # -I$(libpcapdir)
-INCLUDES = -I$(includedir) -I$(libpcapdir) -I$(libnetdir)/include
+INCLUDES = -I$(includedir) #-I$(libpcapdir) -I$(libnetdir)/include
LIBS = @LIBS@ -lpcap
LIBS = @LIBS@ -lpcap -lnet
@@ -108,7 +108,7 @@
@@ -111,7 +111,7 @@
SOURCES = $(sing_SOURCES)
OBJECTS = $(sing_OBJECTS)
-all: libpcap all-redirect
-all: libpcap libnet all-redirect
+all: all-redirect
.SUFFIXES:
.SUFFIXES: .S .c .o .s
@@ -149,11 +149,11 @@
@@ -152,11 +152,11 @@
install-binPROGRAMS: $(bin_PROGRAMS)
@$(NORMAL_INSTALL)
@ -33,7 +33,7 @@
else :; fi; \
done
@@ -223,8 +223,7 @@
@@ -226,8 +226,7 @@
help.o: help.c config.h

View File

@ -1,13 +0,0 @@
--- configure.orig Fri Oct 6 01:19:57 2000
+++ configure Fri Oct 6 01:20:05 2000
@@ -1097,10 +1097,6 @@
fi
fi
-if test -n "$GCC"; then
- CFLAGS="-O3 -Wall"
-fi
-
echo $ac_n "checking how to run the C preprocessor""... $ac_c" 1>&6
echo "configure:1104: checking how to run the C preprocessor" >&5
# On Suns, sometimes $CPP names a directory.

View File

@ -0,0 +1,53 @@
--- configure.orig Thu May 3 17:44:18 2001
+++ configure Thu May 3 16:33:56 2001
@@ -11,6 +11,10 @@
ac_help=
ac_default_prefix=/usr/local
# Any additions from configure.in:
+ac_help="$ac_help
+ --with-libnet-prefix=PATH path for libnet-config"
+ac_help="$ac_help
+ --with-libpcap-prefix=PATH path for libpcap"
# Initialize some variables set by options.
# The variables have the same names as the options, with
@@ -526,8 +530,23 @@
-libpcapdir=libpcap-0.4
-libnetdir=Libnet-1.0.1b
+# Check whether --with-libnet-prefix or --without-libnet-prefix was given.
+if test "${with_libnet_prefix+set}" = set; then
+ withval="$with_libnet_prefix/bin"
+ libnetdir="$withval"
+else
+ libnetdir="Libnet-1.0.1b"
+fi
+
+
+# Check whether --with-libpcap-prefix or --without-libpcap-prefix was given.
+if test "${with_libpcap_prefix+set}" = set; then
+ withval="$with_libpcap_prefix"
+ libpcapdir="$withval"
+else
+ libpcapdir="libpcap-0.4"
+fi
+
@@ -1097,12 +1116,9 @@
fi
fi
-if test -n "$GCC"; then
- CFLAGS="-O3 -Wall"
-fi
echo $ac_n "checking how to run the C preprocessor""... $ac_c" 1>&6
-echo "configure:1106: checking how to run the C preprocessor" >&5
+echo "configure:1122: checking how to run the C preprocessor" >&5
# On Suns, sometimes $CPP names a directory.
if test -n "$CPP" && test -d "$CPP"; then
CPP=

View File

@ -6,7 +6,7 @@
#
PORTNAME= sing
PORTVERSION= 1.0
PORTVERSION= 1.1
CATEGORIES= net security
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@ -15,10 +15,15 @@ EXTRACT_SUFX= .tgz
MAINTAINER= roman@xpert.com
BUILD_DEPENDS= ${LOCALBASE}/lib/libnet.a:${PORTSDIR}/net/libnet \
CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS+= --with-libnet-prefix=${LOCALBASE} --with-libpcap-prefix=/usr
GNU_CONFIGURE= yes
MAN8= sing.8
post-extract:
@${RM} -rf ${WRKSRC}/libpcap*
@${RM} -rf ${WRKSRC}/libpcap-* ;\
${RM} -rf ${WRKSRC}/Libnet-*
.include <bsd.port.mk>

View File

@ -1 +1 @@
MD5 (SING-1.0.tgz) = 0e478a271068eefc6e26e45d236e7694
MD5 (SING-1.1.tgz) = f9f649c4b40174a983601d46e4a3daac

View File

@ -1,24 +1,24 @@
--- Makefile.in.orig Sat Sep 16 13:03:43 2000
+++ Makefile.in Fri Oct 6 01:17:29 2000
@@ -72,7 +72,7 @@
getopt_SOURCES = @getopt_SOURCES@
--- Makefile.in.orig Wed Apr 18 14:11:06 2001
+++ Makefile.in Thu May 3 16:01:19 2001
@@ -76,7 +76,7 @@
libnetdir = @libnetdir@
libpcapdir = @libpcapdir@
-INCLUDES = -I$(includedir) -I$(libpcapdir)
+INCLUDES = -I$(includedir) # -I$(libpcapdir)
-INCLUDES = -I$(includedir) -I$(libpcapdir) -I$(libnetdir)/include
+INCLUDES = -I$(includedir) #-I$(libpcapdir) -I$(libnetdir)/include
LIBS = @LIBS@ -lpcap
LIBS = @LIBS@ -lpcap -lnet
@@ -108,7 +108,7 @@
@@ -111,7 +111,7 @@
SOURCES = $(sing_SOURCES)
OBJECTS = $(sing_OBJECTS)
-all: libpcap all-redirect
-all: libpcap libnet all-redirect
+all: all-redirect
.SUFFIXES:
.SUFFIXES: .S .c .o .s
@@ -149,11 +149,11 @@
@@ -152,11 +152,11 @@
install-binPROGRAMS: $(bin_PROGRAMS)
@$(NORMAL_INSTALL)
@ -33,7 +33,7 @@
else :; fi; \
done
@@ -223,8 +223,7 @@
@@ -226,8 +226,7 @@
help.o: help.c config.h

View File

@ -1,13 +0,0 @@
--- configure.orig Fri Oct 6 01:19:57 2000
+++ configure Fri Oct 6 01:20:05 2000
@@ -1097,10 +1097,6 @@
fi
fi
-if test -n "$GCC"; then
- CFLAGS="-O3 -Wall"
-fi
-
echo $ac_n "checking how to run the C preprocessor""... $ac_c" 1>&6
echo "configure:1104: checking how to run the C preprocessor" >&5
# On Suns, sometimes $CPP names a directory.

View File

@ -0,0 +1,53 @@
--- configure.orig Thu May 3 17:44:18 2001
+++ configure Thu May 3 16:33:56 2001
@@ -11,6 +11,10 @@
ac_help=
ac_default_prefix=/usr/local
# Any additions from configure.in:
+ac_help="$ac_help
+ --with-libnet-prefix=PATH path for libnet-config"
+ac_help="$ac_help
+ --with-libpcap-prefix=PATH path for libpcap"
# Initialize some variables set by options.
# The variables have the same names as the options, with
@@ -526,8 +530,23 @@
-libpcapdir=libpcap-0.4
-libnetdir=Libnet-1.0.1b
+# Check whether --with-libnet-prefix or --without-libnet-prefix was given.
+if test "${with_libnet_prefix+set}" = set; then
+ withval="$with_libnet_prefix/bin"
+ libnetdir="$withval"
+else
+ libnetdir="Libnet-1.0.1b"
+fi
+
+
+# Check whether --with-libpcap-prefix or --without-libpcap-prefix was given.
+if test "${with_libpcap_prefix+set}" = set; then
+ withval="$with_libpcap_prefix"
+ libpcapdir="$withval"
+else
+ libpcapdir="libpcap-0.4"
+fi
+
@@ -1097,12 +1116,9 @@
fi
fi
-if test -n "$GCC"; then
- CFLAGS="-O3 -Wall"
-fi
echo $ac_n "checking how to run the C preprocessor""... $ac_c" 1>&6
-echo "configure:1106: checking how to run the C preprocessor" >&5
+echo "configure:1122: checking how to run the C preprocessor" >&5
# On Suns, sometimes $CPP names a directory.
if test -n "$CPP" && test -d "$CPP"; then
CPP=