- Update to version 0.30.3

PR:		ports/100027
Submitted by:	KATO Tsuguru <tkato432@yahoo.com>
This commit is contained in:
Ion-Mihai Tetcu 2006-07-10 21:07:51 +00:00
parent aabe288d02
commit 76df383f34
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=167405
14 changed files with 99 additions and 76 deletions

View File

@ -6,8 +6,7 @@
#
PORTNAME= aube
PORTVERSION= 0.30.2
PORTREVISION= 2
PORTVERSION= 0.30.3
CATEGORIES= audio gnome
MASTER_SITES= http://www.metadecks.org/software/aube/download/
@ -17,12 +16,23 @@ COMMENT= System for sound generation and processing
LIB_DEPENDS= audiofile.0:${PORTSDIR}/audio/libaudiofile
USE_X_PREFIX= yes
USE_GNOME= imlib
USE_GMAKE= yes
GNU_CONFIGURE= yes
USE_GNOME= gnomeprefix gnomehier gnomehack gtk12 imlib
USE_AUTOTOOLS= libtool:15
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
MAN1= aube.1
PLIST_FILES= bin/aube \
%%DATADIR%%/aube_logo.ppm \
%%DATADIR%%/aube_mini.png \
%%DATADIR%%/gtkrc
PLIST_DIRS= %%DATADIR%%
post-patch:
@${REINPLACE_CMD} -e \
's|-lgdk_imlib|@GDK_IMLIB_LIBS@|g' ${WRKSRC}/src/Makefile.in
@${REINPLACE_CMD} -e \
's|-g -O2 -Wall|@CFLAGS@|g' ${WRKSRC}/src/modules/Makefile.in
.include <bsd.port.mk>

View File

@ -1,3 +1,3 @@
MD5 (aube-0.30.2.tar.gz) = dffa22ed759d05d2b110f03d09906ccf
SHA256 (aube-0.30.2.tar.gz) = 2436f981e325d71baed86cd3b5e57b961f13d6e732ec0a7e6d585a0741fd14d7
SIZE (aube-0.30.2.tar.gz) = 206407
MD5 (aube-0.30.3.tar.gz) = f3244a658f2ffd3bcc4f1f5778b58f3d
SHA256 (aube-0.30.3.tar.gz) = b8d8406b5bdba701aa0f0ece65ceae0f2681251127c258b1775ee11ee4d24b4e
SIZE (aube-0.30.3.tar.gz) = 206516

View File

@ -1,68 +1,24 @@
--- configure.orig Tue Jun 10 00:01:58 2003
+++ configure Tue Jun 10 00:04:25 2003
@@ -2250,27 +2250,29 @@
#AM_PATH_GENERIC(xml, 0.99.0)
-echo $ac_n "checking for in -l""... $ac_c" 1>&6
-echo "configure:2255: checking for in -l" >&5
-ac_lib_var=`echo '_' | sed 'y%./+-%__p_%'`
+LIBS=""
+echo $ac_n "checking for gdk_imlib_render in -lgdk_imlib""... $ac_c" 1>&6
+echo "configure:6942: checking for gdk_imlib_render in -lgdk_imlib" >&5
+ac_lib_var=`echo gdk_imlib'_'gdk_imlib_render | sed 'y%./+-%__p_%'`
if eval "test \"`echo '$''{'ac_cv_lib_$ac_lib_var'+set}'`\" = set"; then
--- configure.orig Wed Oct 16 20:42:09 2002
+++ configure Mon Jun 19 18:54:58 2006
@@ -2257,7 +2257,8 @@
echo $ac_n "(cached) $ac_c" 1>&6
else
ac_save_LIBS="$LIBS"
-LIBS="-l $LIBS"
-cat > conftest.$ac_ext <<EOF
-#line 2263 "configure"
-LIBS="-lgdk_imlib $LIBS"
+GDK_IMLIB_LIBS=`imlib-config --libs-gdk`
+LIBS="${GTK_LIBS} ${GDK_IMLIB_LIBS} $LIBS"
+cat > conftest.$ac_ext <<EOF
+#line 6950 "configure"
cat > conftest.$ac_ext <<EOF
#line 2263 "configure"
#include "confdefs.h"
/* Override any gcc2 internal prototype to avoid an error. */
/* We use char because int might match the return type of a gcc2
builtin and then its argument prototype would still apply. */
-char ();
+char gdk_imlib_render();
int main() {
-()
+gdk_imlib_render()
; return 0; }
EOF
-if { (eval echo configure:2274: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
+if { (eval echo configure:6961: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
rm -rf conftest*
eval "ac_cv_lib_$ac_lib_var=yes"
else
@@ -2285,18 +2287,19 @@
fi
if eval "test \"`echo '$ac_cv_lib_'$ac_lib_var`\" = yes"; then
echo "$ac_t""yes" 1>&6
- ac_tr_lib=HAVE_LIB`echo | sed -e 's/[^a-zA-Z0-9_]/_/g' \
+ ac_tr_lib=HAVE_LIB`echo gdk_imlib | sed -e 's/[^a-zA-Z0-9_]/_/g' \
-e 'y/abcdefghijklmnopqrstuvwxyz/ABCDEFGHIJKLMNOPQRSTUVWXYZ/'`
cat >> confdefs.h <<EOF
#define $ac_tr_lib 1
EOF
- LIBS="-l $LIBS"
+ LIBS="-lgdk_imlib $LIBS"
@@ -2295,6 +2296,7 @@
else
echo "$ac_t""no" 1>&6
+echo "Imlib not found!"; exit 0
fi
- (gdk_imlib, gdk_imlib_init)
+
echo $ac_n "checking for XpmReadFileToXpmImage in -lXpm""... $ac_c" 1>&6
echo "configure:2303: checking for XpmReadFileToXpmImage in -lXpm" >&5
@@ -2743,6 +2746,7 @@
@@ -2743,6 +2745,7 @@
s%@GTK_CONFIG@%$GTK_CONFIG%g
s%@GTK_CFLAGS@%$GTK_CFLAGS%g
s%@GTK_LIBS@%$GTK_LIBS%g

View File

@ -1,11 +0,0 @@
--- src/Makefile.in.orig Tue Jun 10 00:01:16 2003
+++ src/Makefile.in Tue Jun 10 00:01:40 2003
@@ -88,7 +88,7 @@
INCLUDES = -DDATADIR=\"$(pkgdatadir)\" @GTK_CFLAGS@ @AUDIOFILE_CFLAGS@
-aube_LDADD = modules/libmodules.a @AUDIOFILE_LIBS@ @GTK_LIBS@ -lgdk_imlib
+aube_LDADD = modules/libmodules.a @AUDIOFILE_LIBS@ @GTK_LIBS@ @GDK_IMLIB_LIBS@
mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
CONFIG_HEADER = ../config.h

View File

@ -0,0 +1,9 @@
--- src/modules/delay.c.orig Thu Mar 25 06:57:44 1999
+++ src/modules/delay.c Tue Jun 20 02:25:53 2006
@@ -1,5 +1,6 @@
#include <stdio.h>
+#include <stdlib.h>
#include <string.h>
#include <time.h>
#include <unistd.h>

View File

@ -0,0 +1,8 @@
--- src/modules/filter_reslp.c.orig Thu Mar 25 06:58:00 1999
+++ src/modules/filter_reslp.c Tue Jun 20 02:26:52 2006
@@ -1,4 +1,5 @@
#include <stdio.h>
+#include <stdlib.h>
#include <string.h>
#include <time.h>
#include <unistd.h>

View File

@ -0,0 +1,8 @@
--- src/modules/general_mixer.c.orig Thu Mar 25 06:58:07 1999
+++ src/modules/general_mixer.c Tue Jun 20 02:27:38 2006
@@ -1,4 +1,5 @@
#include <stdio.h>
+#include <stdlib.h>
#include <string.h>
#include <time.h>
#include <unistd.h>

View File

@ -0,0 +1,8 @@
--- src/modules/klavier.c.orig Thu Mar 25 06:58:16 1999
+++ src/modules/klavier.c Tue Jun 20 02:28:26 2006
@@ -1,4 +1,5 @@
#include <stdio.h>
+#include <stdlib.h>
#include <string.h>
#include <time.h>
#include <unistd.h>

View File

@ -0,0 +1,8 @@
--- src/modules/minimaube.c.orig Fri Mar 15 21:52:37 2002
+++ src/modules/minimaube.c Tue Jun 20 02:29:29 2006
@@ -1,4 +1,5 @@
#include <stdio.h>
+#include <stdlib.h>
#include <string.h>
#include <math.h>
#include <time.h>

View File

@ -0,0 +1,8 @@
--- src/modules/panner.c.orig Thu Mar 25 06:59:53 1999
+++ src/modules/panner.c Tue Jun 20 02:30:13 2006
@@ -1,4 +1,5 @@
#include <stdio.h>
+#include <stdlib.h>
#include <string.h>
#include <time.h>
#include <unistd.h>

View File

@ -0,0 +1,8 @@
--- src/modules/panner4.c.orig Thu Mar 25 07:00:00 1999
+++ src/modules/panner4.c Tue Jun 20 02:30:52 2006
@@ -1,4 +1,5 @@
#include <stdio.h>
+#include <stdlib.h>
#include <string.h>
#include <time.h>
#include <unistd.h>

View File

@ -0,0 +1,8 @@
--- src/modules/sample_recorder.c.orig Fri Mar 15 21:53:23 2002
+++ src/modules/sample_recorder.c Tue Jun 20 02:31:34 2006
@@ -1,4 +1,5 @@
#include <stdio.h>
+#include <stdlib.h>
#include <string.h>
#include <time.h>
#include <unistd.h>

View File

@ -0,0 +1,8 @@
--- src/modules/xfader.c.orig Thu Mar 25 07:00:35 1999
+++ src/modules/xfader.c Tue Jun 20 02:32:30 2006
@@ -1,4 +1,5 @@
#include <stdio.h>
+#include <stdlib.h>
#include <string.h>
#include <time.h>
#include <unistd.h>

View File

@ -1,5 +0,0 @@
bin/aube
share/gnome/aube/aube_logo.ppm
share/gnome/aube/aube_mini.png
share/gnome/aube/gtkrc
@dirrm share/gnome/aube