Update web2ldap to verstion 1.3.16

Also welcome py-ldap0 to the ports tree as a dependency.

This version adds a rc script to start the standalone mode.
Taking maintainership as bsam@ offered to step down.

Releasenotes:	https://web2ldap.de/changes-1.3.html#r1.3.16
PR:		227459
This commit is contained in:
Palle Girgensohn 2018-05-03 13:26:25 +00:00
parent 9fb6b9e603
commit 76c3268173
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=468926
9 changed files with 116 additions and 47 deletions

View File

@ -1051,6 +1051,7 @@
SUBDIR += py-kafka-python
SUBDIR += py-kombu
SUBDIR += py-ldap
SUBDIR += py-ldap0
SUBDIR += py-ldap3
SUBDIR += py-ldaptor
SUBDIR += py-libcloud

21
net/py-ldap0/Makefile Normal file
View File

@ -0,0 +1,21 @@
# $FreeBSD$
PORTNAME= ldap0
PORTVERSION= 0.0.60
CATEGORIES= net python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= girgen@FreeBSD.org
COMMENT= Python module package for implementing LDAP clients
LICENSE= PSFL
MAKE_ENV+= INCLUDES=${LOCALBASE}/include
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyasn1-modules>=0.2.1:devel/py-pyasn1-modules@${PY_FLAVOR}
USES= python
USE_OPENLDAP= yes
USE_PYTHON= autoplist distutils
.include <bsd.port.mk>

3
net/py-ldap0/distinfo Normal file
View File

@ -0,0 +1,3 @@
TIMESTAMP = 1525015315
SHA256 (ldap0-0.0.60.tar.gz) = a6f02941dda63249e8c7c68947d0c7fb47efaa59ca085396a3ddedadb90a65fe
SIZE (ldap0-0.0.60.tar.gz) = 219348

View File

@ -0,0 +1,11 @@
--- setup.py.orig 2018-02-06 13:04:47 UTC
+++ setup.py
@@ -22,7 +22,7 @@ class OpenLDAP2BuildConfig:
def __init__(self, meta_defines):
self.library_dirs = []
- self.include_dirs = []
+ self.include_dirs = [os.environ['INCLUDES']]
self.extra_compile_args = []
self.extra_link_args = []
self.extra_objects = []

6
net/py-ldap0/pkg-descr Normal file
View File

@ -0,0 +1,6 @@
ldap3 is a pure Python LDAP 3 client library strictly conforming to RFC4511
released under the LGPL v3 open source license. RFC4511 is the current LDAP
specification (June 2006) from IETF and obsoletes the previous LDAP RFCs
2251, 2830, 3771 (December 1997)
WWW: https://github.com/cannatag/ldap3

View File

@ -2,57 +2,42 @@
# $FreeBSD$
PORTNAME= web2ldap
PORTVERSION= 1.2.94
PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://www.web2ldap.de/download/ \
http://www.sfr-fresh.com/unix/www/
PORTVERSION= 1.3.16
CATEGORIES= www python
MASTER_SITES= CHEESESHOP
MAINTAINER= bsam@FreeBSD.org
MAINTAINER= girgen@FreeBSD.org
COMMENT= Python-based WWW gateway to LDAP servers
LICENSE= GPLv2
LICENSE= APACHE20
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}ldap>=2.4.0:net/py-ldap@${PY_FLAVOR} \
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>0:devel/py-setuptools@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}certifi>=0:security/py-certifi@${FLAVOR} \
${PYTHON_PKGNAMEPREFIX}asn1crypto>=0.22.0:devel/py-asn1crypto@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}paramiko>0:security/py-paramiko@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}dns>=0:dns/py-dns@${FLAVOR} \
${PYTHON_PKGNAMEPREFIX}xlwt>0:textproc/py-xlwt@${FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pillow>0:graphics/py-pillow@${FLAVOR} \
${PYTHON_PKGNAMEPREFIX}ldap0>=0.0.60:net/py-ldap0@${PY_FLAVOR} \
${PYTHON_SITELIBDIR}/pyweblib/__init__.py:www/py-pyweblib@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}ipaddr>0:devel/py-ipaddr@${PY_FLAVOR} \
${LOCALBASE}/etc/mime.types:misc/mime-support
OPTIONS_DEFINE= DOCS
USES= cpe python:2.7 shebangfix
python_OLD_CMD= /usr/bin/python2.7
SHEBANG_FILES= sbin/*.py fcgi/*.py
SUB_FILES= pkg-message
USES= cpe python:2.7
USE_PYTHON= distutils autoplist
SUB_FILES= pkg-message ${PORTNAME}
USE_RC_SUBR= ${PORTNAME}
NO_ARCH= yes
PLIST_DIRS= ${DATADIR} ${DATADIR}/var ${DATADIR}/var/log ${DATADIR}/var/run /var/log/web2ldap
PORTDOCS= *
PORTDATA= *
PLIST_DIRS= %%DATADIR%%/var/log %%DATADIR%%/var/run
post-build:
${TOUCH} ${WRKSRC}/etc/web2ldap/ssl/.placeholder
post-patch:
@${REINPLACE_CMD} -e 's|/opt/fcgi/bin/cgi-fcgi|${LOCALBASE}/bin/cgi-fcgi|g' \
${WRKSRC}/cgi-bin/web2ldap.cgi
@${REINPLACE_CMD} -e 's|/etc|${LOCALBASE}/etc|g' \
-e 's|nobody|web2ldap|g' \
${WRKSRC}/etc/web2ldap/web2ldapcnf/standalone.py
@${FIND} ${WRKSRC} -name '*.orig' -delete -o -name '*.bak' -delete
do-build:
${PYTHON_CMD} -m compileall ${WRKSRC}
${PYTHON_CMD} -O -m compileall ${WRKSRC}
do-install:
@${ECHO_MSG} "==> Installing program files..."
@${MKDIR} ${STAGEDIR}${DATADIR}
@(cd ${WRKSRC}; \
${FIND} * -type d | ${GREP} -vE "^htdocs" | ${CPIO} -p ${STAGEDIR}${DATADIR}; \
${FIND} * -type f | ${GREP} -vE "^htdocs" | ${CPIO} -pd ${STAGEDIR}${DATADIR})
post-install-DOCS-on:
@${ECHO_MSG} "==> Installing document files..."
@${MKDIR} ${STAGEDIR}${DOCSDIR}
@(cd ${WRKSRC}; \
${FIND} * -type d | ${GREP} "^htdocs" | ${CPIO} -p ${STAGEDIR}${DOCSDIR}; \
${FIND} * -type f | ${GREP} "^htdocs" | ${CPIO} -pd ${STAGEDIR}${DOCSDIR})
post-stage:
${MKDIR} ${STAGEDIR}${DATADIR}/var/log
${MKDIR} ${STAGEDIR}${DATADIR}/var/run
${MKDIR} ${STAGEDIR}/var/log/web2ldap
.include <bsd.port.mk>

View File

@ -1,3 +1,3 @@
TIMESTAMP = 1505137106
SHA256 (web2ldap-1.2.94.tar.gz) = 1a8ed7b6449c8a4ee370b118082142bf419dd0e0db86e588eaf648cf2ec9898e
SIZE (web2ldap-1.2.94.tar.gz) = 619633
TIMESTAMP = 1525272702
SHA256 (web2ldap-1.3.16.tar.gz) = 0d4b2cac1e86f8c7fc7a904099dbb0f107a13abb9259e914ce1196400031bb0d
SIZE (web2ldap-1.3.16.tar.gz) = 569122

View File

@ -1,15 +1,17 @@
===============================================================================
Run:
%%DATADIR%%/sbin/web2ldap.py
service web2ldap onestart
to start the standalone version of web2ldap. By default it only accepts
connections from localhost, but this can be modified in:
%%DATADIR%%/etc/web2ldap/web2ldapcnf/standalone.py
For instructions on installing the CGI version of web2ldap, please look at the
enclosed documentation in:
For configuration suggestions on installing the WSGI version of web2ldap using
apache *instead of the standalone version*, please look at the enclosed
documentation in:
https://fossies.org/linux/web2ldap/etc/apache2/sample-mod_wsgi.conf
%%DOCSDIR%%/htdocs/
===============================================================================

View File

@ -0,0 +1,40 @@
#!/bin/sh
# $FreeBSD$
# PROVIDE: web2ldap
# REQUIRE: DAEMON NETWORKING
# BEFORE: LOGIN
# KEYWORD: shutdown
# Add the following lines to /etc/rc.conf to enable web2ldap:
# web2ldap_enable="NO"
#
# web2ldap_enable (bool): Set to YES to enable web2ldap
# Default: NO
# web2ldap_user (str): web2ldap daemon user
# Default: nobody
# web2ldap_group (str): web2ldap daemon group
# Default: nogroup
. /etc/rc.subr
name="web2ldap"
rcvar=web2ldap_enable
: ${web2ldap_enable:="NO"}
: ${web2ldap_user:="nobody"}
: ${web2ldap_group:="nogroup"}
# daemon
pidfile="/var/run/${name}.pid"
command=/usr/sbin/daemon
procname="daemon"
command_args=" -c -f -P ${pidfile} %%PREFIX%%/bin/${name}"
start_precmd="web2ldap_precmd"
web2ldap_precmd()
{
install -o ${web2ldap_user} /dev/null ${pidfile}
}
load_rc_config $name
run_rc_command "$1"